Существует несколько способов внедрения видео в документ Animate и его воспроизведения для пользователей.

Приступая к работе

Прежде чем начать работать с видео в Animate, важно принять к сведению следующее.

  • Animate может воспроизводить лишь некоторые форматы видео.

    К ним относятся FLV, F4V и MPEG. Инструкции по преобразованию видео в другие форматы см. в разделе Создание видеофайлов для использования в среде Animate.

  • Используйте приложение Adobe Media Encoder (поставляется вместе с Animate) для преобразования остальных форматов видео в F4V. Инструкции см. в разделе Создание видеофайлов для использования в среде Animate.

  • Добавить видео в Animate можно несколькими способами, в зависимости от конкретной ситуации. Перечень этих способов представлен ниже.

  • В Animate есть Мастер импорта видеоданных, который открывается при выборе в меню «Файл» > «Импорт» > «Импорт видеоролика».

  • Использование компонента FLVPlayback — самый простой способ быстро воспроизвести видео в файле Animate.

    Инструкции см. в разделе «Последовательная загрузка видео с помощью веб-сервера».

Способы использования видео в среде Animate

В Animate видео можно использовать разными способами.

  • Последовательная загрузка с веб-сервера

    При этом подходе видеофайл является внешним и не включается в файл Animate и финальный SWF-файл. Так можно добиться меньшего размера SWF-файла. Это самый популярный способ использования видео в Animate.

  • Потоковая передача видео с использованием сервера Adobe Media Server.

    При этом походе видеофайл также является внешним и не включается в файл Animate. Сервер потокового видео Adobe Media надежно защищает ваше видеосодержимое и обеспечивает плавное воспроизведение.

  • Встраивание видеоданных в файл Animate

    При этом подходе файлы Animate получаются очень объемными. Его можно применять только к коротким роликам. Инструкции см. в разделе Встраивание видео в файл Animate.

Последовательная загрузка видео с помощью веб-сервера

Последовательная загрузка позволяет использовать компонент FLVPlayback или код ActionScript, написанный для загрузки и воспроизведения внешних FLV- или F4V-файлов в SWF-файле во время выполнения.

Поскольку видеофайл является внешним по отношению к остальному содержимому Animate, его обновление становится относительно простой задачей и не требует повторной публикации SWF-файла.

Последовательная загрузка обеспечивает следующие преимущества по сравнению с внедрением видео во временную шкалу:

  • Во время разработки может производиться публикация только SWF-файла для просмотра или тестирования всего содержимого Animate или его части. Это позволяет тратить меньше времени на предварительный просмотр и быстрее выполнять отладочный цикл.

  • Видео начинает воспроизводиться сразу же после того, как первый сегмент видео загружен и закэширован на жесткий диск локального компьютера.

  • Во время выполнения видеофайлы загружаются проигрывателем Flash Player с диска компьютера в SWF-файл без ограничений по размеру и продолжительности. Не существует никаких проблем синхронизации и ограничений по оперативной памяти.

  • Частота кадров видеофайла может отличаться от частоты кадров SWF-файла, предоставляя большую гибкость при разработке содержимого Animate.

Импорт видео для последовательной загрузки

Можно импортировать видеофайл, сохраненный на локальном компьютере, а затем отправить его на сервер, импортировав во FLA-файл. При импорте видео в Animate для последовательной загрузки вы в действительности добавляете лишь ссылку на видеофайл. С ее помощью Animate находит видеофайл на вашем компьютере или на сервере.

Кроме того, можно импортировать видеофайл, который уже отправлен на стандартный веб-сервер, сервер Adobe Media Server (AMS) или в службу Flash Video Streaming Service (FVSS).

  1. Выберите «Файл» > «Импорт» > «Импортировать видеофайл», чтобы импортировать фрагмент видеоролика в текущий документ Animate.

  2. Выберите нужный видеоролик. Можно выбрать видеоролик, сохраненный на локальном компьютере или URL-адрес видео, уже загруженного на веб-сервер или сервер Adobe Media Server.

    • Чтобы импортировать видео на локальный компьютер, выберите «Загрузить внешнее видео с компонентом воспроизведения».

    • Чтобы импортировать видео, уже развернутое на веб-сервере, сервере Adobe Media Server или в службе Flash Video Streaming Service, выберите параметр уже развернутого на веб-сервере видео, видео Flash Video Streaming Service или потоковой передачи видео с сервера Adobe Media Server и введите URL видеоролика.

      Примечание. URL-адрес видеоролика, размещенного на веб-сервере, использует протокол связи HTTP. URL-адрес видеоролика, размещенного на сервере Adobe Media Server или Flash Streaming Service, использует протокол связи RTMP.

  3. Выберите обложку для видеоролика. Могут быть выбраны следующие варианты.

    • Можно не использовать обложку с компонентом FLVPlayback, в этом случае нужно выбрать «Нет».

    • Можно выбрать одну из предустановленных обложек компонента FLVPlayback. Animate копирует обложку в ту же папку, что и FLA-файл.

      Примечание. Обложки компонента FLVPlayback несколько отличаются в зависимости от того, на AS2 или на AS3 основан создаваемый документ Animate.

       

    • Можно выбрать пользовательскую обложку, введя ее URL-адрес на веб-сервере.

      Примечание. Если выбрана пользовательская обложка из удаленного местоположения, интерактивный просмотр видео в рабочей области будет невозможен.

       

  4. Мастер импорта видео создает в рабочей области компонент видео FLVPlayback, который можно использовать для локального тестирования воспроизведения. Когда документ Animate будет готов и можно будет приступать к развертыванию SWF-файла и видеоролика, загрузите следующие ресурсы на веб-сервер или Adobe Media Server, на котором размещено видеосодержимое.

    • Если используется локальная копия видеоролика, загрузите видеоролик на сервер (он находится в той же папке, что и выбранный вами исходный видеоролик с расширением .flv).

      Примечание. Animate использует относительный путь для указания на FLV- или F4V-файл (относительно SWF-файла), что позволяет использовать на локальном компьютере ту же структуру каталогов, что и на сервере. Если видео было уже развернуто на сервере FMS или в службе FVSS, этот этап можно пропустить.

    • Обложка видео (если выбрано ее использование)

      Если используется стандартная обложка, Animate копирует ее в ту же папку, в которой находится FLA-файл.

    • Компонент FLVPlayback

      Чтобы изменить URL компонента FLVPlayback на адрес веб-сервера или Adobe Media Server, на который загружается видео, измените параметр contentPath с помощью Инспектора компонентов («Окно» > «Инспектор компонентов»).

Потоковая передача видео с использованием сервера Adobe Media Server

Сервер Adobe Media Server в реальном времени передает потоковое содержимое во Flash Player и среду AIR. Функция определения пропускной способности сети позволяет серверу Adobe Media Server учитывать максимальную скорость доставки аудио- и видеосодержимого, доступную пользователю.

Потоковая передача видео с использованием сервера Adobe Media Server дает по сравнению с внедренным видео и последовательной загрузкой следующие преимущества.

  • Воспроизведение начинается быстрее, чем для внедренного видео.

  • При потоковой передаче данных на клиентском компьютере используется меньше памяти и места на диске, так как не требуется загрузка полного файла.

  • Сетевые ресурсы используются эффективнее, поскольку клиенту передается только часть просматриваемого видео.

  • Доставка мультимедиа более надежна, потому что при потоковой передаче данные не сохраняются в кэше клиентского компьютера.

  • Потоковое видео обеспечивает лучшую поддержку отслеживания, учета и ведения журналов.

  • Потоковая передача данных дает возможность проводить видео- и аудиопрезентации в режиме реального времени и захватывать видео с цифровой или веб-камеры.

  • Adobe Media Server обеспечивает многостороннюю и многопользовательскую передачу данных для приложений видеоконференций, видеочатов и обмена видеосообщениями.

  • Серверные сценарии для управления видео- и аудиопотоками позволяют создавать на сервере списки воспроизведения, синхронизированные потоки и интеллектуальное управление параметрами доставки, исходя из скорости соединения клиента.

Получить дополнительные сведения о сервере Adobe Media Server можно на странице по адресу http://www.adobe.com/go/flash_media_server_ru.

Дополнительные сведения о службе Flash Video Streaming Service см. на странице http://www.adobe.com/go/learn_fvss_ru.

Встраивание видеофайла в файл Animate

При встраивании видео все данные видеофайла добавляются в файл Animate. В результате создается файл Animate гораздо большего размера, а затем — SWF-файл. Видео помещается на временную шкалу, где можно просматривать отдельные кадры, представленные кадрами временной шкалы. Поскольку каждый видеокадр представлен кадром на временной шкале, частота кадров видеоролика и SWF-файла должна совпадать. Если частота кадров для SWF-файла и внедренного видеоролика не совпадает, воспроизведение видео будет несогласованным.

Примечание. Видео с переменной частотой кадров должно передаваться через последовательную загрузку или с сервера Adobe Media Server. При импорте видеофайла одним из этих методов FLV- или F4V-файл становится автономным и воспроизводится с другой частотой кадров, нежели SWF-файл.

 

Внедренное видео лучше всего работает с небольшими видеороликами длительностью не более 10 секунд. Для более длительных видеороликов лучше подумать над возможностью последовательной загрузки или потоковой передачи видео с сервера Adobe Media Server.

Для внедренного видео существуют следующие ограничения.

  • Если полученные SWF-файлы станут слишком большими, могут возникнуть проблемы. При загрузке и попытке воспроизведения большого SWF-файла с внедренным видео Flash Player резервирует значительный объем памяти, что может привести к возникновению ошибки.

  • В видеофайлах продолжительностью более 10 секунд часто случается рассинхронизация фрагментов видео и звука в видеоклипе. Через некоторое время рассогласование звука и изображения становится значительным, вызывая неприятные ощущения от просмотра.

  • Для воспроизведения видео, внедренного в SWF-файл, необходимо, чтобы был загружен весь видеофайл целиком. При внедрении слишком большого видеофайла для его загрузки и начала воспроизведения может понадобиться значительное время.

  • После импорта видеоролика он будет недоступен для редактирования. В таком случае видеофайл нужно будет повторно редактировать и импортировать еще раз.

  • Если SWF-файл публикуется через Интернет, пользователь должен загрузить видеофайл полностью, прежде чем начать воспроизведение.

  • Во время выполнения весь видеофайл должен находиться в памяти воспроизводящего компьютера.

  • Продолжительность импортированного видеофайла не должна превышать 16 000 кадров.

  • Частота кадров видеофайла и временной шкалы Animate должна совпадать. Установите для файла Animate частоту кадров, соответствующую частоте встраиваемого видео.

Просмотр кадров внедренного видео производится перетаскиванием точки воспроизведения на временной шкале (т. е. путем очистки). Обратите внимание, что звуковая дорожка во время очистки не воспроизводится. Просмотреть видео со звуком позволяет команда «Тестировать ролик».

Встраивание видео в файл Animate

  1. Выберите «Файл» > «Импорт» > «Импортировать видеофайл», чтобы импортировать фрагмент видеоролика в текущий документ Animate.

  2. Выберите один из следующих вариантов.

    Загрузить внешний видеофайл с компонентом воспроизведения. Импортирует видео и создает экземпляр компонента FLVPlayback для управления воспроизведением.

    Внедрить FLV-файл в SWF-файл и воспроизвести во временной шкале. Встраивает FLV-файл в документ Animate и размещает его на временной шкале.

    Внедрить видео H.264 во временную шкалу. Встраивает видео H.264 в документ Animate. При импорте видеофайла с помощью этой функции он размещается в рабочей области и используется во время разработки в качестве направляющей анимации. Рендеринг кадров из этого видеофайла выполняется в рабочей области при перемещении по нему или при воспроизведении во временной шкале. Кадры воспроизводятся со звуком.

    Примечание.

    • При попытке опубликовать FLA-файл с видеоконтентом H264 на слое, который не является направляющим или скрытым, появляется предупреждение о том, что платформа для публикации не поддерживает внедрение видеофайлов H.264.
  3. Нажмите кнопку «Обзор», выберите на компьютере видеофайл и нажмите кнопку «Далее».

    Дополнительно: если у вас на компьютере установлено приложение Adobe Media Encoder и вы хотите с его помощью преобразовать видео в другой формат, нажмите «Преобразовать видео».

  4. Выберите тип символа, с которым будет внедрено видео.

    Внедренное видео

    Если видеоролик используется для линейного воспроизведения на временной шкале, может оказаться удобнее импортировать видео на временную шкалу.

    Фрагмент ролика

    Чтобы обеспечить гибкое управление содержимым, рекомендуется помещать видео в экземпляр фрагмента ролика. Временная шкала видео воспроизводится независимо от основной временной шкалы. Расширять основную временную шкалу, чтобы вместить видео, не потребуется — это лишь затруднит работу с FLA-файлом.

    Графика

    При внедрении видеоролика в качестве графического символа взаимодействие с видео через ActionScript будет невозможно (как правило, графические символы используются для статических изображений и создания многократно используемых фрагментов анимации).

  5. Импорт видеоролика может быть выполнен в рабочую область (и на временную шкалу) или в качестве элемента библиотеки.

    По умолчанию Animate помещает импортируемое видео в рабочую область. Чтобы импорт производился только в библиотеку, снимите флажок «Разместить экземпляр в рабочей области».

    При создании простой презентации с линейным изложением и отсутствием интерактивности примите настройки по умолчанию, чтобы импортировать видео в рабочую область. При создании более динамичных презентаций можно работать с несколькими видеороликами, при помощи ActionScript добавлять динамические переходы и другие элементы, а также импортировать видео в библиотеку. После того как видеоролик помещен в библиотеку, его можно преобразовать в объект MovieClip, которым легче управлять с помощью ActionScript.

    По умолчанию Animate расширяет временную шкалу таким образом, чтобы она вмещала продолжительность воспроизведения внедряемого видеоролика.

    Если видеофайл содержит аудиодорожку, которую не нужно импортировать, снимите флажок «Включить звук».  

  6. Нажмите кнопку «Далее». Просмотрите сообщения с подтверждениями и нажмите «Готово».

    Мастер импорта видео внедряет видео в SWF-файл. Видео появляется в рабочей области или в библиотеке в зависимости от настройки параметров внедрения.

  7. В инспекторе свойств (меню «Окно > Свойства») задайте для видеоролика имя экземпляра и при необходимости измените его свойства.

Импорт видеофайлов в библиотеку

Для импорта видеофайлов в формате FLV, F4V или H.264 перейдите в меню «Импорт» > «Импортировать видеофайл» или выберите команду «Импортировать в библиотеку».

Чтобы создать собственный видеоплеер, который будет динамически загружать FLV- или F4V-файлы из внешнего источника, поместите видео на символ фрагмента ролика. Если FLV- или F4V-файл загружается динамически, измените размеры фрагмента ролика таким образом, чтобы они соответствовали фактическим размерам видеофайла, и настройте размер видео, масштабируя фрагмент ролика.

Примечание.

Рекомендуется размещать видео внутри экземпляра фрагмента ролика, это обеспечивает наибольшую гибкость при управлении содержимым. Временная шкала видео воспроизводится независимо от основной временной шкалы. Расширять основную временную шкалу, чтобы вместить видео, не потребуется — это лишь затруднит работу с FLA-файлом.

  1. Чтобы выполнить импорт FLV-, SWF- или H.264-файла в библиотеку, выполните одно из следующих действий.

    • Выберите меню «Файл» > «Импорт» > «Импортировать в библиотеку».

    • Выделите любой существующий видеоролик на панели «Библиотека» и выберите пункт «Свойства» в меню панели «Библиотека». Нажмите кнопку «Импорт». Выберите нужный файл и нажмите кнопку «Открыть».

Изменение свойств видеоролика

Можно изменять свойства экземпляра внедренного видеоролика в рабочей области, присваивать имя экземпляра и изменять ширину, высоту и положение видеоролика в рабочей области. Можно также заменить экземпляр видеоролика, то есть присвоить ему другой символ. При присваивании экземпляру другого символа в рабочей области отображается другой экземпляр, но все его свойства (размеры, точка регистрации и другие) остаются неизменными.

Диалоговое окно «Свойства видео» позволяет выполнить следующие действия.

  • Просматривать информацию об импортируемом видеоролике, включая его имя, путь, дату создания, размеры в пикселах, продолжительность и размер файла.

  • Изменять имя видеоролика.

  • Обновить видеоролик, если он модифицирован во внешнем редакторе.

  • Импортировать FLV- или F4V-файл вместо выделенного фрагмента

  • Экспортировать видеофрагмент в виде FLV-или F4V-файла

Изменение свойств экземпляра видео в инспекторе свойств

  1. Выделите экземпляр внедренного или связанного видеоролика в рабочей области.
  2. Выберите меню «Окно» > «Свойства» и выполните одно из следующих действий.
    • Введите имя экземпляра в текстовом поле «Имя» в левой части инспектора свойств.

    • Введите значения «W» и «H», чтобы изменить размеры экземпляра видео.

    • Введите значения «X» и «Y», чтобы изменить положение левого верхнего угла экземпляра в рабочей области.

    • Нажмите кнопку «Заменить». Выберите видеоролик для замены текущего ролика, назначенного экземпляру.

      Примечание. Внедренный видеоролик может быть заменен только другим внедренным видеороликом, а связанный — только другим связанным видеороликом.

Просмотр свойств видеороликов в диалоговом окне «Свойства видеоролика»

  1. Выделите видеоролик на панели «Библиотека».
  2. В меню панели «Библиотека» выберите пункт «Свойства» или нажмите кнопку «Свойства» в нижней части панели «Библиотека». Отобразится диалоговое окно «Свойства видеоролика».

Переименование, обновление видео и его замена

  1. Выделите видеоролик на панели «Библиотека» и выберите пункт «Свойства» в меню панели.
  2. Выполните одно из следующих действий.

    • Чтобы задать новое имя, введите его в текстовое поле «Имя».

    • Чтобы обновить видео, перейдите к обновленному видеофайлу и нажмите кнопку «Открыть».

    • Чтобы заменить видео, нажмите кнопку «Импорт», перейдите к нужному FLV-, F4V- или H.264-файлу и нажмите кнопку «Открыть».

Управление воспроизведением видео с помощью временной шкалы

Управление воспроизведением внедренного видеофайла производится при помощи временной шкалы, в которой он содержится. Например, чтобы приостановить видео, воспроизводящееся на основной временной шкале, необходимо вызвать функцию stop() для этой временной шкалы. Аналогичным образом производится управление видеообъектом в символе фрагмента ролика — при использовании временной шкалы этого символа.

К видеообъектам, импортированным во фрагменты ролика, могут быть применены следующие действия: goTo, play, stop, toggleHighQuality, stopAllSounds, getURL, FScommand, loadMovie, unloadMovie, ifFrameLoaded и onMouseEvent. Чтобы применить действие к объекту Video, вначале следует преобразовать его во фрагмент ролика.

Отображение видеопотока в реальном времени с видеокамеры может быть реализовано при помощи ActionScript. Сначала поместите в рабочую область объект Video с помощью команды «Создать видео» на панели «Библиотека». Связать с этим объектом видеопоток позволяет метод Video.attachVideo.

См. также раздел «Видео и метод attachVideo (Video.attachVideo)» в руководстве Справочник ActionScript® 2.0 для Adobe® Flash® Professional CS5 и раздел «fl.video» в руководстве Справочник ActionScript® 3.0 для Adobe® Flash® Professional CS5.

Обновление внедренного видео после редактирования исходного файла

  1. Выделите видеоролик на панели «Библиотека».
  2. Выберите пункт «Свойства» и нажмите кнопку «Обновить».

    Внедренный видеоролик будет заменен отредактированной версией файла. К обновляемому ролику применяются настройки сжатия, заданные при импорте видео.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет