Руководство пользователя Отмена

Работа с символами в Animate

  1. Руководство пользователя Adobe Animate
  2. Введение в Animate
    1. Новые возможности Animate
    2. Визуальный глоссарий
    3. Системные требования Animate
    4. Сочетания клавиш Animate
    5. Разные типы файлов в Animate
  3. Анимация
    1. Основы анимации в Animate
    2. Кадры и ключевые кадры в Animate
    3. Покадровая анимация в Animate
    4. Классическая анимация движения в Animate
    5. Инструмент «Кисть»
    6. Руководство по движению
    7. Анимация движения и язык ActionScript 3.0
    8. Сведения об анимации движения
    9. Анимация движения
    10. Создание анимации движения
    11. Использование ключевых кадров свойств
    12. Положения в анимации движения
    13. Использование Редактора движения для анимаций
    14. Редактирование траектории анимации движения
    15. Управление анимациями движения
    16. Настраиваемое ускорение и замедление
    17. Создание и применение стилей движения
    18. Настройка диапазонов анимации движения
    19. Сохранение анимации движения в файлах XML
    20. Анимация движения и классическая анимация
    21. Анимация фигур
    22. Инструмент «Кость» в Animate
    23. Скелетная анимация персонажей в Animate
    24. Слои-маски в Adobe Animate
    25. Работа со сценами в Animate
  4. Интерактивность
    1. Создание кнопок в Animate
    2. Преобразование проектов Animate в другие форматы документов
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Добавление интерактивных возможностей с помощью фрагментов кода в Animate
    5. Создание пользовательских компонентов HTML5
    6. Использование компонентов в HTML5 Canvas
    7. Создание пользовательских компонентов: примеры
    8. Фрагменты кода для пользовательских компонентов
    9. Рекомендации: реклама в Animate
    10. Разработка и публикация контента для виртуальной реальности
  5. Рабочая среда и рабочий процесс
    1. Создание и использование малярных кистей
    2. Использование шрифтов Google в документах HTML5 Canvas
    3. Использование библиотек Creative Cloud Libraries и Adobe Animate
    4. Использование рабочей области и панели «Инструменты» в Animate
    5. Рабочие процессы и рабочая среда Animate
    6. Использование веб-шрифтов в документах HTML5 Canvas
    7. Временные шкалы и ActionScript
    8. Работа с несколькими временными шкалами
    9. Задание настроек
    10. Использование панелей разработки Animate
    11. Создание слоев временной шкалы в Animate
    12. Экспорт анимаций для мобильных приложений и игровых платформ
    13. Перемещение и копирование объектов
    14. Шаблоны
    15. Поиск и замена в Animate
    16. Отмена/повтор действий и панель «История»
    17. Сочетания клавиш
    18. Использование временной шкалы в Animate
    19. Создание HTML-расширений
    20. Параметры оптимизации изображений и GIF-анимаций
    21. Настройки экспорта для изображений и GIF
    22. Панель «Ресурсы» в Animate
  6. Мультимедиа и видео
    1. Преобразование и объединение графических объектов в Animate
    2. Создание экземпляров символов и работа с ними в Animate
    3. Трассировка изображения
    4. Использование звука в Adobe Animate
    5. Экспорт SVG-файлов
    6. Создание видеофайлов для использования в Animate
    7. Добавление видео в Animate
    8. Работа с ключевыми точками видео
    9. Рисование и создание объектов в Animate
    10. Изменение линий и фигур
    11. Обводки, заливки и градиенты в Animate CC
    12. Работа с Adobe Premiere Pro и After Effects
    13. Панели «Цвет» в Animate CC
    14. Открытие файлов Flash CS6 в Animate
    15. Работа с классическим текстом в Animate
    16. Размещение иллюстраций в Animate
    17. Импортированные растровые изображения в Animate
    18. Трехмерная графика
    19. Работа с символами в Animate
    20. Рисование линий и фигур в Adobe Animate
    21. Работа с библиотеками в Animate
    22. Экспорт звуков
    23. Выделение объектов в Animate CC
    24. Работа с AI-файлами Illustrator в Animate
    25. Нанесение узоров с помощью инструмента «Аэрограф»
    26. Применение режимов наложения
    27. Упорядочивание объектов
    28. Автоматизация задач с помощью меню «Команды»
    29. Многоязычный текст
    30. Использование камеры в Animate
    31. Использование Animate с Adobe Scout
    32. Работа с файлами Fireworks
    33. Графические фильтры
    34. Звук и ActionScript
    35. Настройки рисования
    36. Рисование инструментом «Перо»
  7. Платформы
    1. Преобразование проектов Animate в другие форматы документов
    2. Поддержка специализированных платформ
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Создание и публикация документа WebGL
    5. Упаковка приложений AIR for iOS
    6. Публикация приложений AIR for Android
    7. Публикация для Adobe AIR на настольных ПК
    8. Параметры публикации ActionScript
    9. Рекомендации: размещение ActionScript в приложении
    10. Использование ActionScript в Animate
    11. Рекомендации: специальные возможности
    12. Специальные возможности в среде Animate
    13. Создание и использование сценариев
    14. Обеспечение поддержки специализированных платформ
    15. Общие сведения о поддержке специализированных платформ
    16. Создание содержимого со специальными возможностями
    17. Работа с плагинами поддержки специализированных платформ
    18. Отладка сценариев ActionScript 3.0
    19. Обеспечение поддержки специализированных платформ
  8. Экспорт и публикация
    1. Экспорт файлов из Animate CC
    2. Публикация OAM
    3. Экспорт SVG-файлов
    4. Экспорт графики и видео из Animate
    5. Публикация документов AS3
    6. Экспорт анимаций для мобильных приложений и игровых платформ
    7. Экспорт звуков
    8. Экспорт видеофайлов в QuickTime
    9. Управление воспроизведением внешнего видео с помощью ActionScript
    10. Рекомендации: советы по созданию контента для мобильных устройств
    11. Рекомендации: правила работы с видео
    12. Рекомендации: руководство по созданию SWF-приложений
    13. Рекомендации: формирование структуры FLA-файлов
    14. Рекомендации: оптимизация FLA-файлов для Animate
    15. Параметры публикации ActionScript
    16. Задание параметров публикации для Animate
    17. Экспорт файлов-проекторов
    18. Экспорт изображений и анимированных файлов GIF
    19. Шаблоны публикации HTML
    20. Работа с Adobe Premiere Pro и After Effects
    21. Быстрая публикация анимаций

О символах

Символ — это изображение, кнопка или фрагмент ролика, который создается один раз в среде разработчика Animate (ранее Flash Professional CC) или посредством классов SimpleButton (AS 3.0) и MovieClip. Затем символ может быть повторно использован в этом или других документах.

Символ может включать иллюстрации, импортированные из другого приложения. Любой созданный символ автоматически становится частью библиотеки текущего документа.

Экземпляр представляет собой копию символа, расположенную в рабочей области или вложенную в другой символ. Экземпляр может отличаться от родительского символа цветом, размером и функциональностью. При редактировании символа обновляются все его экземпляры, но при применении к нему эффектов изменится только используемый экземпляр.

Использование в документах символов значительно уменьшает размер файла. Для хранения нескольких экземпляров символа требуется меньше места, чем для хранения множества копий содержимого символа. Например, для уменьшения размера файла документа можно преобразовать статические графические объекты (например, фоновые изображения) в символы, а затем использовать их повторно. Использование символов также повышает производительность воспроизведения SWF-файла, поскольку загрузка символа в проигрыватель Flash® Player выполняется только один раз.

Общий доступ к символам в документах в виде ресурсов общей библиотеки доступно как на этапе разработки, так и при исполнении. На этапе выполнения общие ресурсы, находящиеся в исходном документе, могут быть связаны с любым числом целевых документов без необходимости их импорта. В ресурсах, разделяемых на этапе разработки, любой символ может быть обновлен или заменен любым другим символом, доступным по локальной сети.

Если импортируемый библиотечный ресурс имеет то же имя, что и ресурс, уже находящийся в библиотеке, то конфликты именования можно устранить без риска случайной перезаписи существующего ресурса.

Дополнительные вводные инструкции по работе с символами доступны в следующих ресурсах:

Типы символов

Каждый символ имеет собственную временную шкалу и рабочую область со слоями. Как и к основной временной шкале, к временной шкале символа могут добавляться кадры, ключевые кадры и слои. При создании символа пользователь выбирает его тип.

  • Графические символы предназначены для создания статических изображений и повторно используемых фрагментов анимации, связанных с основной временной шкалой. Графические символы работают синхронно с основной временной шкалой. Интерактивные элементы управления и звуки в последовательности анимации графического символа работать не будут. При использовании графических символов размер FLA-файла увеличивается меньше, чем при применении кнопок и фрагментов роликов, так как они не имеют временной шкалы.

  • Кнопки-символы позволяют создавать интерактивные кнопки, которые реагируют на щелчки кнопкой мыши, перемещение указателя или другие действия. Пользователь определяет графику, связанную с различными состояниями, а затем назначает действия экземпляру кнопки. Дополнительные сведения см. в разделе Обработка событий в руководстве разработчика ActionScript 3.0.

  • Символы фрагмента ролика позволяют создавать повторно используемые фрагменты анимации. Фрагменты ролика имеют собственную многокадровую временную шкалу, которая не зависит от основной. Она может рассматриваться как вложенная в основную временную шкалу, и может содержать интерактивные элементы управления, звуки и даже другие экземпляры фрагмента ролика. Для создания анимированных кнопок экземпляры фрагмента ролика могут быть размещены внутри временной шкалы символа-кнопки. Кроме того, фрагменты ролика доступны из сценариев ActionScript®.

  • Шрифтовые символы позволяют экспортировать шрифт и использовать его в других документах Animate.

    Animate содержит встроенные компоненты, фрагменты ролика с заданными параметрами, которые позволяют дополнять документ элементами пользовательского интерфейса: кнопками, флажками и полосами прокрутки. Дополнительные сведения см. в разделе О компонентах ActionScript 3.0 в руководстве Использование компонентов ActionScript 3.0.

     Для просмотра анимации в экземплярах компонента и фрагментов ролика с 9-фрагментным масштабированием в среде разработки Animate выберите меню «Управление» > «Разрешить интерактивный просмотр».

Создание символов

Можно создать символ на основе объектов, выделенных в рабочей области, создать пустой символ и подготовить или импортировать содержимое в режиме редактирования символов либо создать символы шрифтов в Animate. Символы могут содержать любую функциональность Animate, в том числе анимацию.

Использование символов, содержащих анимацию, позволяет создавать весьма динамичные приложения Animate при минимальных размерах файла. Удобно создавать анимацию на основе символов с повторяющимися или циклическими действиями — такими, например, как взмахи крыльев птицы.

Для добавления символов в документ следует пользоваться ресурсами общей библиотеки на этапе разработки или при исполнении.

Преобразование выделенных элементов в символы

  1. Выделите один или несколько элементов в рабочей области. Выполните одно из следующих действий.
    • Выберите меню «Модификация» > «Преобразовать в символ».

    • Перетащите выделенные элементы на панель «Библиотека».

    • Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), а затем выберите из контекстного меню пункт «Преобразовать в символ».

  2. Введите имя символа и выберите поведение в диалоговом окне «Преобразовать в символ».
  3. Щелкните сетку точек отсчета, чтобы указать для символа положение точки регистрации.
  4. Нажмите кнопку ОК.

    Animate добавляет символ в библиотеку. Элементы, выделенные в рабочей области, становятся экземпляром символа. Созданный символ доступен для редактирования в режиме изменения символов в меню «Правка» > «Изменить символы» либо в контексте рабочей области в меню «Правка» > «Изменить на месте». Можно также изменить точку регистрации символа.

Создание пустого символа

  1. Выполните одно из следующих действий.
    • Выберите меню «Вставка» > «Создать символ».

    • Нажмите кнопку «Новый символ» в нижней левой части панели «Библиотека».

    • Выберите команду «Создать символ» из меню «Панель» в правом верхнем углу панели «Библиотека».

  2. Введите имя символа и выберите поведение в диалоговом окне «Создать новый символ».
  3. Нажмите кнопку ОК.

    Программа Animate добавляет символ в библиотеку и переключается в режим его редактирования. В режиме редактирования имя символа отображается над верхним левым углом рабочей области, а указатель-перекрестие обозначает точку регистрации символа.

  4. Создание содержимого символа производится при использовании временной шкалы, инструментов рисования, путем импорта мультимедийных данных или создания экземпляров других символов.
  5. Чтобы вернуться в режим редактирования документа, выполните одно из следующих действий.
    • Нажмите кнопку «Назад».

    • Выберите меню «Правка» > «Редактировать документ».

    • Щелкните имя монтажного кадра на панели редактирования.

      При создании символа его точка регистрации помещается в центре окна в режиме редактирования символов. Содержимое символа может быть перемещено в окне относительно точки регистрации. Чтобы при редактировании символа изменить точку регистрации, переместите содержимое символа относительно нее.

  6. В разделе привязки к ActionScript можно выбрать экспорт для ActionScript, установив флажок «Экспорт для ActionScript». Автоматически будут отображены поля «Класс» и «Базовый класс» (можно сменить имена классов). Программа Animate выполняет поиск определения класса во внешнем файле AS или в связанном файле SWC. Если определение класса не найдено, Animate автоматически формирует файлы класса.

(Только в Animate.) Замена нескольких символов

Команда «Заменить растровое изображение» позволяет заменять символы другими выбранными символами или растровыми изображениями.

  1. Во Animate CC выберите в рабочей области несколько символов.

  2. На панели «Свойства» нажмите «ЗАМЕНИТЬ».
  3. В диалоговом окне «Замена символа» выберите символ, которым требуется заменить все выбранные символы или растровые изображения.
  4. Нажмите кнопку ОК.

Преобразование анимации в рабочей области в символ фрагмента ролика

Чтобы повторно использовать анимированную последовательность в рабочей области или работать с ней в экземпляре, выделите ее и сохраните как символ фрагмента ролика.

  1. На основной временной шкале выделите в рабочей области все кадры и слои, используемые анимацией. Дополнительные сведения о выделении кадров см. в разделе Добавление кадров во временную шкалу.
  2. Для копирования кадров выполните одно из следующих действий.
    • Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), любой выделенный кадр, а затем выберите из контекстного меню пункт «Копировать кадры». Чтобы удалить последовательность после ее преобразования во фрагмент ролика, выберите команду «Вырезать».

    • Выберите меню «Правка» > «Временная шкала» > «Копировать кадры». Чтобы удалить последовательность после ее преобразования во фрагмент ролика, выберите команду «Вырезать кадры».

  3. Отмените выделение и убедитесь, что ни один объект рабочей области не выделен. Выберите меню «Вставка» > «Создать символ».
  4. Задайте имя символа. Выберите тип «Фрагмент ролика», затем нажмите кнопку ОК.
  5. На временной шкале нажмите кадр 1 в слое 1 и выберите меню «Правка» > «Временная шкала» > «Вставить кадры».

    Это действие вставляет во временную шкалу данного символа фрагмента ролика кадры (все слои вместе с их именами), скопированные из основной временной шкалы. Анимация, кнопки или интерактивные элементы из скопированных на этом этапе кадров становятся независимыми (символом фрагмента ролика) и пригодны для повторного использования.

  6. Чтобы вернуться в режим редактирования документа, выполните одно из следующих действий.
    • Нажмите кнопку «Назад».

    • Выберите меню «Правка» > «Редактировать документ».

    • Щелкните имя монтажного кадра на панели редактирования над рабочей областью.

Дублирование символов

Дублирование символа позволяет использовать существующий символ как отправную точку для создания нового символа.

Версии символов, отличающиеся внешним видом, создают также при помощи экземпляров.

Дублирование символа при помощи панели «Библиотека»

  1. Выделите символ на панели «Библиотека» и выполните одно из следующих действий.
    • Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), а затем выберите из контекстного меню пункт «Дублировать».

    • Выберите пункт «Дублировать» из меню панели «Библиотека».

Дублирование символа путем выбора экземпляра

  1. Выделите в рабочей области экземпляр символа.
  2. Выберите меню «Модификация» > «Символ» > «Дублировать символ».

    Создается дубликат символа, а его экземпляр заменяется экземпляром дубликата.

Изменение символов

При редактировании символа Animate обновляет все экземпляры этого символа в документе. Редактирование символа может быть произведено следующими способами.

  • В контексте с другими объектами рабочей области по команде «Редактировать на месте». Другие объекты затеняются, чтобы можно было отличить их от редактируемого символа. Имя редактируемого символа отображается на панели редактирования в верхней части рабочей области, справа от имени текущего монтажного кадра.

  • В отдельном окне по команде «Редактировать в новом окне». Редактирование символа в отдельном окне позволяет видеть одновременно символ и основную временную шкалу. Имя редактируемого символа отображается на панели редактирования в верхней части рабочей области.

    В режиме редактирования символа окно переключается в вид, в котором представлен только символ. Имя редактируемого символа отображается на панели редактирования в верхней части рабочей области, справа от имени текущего монтажного кадра.

    При редактировании символа Animate обновляет все экземпляры символа во всем документе, чтобы отразить сделанные изменения. При редактировании символа можно пользоваться любыми инструментами рисования, импортом мультимедиа-данных или создавать экземпляры других символов.

  • Точка регистрации символа (точка с координатами 0, 0) может быть изменена любым методом редактирования символа.

 

Редактирование символа на месте

  1. Выполните одно из следующих действий.
    • Дважды щелкните экземпляр символа в рабочей области.

    • Выделите экземпляр символа в рабочей области, щелкнув правой кнопкой мыши (Windows) или щелкнув, удерживая нажатой клавишу Control (Macintosh), а затем выберите команду «Изменить на месте».

    • Выделите экземпляр символа в рабочей области и выберите меню «Правка» > «Изменить на месте».

  2. Отредактируйте символ.
  3. Чтобы выйти из режима редактирования на месте и вернуться в режим редактирования документа, выполните одно из следующих действий.
    • Нажмите кнопку «Назад».

    • Выберите имя текущего монтажного кадра в меню «Монтажный кадр» панели правки.

    • Выберите меню «Правка» > «Редактировать документ».

    • Дважды щелкните мышью за пределами символа.

Редактирование символа в новом окне

  1. Выделите экземпляр символа в рабочей области, щелкнув его правой кнопкой мыши (Windows) или щелкнув, удерживая нажатой клавишу Control (Macintosh), а затем выберите команду «Редактировать в новом окне».
  2. Отредактируйте символ.
  3. Нажмите кнопку «Закрыть» в верхнем правом углу (Windows) или верхнем левом углу (Macintosh), чтобы закрыть новое окно, а затем щелкните основное окно документа, чтобы вернуться к редактированию основного документа.

Редактирование символа в режиме редактирования символа

  1. Выделите символ, выполнив одно из следующих действий.
    • Дважды щелкните значок символа на панели «Библиотека».

    • Выделите экземпляр символа в рабочей области, щелкнув правой кнопкой мыши (Windows) или щелкнув, удерживая нажатой клавишу Control (Macintosh), а затем выберите в контекстном меню команду «Редактировать».

    • Выделите экземпляр символа в рабочей области и выберите меню «Правка» > «Редактировать символы».

    • Выделите символ на панели «Библиотека» и выберите меню «Правка» из меню панели либо щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), символ на панели «Библиотека», а затем выберите пункт «Редактировать».

  2. Отредактируйте символ.
  3. Чтобы выйти из режима редактирования символа и вернуться в режим редактирования документа, выполните одно из следующих действий.
    • Нажмите кнопку «Назад» слева от панели редактирования вверху рабочей области.

    • Выберите меню «Правка» > «Редактировать документ».

    • Щелкните имя монтажного кадра на панели редактирования в верхней части рабочей области.

    • Дважды щелкните мышью за пределами символа.

 Adobe

Получайте помощь быстрее и проще

Новый пользователь?