Обзор

Adobe Animate предоставляет несколько способов использования звука. Звук может быть синхронизирован с анимацией при помощи временной шкалы либо воспроизводиться непрерывно, безотносительно нее. Звук можно добавить к кнопкам, чтобы сделать их интерактивными, а также делать звук тише и громче, добиваясь максимального эффекта.

В программе Animate существует два типа звуков: звуки событий и потоковые звуки. Звук события до начала воспроизведения должен быть полностью загружен, и он будет воспроизводиться до тех пор, пока не будет явным образом остановлен. Воспроизведение потокового звука начинается в тот момент, когда загружено достаточно данных для нескольких первых кадров. При воспроизведении с веб-сайта потоковый звук синхронизируется с временной шкалой.

При создании содержимого Animate для мобильных устройств Animate также позволяет включать в публикуемый SWF-файл звуки устройств. Звук устройства закодирован в собственном аудиоформате устройства (MIDI, MFi, SMAF и т.д.).

Чтобы сделать звук доступным из нескольких документов, можно воспользоваться общими библиотеками. Для выполнения действий по завершении проигрывания звука можно использовать события ActionScript® 2.0 onSoundComplete и ActionScript® 3.0 soundComplete.

Загружают и управляют звуком также предустановленные варианты поведения и мультимедийные компоненты (последние реализуют средство управления для функций остановки, паузы, перемотки и т.д.). Можно также загрузить звук динамически при помощи ActionScript 2.0 или 3.0.

Дополнительные сведения см. в разделах attachSound (метод Sound.attachSound) и loadSound (метод Sound.loadSound) в руководстве Справочник ActionScript 2.0 для Adobe Flash Professional CS5 или в разделе класс Sound в руководстве Справочник ActionScript 3.0 для Adobe Flash Professional CS5.

Примечание.

Версии ActionScript 2.0 и ActionScript 1.0 не поддерживаются в среде Animate.

Импорт звуков

Чтобы звуковой файл стал доступен в программе Animate, его необходимо импортировать в библиотеку или непосредственно в рабочую область.

Команда меню «Файл» > «Импорт» > «Импортировать в библиотеку» помещает аудиофайл только в библиотеку, а не на временную шкалу.

Когда аудиофайл импортируется с использованием команду «Файл» > «Импорт» > «Импортировать в рабочую область» или перетаскиванием непосредственно на временную шкалу, он помещается в активный кадр активного слоя. Если перетаскивается несколько видеофайлов, только один из них будет импортирован, так как один кадр может содержать только один аудиофайл. 

Чтобы импортировать аудиофайл, используйте один из следующих способов.

  • Чтобы импортировать аудиофайл в библиотеку, выберите «Файл» > «Импорт» > «Импортировать в библиотеку» и укажите аудиофайл, который нужно импортировать.
  • Чтобы импортировать аудиофайл в рабочую область, выберите «Файл» > «Импорт» > «Импортировать в рабочую область» и укажите аудиофайл, который нужно импортировать. 
  • Перетащите аудиофайл непосредственно в рабочую область.
import-sounds

Примечание.

Можно также перетащить звук из общей библиотеки в библиотеку текущего документа.

Animate сохраняет звук в библиотеке вместе с растровыми изображениями и символами. Для любого метода использования звука в документе необходима только одна копия звукового файла.

Чтобы звук был доступен из нескольких документов Animate, его можно включить в общую библиотеку.

Animate включает библиотеку «Звуки», где содержится множество полезных звуков для создания эффектов. Чтобы открыть библиотеку «Звуки», выберите «Окно» > «Общие библиотеки» > «Звуки». Чтобы импортировать звук из библиотеки звуков в файл Animate, перетащите его из библиотеки «Звуки» на панель «Библиотека» этого файла Animate. Также можно перетаскивать звуки из библиотеки звуков в другие общие библиотеки.

Звуки зачастую занимают большой объем оперативной памяти и места на диске. Звуковые данные в формате mp3 сжаты и имеют меньший размер, чем в форматах WAV или AIFF. Обычно при работе с файлами WAV и AIFF лучше всего пользоваться моно звуками 16-22 кГц (стерео занимает в два раза больше места), но Animate позволяет импортировать 8-битные или 16-битные звуки с частотой дискретизации 11, 22 или 44 кГц. Звуки, частота дискретизации которых не кратна 11 кГц (например, 8, 32 или 96 кГц), при импорте в программу Animate будут интерполированы. В Animate звук может быть приведен к более низкой частоте дискретизации при экспорте.

Если в Animate экспорте планируется добавление эффектов, то лучше всего импортировать 16-битный звук. Если на компьютере мало оперативной памяти, то лучше работать с короткими фрагментами или с 8-битным звуком вместо 16-битного звука.

Примечание.

Для импорта или воспроизведения звуков в среде Animate CC не требуется предварительная установка QuickTime или iTunes.

Поддерживаемые форматы звуковых файлов

Animate поддерживает импорт звуковых файлов в следующих форматах:

  • Adobe Sound (.asnd). Это собственный звуковой формат Adobe® Soundbooth™;

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • mp3

    Возможен импорт следующих дополнительных форматов звуковых файлов:

  • Sound Designer® II (.sd2);

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

Примечание.

  • Формат ASND — это недеструктивный формат аудиофайла Adobe Soundbooth. Файлы ASND могут содержать звуковые данные с эффектами, которые впоследствии можно изменять, многодорожечные сеансы Soundbooth и «мгновенные снимки», позволяющие вернуться к предыдущему состоянию файла ASND.
  • Документы типа WebGL и HTML5 Canvas поддерживают только форматы MP3 и WAV.

Добавление звуков в Animate

Добавление звука с компьютера на временную шкалу

Можно импортировать аудиофайл непосредственно с компьютера на временную шкалу одним из следующих способов:

  • Выберите Файл > Импорт > Импортировать в рабочую область и укажите аудиофайл, который нужно импортировать.
  • Перетащите аудиофайл в рабочую область/на временную шкалу. 

Обратите внимание, что можно добавлять только по одному аудиофайлу за один раз. При перетаскивании нескольких аудиофайлов на временную шкалу будет импортирован только один из них.

Добавление звука из медиатеки на временную шкалу

Звук может быть добавлен в документ из библиотеки либо загружен во время выполнения методом loadSound объекта Sound. Дополнительные сведения см. в разделе Класс Sound в руководстве ActionScript 3.0.

  1. Импортируйте звук в библиотеку, если он еще не импортирован.
  2. Выберите меню Вставка > Временная шкала > Слой.

    timeline-layer
  3. Выделив новый звуковой слой, перетащите звук из панели «Библиотека» в рабочую область. Звук будет добавлен в текущий слой.

    В одном слое может быть размещено несколько звуков либо звуки вместе с другими объектами. Хотя рекомендуется размещать каждый звук на отдельном слое. Каждый слой представляет собой отдельный звуковой канал. При воспроизведении SWF-файла звуки со всех слоев смешиваются.

  4. На временной шкале выделите первый кадр, в котором содержится звуковой файл.
  5. Выберите меню Окно > Свойства и щелкните стрелку в нижнем правом углу, чтобы открыть инспектор свойств.

  6. В инспекторе свойств выберите звуковой файл во всплывающем меню «Звук».
  7. Выберите нужный эффект из всплывающего меню «Эффекты».

    Не задано

    Не применяет никаких эффектов к звуковому файлу. Выберите этот параметр, чтобы удалить все примененные эффекты.

    Левый канал/правый канал

    Воспроизводит звук только в левом или правом каналах.

    Перемещение слева направо/Перемещение справа налево

    Перемещает звук из одного канала в другой.

    Сильнее

    Постепенно увеличивает громкость звука по мере его воспроизведения.

    Слабее

    Постепенно уменьшает громкость звука по мере его воспроизведения.

    Заказная

    Позволяет создавать заказную начальную и конечную точки звука по команде «Редактировать огибающую».

    Примечание.

    Эффекты не поддерживаются в документах WebGL и HTML5 Canvas.

  8. Выберите параметр синхронизации во всплывающем меню «Синхронизация».

    Событие

    Синхронизирует звук с возникновением события. Звук события воспроизводится при появлении его начального ключевого кадра и длится в течение всего события независимо от точки воспроизведения на временной шкале, даже если SWF-файл останавливается. Все звуки событий смешиваются при воспроизведении опубликованного SWF-файла.

    Если звук события воспроизводится и повторяется снова (например, когда пользователь еще раз нажимает кнопку или точка воспроизведения пересекает начальный ключевой кадр звука), первый экземпляр звука продолжает воспроизводиться и одновременно запускается второй экземпляр того же звука. Помните об этом при использовании более длительных звуков, так как может произойти их наложение, приводящее к неожиданным аудиоэффектам.

    Начало

    То же самое, что и «Событие», за исключением того, что, если звук уже воспроизводится, то воспроизведение второго экземпляра не начинается.

    Остановить

    Останавливает указанный звук.

    Поток

    Синхронизирует звук для воспроизведения на веб-сайте. Animate следит за тем, чтобы анимация не отставала от потокового звука. Если в Animate отрисовка кадров анимации выполняется недостаточно быстро, то будет производиться их пропуск. В отличие от звука события, потоковый звук останавливается при остановке воспроизведения SWF-файла. Кроме того, потоковый звук никогда не воспроизводится после окончания занимаемых им кадров. Потоковые звуки смешиваются при публикации SWF-файла.

    В качестве примера потокового звука можно привести голос персонажа анимации, который воспроизводится в нескольких кадрах.

    Animate запоминает параметры синхронизации звука в инспекторе свойств. Если выбрать звук в разделе «Звук» инспектора свойств, то при попытке задать в новом ключевом кадре другой звук из инспектора свойств Animate запоминает параметры синхронизации для свойств «Поток» или «Событие» предыдущего звука.

    Примечание.

    Если в качестве потокового звука используется mp3, то при экспорте его необходимо будет сжать заново. Звук может быть экспортирован в формате mp3 с теми же параметрами сжатия, которые применялись при импорте.

    Потоковый режим не поддерживается в документах WebGL и HTML5 Canvas.

  9. Укажите в параметре «Повторить» число повторов при воспроизведении звука либо выберите параметр «Цикл», чтобы он повторялся бесконечно.

    Для непрерывного воспроизведения введите число, достаточно большое для длительного воспроизведения звука. Например, чтобы 15-секундный звук воспроизводился в течение15 минут, введите значение 60. Зацикливать потоковый звук не рекомендуется. При зацикливании потокового звука в файл добавляются кадры, и размер файла увеличивается на число циклов повтора.

  10. Чтобы протестировать звук, перетащите точку воспроизведения по кадрам, в которых он содержится, либо воспользуйтесь командами в меню «Пульт управления» или в меню «Управление».

Удаление звука с временной шкалы

  1. В слое временной шкалы, который содержит звук, выберите кадр, также содержащий звук.
  2. В окне инспектора свойств перейдите в раздел «Звук» и выберите «Нет» в меню «Имя».

    Программа Animate удаляет звук из слоя временной шкалы.

Добавление звука к кнопке

Звук может быть связан с различными состояниями символа кнопки. Поскольку звуки хранятся вместе с символами, они будут доступны во всех экземплярах символа.

  1. Выберите кнопку на панели «Библиотека».
  2. В меню «Панель» в верхнем правом углу панели выберите «Редактировать».
  3. Во временной шкале кнопки добавьте слой для звука (меню Вставка > Временная шкала > Слой).

  4. На слое звука создайте обычный или пустой ключевой кадр, соответствующий состоянию кнопки, к которой добавляется звук.

    Выберите Вставка > Временная шкала > Ключевой кадр или Вставка > Временная шкала > Пустой ключевой кадр.

    Например, чтобы добавить звук, который будет воспроизводиться при нажатии кнопки, создайте ключевой кадр в кадре, имеющем метку «Вниз».

    insert-keyframes
  5. Щелкните созданный ключевой кадр.
  6. Выберите меню Окно > Свойства.

  7. В инспекторе свойств выберите звуковой файл во всплывающем меню «Звук».
  8. Во всплывающем меню «Синхронизация» выберите «Событие».

    Чтобы связать с каждым из ключевых кадров кнопки соответствующий звук, создайте пустой ключевой кадр и добавьте для каждого ключевого кадра другой звуковой файл. Можно также использовать для разных ключевых кадров кнопки тот же самый звуковой файл, применив другие звуковые эффекты.

Синхронизация звука с анимацией

Чтобы синхронизировать звук с анимацией, его следует запускать и останавливать на ключевых кадрах.

  1. Добавьте звук на специально выделенный слой временной шкалы (см. инструкции выше).
  2. Чтобы синхронизировать этот звук с событием на сцене, создайте начальный ключевой кадр для звука, соответствующего ключевому кадру события на сцене, где требуется воспроизвести звук. Можно выбрать любой из параметров синхронизации, описанных выше (см. подраздел «Добавление звука на временную шкалу»).
  3. Создайте на временной шкале слоя звука ключевой кадр в том месте, где должно заканчиваться воспроизведение звука. Представление звукового файла появляется на временной шкале.
  4. Выберите меню Окно > Свойства и щелкните стрелку в нижнем правом углу, чтобы открыть инспектор свойств.

  5. В инспекторе свойств выберите тот же звук во всплывающем меню «Звук».
  6. В окне инспектора свойств по-прежнему выберите «Остановить» в раскрывающемся меню «Синхронизация».

    При воспроизведении SWF-файла в момент достижения конечного ключевого кадра звук останавливается.

  7. Чтобы воспроизвести звук, перетащите точку воспроизведения на временной шкале.

Редактирование звуков

Редактирование звуков в Animate 

В Animate можно определить для звука начальную точку или управлять его громкостью по мере воспроизведения. Можно также изменить точку, в которой начинается и заканчивается воспроизведение звука. Это может помочь в уменьшении звукового файла путем удаления неиспользуемых разделов.

  1. Добавьте звук в кадр или выберите кадр, который уже содержит звук.
  2. Выберите меню Окно > Свойства.

    windows-properties
  3. Нажмите кнопку «Редактировать» в правой части инспектора свойств.
  4. Выполните одно из следующих действий.
    • Чтобы изменить начальную и конечную точку воспроизведения, перетащите элементы «Время начала» и «Время окончания» в окне «Изменить огибающую».

    • Форму огибающей звука изменяют, перетаскивая маркеры огибающей, которые позволяют изменить уровень в различных точках воспроизведения звука. Линии огибающей по мере воспроизведения отображают громкость звука. Для создания нового маркера огибающей (всего не более восьми) щелкните линию огибающей. Чтобы удалить маркер огибающей, перетащите его за пределы окна.

    • Изменить масштаб отображения звука в окне можно кнопками «Увеличить» и «Уменьшить».

    • Переключать единицы измерения времени между секундами и кадрами позволяют кнопки «Секунды» и «Кадры».

  5. Для прослушивания отредактированного звука нажмите кнопку «Воспроизвести».

Редактирование звука в Soundbooth

Если на компьютере установлена программа Adobe Soundbooth, можно использовать ее для редактирования звуков, импортированных в файл Animate. После внесения изменений в Soundbooth, когда файл сохранен с переписыванием оригинала, изменения автоматически вступают в силу и в файле Animate.

Если имя или формат файла изменены после редактирования, его придется импортировать в Animate еще раз.

Примечание.

Soundbooth поддерживается только на компьютерах Windows и на компьютерах Macintosh с процессором Intel®.

Чтобы импортировать звук в Soundbooth, выполните следующие действия.

  1. Щелкните правой кнопкой мыши (Windows) или левой кнопкой с удержанием клавиши Ctrl (Macintosh) на звуке в панели «Библиотека».
  2. В Soundbooth выберите «Редактировать» из контекстного меню. Файл откроется в Soundbooth.
  3. Измените файл в Soundbooth.
  4. После внесения изменений сохраните файл. Чтобы сохранить изменения в недеструктивном формате, выберите ASND. Если файл сохраняется в формате, отличном от исходного, его придется еще раз импортировать в Animate.

  5. Вернитесь в Animate, чтобы увидеть измененную версию звукового файла на панели Библиотека.

Примечание.

С помощью команды «Редактировать в Soundbooth» нельзя редактировать звуки из библиотеки «Звуки» («Окна» > «Общие библиотеки» > «Звуки»). Необходимо открыть Soundbooth и выбрать звук на панели «Центр ресурсов». Отредактированный таким образом звук следует импортировать в Animate.

Разделение или зацикливание звука на временной шкале

Разделение звука на временной шкале

Для разделения потокового звука, добавленного на временную шкалу, служит команда контекстного меню «Разделить аудио». Команда «Разделить аудио» дает возможность приостановить звук в нужный момент и возобновить его воспроизведение с того же места на одном из дальнейших кадров временной шкалы. Можно выбрать разделение потокового аудио на несколько частей с сохранением его эффектов.

Чтобы разделить аудиоклип на временной шкале и сохранить его эффекты, выполните следующие действия.

  1. Выберите меню Файл > Импорт > Импортировать в библиотеку

  2. Выберите нужный аудиоклип и импортируйте его в библиотеку.

  3. Создайте новый слой временной шкалы и добавьте аудиоклип в этот слой. 

  4. В разделе Свойства > Звук выберите эффект.

    audio_split
  5. В поле «Тип синхронизации» выберите «Поток».

    sound-properties-stream
  6. Щелкните правой кнопкой кадр, на котором нужно разделить звук, и выберите пункт Разделить аудио

    Split-audio

    Примечание.

    Аудиоэффекты сохраняются, даже если аудио перемещается в другой диапазон времени или кадров.

Зацикливание звука на временной шкале

Зацикливание звука — это многократное повторение небольшого звукового фрагмента на протяжении последовательности кадров на временной шкале. Когда параметр «цикл» включен на временной шкале, можно зациклить потоковый звук для диапазона кадров вместе с другими анимациями.

Чтобы создать цикл, включите параметр «Цикл» на временной шкале следующим образом:

Audio
Кнопка «Зацикливание звука» на временной шкале

Использование звуков во Flash Lite

Adobe® Flash® Lite поддерживает два типа звуков: стандартные звуки Animate (которые используются в настольных приложениях Animate) и звуки устройств. Flash Lite 1.0 поддерживает только звуки устройств. Flash Lite 1.1 и 2.x поддерживает как те, так и другие.

Звуки устройств хранятся в опубликованном SWF-файле в собственном аудиоформате (например, MIDI или Fi). Во время воспроизведения Flash Lite передает звуковые данные на устройство, которое декодирует и воспроизводит их. Так как импортировать многие аудиоформаты в Animate невозможно, импортируется прокси-звук в одном из поддерживаемых форматов (mp3, AIFF и др.), который заменяется указанным звуком внешнего устройства.

Звуки устройств могут использоваться как звуки событий, так как их невозможно синхронизировать с временной шкалой, как стандартные звуки.

Flash Lite 1.0 и Flash Lite 1.1 не поддерживают следующие функции, доступные в настольной версии Flash® Player:

  • Объект Sound для сценариев ActionScript

  • Загрузка внешних файлов mp3

  • Сжатие речи

Дополнительные сведения см. в разделе «Working with Sound, Video, and Images» руководства Developing Flash Lite 2.x Applications или разделе «Working with Sound» руководства Developing Flash Lite 1.x Applications.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет