Форматирование кода

Программный код может форматироваться автоматически при вводе. Если используется динамическая подстановка шрифтов, убедитесь, что для многоязычного текста применяются нужные шрифты.

Установка параметров автоформата

  1. Выполните одно из следующих действий.
    • В меню панели (в правой верхней части панели «Действия») выберите «Настройки».

    • В окне «Сценарий» выберите «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh).

  2. В диалоговом окне «Установки» выберите «Автоформат».
  3. Установите параметры автоформата.

    После установки настройки автоформата автоматически применяются к вводимому коду, однако к уже введенному коду новые параметры автоформата необходимо применить вручную.

Форматирование кода в соответствии с настройками автоформата

  • Выберите инструмент «Автоформат»  на панели «Действия» или в окне «Сценарий».
  • В меню панели (в правой верхней части панели «Действия») выберите «Автоформат».
  • Нажмите клавиши «Control» + «Shift» + «F» (Windows) или «Command» + «Shift» + «F» (Macintosh).
  • В окне «Сценарий» выберите «Инструменты > Автоформат».

Использовать динамическую подстановку шрифтов

  1. Для включения или отключения динамической подстановки шрифтов установите или снимите флажок «Использовать динамическую подстановку шрифтов» в диалоговом окне «Настройки».

    Динамическая подстановка шрифтов отключена по умолчанию, поскольку она снижает производительность при создании сценариев. При работе с многоязычным текстом необходимо включать динамическую подстановку шрифтов, поскольку она обеспечивает применение правильных шрифтов.

Использование автоотступа

  1. Чтобы включить или отключить автоотступ, установите или снимите флажок «Автоматические отступы» в диалоговом окне «Настройки».

    При установке автоотступа текст, который вводится после открытой простой «(» или фигурной «{» скобки, автоматически смещается вправо в соответствии с параметром табуляции в настройках ActionScript.

    В сценарии можно установить отступ строки, выбрав ее и нажав клавишу «Tab». Для удаления отступа выберите строку и нажмите клавиши «Shift» + «Tab».

Комментирование частей кода

Комментарии кода — это фрагменты кода, которые игнорируются компилятором языка ActionScript. Строка комментария объясняет, какие действия выполняет код, или временно отключает код, который не нужно удалять. Строка комментария начинается с двойной косой черты (//). Компилятор игнорирует весь текст в этой строке, идущий за двойной косой чертой. Можно также закомментировать блок кода, поместив косую черту со звездочкой (/*) в начале блока и звездочку с косой чертой (*/) в его конце.

Маркеры комментариев можно вводить вручную или с помощью кнопок в верхней части панели «Действия» или окна «Сценарий».

Комментирование строки кода

  1. Поместите курсор вставки в начало строки или перед символом, где должен начинаться комментарий.
  2. Щелкните правой кнопкой мыши и выберите «Комментировать». Также можно использовать комбинации клавиш Ctrl + M (Windows) или Command + M, либо пункт меню «Правка» > «Комментировать выделенный фрагмент».

Под курсором вставки появится двойная косая черта (//).

Комментирование нескольких строк кода

  1. Выделите строки, которые необходимо закомментировать. (Первую и последнюю строку можно закомментировать не полностью.)
  2. Щелкните правой кнопкой мыши и выберите «Комментировать». Также можно использовать комбинации клавиш Ctrl + M (Windows) или Command + M, либо пункт меню «Правка» > «Комментировать выделенный фрагмент».

Символы блока комментариев появятся в начале (/*) и конце (*/) выделенных строк.

Примечание.

Если среди выделенных строк текста уже присутствуют комментарии, то каждая строка будет закомментирована по отдельности.

Удаление комментария

  1. Поместите курсор вставки в строку, которая содержит комментарий, или выделите закомментированный блок кода.
  2. Щелкните правой кнопкой мыши и выберите «Удалить комментарий». Также можно использовать комбинации клавиш Ctrl + Shift + M (Windows) или Command + Shift + M либо пункт меню «Правка» > «Удалить комментарий выделенного фрагмента».

Использование цветовой подсветки синтаксиса

В ActionScript, как и в любом другом языке, синтаксис — это способ объединения элементов языка и придания им значения. При неверном синтаксисе ActionScript сценарий не будет работать.

Для цветовой подсветки синтаксических ошибок установите цветомаркировку для различных составляющих сценария. Допустим, для ключевых слов установлена синяя цветомаркировка. В этом случае при вводе var слово var отображается синим цветом. Однако если по ошибке напечатать vae, слово vae останется черным, и это указывает на ошибку ввода.

Выполните одно из следующих действий.

  • Выберите «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh), нажмите «Редактор кода» в списке «Категория» и задайте параметры цветовой маркировки синтаксиса.

  • Установите курсор вставки на панели «Сценарий» и нажмите клавиши «Control» + «U» (Windows) или «Command» + «U» (Macintosh).

Примечание.

При создании сценариев на панели «Действия» команды, не поддерживаемые версией проигрывателя, для которого предназначен сценарий, отображаются на панели инструментов «Действия» желтым цветом. Например, если для SWF-файла Flash Player задана версия Flash 7, желтым цветом на панели инструментов «Действия» будут выделены элементы языка ActionScript, которые поддерживаются только в версии Flash Player 8.

Использование списков ключевых слов и идентификаторов во время выполнения

При запуске Animate списки ключевых слов и идентификаторов считываются из файла ресурсов и кэшируются. Помимо списков по умолчанию, входящих в состав ресурса, программа также ищет дополнительные списки ключевых слов и идентификаторов в папке пользовательских настроек. Эти дополнительные списки можно добавить в виде файлов .txt в следующие папки:

  • C:\Пользователи\<Имя пользователя>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Пользователи\<Имя пользователя>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Пользователи\<Имя пользователя>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Пользователи\<Имя пользователя>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Использование номеров строк и перенос слов

При редактировании кода номера строк облегчают прокрутку и анализ кода. Перенос слов помогает избежать горизонтальной прокрутки длинных строк кода (особенно при работе в среде разработчика или при низких разрешениях экрана).

Включение и отключение номеров строк

  • В окне «Сценарий» выберите «Просмотр» > «Номера строк».
  • Нажмите клавиши «Control» + «Shift» + «L» (Windows) или «Command» + «Shift» + «L» (Macintosh).

Подсветка одиночной строки

  • В окне «Сценарий» выберите «Правка > «Перейти к строке».

Включение и отключение переноса слов

  • В окне «Сценарий» выберите «Просмотр» > «Перенос слов».
  • Нажмите клавиши «Control» + «Shift» + «W» (Windows) или «Command» + «Shift» + «W» (Macintosh).

Отображение скрытых символов

В коде ActionScript скрыты такие символы, как пробел, табуляция и разрыв строки. Эти символы могут отображаться, например, если нужно найти двухбайтовые пробелы, не являющиеся частью строкового значения, потому что они вызывают ошибки компиляции.

  • Нажмите клавиши «Control» + «Shift» + «8» (Windows) или «Command» + «Shift» + «8» (Macintosh).

Для отображения скрытых символов используются следующие знаки.

Скрытый символ

Символ

Однобайтовый пробел

.

Двухбайтовый пробел

l

Табуляция

>>

разрыв строки


Поиск текста в сценарии

Инструмент «Найти» позволяет искать и заменять текстовые строки в сценариях.

Примечание.

Чтобы выполнить поиск по всему тексту в каждом сценарии документа Animate, используется панель «Обзор ролика».

Поиск текста

  1. На панели «Действия» или в окне «Сценарий» нажмите «Найти»  или нажмите клавиши «Control» + «F» (Windows) либо «Command» + «F» (Macintosh).
  2. Введите строку поиска.
  3. Нажмите кнопку «Найти далее».

Поиск и замена текста в сценарии

  1. На панели «Действия» или в окне «Сценарий» нажмите «Найти»  или нажмите клавиши «Control» + «F» (Windows) либо «Command» + «F» (Macintosh).
  2. Введите строку поиска.
  3. В поле «Заменить» введите новую строку.
  4. Нажмите кнопку «Найти далее».
  5. Чтобы заменить строку, нажмите кнопку «Заменить», чтобы заменить все вхождения этой строки, нажмите кнопку «Заменить все».

(Не поддерживается в Animate.) Повтор поиска в панели «Действия»

  1. В меню панели  (в правой верхней части панели «Действия») выберите «Повторить поиск».

(Не поддерживается в Animate.) Повтор поиска в окне «Сценарий»

  1. Выберите «Правка» > «Повторить поиск».

(Не поддерживается в Animate.) Проверка синтаксиса и пунктуации

Можно выполнить быструю проверку кода ActionScript, не публикуя FLA-файл.

При проверке синтаксиса проверяется текущий сценарий. Если текущий сценарий вызывает классы ActionScript, они также проверяются. Другие сценарии, которые могут присутствовать в FLA-файле, не проверяются.

Для файлов ActionScript 2.0 проверка синтаксиса выполняет код через компилятор, создавая ошибки синтаксиса и компилятора.

Для файлов ActionScript 3.0 проверка синтаксиса создает только ошибки синтаксиса. Чтобы получить ошибки компилятора, такие как несоответствия типов, возврат неверных значений, ошибки в именах переменных или методов, необходимо использовать команду «Управление» > «Тест».

Проверка синтаксиса

Чтобы проверить синтаксис, выполните одно из следующих действий.

  • На панели «Действия» или в окне «Сценарий» нажмите «Проверить синтаксис» .
  • Щелкните мышью в поле «Сценарий» и нажмите клавиши «Control» + «T» (Windows) или «Command» + «T» (Macintosh). При щелчке или вводе текста на панели «Сценарий» на нее переводится фокус. Если фокус установлен на объекте в рабочей области, открывается панель «Преобразование».

Список синтаксических ошибок приводится на панели «Ошибки компиляции».

Примечание.

Во внешнем файле классов ActionScript в окне «Сценарий» глобальный путь к классам (AS2) или исходный путь (AS3) влияет на проверку синтаксиса. Даже если глобальный путь к классам установлен правильно, могут возникнуть ошибки, поскольку компилятору неизвестно, что компилируется именно этот класс.

Проверка симметричности пунктуации

  1. Щелкните мышью в сценарии между фигурными скобками {}, квадратными [] или простыми ().
  2. В Windows нажмите клавиши «Control» + ' (одинарная кавычка), в Macintosh — Command + ' (одинарная кавычка). Текст внутри скобок будет подсвечен, и можно будет проверить парность открывающей и закрывающей скобок.

(Не поддерживается в Animate.) Импорт и экспорт сценариев

Сценарий можно импортировать на панель «Действия» или окно «Сценарий». Из панели «Действия» сценарии также можно экспортировать во внешние файлы ActionScript. (При работе в окне «Сценарий» экспорт не нужен, поскольку можно просто сохранить AS-файл.)

Если при открытии или импорте файла текст сценария выглядит не так, как ожидалось, измените настройки кодировки при импорте.

Импорт внешнего AS-файла

  1. На панели «Сценарий» установите курсор вставки там, где нужно разместить первую строку внешнего сценария.
  2. Выполните одно из следующих действий.
    • На панели «Действия» выберите «Импортировать сценарий» в меню панели или нажмите клавиши «Control» + «Shift» + «I» (Windows) либо «Command» + «Shift» + «I» (Macintosh).

    • В окне «Сценарий» выберите «Файл» > «Импортировать сценарий» или нажмите клавиши «Control» + «Shift» + «I» (Windows) либо «Command» + «Shift» + «I» (Macintosh).

Экспорт сценария из панели «Действия»

  1. Выберите сценарий, который нужно экспортировать. Затем на панели «Действия» выберите «Экспортировать сценарий» в меню панели или нажмите клавиши «Control» + «Shift» + «X» (Windows) либо «Command» + «Shift» + «X» (Macintosh).
  2. Сохраните файл ActionScript (AS-файл).

Установка параметров кодировки текста

  1. Выберите «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh) и нажмите «ActionScript» в списке «Категория».

  2. Установите любой из следующих параметров.

    Открыть/Импортировать

    Выберите кодировку UTF-8 для открытия и импорта с помощью кодировки Юникода или выберите «Кодировка по умолчанию» для открытия и импорта с помощью кодировки, которую использует система.

    Сохранить/Экспортировать

    Выберите кодировку UTF-8 для сохранения и экспорта с помощью кодировки Юникода или выберите «Кодировка по умолчанию» для сохранения и экспорта с помощью кодировки языка, которую использует система.

Включение и отключение предупреждения о кодировке при экспорте

  1. Выберите «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh) и нажмите «Предупреждения» в списке «Категория».

  2. Установите или снимите флажок «Предупреждать о конфликтах кодировки при экспорте файлов ActionScript».

(Не поддерживается в Animate.) Кодировка импортированных и экспортированных сценариев

Можно задать установки ActionScript, чтобы определить, какой тип кодировки следует использовать в импортируемых и экспортируемых файлах ActionScript. Кодировка UTF‑8 — это 8-битный формат Юникода, позволяющий включать в файл текст на нескольких языках. Кодировкой по умолчанию является текущая кодировка языка системы, которая также называется кодовой страницей по умолчанию.

Примечание.

При использовании локализованных приложений в системе с английским языком команда «Тестировать ролик» возвращает ошибку, если в пути доступа к SWF-файлу встречаются символы, которые нельзя представить в схеме кодировки многобайтовых наборов символов (MBCS). Например, пути доступа, представленные на японском языке и работающие в японских системах, не будут работать в системах на английском языке. В английских системах необходимо использовать пути доступа только на английском языке. Это ограничение применяется ко всем элементам приложений, использующим проигрыватель Test Movie.

Закрепление сценариев на панели «Действия»

Используйте функцию «Закрепить сценарий» для закрепления вкладок отдельных сценариев на панели «Сценарий» и их перемещения по ней. Эта функция полезна, если код файла FLA не упорядочен относительно одного централизованного местоположения или используется несколько сценариев.

Можно закрепить сценарий, чтобы оставить открытым расположение кода на панели «Действия» и переключаться между несколькими открытыми сценариями. Это особенно полезно при отладке. 

Можно отменить закрепление одного или всех сценариев, чтобы открепить выделенный сценарий или все сценарии на панели «Действия».

На следующем рисунке сценарий, связанный с текущим местоположением на временной шкале, находится на кадре 1 слоя с именем Cleanup. (Крайняя слева вкладка всегда соответствует местоположению на временной шкале.) Этот сценарий закреплен (показано на крайней правой вкладке). Следующие два сценария закреплены.

  • Кадр 1 
  • Кадр 15 слоя Intro

Между закрепленными сценариями можно перемещаться, нажимая на нужные вкладки или используя комбинации клавиш. Перемещение от одного закрепленного сценария к другому не изменяет текущее положение на временной шкале. Если в навигаторе сценариев действий выбран новый сценарий, фокус смещается на первый кадр, например кадр 1.

Примечание.

Если содержимое поля «Сценарий» не меняется при перемещении по временной шкале, в поле «Сценарий», вероятно, отображается закрепленный сценарий. Щелкните текущий кадр в верхней левой части панели «Сценарий», чтобы отобразить сценарий, связанный с местоположением на временной шкале.

as_pin_scripts
Закрепленный сценарий

Закрепление сценария

  1. Щелкните временную шкалу, чтобы на панели Действия появился сценарий в левой верхней части поля Сценарий.

  2. Выполните одно из следующих действий.
    • Щелкните значок канцелярской кнопки справа на вкладке.
    • Выберите Просмотр > Закрепить сценарий.

     

Открепить все сценарии

  1. Выберите закрепленный сценарий на панели «Действия».

  2. Выберите «Просмотр» > «Открепить сценарий», чтобы открепить выделенный сценарий от панели «Действия».

  3. Выберите «Просмотр» > «Открепить все сценарии», чтобы открепить все сценарии от панели «Действия».

pinscript4
Параметры открепления

Клавиатурные сокращения для закрепленных сценариев

Если курсор вставки находится на панели «Сценарий», для работы с закрепленными сценариями используются следующие клавиатурные сокращения.

Операция

Windows 

Macintosh

Закрепить сценарий

«Control» + «Shift» + «=» (знак равно)

«Command» + «Shift» + «=»

Отменить закрепление сценария

«Control» + «Shift» + «-» (знак минус)

«Command» + «Shift» + «-»

Вставка целевых путей

Многие действия сценариев затрагивают фрагменты роликов, кнопки и другие экземпляры символов. В программном коде можно ссылаться на экземпляры символов на временной шкале, указывая целевой путь — адрес нужного экземпляра. Можно указывать абсолютный или относительный целевой путь. Абсолютный целевой путь содержит полный адрес экземпляра. Относительный целевой путь содержит только ту часть адреса, которая отличается от адреса самого сценария в FLA-файле и становится недействительным, если сценарий перемещается в другое местоположение.

  1. На панели «Действия» нажмите нужное действие в сценарии.
  2. Нажмите «Целевой путь» .
  3. Введите путь к целевому экземпляру или выберите из списка.
  4. Выберите абсолютный или относительный путь назначения.

Использование подсказок кода

При работе на панели «Действия» или окне «Сценарий» программа может определить вводимое действие и вывести соответствующую подсказку кода . Существует два типа подсказок кода: всплывающая подсказка с полным синтаксисом действия и всплывающее меню, в котором приводится список всех возможных элементов ActionScript, таких как методы или имена свойств (иногда такое меню называют формой завершения кода).

Подсказки кода включены по умолчанию. В установках можно отключить подсказки кода или определить скорость их появления. Если подсказки кода отключены, можно вручную вывести подсказку кода для конкретной команды.

Примечание.

Если не удается вывести подсказки кода для переменной или объекта, созданных на языке ActionScript 2.0, но подсказки кода включены в установках ActionScript, убедитесь, что у имени переменной или объекта правильный суффикс и что для этой переменной или объекта использован режим строгой типизации.

Включение подсказок кода

Подсказки кода можно запускать разными способами.

Строгая типизация для объектов

При использовании ActionScript 2.0 и строгой типизации для переменной, основанной на встроенном классе (например, Button, Array и так далее), на панели «Сценарий» отображаются подсказки кода для этой переменной. Представим, что вводятся следующие две строки кода:

var foo:Array = new Array(); 
foo.

Как только вводится точка (.), Animate отобразит список методов и свойств, доступных для объектов Array, во всплывающем меню, поскольку тип переменной был определен как массив.

Суффиксы и подсказки кода

Если используется ActionScript 1.0 или нужно отображать подсказки кода для объектов без строгой типизации, при создании каждого объекта добавьте суффикс к имени этого объекта. Например, суффиксом, запускающим подсказки кода для класса Camera, является _cam. Допустим, вводится следующий программный код: var my_array = new Array(); var my_cam = Camera.get();

Если затем ввести my_cam и точку, появятся подсказки кода для объекта Camera.

Для объектов, которые появляются в рабочей области, используется суффикс в поле «Имя экземпляра» в инспекторе свойств. Например, чтобы вывести подсказки кода для объектов MovieClip, используется инспектор свойств для присвоения именам экземпляров суффикса _mc всем объектам MovieClip. После этого при вводе имени экземпляра, за которым следует точка, появится подсказка кода.

var my_array = new Array(); 
var my_cam = Camera.get();

Примечание.

Хотя при использовании строгой типизации для запуска подсказок кода не требуются суффиксы, их использование делает программный код более понятным.

В следующей таблице приводится список суффиксов, которые запускают подсказки кода в языке ActionScript 2.0.

Тип объекта

Суффикс переменной

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Комментарии и подсказки кода

Чтобы задать класс объекта для подсказок кода, можно также использовать примечания ActionScript. В следующем примере примечание сообщает ActionScript, что классом экземпляра theObject является Object и так далее.

// Object theObject;// Array theArray;// MovieClip theMC;

Если затем ввести theMC и точку, отобразятся подсказки кода со списком методов и свойств MovieClip. Если ввести theArray и точку, появятся подсказки кода со списком методов и свойств Array и так далее.

Однако вместо этого метода рекомендует использовать строгую типизацию или суффиксы, поскольку такие методы автоматически включают подсказки кода и делают программный код более понятным.

Настройки автоматического вывода подсказок кода

  • На панели «Действия» или в окне «Сценарий» выберите «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh), выберите «Редактор кода» в списке категорий и включите или отключите параметр «Подсказки кода».

(Не поддерживается в Animate.) Установка задержки подсказок кода

  1. На панели «Действия» или в окне «Сценарий» выберите «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh).

  2. Нажмите ActionScript в списке категорий.
  3. С помощью ползунка установите время задержки (в секундах).

Использование всплывающих подсказок кода

  1. Отобразите подсказку кода, введя открывающую скобку «(» после элемента, требующего скобки (например, после имени метода или команды if либо do..while и так далее).
    as_code_hint_paren1
    Открывающая скобка вызывает подсказку кода.

  2. Введите значение параметра.

    Значения для нескольких параметров разделяются запятыми. Значения для функций и операторов, например для цикла for, разделяются точками с запятой.

    Для перегружаемых команд (функций или методов, которые можно вызывать с разными наборами параметров), например gotoAndPlay() или for, отображается индикатор, позволяющий выбрать нужный параметр. Для выбора параметра щелкните одну из маленьких стрелок или нажмите клавиши «Control» + «Стрелка влево» или «Control» + «Стрелка вправо».

    as_code_hint_paren3
    Подсказка кода с несколькими наборами параметров.

  3. Чтобы закрыть подсказку кода, выполните одно из следующих действий.
    • Введите закрывающую скобку «)».

    • Щелкните мышью за пределами оператора.

    • Нажмите клавишу «Escape».

Использование подсказок кода в меню

  1. Отображение подсказок кода при вводе точки после имени переменной или объекта.
    as_code_hint_dot1
    Подсказки кода в меню

  2. Для перемещения по подсказкам кода используются клавиши со стрелками вверх и вниз.
  3. Чтобы выбрать элемент меню, нажмите клавишу «Enter» или «Tab» либо дважды щелкните мышью этот элемент.
  4. Чтобы закрыть подсказку кода, выполните одно из следующих действий.
    • Выберите один из элементов меню.

    • Щелкните мышью над окном меню или под ним.

    • Введите закрывающую скобку «)», если уже введена открывающая «(».

    • Нажмите клавишу «Escape».

Вывод подсказки кода вручную

  1. Щелкните мышью место в коде, где может появиться подсказка кода, например следующие места.
    • после точки (.); после оператора или команды, где нужно ввести свойство или метод;

    • между скобками [()] в имени метода.

  2. Выполните одно из следующих действий.
    • Чтобы включить подсказки кода вручную, выберите пункт меню «Вид» > «Показать подсказку кода».

    • Нажмите клавиши Control + Пробел (Windows) или Command + Пробел (Macintosh).

Подсказки кода для заказных классов

При создании пользовательских классов ActionScript 3.0 среда Animate автоматически анализирует классы и определяет включенные в них объекты, свойства и методы. В процессе написания кода, в котором используются ссылки на пользовательские классы, можно воспользоваться подсказкой кода Animate. Завершение кода заказного класса выполняется автоматически для любого класса, связываемого с любым другим кодом командой import.

Подсказка кода ускоряет работу разработчиков, поскольку им не требуется запоминать все объекты, методы и свойства, используемые классом. Дизайнеры могут работать с классами, которые они не создавали самостоятельно, поскольку не требуется личный опыт работы с этими классами.

Подсказка кода включает следующее:

  • Подсказка кода для ступенчатых ссылок классов

    При написании ступенчатых ссылок постоянная поддержка подсказок кода может быть полезной.

  • Подсказка кода для строки this

    При вводе строки this в файле класса создается подсказка кода для этого класса.

  • Подсказка кода для строки «new+<пробел>»

    При вводе строки «new+<пробел>» в среде Animate отображается список доступных классов и пакетов.

  • Подсказка кода для строки import

    При вводе строки «import + <пробел>» в среде Animate отображается список всех встроенных и заказных пакетов.

  • Подсказка кода для библиотек SWC

    При добавлении библиотеки SWC в путь к внешней библиотеке в среде Animate включаются подсказки кода для всех классов, содержащихся в SWC-файле.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет