Руководство пользователя Отмена

Параметры публикации ActionScript

  1. Руководство пользователя Adobe Animate
  2. Введение в Animate
    1. Новые возможности Animate
    2. Визуальный глоссарий
    3. Системные требования Animate
    4. Сочетания клавиш Animate
    5. Разные типы файлов в Animate
  3. Анимация
    1. Основы анимации в Animate
    2. Кадры и ключевые кадры в Animate
    3. Покадровая анимация в Animate
    4. Классическая анимация движения в Animate
    5. Инструмент «Кисть»
    6. Руководство по движению
    7. Анимация движения и язык ActionScript 3.0
    8. Сведения об анимации движения
    9. Анимация движения
    10. Создание анимации движения
    11. Использование ключевых кадров свойств
    12. Положения в анимации движения
    13. Использование Редактора движения для анимаций
    14. Редактирование траектории анимации движения
    15. Управление анимациями движения
    16. Настраиваемое ускорение и замедление
    17. Создание и применение стилей движения
    18. Настройка диапазонов анимации движения
    19. Сохранение анимации движения в файлах XML
    20. Анимация движения и классическая анимация
    21. Анимация фигур
    22. Инструмент «Кость» в Animate
    23. Скелетная анимация персонажей в Animate
    24. Слои-маски в Adobe Animate
    25. Работа со сценами в Animate
  4. Интерактивность
    1. Создание кнопок в Animate
    2. Преобразование проектов Animate в другие форматы документов
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Добавление интерактивных возможностей с помощью фрагментов кода в Animate
    5. Создание пользовательских компонентов HTML5
    6. Использование компонентов в HTML5 Canvas
    7. Создание пользовательских компонентов: примеры
    8. Фрагменты кода для пользовательских компонентов
    9. Рекомендации: реклама в Animate
    10. Разработка и публикация контента для виртуальной реальности
  5. Рабочая среда и рабочий процесс
    1. Создание и использование малярных кистей
    2. Использование шрифтов Google в документах HTML5 Canvas
    3. Использование библиотек Creative Cloud Libraries и Adobe Animate
    4. Использование рабочей области и панели «Инструменты» в Animate
    5. Рабочие процессы и рабочая среда Animate
    6. Использование веб-шрифтов в документах HTML5 Canvas
    7. Временные шкалы и ActionScript
    8. Работа с несколькими временными шкалами
    9. Задание настроек
    10. Использование панелей разработки Animate
    11. Создание слоев временной шкалы в Animate
    12. Экспорт анимаций для мобильных приложений и игровых платформ
    13. Перемещение и копирование объектов
    14. Шаблоны
    15. Поиск и замена в Animate
    16. Отмена/повтор действий и панель «История»
    17. Сочетания клавиш
    18. Использование временной шкалы в Animate
    19. Создание HTML-расширений
    20. Параметры оптимизации изображений и GIF-анимаций
    21. Настройки экспорта для изображений и GIF
    22. Панель «Ресурсы» в Animate
  6. Мультимедиа и видео
    1. Преобразование и объединение графических объектов в Animate
    2. Создание экземпляров символов и работа с ними в Animate
    3. Трассировка изображения
    4. Использование звука в Adobe Animate
    5. Экспорт SVG-файлов
    6. Создание видеофайлов для использования в Animate
    7. Добавление видео в Animate
    8. Работа с ключевыми точками видео
    9. Рисование и создание объектов в Animate
    10. Изменение линий и фигур
    11. Обводки, заливки и градиенты в Animate CC
    12. Работа с Adobe Premiere Pro и After Effects
    13. Панели «Цвет» в Animate CC
    14. Открытие файлов Flash CS6 в Animate
    15. Работа с классическим текстом в Animate
    16. Размещение иллюстраций в Animate
    17. Импортированные растровые изображения в Animate
    18. Трехмерная графика
    19. Работа с символами в Animate
    20. Рисование линий и фигур в Adobe Animate
    21. Работа с библиотеками в Animate
    22. Экспорт звуков
    23. Выделение объектов в Animate CC
    24. Работа с AI-файлами Illustrator в Animate
    25. Нанесение узоров с помощью инструмента «Аэрограф»
    26. Применение режимов наложения
    27. Упорядочивание объектов
    28. Автоматизация задач с помощью меню «Команды»
    29. Многоязычный текст
    30. Использование камеры в Animate
    31. Использование Animate с Adobe Scout
    32. Работа с файлами Fireworks
    33. Графические фильтры
    34. Звук и ActionScript
    35. Настройки рисования
    36. Рисование инструментом «Перо»
  7. Платформы
    1. Преобразование проектов Animate в другие форматы документов
    2. Поддержка специализированных платформ
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Создание и публикация документа WebGL
    5. Упаковка приложений AIR for iOS
    6. Публикация приложений AIR for Android
    7. Публикация для Adobe AIR на настольных ПК
    8. Параметры публикации ActionScript
    9. Рекомендации: размещение ActionScript в приложении
    10. Использование ActionScript в Animate
    11. Рекомендации: специальные возможности
    12. Специальные возможности в среде Animate
    13. Создание и использование сценариев
    14. Обеспечение поддержки специализированных платформ
    15. Общие сведения о поддержке специализированных платформ
    16. Создание содержимого со специальными возможностями
    17. Работа с плагинами поддержки специализированных платформ
    18. Отладка сценариев ActionScript 3.0
    19. Обеспечение поддержки специализированных платформ
  8. Экспорт и публикация
    1. Экспорт файлов из Animate CC
    2. Публикация OAM
    3. Экспорт SVG-файлов
    4. Экспорт графики и видео из Animate
    5. Публикация документов AS3
    6. Экспорт анимаций для мобильных приложений и игровых платформ
    7. Экспорт звуков
    8. Экспорт видеофайлов в QuickTime
    9. Управление воспроизведением внешнего видео с помощью ActionScript
    10. Рекомендации: советы по созданию контента для мобильных устройств
    11. Рекомендации: правила работы с видео
    12. Рекомендации: руководство по созданию SWF-приложений
    13. Рекомендации: формирование структуры FLA-файлов
    14. Рекомендации: оптимизация FLA-файлов для Animate
    15. Параметры публикации ActionScript
    16. Задание параметров публикации для Animate
    17. Экспорт файлов-проекторов
    18. Экспорт изображений и анимированных файлов GIF
    19. Шаблоны публикации HTML
    20. Работа с Adobe Premiere Pro и After Effects
    21. Быстрая публикация анимаций

В этой статье рассматривается работа с параметрами публикации ActionScript в Adobe Animate.

Изменение параметров публикации ActionScript

При создании FLA-документа Animate запрашивает, какую версию ActionScript нужно использовать. Этот параметр можно изменить позже, если возникнет необходимость создавать сценарии в версии ActionScript.

 Язык ActionScript 3.0 несовместим с ActionScript 2.0. Компилятор ActionScript 2.0 может компилировать весь код ActionScript 1.0, за исключением синтаксиса с косой чертой (/), который используется для указания путей к фрагменту ролика (например, parentClip/testMC:varName= "hello world"). Чтобы избежать этой проблемы, перепишите код, используя нотацию с точкой (.), или используйте компилятор ActionScript 1.0.

  1. Выберите «Файл» > «Параметры публикации».
  2. Выберите версию ActionScript из всплывающего меню «Сценарий».

Файлы классов и файлы конфигурации

При установке Animate в системе создаются несколько папок и файлов конфигурации, относящихся к ActionScript. Перед модификацией этих файлов для настройки среды разработчика сохраните резервные копии исходных файлов.

Папка классов ActionScript

Содержит все встроенные классы ActionScript 2.0 (в виде AS-файлов). Обычные пути к этой папке.

  • Windows 7 и 8: <жесткий диск>\Program Files\Adobe\Adobe Animate\Common\Configuration\ActionScript 3.0\Configuration\Classes

  • Macintosh: <жесткий диск>/Users/пользователь/Library/Application Support/Adobe/Animate/язык/Configuration/Classes

    Папка классов Classes разделена на классы для Flash Player 10 и классы для Flash Player 11. Дополнительные сведения об организации этого каталога см. в файле Read Me в папке Classes.

Папка класса Include

Содержит все глобальные включаемые файлы ActionScript. Пути к этой папке:

  • Windows 7 и 8: <жесткий диск>\Program Files\Adobe\Adobe Animate\Common\Configuration\ActionScript 3.0\libs\

  • Macintosh: <жесткий диск>/Users/пользователь/Library/Application Support/Adobe/Animate/язык/Configuration/Include

Файл конфигурации ActionsPanel.xml

Включает файл конфигурации для подсказок кода ActionScript. В отдельных файлах содержатся данные конфигурации для каждой версии ActionScript и Flash Lite, а также для JavaScript. Пути к этой папке:

  • Windows 7 и 8: <жесткий диск>\Program Files\Adobe\Adobe Animate\Common\Configuration\ActionScript 3.0\libs\

  • Macintosh: <жесткий диск>/Users/пользователь/Library/Application Support/Adobe/Animate/язык/Configuration/ActionsPanel

Файл конфигурации AsColorSyntax.xml

Файл конфигурации для цветовой подсветки синтаксиса в коде ActionScript. Пути к этой папке:

  • Windows 7 и 8: <жесткий диск>\Program Files\Adobe\Adobe Animate\Common\Configuration\ActionScript 3.0\libs\

  • Macintosh: <жесткий диск>/Users/пользователь/Library/Application Support/Adobe/Animate/язык/Configuration/ActionsPanel

Объявление класса документа ActionScript 3.0

При использовании ActionScript 3.0 SWF-файл может иметь связанный с ним класс более высокого уровня. Такой класс называется классом документа. При загрузке SWF-файла в Flash Player создается экземпляр класса, который является объектом верхнего уровня для этого SWF-файла. Такой объект SWF-файла может быть экземпляром любого заказного класса.

Например, в SWF-файле, реализующем компонент календаря, объект верхнего уровня может быть связан с классом Calendar, с методами и свойствами, соответствующими компоненту календаря. При загрузке такого SWF-файла Flash Player создает его как экземпляр класса Calendar.

  1. Отмените выделение всех объектов в рабочей области и на временной шкале, щелкнув мышью пустую область в рабочей области. В инспекторе свойств отобразятся свойства документа.
  2. Введите имя файла ActionScript для класса в текстовом поле «Класс документа» в инспекторе свойств. Не включайте расширение имени файла .as.

 Информацию о классе документа также можно ввести в диалоговом окне «Параметры публикации».

 Дополнительно можно указать имя класса в файле SWC (привязанном через параметр «Путь к библиотеке»), назначив этот класс в качестве класса документа.

Указание местоположения файлов ActionScript

Для работы с уже определенным классом ActionScript Animate требуется определить местонахождение внешних файлов ActionScript, которые содержат его определение. Список папок, в которых Animate ищет определения классов, называется путем к классам в ActionScript 2.0 и исходным путем в ActionScript 3.0. Пути к классам и исходные пути существуют на уровне приложения (глобально) и на уровне документа. Дополнительные сведения о путях к классам см. в разделе «Классы» в руководстве Изучение ActionScript 2.0 в Adobe Animate или в разделе Пакеты в руководстве Изучение ActionScript 3.0.

В Animate можно задать следующие местоположения ActionScript.

  • ActionScript 2.0

    • На уровне приложения (доступно для всех FLA-файлов AS2):

      • Путь к классам (задается в параметрах ActionScript)

    • На уровне документа (доступно только для FLA-файла, который указывает этот путь):

      • Путь к классам (задается в параметрах публикации)

  • ActionScript 3.0

    • На уровне приложения (доступно для всех FLA-файлов AS3):

      • Исходный путь (задается в параметрах ActionScript)

      • Путь к библиотеке (задается в параметрах ActionScript)

      • Путь к внешней библиотеке (задается в параметрах ActionScript)

    • На уровне документа (доступно только для FLA-файла, который указывает эти пути):

      • Исходный путь (задается в параметрах публикации)

      • Путь к библиотеке (задается в параметрах публикации)

      • Класс документа (задается в инспекторе свойств документа)

Путь к библиотеке указывает местоположение еще не скомпилированного кода ActionScript, который находится в созданных SWC-файлах. FLA-файл, указывающий этот путь, загружает каждый SWC-файл на верхнем уровне этого пути и другие ресурсы кода, указанные в этих SWC-файлах. Используя путь к библиотеке, убедитесь, что скомпилированный код в SWC-файлах не дублируется в нескомпилированных AS-файлах в исходном пути. Наличие продублированного кода замедляет компиляцию SWF-файла.

Для Animate можно задать более одного пути для поиска. Будут использоваться ресурсы, найденные по любому из указанных путей. При добавлении или модификации пути можно добавить абсолютные пути (например, C:/my_classes) и относительные пути (например, ../my_classes или «.»).

Установка подкаталогов классов для ActionScript 2.0

Примечание. ActionScript 2.0 в Animate не поддерживается. Дополнительные сведения см. в этой статье

Чтобы задать путь к классам на уровне документа, выполните следующие действия.

  1. Выберите меню «Файл» > «Параметры публикации», а затем «Flash».

  2. Убедитесь, что во всплывающем меню «Версия ActionScript» выбрано значение ActionScript 2.0, а затем нажмите кнопку «Настройки».
  3. В текстовом поле «Экспортировать кадр для классов» укажите кадр, в котором должно находиться определение класса.
  4. Чтобы добавить пути в список путей к классам, выполните одно из следующих действий.
    • Чтобы добавить к подкаталогам классов новую папку, нажмите кнопку  «Перейти к пути», выберите нужную папку и нажмите кнопку ОК.

    • Чтобы добавить к списку подкаталогов классов новую строку, нажмите кнопку «Добавить новый путь» . Дважды щелкните новую строку, введите относительный или абсолютный путь, а затем нажмите кнопку ОК.

    • Чтобы изменить существующую папку подкаталогов классов, выделите путь в списке подкаталогов классов, нажмите кнопку «Перейти к пути», выберите другую папку и нажмите кнопку ОК. Можно также дважды щелкнуть путь в списке подкаталогов классов, ввести нужный путь и нажать кнопку ОК.

    • Чтобы удалить папку из подкаталогов классов, выделите путь в списке «Подкаталоги классов» и нажмите кнопку «Удалить выделенный путь» .

Чтобы задать путь к классам на уровне приложения, выполните следующие действия.

  1. Выберите «Редактировать настройки» (Windows) или «Flash» > «Настройки» (Macintosh) и щелкните категорию ActionScript.

  2. Нажмите кнопку «Параметры ActionScript 2.0» и добавьте путь (-и) в список «Путь к классам».

Установка исходного пути для ActionScript 3.0

Чтобы задать исходный путь на уровне документа, выполните следующие действия.

  1. Выберите меню «Файл» > «Параметры публикации», а затем «Flash».

  2. Убедитесь, что во всплывающем меню «Версия ActionScript» выбрано значение ActionScript 3.0, а затем нажмите кнопку «Параметры». Для использования ActionScript 3.0 должна быть установлена версия Flash Player 9 или более поздняя версия.
  3. В текстовом поле «Экспортировать классы в кадре» укажите кадр, в котором должно находиться определение класса.
  4. Задайте настройки обработки ошибок. Можно выбрать «Строгий режим» или «Режим предупреждений». При строгом режиме предупреждения считаются ошибками. Это означает, что компиляция не завершится успешно, пока остаются эти типы ошибок. В «Режиме уведомлений» создаются дополнительные предупреждения, полезные при обнаружении несовместимостей при обновлении кода ActionScript 2.0 до ActionScript 3.0.
  5. Выберите рабочую область, чтобы автоматически объявить экземпляры рабочей области (необязательный параметр).
  6. Укажите в качестве диалекта ActionScript 3.0 или ECMAScript. Рекомендуется использовать ActionScript 3.0.
  7. Чтобы добавить пути в список исходных путей, выполните одно из следующих действий.
    • Чтобы добавить папку в исходный путь, перейдите на вкладку «Исходный путь», а затем нажмите кнопку «Перейти к пути» , укажите папку для добавления и щелкните ОК.

    • Чтобы добавить в список «Исходный путь» новую строку, нажмите кнопку «Добавить новый путь» . Дважды щелкните новую строку, введите относительный или абсолютный путь, а затем нажмите кнопку ОК.

    • Чтобы изменить существующую папку исходного пути, выделите путь в списке «Исходный путь», нажмите кнопку «Перейти к пути», выберите другую папку и нажмите кнопку ОК. Можно также дважды щелкнуть мышью путь в списке исходных путей, ввести нужный путь и нажать кнопку ОК.

    • Чтобы удалить папку из исходного пути, выделите путь в списке «Исходный путь» и нажмите кнопку «Удалить выделенный путь» .

Чтобы задать исходный путь на уровне приложения, выполните следующие действия.

  1. Выберите «Редактировать настройки» (Windows) или «Animate» > «Настройки» (Macintosh) и щелкните категорию ActionScript.

  2. Нажмите кнопку «Параметры ActionScript 3.0» и добавьте пути в список «Исходный путь».

Установка пути к библиотеке для файлов ActionScript 3.0

Процедура установки пути к библиотеке на уровне документа подобна указанию исходного пути.

  1. Выберите «Файл» > «Параметры публикации».
  2. В меню «Сценарий» выберите ActionScript 3.0 и нажмите кнопку «Параметры ActionScript».
  3. В диалоговом окне дополнительных параметров ActionScript 3.0 перейдите на вкладку «Путь к библиотеке».
  4. Добавьте путь к библиотеке в список «Путь к библиотеке». В список путей можно добавлять папки или отдельные SWC-файлы.
  5. Чтобы правильно задать свойство «Тип ссылки», дважды щелкните «Тип ссылки» в дереве свойств пути. Свойство «Тип ссылки» может иметь следующие значения.
    • Объединено с кодом: ресурсы кода, обнаруженные в пути, добавляются в опубликованный SWF-файл.

    • Внешний: ресурсы кода, обнаруженные в пути, не добавляются в опубликованный SWF-файл, но компилятор проверяет их наличие в указанных вами местоположениях.

    • Общая библиотека во время выполнения: Flash Player загружает ресурсы во время выполнения.

Чтобы задать путь к библиотеке на уровне приложения, выполните следующие действия.

  1. Выберите «Редактировать настройки» (Windows) или «Animate» > «Настройки» (Macintosh) и щелкните категорию ActionScript.

  2. Нажмите кнопку «Параметры ActionScript 3.0» и добавьте путь (-и) в список «Путь к библиотеке».

Условная компиляция ActionScript

В языке ActionScript 3.0 можно использовать условную компиляцию так же, как в C++ и других языках программирования. Например, условную компиляцию можно использовать для включения или выключения блоков кода в рамках всего проекта, например кода, реализующего определенную функцию или используемого для отладки.

С помощью констант конфигурации, определяемых в параметрах публикации, можно указать, нужно компилировать определенные строки ActionScript или нет. Каждая константа принимает следующую форму:

CONFIG::SAMPLE_CONSTANT

В этой форме CONFIG представляет пространство имен конфигурации, а SAMPLE_CONSTANT — константу, которой будет присвоено значение true или false в параметрах публикации. Когда константа имеет значение true, следующая за ней строка кода ActionScript компилируется. Если константа имеет значение false, следующая за ней строка кода не компилируется.

Например, следующая функция имеет две строки кода, которые компилируются, только если предшествующая им константа имеет значение true в параметрах публикации.

public function CondCompTest() { 
    CONFIG::COMPILE_FOR_AIR { 
        trace(&quot;Эта строка кода будет скомпилирована, если COMPILE_FOR_AIR=true.&quot;); 
    } 
    CONFIG::COMPILE_FOR_BROWSERS { 
        trace(&quot;Эта строка кода будет скомпилирована, если COMPILE_FOR BROWSERS=true.&quot;); 
    } 
}

Чтобы определить константу конфигурации в диалоговом окне «Параметры публикации», выполните следующие действия.

  1. Выберите «Файл» > «Параметры публикации».

  2. Выберите значение ActionScript 3.0 в меню «Сценарий» и нажмите кнопку «Параметры» рядом.

  3. В диалоговом окне дополнительных параметров ActionScript 3.0 перейдите на вкладку «Константы конфигурации».

  4. Чтобы добавить константу, нажмите кнопку «Добавить».

  5. Введите имя добавляемой константы. По умолчанию используется пространство имен конфигурации CONFIG и имя константы CONFIG_CONST.

    Примечание.

    Пространство имен конфигурации CONFIG объявляется компилятором Animate автоматически. Можно добавлять собственные пространства имен конфигурации. Для этого нужно ввести их вместе с именем константы в параметрах публикации и добавить в код ActionScript, используя следующий синтаксис:

    настройка пространства имен MY_CONFIG;
  6. Введите требуемое значение для константы: true или false. Изменяя это значение, можно включать или выключать компиляцию определенных строк кода.

Настройка контекстного меню в документах (CS5.5)

Во Flash Player 7 и более поздних версиях можно настраивать стандартные контекстные меню и контекстное меню текстового редактирования, которые появляются в SWF-файлах.

  • Стандартное контекстное меню выводится щелчком правой кнопкой мыши (Windows) или удерживанием нажатой клавиши Control (Macintosh) в SWF-файле во Flash Player в любой области, кроме редактируемого текстового поля. В контекстное меню можно добавить заказные элементы и скрыть любые встроенные элементы меню, за исключением элементов «Настройки» и «Отладчик».

  • Контекстное меню редактирования выводится щелчком правой кнопкой мыши (Windows) или удерживанием нажатой клавишу Control (Macintosh) в редактируемом текстовом поле SWF-файла во Flash Player. В это меню можно добавить заказные элементы. Скрыть встроенные элементы меню нельзя.

 Flash Player также отображает контекстное меню ошибки щелчком правой кнопкой мыши (Windows) или удерживанием нажатой клавиши Control (Macintosh) во Flash Player, когда SWF-файл не загружен. Это меню настроить нельзя.

Настройку контекстных меню в Flash Player 7 можно проводить с помощью объектов ContextMenu и ContextMenuItem в ActionScript 2.0. Дополнительные сведения об использовании этих объектов см. в разделе ContextMenu в справочнике ActionScript® 2.0.

При создании пользовательских элементов контекстного меню для Flash Player имейте в виду следующие условия.

  • Заказные элементы добавляются в контекстное меню в том порядке, в котором они были созданы. После создания меню изменить этот порядок нельзя.

  • Можно задавать видимость и включение заказных элементов.

  • Заказные элементы контекстного меню автоматически кодируются в Юникод UTF‑8.

Папки конфигурации, устанавливаемые вместе с Flash (CS5.5)

При установке приложения Flash помещает на компьютер несколько папок конфигурации. В папках конфигурации файлы, связанные с приложением, упорядочены по соответствующим уровням доступа пользователя. При работе с языком ActionScript® или его компонентами, возможно, понадобится просмотреть содержимое этих папок. Для Flash предусмотрены следующие папки конфигурации.

Папка конфигурации уровня приложения

Поскольку эта папка относится к уровню приложения, пользователи, не имеющие прав администратора, не могут получить к ней доступ с правом записи. Обычные пути к этой папке:

  • В Microsoft Windows XP и Microsoft Windows Vista перейдите в каталог загрузочное устройство\Program Files\Adobe\Adobe Flash CS3\язык\Configuration\.

  • В Macintosh перейдите в каталог жесткий диск Macintosh/Программы/Adobe Flash CS3/Configuration/.

Папка First Run

Эта папка равного уровня с папкой конфигурации приложения облегчает общий доступ к файлам конфигурации пользователям на одном компьютере. Папки и файлы в папке First Run автоматически копируются в папку конфигурации на уровне пользователя. Все новые файлы, помещенные в папку First Run, копируются в папку конфигурации на уровне пользователя при запуске приложения.

Обычные пути к папке First Run:

  • В Microsoft Windows XP и Microsoft Windows Vista перейдите в каталог загрузочное устройство\Program Files\Adobe\Adobe Flash CS3\язык\First Run\.

  • В Macintosh перейдите в каталог жесткий диск Macintosh/Программы/Adobe Flash CS3/First Run/.

Папка конфигурации пользовательского уровня

Находится в области профиля пользователя, текущий пользователь всегда имеет к ней доступ с правом записи. Обычные пути к этой папке:

  • В Microsoft Windows XP и Microsoft Windows Vista перейдите в каталог загрузочное устройство\Documents and Settings\имя_пользователя\Local Settings\Application Data\Adobe\Flash CS3\язык\Configuration.

  • В Macintosh перейдите в каталог жесткий диск Macintosh/Пользователи/имя_пользователя/Библиотеки/Application Support/Adobe/Flash CS3/язык/Configuration/.

Папка конфигурации уровня всех пользователей

Находится в области профиля стандартного пользователя. Эта папка устанавливается по умолчанию в операционных системах Windows и Macintosh и является общей для всех пользователей конкретного компьютера. Операционная система открывает всем пользователям доступ к любому файлу, хранящемуся в этой папке. Обычные пути к этой папке:

  • В Microsoft Windows XP и Microsoft Windows Vista перейдите в каталог загрузочное устройство\Documents and Settings\All Users\Application Data\Adobe\Flash CS3\язык\Configuration\.

  • В Macintosh перейдите каталог жесткий диск Macintosh/Пользователи/Shared/Application Support/Adobe/Flash CS3/язык/Configuration/.

Папка конфигурации Restricted Users

Для пользователей с ограниченными правами на рабочей станции. Обычно в сетевой среде только системные администраторы имеют административный доступ к рабочим станциям. Все остальные пользователи получают ограниченный доступ, как правило, это означает, что эти пользователи не имеют права на запись в файлы уровня приложений (например, в папку Program Files в Windows и папку Applications в Macintosh OS X).

Логотип Adobe

Вход в учетную запись