Работа с библиотеками

В библиотеке документа Animate хранятся ресурсы, как созданные в среде разработки Animate, так и импортированные для использования в документе. Векторные иллюстрации, текст и символы могут быть созданы непосредственно в Animate, а векторные иллюстрации, растровые изображения, видео и звук могут быть импортированы. Символ — это изображение, кнопка, фрагмент ролика или текст, который будучи однажды создан, может быть после этого многократно использован. Чтобы придать динамику документам, можно также применять сценарии ActionScript для добавления мультимедийного содержимого.

Библиотека также содержит все компоненты, добавленные в документ. Компонентами могут быть либо скомпилированные клипы, либо объекты на основе MovieClip.

Все элементы библиотеки любого документа Animate, открытого в Animate, становятся доступными из этого файла для текущего документа. Можно осуществлять поиск символов в библиотеке по именам или именам связывания ActionScript.

Animate позволяет создавать постоянные библиотеки, доступные при запуске. Animate также включает несколько библиотек образцов, в которых содержатся кнопки, графические объекты, фрагменты роликов и звуки.

Ресурсы библиотеки могут быть экспортированы в виде SWF-файла по URL-адресу, то есть создать общую библиотеку, используемую во время выполнения. Это позволяет ссылаться из документов Animate на ресурсы библиотеки, которые импортируют символы на этапе выполнения.

На панели «Библиотека» («Окно» > «Библиотека») находится прокручиваемый список, который содержит имена всех содержащихся в библиотеке элементов и позволяет просматривать и упорядочивать их в процессе работы. Значок рядом с именем элемента на панели «Библиотека» указывает тип файла.

Примечание. (Только для Animate CC и более поздних версий) Перетаскивание объектов из рабочей области на панель «Библиотека» для преобразования в символ больше не поддерживается, эта функция не будет работать в Animate CC.

Примечание. (Только для Animate CC и более поздних версий) Перетаскивание объектов на рабочую область между двумя несостыкованными документами больше не поддерживается, эта функция не будет работать в Animate CC.

 

Открытие библиотеки из другого файла Animate

  1. Из текущего документа выберите меню «Файл» > «Импорт» > «Открыть внешнюю библиотеку».
  2. Перейдите к файлу Animate, библиотеку которого нужно открыть, и нажмите кнопку «Открыть».

    Библиотека выбранного файла открывается в текущем документе, отражая имя файла в верхней части панели «Библиотека». Чтобы использовать элементы из библиотеки выбранного файла в текущем документе, перетащите их на панель «Библиотека» текущего документа или на рабочую область.

Изменение размера панели «Библиотека»

  1. Выполните одно из следующих действий.
    • Перетащите нижний правый угол панели.

    • Кнопка «Широкая область просмотра библиотеки» позволяет увеличить размер панели «Библиотека», показав все столбцы.

    • Нажмите кнопку «Узкая область просмотра библиотеки», чтобы уменьшить ширину панели «Библиотека».

Изменение ширины столбцов

  1. Чтобы изменить ширину столбца, перетащите границу между заголовками столбцов.

Работа с папками на панели «Библиотека»

Элементы на панели «Библиотека» могут быть упорядочены по папкам. При создании нового символа он сохраняется в выделенной папке. Если не выделена ни одна из папок, то символ сохраняется в корневом каталоге библиотеки.

Кроме того, Animate организованно импортирует анимированные файлы GIF, помещая их в отдельную папку в корневой папке библиотеки и присваивая связанным растровым изображениям имена на основе их последовательности. 

Создание новой папки

  1. Нажмите кнопку «Создать папку»  в нижней части панели «Библиотека».

Открытие или закрытие папки

  1. Дважды щелкните мышью папку либо выделите папку и в меню «Панель» для панели «Библиотека» выберите пункт «Развернуть папку» или «Свернуть папку».

Открытие или закрытие всех папок

  1. Выберите пункт «Развернуть все папки» или «Свернуть все папки» в меню «Панель» для панели «Библиотека».

Перемещение элемента между папками

  1. Перетащите элемент из одной папки в другую.

    Если в новом месте элемент с таким же именем уже существует, то Animate предложит заменить его перемещаемым элементом.

Сортировка элементов на панели «Библиотека»

На панели «Библиотека» для каждого элемента указаны его имя, тип, сколько раз он использован в файле, состояние и идентификатор привязки (если элемент связан с общей библиотекой или экспортирован для ActionScript), а также дата последнего изменения.

Элементы панели «Библиотека» могут быть отсортированы в алфавитном порядке по любому из столбцов. Элементы сортируются внутри папок.

Библиотека Animate помещает импортированные анимированные файлы GIF в отдельную папку в корневой папке библиотеки и присваивает связанным растровым изображениям имена на основе их последовательности. 

  1. Щелкните заголовок столбца, чтобы отсортировать данные по нему. Чтобы изменить порядок сортировки на обратный, щелкните треугольную кнопку справа от заголовка столбца.

Конфликты между ресурсами библиотеки

При импорте или копировании ресурса библиотеки в документ, где уже содержится другой ресурс с тем же именем, необходимо указать, должен ли существующий элемент быть заменен новым. Этой функцией пользуются все методы импорта и копирования ресурсов библиотеки.

Диалоговое окно «Разрешить конфликты библиотеки» появляется при попытке разместить элементы, которые конфликтуют с существующими элементами в документе. Конфликт возникает при копировании из исходного документа элемента, который уже существует в целевом документе, если элементы имеют различные даты изменения. Чтобы избежать конфликтов имен, ресурсы в библиотеке документа должны быть упорядочены по папкам. Диалоговое окно также появляется при вставке символа или компонента в рабочую область документа, если уже имеется копия символа или компонента с другой датой изменения.

Если отказаться от замены существующих элементов, то Animate вместо добавляемого элемента пытается использовать существующий. Например, если скопировать символ с именем «Symbol 1» и попытаться вставить его в рабочую область документа, в которой уже имеется символ «Symbol 1», то Animate создаст экземпляр существующего символа «Symbol 1».

Если выбрана замена существующих элементов, то Animate заменяет их (а также все их экземпляры) новыми элементами с тем же именем. Если отменить операцию импорта или копирования, то операция будет отменена для всех элементов (не только элементов, которые конфликтуют в целевом документе).

Допускается замена элементов библиотеки только одинаковых типов. Иными словами, нельзя заменить звук с именем Test растровым изображением с именем Test. В таких случаях в библиотеку добавляются новые элементы, к имени которых будет добавлено слово «Copy».

Примечание.

Замена элементов библиотеки с использованием этого метода необратима. Прежде чем выполнять сложные операции вставки, которые вызывают замену конфликтующих элементов библиотеки, сохраните резервную копию FLA-файла.

Если при импорте или копировании ресурсов библиотеки в документ появляется диалоговое окно «Разрешить конфликты библиотеки», устраните конфликт имен.

Устранение конфликтов имен между ресурсами библиотеки

  1. Выполните одно из следующих действий в диалоговом окне «Разрешить конфликты библиотеки».

    • Чтобы сохранить существующие ресурсы в целевом документе, выберите «Не заменять существующие элементы».

    • Чтобы заменить существующие ресурсы и их экземпляры новыми элементами с теми же именами, выберите «Заменить существующие элементы».

Работа с элементами библиотеки

При выборе элемента на панели «Библиотека» его миниатюра отображается в верхней части панели. Если выбран анимированный или звуковой файл, то просмотреть его можно по нажатию кнопки «Воспроизвести» в окне просмотра библиотеки или через «Средство управления».

Поиск элементов библиотеки по имени связывания

Панель поиска библиотеки позволяет осуществлять поиск символов по именам или именам связывания ActionScript.

  • Чтобы найти элемент библиотеки, введите первые буквы имени символа или имени связывания ActionScript этого объекта. По мере набора в панели поиска будет отображаться список совпадений среди символов.

Использование элемента библиотеки в текущем документе

  1. Перетащите элемент из панели «Библиотека» на рабочую область.

    Элемент добавляется на текущий слой.

Преобразование объекта на рабочей области в библиотечный символ

  1. Выберите объект рабочей области, щелкните его правой кнопкой мыши, выберите «Преобразовать в символ».

Использование элемента библиотеки из текущего документа в другом документе

  1. Перетащите элемент из панели «Библиотека» или из рабочей области на панель «Библиотека» или на рабочую область другого документа.

Копирование элементов библиотеки из другого документа

  1. Выделите документ, который содержит элементы библиотеки.
  2. Выделите элементы библиотеки на панели «Библиотека».
  3. Выберите меню «Правка» > «Копировать».
  4. Выберите документ, в который должны быть скопированы элементы библиотеки.
  5. Выберите панель «Библиотека» этого документа.
  6. Выберите меню «Правка» > «Вставить».

Редактирование элемента библиотеки

  1. Выделите элемент на панели «Библиотека».
  2. Выберите один из следующих пунктов в меню «Панель» для панели «Библиотека».
    • Чтобы редактировать элемент в Animate, выберите пункт «Правка».

    • Чтобы редактировать элемент в другом приложении, выберите «Изменить с помощью», а затем выберите внешнее приложение.

Примечание.

При запуске поддерживаемого внешнего редактора Animate открывает исходный импортированный документ.

Переименование элемента библиотеки

При переименовании элемента библиотеки имя исходного импортированного файла не меняется.

  1. Выполните одно из следующих действий.
    • Дважды щелкните мышью имя элемента.

    • Выделите элемент и выберите пункт «Переименовать» в меню «Панель» для панели «Библиотека».

    • Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh), и выберите из контекстного меню пункт «Переименовать».

  2. Введите в поле новое имя.

Удаление элемента библиотеки

При удалении элемента из библиотеки все экземпляры или повторения этого элемента в документе также удаляются.

  1. Выделите элемент и нажмите значок мусорной корзины в нижней части панели «Библиотека».

Поиск неиспользованных элементов библиотеки

Чтобы упорядочить документ, можно найти все неиспользованные элементы библиотеки и удалить их.

Примечание.

Удаление неиспользованных элементов библиотеки не сокращает размер файла документа Animate, так как они не включаются в SWF-файл. Однако в SWF-файл включаются элементы, связанные для экспорта.

  1. Выполните одно из следующих действий.
    • Выберите пункт «Выделить неиспользуемые элементы» в меню «Панель» для панели «Библиотека».

    • Выполните сортировку элементов библиотеки по столбцу «Счетчик использования», который указывает, используется ли элемент.

Обновление импортированных файлов в библиотеке

Если для изменения файлов, импортированных в Animate (например, растровых изображений или звуковых файлов), используется внешний редактор, то эти файлы могут быть обновлены в Animate без повторного импорта. Можно также обновить символы, импортированные из внешних документов Animate. При обновлении импортированного файла его содержимое заменяется содержимым внешнего файла.

Примечание. Можно найти импортированные анимированные файлы GIF, помещенные в отдельную папку в корневой папке библиотеки вместе со всеми связанными растровыми изображениями, имена которым были присвоены на основе их последовательности. 

  1. Выделите импортированный файл на панели «Библиотека».
  2. Выберите пункт «Обновить» из меню «Панель» для панели «Библиотека».

Копирование ресурсов библиотеки из одного документа в другой

Существует несколько способов копирования ресурсов библиотеки из одного документа в другой: Как на этапе разработки, так и во время выполнения символы также могут использоваться в нескольких документах в качестве ресурсов общей библиотеки.

При копировании ресурсов с теми же именами, что и у существующих, диалоговое окно «Разрешить конфликты библиотеки» позволяет перезаписать или сохранить существующие ресурсы либо добавить новые ресурсы с другими именами. Ресурсы в библиотеке должны быть упорядочены по папкам, чтобы свести к минимуму конфликты имен при копировании ресурсов из других документов.

Копирование ресурса библиотеки копированием и вставкой

  1. Выделите ресурс в рабочей области исходного документа.

  2. Выберите меню «Правка» > «Копировать».

  3. Сделайте активным целевой документ.

  4. Чтобы вставить ресурс в центр отображаемой части монтажного стола, поместите указатель в рабочую область и выберите меню «Правка» > «Вставить в центре». Чтобы вставить ресурс в то же место, что и в исходном документе, выберите меню «Правка» > «Вставить на место».

Копирование ресурса библиотеки перетаскиванием

  1. Открыв целевой документ, выберите ресурс на панели «Библиотека» исходного документа и перетащите его на панель «Библиотека» целевого документа.

Копирование ресурса библиотеки путем открытия библиотеки исходного документа в целевом документе

  1. Сделав активным целевой документ, выберите меню «Файл» > «Импорт» > «Открыть внешнюю библиотеку».

  2. Выделите исходный документ и нажмите кнопку «Открыть».

  3. Перетащите ресурс из библиотеки исходного документа в рабочую область или в библиотеку целевого документа.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет