Узнайте, как пользоваться инструментом «Выделение» в Animate CC

В Animate CC можно пользоваться инструментами «Указатель», «Спецвыделение» и «Лассо». При выделении объектов и обводок Animate подсвечивает их. Может быть выделена только обводка объекта или только его заливка. Подсветку выделения можно скрыть, что позволит работать с объектом без подсветки.

Инструменты «Указатель», «Спецвыделение» и «Лассо»

Модификаторы инструмента «Лассо»

Инструмент Значок Описание
Инструмент «Выделение» (V) Используйте этот инструмент для выделения всего объекта. Щелкните или перетащите объект, чтобы заключить его в прямоугольную рамку выделения. 
Инструмент «Спецвыделение» (A) Используйте этот инструмент для изменения формы траектории движения анимации. Можно открыть доступ к якорным точкам и маркерам Безье на траектории, соответствующем каждому положению ключевого кадра свойств. 
Инструмент «Лассо» (L) Используйте этот инструмент для создания нестандартного контура выделения для объекта. 
Инструмент «Многоугольник» (L) Используйте этот инструмент для определения области выделения с использованием нескольких соединенных прямых линий. Чтобы выбрать этот инструмент, щелкните инструмент «Многоугольник», когда активен инструмент «Лассо». 
Инструмент «Волшебная палочка» (L) Используйте этот инструмент для выделения областей растрового изображения, содержащих одинаковые или подобные цвета. Чтобы выбрать этот инструмент, щелкните инструмент «Волшебная палочка», когда активен инструмент «Лассо».

Изменение объектов

Выделите объект, чтобы изменить его. Отдельные объекты могут быть сгруппированы, что позволяет работать с ними как с единым объектом. Изменение линий и фигур может привести к изменению других линий и фигур на том же слое. Чтобы группу или символ нельзя было случайно выделить и изменить, заблокируйте их.

Изменение свойств объекта

Используйте инспектор свойств, чтобы изменить свойства обводки и заливки объекта. При выделении объекта инспектор свойств выводит следующую информацию.

  • Обводку и заливку объекта, его размеры в пикселях, а также координаты x и y точки трансформации объекта..
  • Смешанное выделение, если выделено несколько элементов. Размеры в пикселях, а также координаты x и y выделенного набора элементов.

Выделение объектов инструментом «Выделение»

Инструмент «Выделение»  позволяет выделить объект целиком, нажав на него, либо, перетаскивая мышью, заключить его в прямоугольную область выделения. Чтобы выбрать экземпляры, группы и текстовые блоки, их необходимо заключить в рамку выделения. 

Примечание.

Выбрать инструмент «Выделение» можно также по нажатию клавиши V. Чтобы временно переключиться на инструмент «Выделение», когда активен другой инструмент, нажмите и удерживайте нажатой клавишу «Control» (Windows) или «Command» (Macintosh). Дополнительные сведения см. в разделе Сочетания клавиш

Параметр, отключающий выделение с использованием клавиши «Shift», находится в разделе настроек «Общие» приложения Animate. См. раздел Задание установок в программе Animate

Выделение объектов

  • Чтобы выделить обводку, заливку, экземпляр или текстовый блок, щелкните мышью объект.
  • Чтобы выделить соединенные линии, дважды щелкните мышью одну из них.
  • Чтобы выделить фигуру с заливкой вместе с обводкой, дважды щелкните мышью заливку.
  • Чтобы выделить объект внутри прямоугольной области, перетащите мышью область выделения вокруг нужного объекта или объектов.
Выделение дополнительных областей
  • Чтобы новое выделение добавлялось к текущему, во время его выполнения удерживайте нажатой клавишу «Shift».
  • Чтобы выделить все объекты на всех слоях монтажного кадра, выберите меню «Правка» > «Выделить все» или нажмите сочетание клавиш «Control» + «A» (Windows) или «Command» + «A» (Macintosh). Команда «Выделить все» не выделяет объекты в блокированных и скрытых слоях, а также в слоях, которые находятся не на текущей временной шкале.
  • Чтобы выделить все между двумя ключевыми кадрами, нажмите кадр на временной шкале.

Отменить выбор всего

Чтобы отменить выделение всех объектов во всех слоях, выберите меню «Правка» > «Отменить выделение всего» или нажмите сочетание клавиш «Control» + «Shift» + «A» (Windows) или «Command» + «Shift» + «A» (Macintosh).Дополнительные сведения см. в разделе Сочетания клавиш

Отмена выделения отдельных элементов

Чтобы отменить выделение отдельного элемента из группы выделенных объектов, выполните следующие действия.

  1. Выберите инструмент «Выделение»
  2. Удерживайте клавишу «Shift»
  3. Щелкните отдельный элемент

Такими отдельными элементами могут быть любые обводки, заливки или графические объекты. 

Заблокировать/разблокировать

Чтобы заблокировать или снять блокировку группы или символа, выделите их и выберите меню «Модификация» > «Упорядочить» > «Заблокировать». Выберите меню «Модификация» > «Упорядочить» > «Разблокировать все», чтобы разблокировать все заблокированные группы и символы.

Рисование произвольной области выделения с помощью инструмента «Лассо»

С помощью инструмента «Лассо» можно создать неправильный контур. Выберите его в меню «Инструменты» или нажмите клавишу «L». В зависимости от заданных параметров для выделения объектов можно заключить графический объект в рамку выделения полностью или только его часть. Дополнительные сведения см. в разделе Выбор настроек для выделения на этой странице. 

  1. Протащите инструментом «Лассо»  вокруг объекта. Чтобы выделить внутреннюю окружность объекта, протащите вокруг него инструментом «Лассо» по произвольной траектории. 

  2. Завершите петлю примерно в том месте, с которого начали, либо позвольте Animate автоматически замкнуть петлю. Animate замыкает контур выделения и подсвечивает выбранный объект. 

Рисование многоугольной области выделения с помощью инструмента модификатора «Режим многоугольника» для инструмента «Лассо».

Модификатор «Режим многоугольника» для инструмента «Лассо» позволяет определить область выделения с помощью последовательности соединенных прямых линий. Когда активен инструмент «Лассо», щелкните инструмент «Многоугольник». 

  1. В области параметров на панели «Инструменты» выберите для инструмента «Лассо»  модификатор «Режим многоугольника».
  2. Щелкните объект, чтобы задать начальную точку. 

  3. Поместите указатель там, где нужно закончить первую линию и щелкните в этой точке. Продолжите настройку конечных точек для остальных сегментов.

  4. Дважды щелкните в последней точке, чтобы замкнуть область выделения. Animate замыкает контур выделения и подсвечивает выбранный объект. 

Рисование произвольной области выделения вместе с многоугольной

Инструмент «Лассо» и его модификатор «Режим многоугольника» позволяют переключаться между произвольным и многоугольным режимами выделения.

  1. Отмените выбор модификатора «Режим многоугольника» для инструмента «Лассо».
  2. Для рисования произвольного сегмента выделения протащите инструментом «Лассо» в рабочей области.
  3. Щелкните область, удерживая нажатой клавишу «Alt» (Windows) или «Option» (Macintosh), чтобы установить начальную и конечную точку для каждого нового сегмента линии. 

    Используйте это действие для рисования многоугольных сегментов. 

  4. Чтобы замкнуть область выделения, выполните одно из следующих действий.
    • Отпустите кнопку мыши. Animate замыкает область выделения.  

    • Дважды щелкните мышью конечную точку области выделения.

Скрытие подсветки выделения

Чтобы посмотреть, как графический объект будет выглядеть в конце, можно скрыть подсветку объекта при выделении и редактировании. 

  1. Выберите меню «Просмотр» > «Скрыть подсветку выделения».

Снова выберите параметр «Скрыть подсветку выделения», чтобы показать подсветку выделения.

Установка заказных цветов ограничительной рамки для выделенных объектов

Можно настроить цвета прямоугольных ограничительных рамок вокруг выделенных объектов на рабочей области.

  1. Выберите меню «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh).

  2. Откройте категорию «Общие».
  3. В разделе «Цвет подсветки» выберите цвет для каждого типа объектов и нажмите кнопку «ОК».

Выбор настроек для выделения

Щелкните объект, чтобы выбрать объект с помощью инструмента «Указатель», «Спецвыделение» или «Лассо». Чтобы выбрать объект с помощью инструментов «Выделение» и «Спецвыделение», перетащите прямоугольную область выделения вокруг объекта. Чтобы выбрать объект с помощью инструмента «Лассо», перетащите произвольную область выделения вокруг объекта. Когда объект выбран, вокруг него появляется прямоугольник.

  1. Выберите меню «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh).

  2. В категории «Общие» диалогового окна «Настройки» выполните одно из следующих действий.
    • Чтобы выделить только объекты и точки, заключенные в рамку, снимите флажок «Инструменты "Выделение" и "Лассо", чувствительные к контакту». Точки, расположенные внутри области выделения, выделяются.

    • Чтобы выделить объекты или группы, частично заключенные в ограничительную рамку, установите флажок «Инструменты "Выделение" и "Лассо", чувствительные к контакту».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет