User Guide Cancel

Activation and licenses | Substance 3D Painter

  1. Home
  2. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  3. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Color picker
    3. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    4. History
    5. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    6. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    7. Project configuration
    8. Properties
    9. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    10. Shader settings
      1. Shader settings overview
      2. Updating a shader
    11. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    12. Toolbars
    13. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    14. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  4. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
  5. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  6. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  7. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via the import window
      2. Adding content on the hard drive
      3. Receiving assets from other Substance 3D applications
  8. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
  9. Technical Support
    1. Hardware requirements
    2. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    3. Configuring Pens and Tablets
    4. Exporting the log file
    5. Exporting a DXDiag
    6. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    7. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Shelf Issues
        1. Thumbnails in the shelf look incorrect
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  10. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  11. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  12. Release notes
    1. Relese notes
    2. All Changes
    3. Version 8.3
    4. Version 8.2
    5. Version 8.1
    6. Old versions
      1. Version 7.4
      2. Version 7.3
      3. Version 7.2
      4. Version 2021.1 (7.1.0)
      5. Version 2020.2 (6.2.0)
      6. Version 2020.1 (6.1.0)
      7. Version 2019.3
      8. Version 2019.2
      9. Version 2019.1
      10. Version 2018.3
      11. Version 2018.2
      12. Version 2018.1
      13. Version 2017.4
      14. Version 2017.3
      15. Version 2017.2
      16. Version 2017.1
      17. Version 2.6
      18. Version 2.5
      19. Version 2.4
      20. Version 2.3
      21. Version 2.2

Activation and licenses

This page has information on how to activate and manage your licenses so you can start using Painter.

Activation process per application type

The activation process depends on where you purchased or have access to Painter:

Application TypeActivation process
Creative Cloud Desktop

See the dedicated page in the HelpX documentation.

In case there are any issues the Creative Cloud documentation may provide additional answers.

SteamLaunch the product directly from your Steam library.
Substance 3D standaloneSee the activation process described below.

Standalone Activation steps

The activation wizard

Three choices are available:

  • Evaluate this product: Legacy trials are no longer available. Instead, you can start a 30 day trial for each Substance 3D application here or with Creative Cloud Desktop. Each trial is independent of the other Substance 3D applications, so you can try them one at a time or all at once.
  • Activate using a license file: activate the product with a license file (*.key) downloaded from your account page on the Substance 3D website before 30 Sep 2022.
  • Activate using your account: Legacy substance accounts can no longer be used for activation. More information about Substance accounts is available here.
Alert:
To install the license file with the Activation Wizard, make sure you run Painter as an administrator and temporarily disable your anti-virus.

Manual activation

You can manually activate Substance Painter by putting the license.key file in the following folder:

PlatformVersionPath
Windows7.2 or newerApp Data (local)C:\Users\[username]\AppData\Local\Adobe\Adobe Substance 3D Painter
App Data (roaming)C:\Users\[username]\AppData\Roaming\Adobe\Adobe Substance 3D Painter
LegacyApp Data (local)C:\Users\[username]\AppData\Local\Allegorithmic\Substance Painter
App Data (roaming)C:\Users\[username]\AppData\Roaming\Allegorithmic\Substance Painter
Mac7.2 or newer/Users/[username]/Library/Application Support/Adobe/Adobe Substance 3D Painter
Legacy/Users/[username]/Library/Application Support/Allegorithmic/Substance Painter
Linux7.2 or newer/home/[username]/.local/share/Adobe/Adobe Substance 3D Painter
Legacy/home/[username]/.local/share/Allegorithmic/Substance Painter
Note:
Some of the directories in the paths mentioned above may be hidden by default. Type the path manually in the file explorer or display hidden files to view them.
Note:

Make sure that the file is called license.key otherwise the application will not be able to find it.

Environment variable

You can override the location that Painter checks for the license.key file with an Environment Variable.

Adobe logo

Sign in to your account