User Guide Cancel

Version 2021.1 (7.1.0) | Substance 3D Painter

  1. Home
  2. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  3. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Color picker
    3. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    4. History
    5. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    6. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    7. Project configuration
    8. Properties
    9. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    10. Shader settings
      1. Shader settings overview
      2. Updating a shader
    11. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    12. Toolbars
    13. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    14. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  4. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (SVG)
  5. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  6. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  7. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  8. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  9. Technical Support
    1. Hardware requirements
    2. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    3. Configuring Pens and Tablets
    4. Exporting the log file
    5. Exporting a DXDiag
    6. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    7. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Shelf Issues
        1. Thumbnails in the shelf look incorrect
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  10. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  11. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  12. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 9.1
    4. Version 9.0
    5. Version 8.3
    6. Old versions
      1. Version 8.2
      2. Version 8.1
      3. Version 7.4
      4. Version 7.3
      5. Version 7.2
      6. Version 2021.1 (7.1.0)
      7. Version 2020.2 (6.2.0)
      8. Version 2020.1 (6.1.0)
      9. Version 2019.3
      10. Version 2019.2
      11. Version 2019.1
      12. Version 2018.3
      13. Version 2018.2
      14. Version 2018.1
      15. Version 2017.4
      16. Version 2017.3
      17. Version 2017.2
      18. Version 2017.1
      19. Version 2.6
      20. Version 2.5
      21. Version 2.4
      22. Version 2.3
      23. Version 2.2

Version 2021.1 (7.1.0)

Substance Painter 2021.1 (7.1.0) introduces several new features and improvements such as the geometry mask and the copy and paste of effects in the layer stack.

Release data: 28 January 2021

Note:

This release raise the minimum version supported of Ubuntu to 18.04 and MacOS to 10.14. For more details see the technical requirements.

Major Features

New Geometry Mask

The Geometry Mask is a new masking tool in the layer stack that allows to hide geometry based on mesh names or UV Tiles. It is an evolution of the previously named UV Tile Mask that masked geometry based on UDIM numbers.

This new tool is a better way of masking geometry than regular painting (or when using the Polygon fill) because it benefits from several engine optimizations. It is also non-destructive as it doesn't store geometry information (like faces or vertices) but instead just the mesh name or the UV Tile number, so re-importing a mesh won't break the mask. Another benefit is that hiding geometry permit to paint on surfaces that weren't accessible before within a Texture Set, this avoids the need to split an object into several Texture Sets for example.

  • New geometry mask on layers
    The geometry mask is automatically available on any layer in the layer stack. By default it has no effect, meaning the layer is fully visible.
    The Geometry Mask has its own contextual menu that allows to quickly select or deselect all its items but also to copy its values to another layer.

  • Editing the geometry mask properties
    The geometry mask follows the same logic as the other layer's contexts (like editing a mask or instanced properties). To enter the geometry mask edition mode, simply click on the doted square at the right of a layer. To exit the geometry mask click on the content or paint mask of the same layer.

  • Masking by mesh names or by UV Tiles
    At the top of the Geometry Mask properties is a dropdown that controls the masking mode. It is possible to choose between masking by UV Tile number or by mesh name. This dropdown is disabled and set to mesh name only in case a project doesn't use the UV Tile workflow.

  • Masking geometry via the properties
    When editing the Geometry Mask, the properties window will display a list of the mesh names (or UV tiles) based on the geometry related to the current Texture Set.

    • The number above the list indicates how many meshes/UV tiles are unmasked over the total available.
    • The menu next to the number gives quick controls to select all or none of the items and even invert the current selection.
    • The list below defines which items are masked or not. Like other list in the application it is possible to click and drag to enable/disable several items at once or event use ALT+Click to isolate an item.

  • Masking geometry via the viewport
    The Geometry Mask selection can also be changed in the 2D and 3D views. Simply move the mouse over the part that should be visible/hidden and click on it to toggle its state. When editing the Geometry Mask, masked geometry is displayed with a gray and diagonal lines effect. It is also possible to do rectangular selections by click and dragging to select multiple items at once.

  • Painting hidden / unreachable geometry.
    After selecting geometry to mask out in the Geometry Mask, it is possible to enable the Hide/Ignore excluded geometry button at the top of the viewport (or by pressing the ALT+H shortcut). When enabled, excluded geometry will be hidden (as well as other Texture Sets) to only show geometry that is included / paintable with the current layer. This option allows to paint areas that were previously blocked or out of reach. This option also applies to any kind of layer.

    Note:

    Painting with masked out geometry remains dynamic: if some geometry blocking the painting was initially hidden when the brush stroke was made and is then unmasked it will block again the previously made brush stroke.

New Copy and Paste of Layer Stack Effects

Effects can now be copied across layers and layer stacks, the same way as regular layers.

Multi-selection is now possible as well to offer the possibility to copy and paste multiple effects at once.

For convenience, copying or moving an effect from a mask on a layer without one will automatically add one. This is because effects from the layer content and mask are not compatible with each other. This means copying an effect from a mask into the content of a layer will automatically switch to the mask (or create one).

  • Copy and paste via the contextual menu
    Right-click on any effect in the layer stack of a Texture Set and choose the cut or copy action. Then right-click again on any layer and choose paste to move or create a copy of the desired effects. We also took the opportunity to rework the contextual menu and give access to more functionalities:

  • Copy and paste with the keyboard shortcuts
    Same as with any layer, the keyboard shortcut CTRL+C (copy)/CTRL+X (cut) and CTRL+V (paste) can be used to copy effects based on the current selection. Like with layers, effects are inserted above the current selection.

  • Quickly duplicate effect with keyboard shortcuts
    Use CTRL+D to duplicate the current selection or press and maintain ALT while dragging any effect to duplicate it at a desired location:

  • Move effects across layers
    In addition to the copy and duplication, it is now possible to move an effect by simply drag and dropping it from one layer to another:

New General Features and Improvements

Several improvements have been made in this release:

  • Add a description per UV Tile
    A description can now be added for each UV Tile via the Texture Set List. This make the project easier to navigate, especially when exporting and baking as the descriptions can also be seen in these contexts.
    To add or edit a description simply click on a UV Tile in the Texture Set List window and then go into the Texture Set Settings window to edit it.

  • New layer stack thumbnails
    The optimized layer stack thumbnails have been improved. A material sphere is now displayed for fill layers, making it easier to navigate and see the main properties of each layer even when working with the UV Tiles workflow. The thumbnail is generated from the layer information but doesn't take into account effects to avoid being recomputed too often.

  • Improved Geometry Mask exit in the layer stack
    Exiting the Geometry Mask (formerly UV Tile Mask) could be proven difficult with folders in the layer stack if it didn't had a mask. This is because there was no other context to switch on other than selecting another layer. It is now possible to click on the folder thumbnail to exit the Geometry Mask. It is also possible to drag and drop materials or smart materials from the Shelf into the viewport while editing the Geometry Mask.

  • New Alt-Click selection in Baking window
    The list of mesh maps in the baking window can now be isolated with the Alt + mouse click to isolate a specific map to bake, instead of having to exclude them manually. The same shortcut can be used to re-enable all the mesh maps.

  • New bake current Texture Set button
    A new button has been added at the bottom of the Baking window to make it quick and easy to re-bake a Texture Set. Using this button won't affect the custom selection that was previously defined and instead will bake the whole Texture Set (including all its UV Tiles if any are available).

New Substance Engine Update

The Substance Engine has been updated to its version 8 to support the latest Substance file format and its functionalities.

For more details on the new Substance Engine features, take a look at this documentation page.

New Nvidia RTX 3000 Support in Iray

The Iray renderer has been updated to its latest version and now supports the new Nvidia Ampere GPUs (RTX 3000 Series and Quadro A Series).

Note:

With this update Kepler GPUs (GeForce 600 and 700 series) are not supported anymore, rendering in Iray will be done on the CPU instead.

New Content

Three new stitch tools have been added in this release and can be used to create complex patterns and realistic stitches. To find them, simply go in the Tool section of the Shelf and look for:

  • Stitches Complex
  • Stitches Cross Seam
  • Stitches Straight

It is recommended to activate the Lazy mouse feature in the contextual toolbar to increase the quality of the painted stitches.

Below is an overview of all the presets contained inside these new tools:

New Python Functionalities

The Python API received several new functionalities. The documentation has also been reworked, notably its examples, to make it easier to understand and learn the API.

  • Resources and shelves management
    The resource module has been improved and can now:
    • Create and manage shelves.
    • Search or import resources in shelves and projects.
    • Know if a shelf is being crawled (allowing to know when resources are ready to use).
    • Assign custom thumbnails to resources in a shelf.
  • UV Tiles information
    It is now possible to query the UV Tile list of a Texture Set. This open the possibility to create custom exports on a specific range of UDIM tiles for example.
  • Project edition status
    A new function and events have been added to know if a project can be edited. This is useful to know if a computation is in progress and modifying the properties of a project is not possible.
Note:

The Python API documentation is accessible from the help menu of the application.

Tutorials

Below are our video tutorials covering the new features:

Release Notes

2021.1

(Released January 28, 2021)
Summary : Major release, new Geometry Mask which allows to select and paint parts of the geometry, copy/paste effects in the layer stack, improvement of UV Tile workflow, update of Iray, Bakers, Substance Engine and new content

Added:

  • New geometry mask and paint selected parts of the geometry
  • [Geometry Mask] Allow to paint selected parts of geometry by mesh names
  • [Geometry Mask] Rectangular selection in both viewports
  • [Geometry Mask] Allow to hide/ignore excluded geometry on any layer
  • [Geometry Mask][Properties] Quick selection for checkboxes with click and drag
  • [Geometry Mask][Properties][UI] Include/Exclude all with a dropdown in Properties window
  • [Geometry Mask][Properties] Allow to quickly select one item in a list with ALT+LEFT CLICK
  • [Geometry Mask][Properties] Overlay in viewports when hovering Mesh names/UV Tiles in Properties window
  • [Geometry Mask][Layer Stack] Add Copy/Paste options to the geometry mask
  • [Geometry Mask] New icon for Hide/ignore excluded geometry button
  • [Geometry Mask] New tooltip for Hide/ignore excluded geometry
  • [Geometry Mask] Keyboard shortcut ALT+H to toggle on/off "hide ignore excluded geometry" button
  • [UV Tiles][Layer Stack] New Fill layer sphere preview thumbnail for UV Tiles and simplified mode
  • [UV Tiles][Layer Stack] Allow to easily exit the UV Tile mask
  • [UV Tiles][Texture Set List] Allow to give a description per UV Tile
  • [UV Tiles][Texture Set Settings][UI] Two new section titles in the dropdown menu to change UV Tile resolution
  • [UV Tiles][Viewport] Exit UV Tile Mask when dragging a material into the viewport
  • [Layer Stack] Add Copy/Paste options for effects
  • [Layer Stack] Allow to copy/paste effects from one Texture Set to another
  • [Layer Stack] Allow multi-selection of effects
  • [Layer Stack] Add copy/paste options as shortcuts for layer effects
  • [Layer Stack] Automatically switch between mask and content when dragging effects to another layer
  • [Layer Stack] Automatically create a mask when pasting a mask from another layer
  • [Layer Stack] Add move effect actions inside the effects' contextual right click menu
  • [Layer Stack] Allow to drag and drop effects from one layer to another
  • [Layer Stack] Dragging items onto a folder places them on the top of the folder
  • Update Iray to version 2020.1.0
  • [Bakers] Update Bakers to version 2.5.4
  • [Bakers] Display individual UV Tiles in the baking progress window
  • [Bakers][UI] Allow to quickly bake the current Texture Set with a new button
  • [Bakers] Allow user to quickly select one of the bakers with ALT+LEFT CLICK
  • Update Substance Engine to version 8.0.8
  • [Substance Engine] Support Default Color in new .sbsar files
  • [Auto Unwrap] Performance improvement
  • [Export] Add visual feedback to indicate which UV Tile's resolution differs from project's default
  • [Export] Add scene size factor into exported shader json file
  • [Language] Add Japanese translation
  • [UI] Update About window with versioning of internal dependencies
  • [Scripting][Python] Allow to manage Shelf resources
  • [Scripting][Python] Allow to know when a project is ready for baking and exporting
  • [Scripting][Python] Allow to know when a Shelf has finished crawling resources on disk
  • [Scripting][Python] Allow to query the list of UV tiles per Texture Sets
  • [Scripting][Python] Allow to assign custom preview to Shelf resources
  • [Scripting][Python] Allow to manage custom shelves
  • [Scripting][Python] Add a method index in each submodule in the documentation
  • [Scripting][Python] New style for the documentation
  • [Scripting][Python] Improvement of resources and Shelf documentation
  • [Content] Three new tool presets to make stitches
  • [Shelf] Temporarily remove "Export to Substance Share" while transitioning to the new Substance Share platform

Fixed:

  • Crash when using monitors with different resolutions
  • Crash in Substance Engine with some rare projects
  • Viewport refresh fails with Hide/Ignore Excluded Geometry when switching layers
  • [2D View] 2D Viewport can be missing on some projects
  • [Baking] "Match by mesh name" ignores parts of the object
  • [Layer Stack] Clicking on a layer effect opens folder
  • [Geometry Mask] UV Tile is still counted in mask even when reimporting the mesh without it
  • [Geometry Mask] Right click menu in the viewport does not provide the correct tools
  • [Engine] Heavy lags on particular projects
  • [Scripting] High latency with remote JSON POST requests on Windows
  • [Linux] Vram amount is not detected properly with specific integrated GPUs
  • [Auto Unwrap] Crashes or long unwrap on some projects
Adobe logo

Sign in to your account