User Guide Cancel

Version 2020.1 (6.1.0) | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Color picker
    3. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    4. History
    5. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    6. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    7. Project configuration
    8. Properties
    9. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    10. Shader settings
      1. Shader settings overview
      2. Updating a shader
    11. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    12. Toolbars
    13. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    14. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (SVG)
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Shelf Issues
        1. Thumbnails in the shelf look incorrect
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 9.1
    4. Version 9.0
    5. Version 8.3
    6. Old versions
      1. Version 8.2
      2. Version 8.1
      3. Version 7.4
      4. Version 7.3
      5. Version 7.2
      6. Version 2021.1 (7.1.0)
      7. Version 2020.2 (6.2.0)
      8. Version 2020.1 (6.1.0)
      9. Version 2019.3
      10. Version 2019.2
      11. Version 2019.1
      12. Version 2018.3
      13. Version 2018.2
      14. Version 2018.1
      15. Version 2017.4
      16. Version 2017.3
      17. Version 2017.2
      18. Version 2017.1
      19. Version 2.6
      20. Version 2.5
      21. Version 2.4
      22. Version 2.3
      23. Version 2.2

Version 2020.1 (6.1.0)

Substance Painter 2020.1 (6.1.0) delivers a brand new exporter, python scripting, a new curvature baker, new content, and lots of other workflow improvements.

Release date: April 22, 2020

Note:

Starting with this release, the application version number will start to change its format. 2020.1 now becomes 6.1.0.

Major Features

New Export Texture Window

The export window has been fully reworked to offer an easier and more straightforward way to configure and export textures from a project. It also brings some new functionalities that make exporting much more convenient. The new export window is now divided into three tabs:

Settings

This tab controls the general and specific settings for each Texture Set.

  • New Global Settings
    Global Settings are a set of parameters shared across all Texture Sets. They can be used to quickly assign or update parameters without having to manually edit each Texture Set individually. Global Settings have the following parameters:

    • Output directory: defines the target location where the textures will be generated.
    • Output template: defines the preset to use to configure naming and packing of the exported textures.
    • File type: defines file format and bit depth of the exported textures.
    • Size: defines the biggest texture resolution a Texture Set will be exported at.
    • Padding: defines how information outside of the UV islands will be generated.
    • Export shaders parameters: if enabled, exports a json file storing the shader settings and their Texture Set assignments.

  • Per Texture Set settings and parameters override
    Below the Global Settings is the list of Texture Sets from the currently opened project. The General Export Parameters section displays settings inherited from Global Parameters. It is possible to choose a different export preset per Texture Set as well.

    Clicking on the Pen icon allows to override a specific parameter to change its value. Clicking on it again will disable the override and reset the value back to default (inherited from Global Settings).

  • Choose which textures to export
    Below the Texture Sets export parameters is a list of textures that will be generated. With this list, it is possible to choose precisely which file should be generated by checking or unchecking them. The list also displays the file format and bit depth for each texture, inherited from the export configuration or the output template. Use the pen icon to override the file format and bit depth for a specific texture.


  • Save settings without exporting
    It is now possible to save the export configuration of the project without having to export textures by using the new Save settings button. This is useful when you'd like to adjust a project without regenerating textures which could take some time.

  • Click and drag to quickly enable/disable exports
    Use the Mouse click plus drag to quickly enable or disable Texture Sets and textures:

Output Templates

This tab allows to create configuration presets to name the exported textures.

  • Create export presets
    The Output Template tab is identical to the Configuration tab from the old exporter. It can be used to create export presets to quickly name and pack textures. To learn how to create custom export presets, take a look at our documentation page.

  • Setup file format and bit depth in export presets
    A new addition to export presets is the possibility to set the file format and the bit depth per texture to make sharing a configuration even easier across projects.

  • Control exported textures from the output template
    When setting up the export process, use the new option Based on output template to define texture properties from the export preset.

List of Exports

This tab displays the export process in progress as well as a global summary of all the texture exported.

  • List of exported textures
    The tab lists each individual texture to be exported per Texture Set, taking into account overridden parameters and ignored/excluded textures. This is a good way to make sure that everything is fine before launching the export process. The interface will automatically switch to this tab when the export process starts.

  • Export process and logging
    On the right of the tab is a console that outputs details about the in-progress export process. It will indicate which textures were exported successfully, as well as any warnings and errors. The bottom of the interface also displays a progress bar that gives the current status of the process:

New Decal Layer Mode

There is a new Decal mode available when drag and dropping a material from the Assets. It creates a new fill layer in Planar Projection mode which allows to position patterns and images more easily. To use it, simply drag and drop any material from the Shelf while pressing the ALT keyboard shortcut to preview the manipulator and release the mouse once the decal is where you want it to be. On the release of the mouse button, a new fill layer will be created.

For this occasion, we'd also included 5 decals in the default Shelf selected from Substance Source. If you want to learn more about this new decal workflow, check out this article.

Note:
To make decals easier to use, we'd implemented a new user-data keyword that allows to specify the default blending mode for each channel when creating layers.

New Python Scripting

It is now possible to write and run Python scripts and modules with Substance Painter. We integrated Python 3.7 and PySide2 with Substance Painter, we also provide a custom Python API via the dedicated substance_painter module. Additionally, we took the opportunity to rethink our API from the JavaScript version to make it clearer and easier to use. They share similarities which should make the creation of Python plugins straightforward for existing users.

To learn more about the Python API, check out the documentation accessible via the Help menu within the application.

  • Installing a Python module
    Python modules can be installed in the dedicated Documents folder under the user account, but we also provide a way to add supplementary path locations via a dedicated environment variable to make the setup across a studio easier.

  • Substance Painter Python sub-modules
    The following sub-modules have been exposed (more will be available at a later date):

    • substance_painter.display

    • substance_painter.event

    • substance_painter.exception

    • substance_painter.export

    • substance_painter.logging

    • substance_painter.project

    • substance_painter.resource

    • substance_painter.textureset

    • substance_painter.ui

  • Python interpreter
    A new Python console window is available to try out modules and/or run python scripts:

Improved Bakers

In this release the Curvature baker has been improved and the Ambient Occlusion baker got a few new parameters.

  • New Curvature from mesh baker
    The old curvature baker is now deprecated and has been replaced by the new "from mesh" version which was recently added to Substance Designer. To learn more about the new baker settings, take a look at the documentation page.
    The new baker has the following features:

    • More accuracy: the curvature computed is much more precise and produces realistic values.
    • Mesh contact: interpenetration between meshes now produces curvature information (which was not the case with the previous baker).
    • High-poly mesh: details are now baked from the high-poly mesh directly instead of converting from the normal map.
    • Performances: the new baker uses raytracing to compute details, which means it benefits from GPU raytracing acceleration (RTX/Optix).

    It is still possible to access the old curvature baker for compatibility reasons via the Curvature baker settings. Choose the setting Generate from Normal Map to use the old baker.

  • Improved Ambient Occlusion
    The Ambient Occlusion baker has been improved to support new settings:

    • Ground Plane: simulates a plane below the mesh to create shadowing coming from the ground. For more information, see the Ambient Occlusion documentation.
    • Ignore Backface: there is a new mesh name suffix to ignore specific object when baking the Ambient Occlusion. For example, this allows to ignore floating geometry details. For more information, take a look at the Matching By Name documentation

Improved Mesh Export (with Tessellation)

The export mesh has been improved with new features and settings:

  • Export original mesh topology or export mesh with tessellation
    When exporting the mesh, it is now possible to choose to apply the tessellation generated for displacement effects. Possible settings are:

    • Without displacement/tessellation: export the base mesh without mesh subdivisions. If Apply Triangulation is disabled, the original mesh triangles, quads or n-gons will be exported.
    • With displacement/tessellation: export the mesh with subdivisions. If Recompute vertex normals is enabled, the mesh normals will be adjusted to match the displacement offsets.

  • Scene hierarchy and mesh names
    The original scene hierarchy and the object names from the imported mesh are now preserved and reapplied to the exported mesh.

  • Export with FBX file format
    The project mesh can now be exported in FBX, alongside other file formats.
    Note: Incompatible data with Substance Painter is still discarded during import (ex: skinning, joints).

Improved Automatic UV Unwrapping

The Automatic UV Unwrap can now be more easily controlled with the help of new settings:

  • Use Automatic UV Unwrapping during project creation
    When creating a project, there is now a new setting that allows to enable or disable the new automatic UV unwrapping process. This setting is also available when re-importing a 3D mesh to an existing project.

  • Advanced Unwrapping settings
    Next to the checkbox to enable the Automatic UV Unwrapping is a new Options button. It opens a new window with advanced settings to control the unwrapping process, allowing to preserve existing mesh information at different part of the process instead of always recomputing everything like it did before. For more information, see the dedicated documentation. Current settings are:

    • Seams: defines if the existing seams are preserved or regenerated.
    • UV islands: defines if the existing UV unwrap is preserved or regenerated.
    • Packing: defines if the UV island packing is preserved or regenerated.
    • Margin size: defines the spacing between each UV island (percentage).

New Content

In this release we included a few new materials as well as updated a lot of our export presets to match new software versions.

  • 5 new decal materials
    We added 5 new materials coming directly from Substance Source to try out the new decal feature:

    • Large Rust Leaks
    • Medium Acarospora Lichen
    • Scarce Blood Leaks
    • Small Bullet Impacts On Concrete Wall
    • Spray Paint Tag

  • New Vray shader, project templates and export presets
    In collaboration with Chaos Group we integrated two new shaders that replicate the VrayMtl behaviors. They should provide a more accurate look when trying to match renders made with Vray. Use the project templates to easily setup any new project for Vray. Take a look at the documentation to learn more about it.

  • New Maxwell project templates and export presets
    In collaboration with Next Limit we integrated new project templates and export presets for the Maxwell renderer.

  • Updated export presets
    Many export presets have been updated, mainly to use the new file format and bit depth settings but also to match new software versions.

Tutorials

Check out our new video tutorials covering the new features:

Release Notes

2020.1.3

(Released June 16, 2020)
Summary : Bugfix

Added:

  • [Export] Add displacement settings in Shader parameters json file

Fixed:

  • [Crash][Engine] Crash when trying to erase and replace existing channels
  • [Crash] Changing shader after painting a mask in material layering
  • [Crash][Engine] Crashes with some heavy projects
  • [Bakers] Matching By Name doesn't work with OBJs exported from zBrush
  • [Displacement][SVT] Textures are not displayed at project opening when displacement is on
  • [Export] Some textures are exported uniform gray
  • [Export] Disabled Texture Sets should not be exported for Dimension and Sketchfab export presets
  • [Scripting][JavaScript] Crash while using the JavaScript API to access the export config in the onProjectOpened event
  • [Scripting][Javascript] onExportFinished() is not called after an export

2020.1.2

(Released May 28, 2020)
Summary : Bugfix with Substance Engine and Bakers update

Added:

  • [Bakers] Update to the most recent version
  • [Bakers] New Sampling method in Ambient Occlusion, Curvature, Thickness bakers
  • Update to the most recent version of Substance Engine
  • [Scripting][Python] Allow creation of ResourceID for project resources
  • [Scripting][Python] Allow querying channel information
  • [Scripting][Python] Add dryrun and callback functions to simulate texture export

Fixed:

  • [Bakers] Incorrect normals in World Space Normals baker using a tangent Normal map in specific cases
  • [Bakers] Error baking Ambient Occlusion with Optix when no high poly
  • [Dynamic Strokes] Lag when loading specific Texture Set
  • [Export] Should not export the disabled texture sets for USD, glTF
  • [Scripting][JavaScript] Cannot edit new Curvature baker settings
  • [Scripting][JavaScript] alg.texturesets.addChannel() does not return an error in some cases
  • [Scripting][JavaScript] Typo in Javascript API documentation for setProjectExportOptions()
  • [Scripting][JavaScript] Always exports all texture sets
  • [Scripting][Python] sys.executable returns a path to python.exe instead of Substance Painter
  • Texture cache not compatible across Mac OS and Windows/Linux
  • [Livelink UE4] Only last material is used for all texture sets in a combined mesh

Known Issues:

  • [Export][Dimension][Skecthfab] Should not export the disabled texture sets
  • [Crash] Change shader after having painted a mask in material layering

2020.1.1

(Released May 05, 2020)

Added:

  • [Export] Overridden state visual feedback on TextureSet

Fixed:

  • [Export] Exporter window size too large on special resolution monitor and can not be resized
  • [Export] Options are not saved after export
  • [Export] Crash or cannot export with "from cache" export preset
  • [Export] Cancelling export generates an unexpected additional empty map
  • [Export] Fix virtual export preset settings
  • [Python] PYTHONPATH env var is not taken into account
  • [Python][Export] Cancelling export via Python returns an exception error
  • [Python][Export] export_project_textures incorrect result with psd file format

Known Issues:

  • [JavaScript] Cannot edit new Curvature baker settings
  • [JavaScript][Export] Always exports all texture sets
  • [Bakers] Crash on Linux with GPU raytracing
  • [Export][USD] Should not export the disabled texture sets

2020.1.0

(Released April 22, 2020)

Added:

  • New texture and mesh exporter
  • [Export] New exporter interface
  • [Export][Export tab] Allow selection of which maps channels are exported per Texture Set
  • [Export][Export tab] Allow modification of the Texture Set size for all Texture Sets in one action
  • [Export][Export tab] Allow a different template per Texture Set (except for USD, glTF, Sketchfab and Dimension)
  • [Export][Export tab] Quick activation and deactivation of maps and Texture Sets
  • [Export][Export tab] Export resolution 8192x8192 no longer experimental
  • [Export][Export tab] Allow modification of the file format and bit depth per map
  • [Export][Export tab] Allow reset to the default parameters' values
  • [Export][Export tab] Allow settings to be saved without exporting
  • [Export][Output templates tab] Rename "Configuration" tab to "Output templates" tab
  • [Export][Output templates tab] Allow definition of file format and bit depth per preset map
  • [Export][List of exports tab] New preview tab to summarize and view export process
  • [Import/Export Mesh] Import/Export time performance optimization
  • [Export Mesh] Export Mesh in FBX
  • [Export Mesh] Export mesh with displacement and tessellation
  • [Export Mesh][UI] New settings for recomputing normal vertex, apply triangulation
  • [Export Mesh] Export original mesh topology with new UVs generated by auto unwrapping
  • Updated auto UV unwrapping with more controls
  • [UV Unwrapping][UI] Add setting to activate auto UV unwrapping in new project window
  • [UV Unwrapping][UI] New Options to control the unwrapping steps (seams, unwrapping, packing)
  • [UV Unwrapping][UI] Allow conservation of existing unwrapping seams/unwrapping/packing
  • [UV Unwrapping][UI] New Options to fully recompute unwrapping steps
  • [UV Unwrapping][UI] New Option to control the margin size (none, small, medium and large)
  • New Bakers
  • [Bakers] Replace old Curvature by new Curvature from mesh
  • [Bakers] Add match by name option to ignore backface in "Ambient Occlusion" baker
  • [Bakers] Add ground plane option in "Ambient Occlusion" baker
  • New scripting Python API (3.7.6)
  • [Python][UI] New scripting menu for Python
  • [Python][UI] New Python documentation in Help menu
  • [Python] Expose Substance Painter python modules: substance_painter, alg, display, project.setting, project, texturesets, ui
  • [Python] Expose new "substance_painter" Python module
  • [Python] Expose new Python sub-module: alg, display, log, project, resource, texturesets, ui
  • [Python] Listener for project changes
  • [Python] New examples in Python documentation
  • [JavaScript][UI] Plugins menu replaced by JavaScript
  • [Viewport] Allow creation of a decal projection by "drag/dropping + ALT" a resource from the shelf
  • New Content
  • [Content] 5 new decal materials from Substance Source
  • [Content] Add new project templates and export presets for Maxwell renderer
  • [Content] Add project template for Keyshot 9 export
  • [Content] Update Keyshot 9 export preset to support displacement and emissive
  • [Content][Exporter] Update of all export presets to match latest versions of game engines and renderers
  • [Content][Exporter] Update export presets files to use new format and dithering settings
  • [Content] New templates and shaders to support VRay material (VRayMtl)
  • [Layer Stack] Allow deletion of layer effects using trash icon or keyboard shortcut Delete
  • Remove plugin Substance Source (use launcher with "send to" functionality)
  • [Windows] Do not display TDR warning on high-end GPUs

Fixed:

  • Translation issues in new project file dialog
  • [Bakers] Setting "Save preprocessed scene file" does not work anymore
  • [Bakers] Crash when baking with optix when no high poly
  • [Planar Projection] Projection does not work on meshes with repeating UVs
  • [Decal] Difference of behavior in normal channel when using different fill layer projection modes
  • [Smudge][Clone] Artifact may appear when painting in mask
  • [Engine] Crash with specific layer content
  • [Engine] Random crash when painting in some cases
  • [Anchor point] Reference to an empty mask always returns white
  • [Export] Layer not taken into account in some particular stack configurations
  • [Export mesh] Cannot export with path containing special characters
  • [Export Mesh] Cannot read glTF files when exported from Linux or MacOS
  • [Import mesh] Re-importing DAE, PLY or glTF does not work as intended
  • [Crash] Change shader after having painted a mask in material layering

Known Issues:

  • [Scripting][JavaScript] Cannot edit new Curvature baker settings
  • [Bakers] Crash on Linux with GPU raytracing
  • [Export][USD] Should not export the disabled texture sets

 Adobe

Get help faster and easier

New user?