User Guide Cancel

Version 7.2 | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Substance 3D Assets
    3. Color picker
    4. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    5. History
    6. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    7. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    8. Project configuration
    9. Properties
    10. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    11. Shader settings
      1. Shader settings overview
      2. Updating a shader
    12. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    13. Toolbars
    14. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    15. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
      9. UV set to UV set projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (.svg & .ai)
    11. Text resource
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Library Issues
        1. Thumbnails in the shelf look incorrect
        2. Error when importing a Font
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 10.0
    4. Version 9.1
    5. Version 9.0
    6. Old versions
      1. Version 8.3
      2. Version 8.2
      3. Version 8.1
      4. Version 7.4
      5. Version 7.3
      6. Version 7.2
      7. Version 2021.1 (7.1.0)
      8. Version 2020.2 (6.2.0)
      9. Version 2020.1 (6.1.0)
      10. Version 2019.3
      11. Version 2019.2
      12. Version 2019.1
      13. Version 2018.3
      14. Version 2018.2
      15. Version 2018.1
      16. Version 2017.4
      17. Version 2017.3
      18. Version 2017.2
      19. Version 2017.1
      20. Version 2.6
      21. Version 2.5
      22. Version 2.4
      23. Version 2.3
      24. Version 2.2

Version 7.2

Substance 3D Painter 7.2 brings new rendering capabilities with the Adobe Standard Material workflow, new ways of sharing content across Substance 3D applications and an overhauled Assets window.

Release date: 23 June 2021

Major features

New Assets window

The old Shelf window has been improved and renamed as the Assets window. This redesign focus on making content more quickly accessible and easier to filter with the new dedicated icons. It also comes with an easier navigation system with the breadcrumbs. This redesign also focus on making the experience similar to other Substance 3D software so that managing content across applications is easier.

Note:

This release introduces changes in the way we manage the application preferences and the Shelf/Assets content. To know how to migrate your data please take a look a the dedicated page.

  • New design and layout
    The new design focus on simplicity but as well on easier organization of the window. The window can now be docked vertically without wasting space. A new "list" display mode allows to search assets by name much more easily.

  • New breadcrumb navigation
    Navigation resource can be hard sometimes in a tiny UI. With the breadcrumb is not now easier to jump between folders without having to display the full folder hierarchy.

  • New usage filters
    There is a lot of different content in the Assets window and the usages are a good way to filter content isolate specific resources. To select a specific usage simply click on the dedicated button. To add or remove multiple usages, press and maintain CTRL while clicking on a button.

  • Improved thumbnail rendering
    We took the time to rework our thumbnail generation system to improve their quality and make them look more consistent across the the Substance 3D ecosystem. We also added the support of displacement.

  • Loading thumbnails from Substance Archives (sbsar)
    Custom thumbnails embedded inside Substance files are not loaded and displayed in the Assets window. Sharing custom resources is now easier as there is no need to include the resource metadata for custom icons.
  • Improved performances
    The loading and generation time of thumbnails has been improved on several aspects and should now be much faster.
  • Increase preview memory budget to load more thumbnails
    By default a limited amount of memory is allocated to the display of thumbnails to save on performances. Having a library with many resources however can lead to loading and unloading thumbnails constantly which make navigation and searching for resources difficult. There is now a new environment variable to override the default budget value.

New Adobe Standard Material workflow

A new shader has been added, named Adobe Standard Material (ASM), which supports several features at once allowing to build more complex and accurate materials within a single Texture Set. With this new shader we also took the opportunity to add new channels to make the creation of materials easier as well.

  • New Adobe Standard Material shader
    The new ASM shader is a shader that regroups several functionalities as well as an evolution of our PBR rendering. It supports at the same time:
    • Anisotropy
    • Clear coat
    • Sheen
    • Specular edge color
    • Additional subsurface scattering methods
    • And of course the other existing features such as Parralax Occlusion, Displacement, etc.
  • New channels and user channels
    In order to support the new ASM shader new channels have been added. We also doubled the number of users channels to expand the possibilities of custom information and custom shaders.
    • Coat color
    • Coat roughness
    • Coat normal
    • Coat opacity
    • Coat specular level
    • Scattering color
    • Sheen color
    • Sheen roughness
    • Sheen opacity
    • Specular edge color
    • User channels from 8 to 15
  • Improved Texture Set settings
    The channel list menu in the Texture Set settings now groups channels base don their compatibility with the current shader. This helps identify which channels will have an effect in the viewport.

  • New Shader API features with visible if and recompilation
    With the development of the ASM shader some changes in the API have been made with two notable features:
    • Visible If: shader parameters can be shown or hidden based on condition make the shader UI easier to read.
    • Recompilation: by declaring parameters in a specific way, it is now possible to disable part of a shader and recompile it to optimize it when the parameter change. This allows to discard unused functionalities.

New Substance 3D ecosystem exchange

Sending resources and assets between Substance 3D applications is now much easier and accessible in one click with this new workflow. It is now possible to receive Substance files from Substance 3D Designer or Substance 3D Sampler or to send a project into Substance 3D Stager very easily to quickly iterate on content.

Alert:

This send and receive functionalities are only available through the Creative Cloud Desktop version of the application as it relies on specific technologies to make it possible. This means the Steam or Substance 3D standalone version don't support these features.

  • Painter to Stager
    Export from Painter to Stager with the updated export preset or use the Send to Substance 3D Stager action to automatically export and import the current project into Stager. No manual configuration needed.
  • Stager to Painter
    Receive models from Stager to texture with a similar one click action directly form Stager.
  • Designer or Sampler to Painter
    Receive Substance materials, filters and more from Designer or Sampler direclty into the Assets window in one click.
  • Substance 3D Assets to Painter
    Receive content such as Substance material from the Creative Cloud Desktop directly into the Assets window of Painter.
  • Show in Bridge
    Resources in the Assets window located in a library managed by Adobe Bridge can be opened in Bridge directly by using the right-click menu over a specific resource.

New content

New content has been added in this release:

  • New project templates for Adobe Stand Material (ASM)
    To make it easier to start using the new ASM shader, new project templates have been created to speed-up project creation:
    • ASM - PBR Metallic Roughness
    • ASM - PBR Metallic Roughness Anisotropy Angle
    • ASM - PBR Metallic Roughness Coated
    • ASM - PBR Metallic Roughness SSS
    • ASM - PBR Metallic Roughness Sheen
  • New environment maps
    Several new environment map has been added to light your projects, including the Studio 06 used to render the new Assets thumbnails:
    • Interior:
      • Atelier
    • Studio:
      • Studio 06
      • Studio 80s Horror Flick A
      • Studio Black Soft
      • Studio White Soft
      • Studio White Umbrella

Improved Automatic UV Unwrapping

A new update of the automatic UV unwrapping has been added which brings the support of UV Tiles and additional control on the UV generation:

  • UV Tile amount
    When generating UVs it is now possible to specific the maximum number of UV Tiles desired to be created. This allows to use the UV generation with the UV Tile workflow as well.
  • UV Island orientation
    A ew parameter has been added to add a constraint on the UV island orientation when packed. This allow to make UV islands that a bit more aligned allowing to texture some objects more easily (ex: a wood door to align the wood pattern).
  • Improved packing performance
    The packing function has been improved as well to offer good performance with the new UV Tile support.

General Improvements

This new version adds several quality of life improvements:

  • Improved sliders performances with graphic tablet's pen
    Dragging around sliders with a pen should now be much more responsive. Sliders shouldn't feel sticky anymore.
  • Improved performances with already painted layers
    Painting in layer with lot of existing brush strokes should now be much faster and not lead to slowdown anymore.
  • Faster painting after opening a project
    Painting on a layer at the top of the layer stack just after opening a project is now immediate. The engine cache computation has been postponed to later, making the re-edition of old projects a bit faster in this context.
  • Sharp normal method
    There is a new Height to Normal method parameter in the Texture Set settings which allows to control how the Height channel is converted into a normal map. This new parameter is useful to improve the quality of surfaces with lot of varying details, such as fabric materials.

  • New interface style
    The general interface has been slightly adjusted to align better with the general Substance 3D ecosystem. This make jumping from one application to the other less surprising and easier to navigate.
  • New translations
    Three new languages have been added to translate the program interface:
    • French
    • German
    • Simplified Chinese

Release notes

7.2.0

(Released June 23, 2021)
Summary : Major release, it provides an update to the asset panel, a new shader with access to new channels and parameters, an overall refresh of the UI, some much-requested performance improvements, expanded language support, and more!

Added:

  • [Libraries] New Asset panel to replace the shelf
  • [Libraries][UI] New Asset panel layout
  • [Libraries][UI] Change default Asset panel orientation and UI
  • [Libraries][UI] Introduce a list view option to library
  • [Libraries][UI] New breadcrumbs navigation in the Asset panel
  • [Libraries][UI] Select "All libraries" when selecting a saved search
  • [Libraries][UI] Select "All libraries" when all folders are deselected
  • [Libraries][UI] New tag for particle brushes
  • [Libraries][UI] Replaced "shelf" by "All libraries" across the app
  • [Libraries][UI] Allow to hide empty folders
  • [Libraries][UI] Default user library should be visible even if empty
  • [Libraries][UI] New filtering method via asset type icons
  • [Libraries] Shortcut "CTRL" to select multiple asset types
  • [Libraries] New environment variable to control the asset preview memory budget
  • [Libraries][Content] New environment maps
  • [Libraries][Content][UI] Render displacement on default materials
  • [Libraries][Content] Set Adobe Standard Material (ASM) shader as default for previews generation
  • [Libraries][Content][ASM] New Project Templates for new ASM shader
  • [Libraries][Thumbnail] Use new Studio 6 environment map
  • [Libraries][Thumbnail] Read thumbnail in resource instead of generating it
  • [Libraries][Thumbnail] Add displacement to thumbnail generation
  • [Texture Set Settings]
  • [Texture Set Settings][UI] Expose new height to normal conversion method
  • [Texture Set Settings][UI] Rework of the channels' UI organization
  • [Texture Set Settings] User Channels limit raised to 16 channels
  • [Texture Set Settings][UI] Indicate which channels are compatible with currently selected shader
  • [Shader][ASM] New Adobe Standard Material shader
  • [Shader][ASM] Added support for Anisotropy, Clear Coat, Subsurface Scattering, Specular Edge Color, and Sheen
  • [Shader][ASM] Change default channels' color values
  • [Shader][ASM][Export] Updated export template Adobe Dimension to Adobe Substance 3D Stager
  • [Shader][ASM] Added labels and tooltips for shader and MDL parameters
  • [Shader][ASM] Make the Scatter Color visible in 2D View even if SSS is not supported
  • [Shader][ASM][Iray] Support ASM shader in Iray with new MDL
  • [Shader][ASM][Iray] Updated Subsurface Scattering in legacy PBR spec gloss & coated
  • [Shader][ASM][Content] Changed the default SSS type for samples
  • [Shader][ASM] Added documentation for ASM API
  • [Shader][ASM] Optimize shaders to ignore unused channels
  • [Shader] Expose new Texture Set channels
  • [Shader] Improved Subsurface Scattering
  • [Shader] Hided new shader parameters for some shaders
  • [Shader] Visible if for shader parameters
  • [Performance]
  • [Libraries] Resource preview loading time and calculation performance improvements
  • [Engine] Painting performance improvements
  • [Auto Unwrap] Packing performance improvements
  • [Auto Unwrap]
  • [Auto Unwrap] Auto unwrap compatible with UV Tile workflow
  • [Auto-Unwrap] New option to position UVs according to mesh orientation
  • [Other]
  • [Settings] Changed default zoom direction
  • [UI] Overall refresh of the UI
  • [UI] Rework of the Help Menu
  • [UI] Replace invert icon
  • [UI][Plugin] Replace icon for the plugin dcc link
  • [UI][AMD] Update minimum required version and popup message
  • [Layer Stack] Create new layer inside selected empty folder
  • Update Python Documentation
  • [Branding]
  • [Branding][UI] Updated application name to Adobe Substance 3D Painter
  • [Branding][UI] Updated standalone version to 'Substance edition'
  • [Branding][UI] Updated application executable name, installation path, package and icons
  • [Branding][UI] Renamed default library and path
  • [Branding][UI] Updated About Window
  • [Branding][UI] Updated Welcome screen
  • [Branding][UI] Removed year-based version number
  • [Localization] New translations in German, French, and Simplified Chinese
  • [Interoperability] Not available for Steam and Substance editions
  • [Interoperability] Interoperability with Adobe Ecosystem: Designer, Sampler, Stager, and Bridge
  • [Interoperability][UI] Receive and update asset from Designer
  • [Interoperability][UI] Receive asset from Sampler
  • [Interoperability][UI] Send asset to Stager
  • [Interoperability][UI] Show in Adobe Bridge
  • [Interoperability][UI] Allow to quickly access Adobe 3D Assets
  • [Interoperability] New usage tags of sbsar
  • [Interoperability] Handle received asset types
  • [Interoperability] Asset received from Adobe Substance 3D Designer or Adobe Substance 3D Sampler are stored in user's default chosen library
  • [Interoperability][UI] New icon in left toolbar to send to Stager or Photoshop

Fixed:

  • [Tablet] Low performance when Painting with pressure
  • [Tablet] Issue on tablets with slider controls
  • [Crash] Name mismatch between Texture Set list and Exporter
  • [Crash][Libraries] Double click on a sub-library
  • [Libraries] Issue when Crawling library directories
  • [Libraries] Force preview generation command line does not work as expected
  • [Libraries][Content] Baked Light Environment filter is black by default
  • [Linux][MacOS][Export Mesh] Cannot import glTF created on Linux/MacOS
  • [Linux] Dragging and dropping a file into the Asset panel can lead to a crash
  • [Auto-Unwrap] Auto-Unwrap is available even if a mesh has not been selected for reloading
  • [Particles] Wrong particle behavior with gravity
  • [Layer Stack] Level histogram can only use Luminance with some channels
  • [Geometry Mask] Right-click menu on a folder when editing the geometry mask does not work
  • [Projection] Seam with spherical projection & bilinear filtering
  • [UV Tiles] Export mask to file only exports tile 0, 0
  • [Export Mesh] FBX mesh export is empty
  • [Iray] Normal map is not taken into account in new projects when rendering
  • [Save] Save issues on shared drives
  • [Baking] Rebaking a mesh with modified parameters displays a warning
  • [Baking][Regression] Incorrect result when high poly meshes' global bounding box does not include the scene origin
  • [Python] Custom user libraries are not taken into consideration

Known Issues:

  • [Libraries] Saved searches not saved if no project opened
  • [NVIDIA] Message for outdated driver even if the driver is up to date

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online