User Guide Cancel

Version 2020.2 (6.2.0) | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Color picker
    3. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    4. History
    5. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    6. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    7. Project configuration
    8. Properties
    9. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    10. Shader settings
      1. Shader settings overview
      2. Updating a shader
    11. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    12. Toolbars
    13. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    14. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (SVG)
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Shelf Issues
        1. Thumbnails in the shelf look incorrect
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 9.1
    4. Version 9.0
    5. Version 8.3
    6. Old versions
      1. Version 8.2
      2. Version 8.1
      3. Version 7.4
      4. Version 7.3
      5. Version 7.2
      6. Version 2021.1 (7.1.0)
      7. Version 2020.2 (6.2.0)
      8. Version 2020.1 (6.1.0)
      9. Version 2019.3
      10. Version 2019.2
      11. Version 2019.1
      12. Version 2018.3
      13. Version 2018.2
      14. Version 2018.1
      15. Version 2017.4
      16. Version 2017.3
      17. Version 2017.2
      18. Version 2017.1
      19. Version 2.6
      20. Version 2.5
      21. Version 2.4
      22. Version 2.3
      23. Version 2.2

Version 2020.2 (6.2.0)

Substance Painter 2020.2.0 (6.2.0) introduces the new UV Tile workflow which allows to paint across UDIMs. It also includes several performance and project size improvements for any type of project.

Release date: July 23, 2020

Artist credits: Dragon by Damien Guimoneau and Robot by Jason Huang.

Major Features

New UV Tile Workflow with Painting Across UDIMs

In this release we introduce the new UV Tiles workflow to Substance Painter which allows to paint across UDIM tiles.

With the new workflow, the UVs are not split into individual Texture Sets anymore. Instead, UV Tiles are contained inside a single Texture Set based on the material assignation of the mesh. UV Tiles which are within the same Texture Set can be painted across without seams, in both the 2D and 3D viewports.

UV Tile is the term used to describe in a generic manner this new workflow since UDIM is mainly a naming convention. While UDIM is currently the only convention available, we have plans to expand it in the future (such as supporting Mudbox or ZBrush naming). We’re also thinking about supporting tiles with negative coordinates, which isn't possible with the UDIM scheme. This is why we chose a broader term for this workflow.

Here is an overview of the changes introduced with this new workflow:

  • Creating a UV Tile project
    When creating a new project, there is a new setting to specify if the new workflow should be used or not.

    Note that once the workflow has been decided and the project created, it cannot be changed later contrary to other settings.

  • UV Tiles in 2D Viewport

    When using the new UV Tile workflow, the 2D view will now display a new grid where each UV Tile has a dedicated UDIM number. Each tile can be painted individually.



  • Painting across UV Tiles

    UV Tiles

    which are within the same Texture Set can be painted across seamlessly. This allows to increase the general resolution and quality of an asset by simply multiplying the number of UV Tiles.

  • UV Tiles in Texture Set List window

    The

    Texture Set List has

    been updated to list the UV tiles related to the material found on the imported mesh. Each UV Tile is displayed with its name based on the UDIM convention.



  • Changing resolution per UV Tile

    While the default resolution for each UV Tile is based on its parent Texture Set, it is possible to override it per tile. Simply select the tiles in the Texture Set List and then go to the Texture Set Settings window to change the resolution. When a tile has its resolution overridden, the new resolution will be displayed in the 2D View next to its number.

  • New layer stack icons

    The layer stack features new icons for paint and fill layers. Since UV Tiles feature many more set of textures, it wasn't possible to display all of them in this small area. This help performance since there is no need to compute specific thumbnails anymore. This new set of icons can be used for regular project as well by enabling a settings in the main settings (see below).

  • New UV Tile Mask on layers

    The UV Tile Mask is a new way to mask in/out layers which is more efficient than regular masking. It offers better performances as it allows to fully discard the computation of specific UV Tiles. This is a tool we recommend to use to get a comfortable experience when working in a project with many UV Tiles. For more information, see the dedicated page in the documentation.

  • Painting through masked UV Tiles
    With multiple UV Tiles being in the same Texture Set, it might be difficult to paint certain areas of a mesh because of other parts of the geometry being in the way. To circumvent that situation, a new painting setting has been added in the contextual toolbar named Paint strokes ignore masked UV Tiles. When this setting is enabled, any UV Tile excluded via the UV Tile Mask will be hidden in the viewport, allowing paint strokes to go through/ignore them. Modifying the UV Tile Mask will recompute the brush strokes as it allows reimporting a mesh which may have modified UV Tile or new geometry that needs to be excluded as well. This avoids redoing the paint strokes.

  • Baking UV Tiles

    The bakers also support UV Tiles and there is now a selection list in the baking window

    to specify which tiles and Texture Sets should be baked. The selection can be quickly changed by clicking and dragging over the checkbox or by using the new dropdown menus.



  • Exporting UV Tiles textures with the new $udim tag

    A new tag has been added to the output templates which allows to export files with the UV Tile number in their filenames. Currently only the UDIM convention is available. It is also possible to use parentheses to define optional elements in a filename when a tag is not available. This allows for example to create filenames that only append the UDIM number when available with UV Tile projects, making export presets compatible with any type of projects.

  • Importing image sequences
    A sequence of images is a series of textures where each of them match a specific UV Tile. To import an image sequence, simply drag and drop the first file of the sequence into the Shelf or use the import resources window. The remaining files in the sequence will be automatically imported as well. The sequences will be displayed in the Shelf as a single resource with a number indicating how many files they contain. To use the sequence, simply drag and drop it into a fill layer. The projection mode will be automatically set to Fill (Match Per UV Tile).

  • Support of Facesets with Alembic meshes

    Alembic Facesets are now imported as materials to be split into Texture Sets. This change makes Alembic meshes compatible with the new UV Tiles workflow. If an Alembic mesh contains faces which are not in a Facesets, they will be put automatically into a Texture Set named DefaultMaterial.

To learn more details about the new UV Tile workflow, take a look at the dedicated documentation.

Note:
The UV Tile workflow can be very demanding, we recommend working with SSDs to store both the cache and a project file to reduce loading times and get a smooth experience.

New Pause Engine

It is now possible to pause Substance Painter engine while working. With the engine paused, any texture computation, viewport updates or paint strokes is registered but not computed.

This new action allows to setup and tweak complex layer stacks and delay the computation to the last moment. The main advantage of pausing the engine is avoiding intermediate computations and instead only compute the final result. This makes the application more responsive and the update overall more rapid. The trade-off is that there is no visual feedback until the engine is unpaused.

To pause the engine, simply click on the button in the contextual toolbar above the viewport, or use the shortcut Shift + Escape (can be modified in the Settings). To unpause the engine toggle off the button or reuse the shortcut.

Performances Improvements

  • Faster export of textures
    Exporting textures should be significantly faster, especially with heavy projects that generate many textures. Several improvements have been made in the way textures are generated generate and written. In our internal tests on projects with many Textures Sets or complex layer stacks we saw the export process being generally up to 4 or 5 times faster.

  • Delayed cache computation when opening projects
    Substance Painter uses a cache system to allow fast tweaking and blending of layers. In previous versions this cache was being computed each time a project was opened (visible by the green loading bar at the bottom of the viewport). Now the cache computation is only triggered when trying to edit a layer (by painting or tweaking a fill layer parameter for example). This change allows to open projects without waiting and switching to the desired Texture Sets before starting to work. The computation is also more granular, which allows to only compute what is needed. For example with a project containing UV Tiles, only the tiles that need to be modified are computed.

  • Asynchronous loading of mesh maps
    Mesh maps are now loaded asynchronously. This means the application will not be blocked anymore while waiting for the mesh maps to load. This is especially visible when displaying the mesh map in the viewport (as in the image below). It also makes opening projects quicker since there is no wait for the mesh maps anymore.



  • Improved mask view mode editing
    When using ALT+Click on a mask (or the dedicated view mode) to display it in the viewport, the texture updates are now only performed for the mask. This means painting and editing effects is much more smooth using this view mode as any other computations is delayed until the viewport is set back to the material mode.

  • New layer stack thumbnails
    As mentioned previously, the layer stack can now use a new set of icons. Using these icons can improve general performances as no thumbnails has to be computed. While this is automatic for UV Tile projects, regular projects can choose to use these icons as well by going to Edit > Settings and enabling Replace layer stacks thumbnails with icons.

  • Faster incremental save
    As project can be smaller and the save process is more granular regarding the data that changed, incremental save (pressing CTRL+S) is now much quicker. This is especially noticeable on heavy projects.

  • Improved Iray startup performances
    Switching to the render mode with Iray should be quicker as we improved the way we manage the memory shared within the application.

Project Size Improvements

Project files are notorious to have an heavy file footprint. We took the time to investigate the root cause of this problem and designed a few solutions. This version introduces a first set of changes:

  • Switching bakers outputs to grayscale images
    In previous versions, the bakers would output RGB images in any cases. Now grayscale bakers (curvature, ambient occlusion) will only output grayscale images. This simple change can reduce projects size from 20% to 60% down. To take advantage of this change, mesh maps in existing projects need to be regenerated.

  • Changing default diffusion and dilation settings for bakers
    Previously, the bakers would generate a 1 pixel dilation and then a diffusion pattern (blurry pixels outsides the UV islands). This setup generate quite heavy textures as gradient are hard to compress. The default settings have therefore been changed to reduce that issue. By default diffusion is now off and the dilation has been set to 32 pixels (which should match 4K resolutions). We recommend switching existing project to these new settings and rebaking to take advantage this improvement.

Miscellaneous Improvements

This new version includes a few additional changes:

  • Baking Selection
    To make things easier with the new UV Tile workflow, the baking window has been slightly modified to include a new selection list, which includes the UV Tile list per Texture Set. The "bake current Texture Set" button has therefore been removed. To keep the selection of what to bake convenient, several options has been added in dropdown menus:



  • Shader Instance in Texture Set Settings
    With the rework of the Texture Set list to includes UV Tiles, some slight changes have been made to make the UI less cluttered. The functionality which previously allowed to create and switch to different shader instances has now been moved into the Texture Set settings.

Tutorials

Below are our new video tutorials covering the new features. More videos are available on Substance Academy about the new UV Tile workflow.

Release Notes

2020.2.0

(Released July 23, 2020)

Added:

  • UV Tiles (UDIMs)
  • [UV Tiles] Paint across UV tiles
  • [UV Tiles] Allow to choose between new and legacy workflow for UV Tiles
  • [UV Tiles] Import UDIMs/UV Tile image sequences as a resource
  • [UV Tiles] Add list of UV Tiles per Texture Set in Texture Set List window
  • [UV Tiles] Allow to edit the resolution of multiple UV Tiles at once in Texture Set Settings
  • [UV Tiles][2D View] Display UV Tiles as a grid
  • [UV Tiles][2D View] New viewport button to display or hide UV Tiles information
  • [UV Tiles] Switch painting tool to single channel by default for UV Tile projects
  • [UV Tiles] New button in contextual toolbar to ignore masked UV Tiles while painting
  • [UV Tiles][Layer Stack] New layer stack icons to improve performance
  • [UV Tiles][Layer Stack] Improve Paint and Fill icons in the toolbar
  • [UV Tile Mask][2D View] Allow to include or exclude multiple UV Tiles at once (left click, CTRL+left click)
  • [UV Tile Mask] New UV Tile mask to include, exclude tiles per layer with a new icon
  • [UV Tile Mask][Layer Stack] Display the number of UV Tiles in the UV Tiles mask icon when not all are included
  • [UV Tile Mask][2D/3D View] Add hover effect to visualize UV Tiles under the cursor
  • [UV Tiles][Bakers] Allow to select and bake specific UV Tiles
  • [UV Tiles][Bakers] Add selection options for Texture Sets/UV Tiles
  • [UV Tiles][Bakers] Right click menu option to select UV Tiles within a Texture Set
  • [UV Tiles][Bakers] Allow quick selection in the Texture Set/UV Tiles by dragging
  • [UV Tiles][Bakers] Replace "All" and "None" buttons in Mesh Maps by more explicit selection options
  • [UV Tiles][Bakers] Display number of textures to be baked
  • [UV Tiles][Export] Allow to select and export specific UV Tiles
  • [UV Tiles][Export] Allow quick selection of UV Tiles by dragging
  • [UV Tiles][Export] Add dropdown menu options for UV Tiles
  • [UV Tiles][Export] Make some export presets unavailable if they do not work with UV Tiles (Adobe Dimension, Sketchfab, glTF, USD)
  • [UV Tiles][Content] Update export presets to use the new $udim tag
  • [UV Tiles] Improve error reporting when importing meshes with overlapping UV islands
  • [UV Tiles] UV Tiles compatible in Iray
  • [UV Tiles][Scripting] Add UV Tile export documentation to Python doc
  • Performance
  • [Performance] New button in contextual toolbar to pause engine computation when working (SHIFT+ESC)
  • [Performance] Faster project opening by delaying Texture Set cache computation
  • [Performance] Don't wait for mesh maps to load when opening project
  • [Performance][2D/3D View] Don't compute Mask channel in viewport when it is not used
  • [Performance] Do not block the application when loading mesh maps displayed in the viewports
  • [Performance] Improve incremental save speed when saving a project
  • [Performance][Bakers] Change default dilation settings to improve saving time and project size
  • [Performance][Bakers] Switch to grayscale on specific Bakers to improve saving time and project size
  • [Performance][Export] Improve engine performance to export textures faster
  • [Performance][Export] Improve responsiveness when opening the export dialog with a lot of Texture Sets
  • [Performance][Export] Improve performance when switching to tab "List of Exports"
  • [Performance][Iray] Reduce Iray startup time
  • Other
  • [Bakers] Add selection options for Texture Sets
  • Move shader instance management to Texture Set Settings
  • [2D/3D View] Add message at bottom of the viewport to indicate which mask type is edited
  • [Layer Stack] New option in settings to switch between legacy and new thumbnails
  • [Layer Stack] Add visual feedback to indicate loading state of the thumbnails
  • [Proj] New projection mode "Fill (Match Per UV-Tile)" to load image sequences
  • [Proj] Change fill layers projection mode to "Fill (Match Per UV-Tile)" in specific cases
  • [Content] Optimize Charcoal brush presets to improve performance
  • Update Iray to version 2020.0.0
  • [Export] Disable List of Exports tab when nothing is selected
  • Auto Unwrap
  • [Auto Unwrap] Improve quality of seams placement
  • [Auto Unwrap] Improved parameterization to increase speed and stability

Fixed:

  • [Alembic] Facesets are ignored when importing files
  • [Alembic] Infinite loading time with specific files
  • [Import] Incorrect UDIM image sequence is imported when only the file extension differs
  • [Crash] Trying to open project locked by another process leads to a crash
  • [Export] Emissive channel is not exported with USD format
  • [Content] Smart Material "Charcoal" contains paint strokes

Known Issues:

  • [Texture Set List] Cannot hide description
  • [Texture Set List] UI issues

 Adobe

Get help faster and easier

New user?