User Guide Cancel

Export settings | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Substance 3D Assets
    3. Color picker
    4. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    5. History
    6. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    7. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    8. Project configuration
    9. Properties
    10. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    11. Shader settings
      1. Shader settings overview
      2. Updating a shader
    12. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    13. Toolbars
    14. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    15. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
      9. UV set to UV set projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (.svg & .ai)
    11. Text resource
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Library Issues
        1. Thumbnails in the shelf look incorrect
        2. Error when importing a Font
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 10.0
    4. Version 9.1
    5. Version 9.0
    6. Old versions
      1. Version 8.3
      2. Version 8.2
      3. Version 8.1
      4. Version 7.4
      5. Version 7.3
      6. Version 7.2
      7. Version 2021.1 (7.1.0)
      8. Version 2020.2 (6.2.0)
      9. Version 2020.1 (6.1.0)
      10. Version 2019.3
      11. Version 2019.2
      12. Version 2019.1
      13. Version 2018.3
      14. Version 2018.2
      15. Version 2018.1
      16. Version 2017.4
      17. Version 2017.3
      18. Version 2017.2
      19. Version 2017.1
      20. Version 2.6
      21. Version 2.5
      22. Version 2.4
      23. Version 2.3
      24. Version 2.2

Export settings

This page regroups information about the settings section of the export textures window. This section allow to configure the composition, size and location of the textures generated by the application that will be exported.

General and Texture Sets configuration

The first element of the window is the list of Texture Sets on the left. The Global settings section allow to specific common parameters across all Texture Sets. This make it easy to adjust a single set of settings to apply or any Texture Sets. Each Texture Sets can then specify its own set of rules as override. For example setting 2048 as the export resolution in the global settings and 1024 as an override for a specific Texture Set.

The checkbox next to each Texture Set name signifies if the associated textures will be exported or not.

The dropdown menu allow to quickly modify the selection with Check all, Uncheck all, Invert all actions.

General export parameters

This section contains the shared settings for each textures that will be generated:

SettingDescription
Output directoryLocation to where the generated texture will be written on the disk.
Output templateExport preset configuration used to name and composite the channels into texture files. For more information on the presets see the Export presets list.
File type

The file format and its bit depth. If the option Based on output template is selected, the file format is inherited form the export preset (which allow a format and bit depth per textures instead of a global one).

The available bit depth depends on the file type, see the table below for more information.

Size

The resolution of the exported texture file. Possible values:

  • Based on each Texture Set's size
  • 128
  • 256
  • 512
  • 1024
  • 2048
  • 4096
  • 8192 (only available with GPUs that have more than 1.5GB of Vram)
Padding

How the area outside the UV islands is filled inside the texture. Possible values are:

  • No padding (passthrough): use the current state of the texture as-is.
  • Dilation infinite: stretch UV island borders until they reach neighbor borders or the end of the texture.
  • Dilation + transparent: stretch UV island borders to the given distance in pixels, the rest is transparent.
  • Dilation + default background color: stretch UV island borders to the given distance in pixels, the rest is filled with the default color of the Texture Set's channel.
  • Dilation + default background color: stretch UV island borders to the given distance in pixels, the rest is filled with the default color of the Texture Set's channel.
  • Dilation + diffusion: stretch UV island borders to the given distance in pixels, the rest is filled with a blurry version of the UV island (based on mip-maps).
Note:

The psd file format is a container, this means that output maps will be gathered together inside a single file on disk.

Dithering

Exporting textures in 8 bit can lead to banding in gradients. This is especially noticeable with Normal and Height maps. There are two ways to solve that issue: using higher precision or compensating with dithering.

Higher precision (16 or 32 bit) is ideal, but this may not be compatible with all application. Game engines notably will compress to 8bit in most cases. Dithering introduces a slight noise which mitigates the banding issue while still using 8 bit of information.

Texture file formats

Below is a list of all the file format supported by the application:

Format nameFormat extensionSupported bit-depth
Bitmapbmp8, 8 + dithering
OpenEXRexr16 (floating), 32 (floating)
Graphics Interchange Formatgif8, 8 + dithering
Radiance HDRhdr32 (floating)
Iconico8, 8 + dithering
Jpeg 2000j2k8, 8 + dithering, 16
Jpeg Network Graphics
jng8, 8 + dithering, 16
Jpeg 2000jp28, 8 + dithering, 16
Jpeg
jpeg8, 8 + dithering
JPEG extended rangejpeg-xr8, 8 + dithering, 16, 32 (floating)
Portable Bit Map
pbm8, 8 + dithering, 16
Portable Float Map
pfm32 (floating)
Portable Gray Map
pgm8, 8 + dithering, 16
Portable Network Graphicspng8, 8 + dithering, 16
Portable Pixel Map
ppm8, 8 + dithering, 16
Photoshop Document
psd8, 8 + dithering, 16
Truevision TGAtarga8, 8 + dithering
Tag Image File Formattiff8, 8 + dithering, 16, 32 (floating)
Wireless Application Protocol Bitmap Formatwbmp8, 8 + dithering
WebP
webp8, 8 + dithering
X PixMap
xpm8, 8 + dithering

Output maps

This section list all the textures that will be generated based on the current export preset. It indicates the texture name template, the file format and bit depth, and the color space as well if Color management is enabled.

This section allows to disable the export of specific files or to override the file format and bit depth.

Export USD asset

Checking this box will allow you to export in USD format. Unlike the USDz (Apple AR) preset available in Output templates, this export will take into consideration any template or parameter you've configured for your export. The following files are exported when you check the USD asset box -

  • A folder with texture maps
  • A .usda which points to the texture maps folder.
  • An optional .usd that assembles materials and original mesh file. It can directly be used in Omniverse to show your mesh with materials applied automatically.
  • An optional .usd which creates a file with the mesh used in project. It is exported only if the original mesh file is not a USD or if Painter's auto-unwrap was used to generate UVs.

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online