User Guide Cancel

Version 7.3 | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Color picker
    3. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    4. History
    5. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    6. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    7. Project configuration
    8. Properties
    9. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    10. Shader settings
      1. Shader settings overview
      2. Updating a shader
    11. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    12. Toolbars
    13. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    14. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (SVG)
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Shelf Issues
        1. Thumbnails in the shelf look incorrect
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 9.1
    4. Version 9.0
    5. Version 8.3
    6. Old versions
      1. Version 8.2
      2. Version 8.1
      3. Version 7.4
      4. Version 7.3
      5. Version 7.2
      6. Version 2021.1 (7.1.0)
      7. Version 2020.2 (6.2.0)
      8. Version 2020.1 (6.1.0)
      9. Version 2019.3
      10. Version 2019.2
      11. Version 2019.1
      12. Version 2018.3
      13. Version 2018.2
      14. Version 2018.1
      15. Version 2017.4
      16. Version 2017.3
      17. Version 2017.2
      18. Version 2017.1
      19. Version 2.6
      20. Version 2.5
      21. Version 2.4
      22. Version 2.3
      23. Version 2.2

Version 7.3

Substance 3D Painter 7.3 brings new ways of texturing meshes with the new warp and cylinder projections for fill layers.

Release date: 13 October 2021

Major features

New warp projection

This release introduces the new 3D warp projection for fill layers and fill effects. This projection allows to distort a texture or an image with the help of a deformation grid and controllable points.

  • Quick setup via drag and drop
    Choose a material, an alpha, a texture or a procedural from the Assets library, drag and drop onto the desired part of the mesh (shortcut ALT required for Materials). If your asset is not a material, a popup with inquire which channel you would like to assign it to.
    Once the layer is created, you will see that the new Warp projection is automatically selected. The layer has standard 3D projection mode controls, but also a new parameter Projection Depth which allows to set the depth of the warp projection (represented by green arrows as a visual queue).
    You can also select this projection mode manually on any fill layer or effect without having to drag and drop an asset into the viewport.

  • Automatic placement with the Surface tool
    When the new Warp layer is created, you will see that the Surface tool is automatically selected. This allows you to move the image so it remains on the surface of your mesh at all times. However you can always switch to any of the other manipulators and adjust its translation (shortcut W), rotation (shortcut E) or scale (shortcut R). To return to the Surface tool, use shortcut SHIFT + W. When switching to Edit vertices mode, the Surface tool is also the default selection and it snaps vertex movement to the surface of your mesh. However you can temporarily and quickly override the surface tool by maintaining CTRL which allows you to move the selected point in any direction, not just on the surface.

  • Easily editable warp grid
    Once the global placement of the image is done, it is also possible to edit the warp grid itself for greater precision and flexibility. To go into grid edit mode, you can either use the newly added warp menu, or the shortcut SHIFT + V. This will allow to edit existing vertices of the grid.
    You can evenly subdivide the grid as a whole, but keep in mind that if you had previously moved the vertices, they will be reset to their original positions. Grid subdivision can be done via the new warp options menu.
    Alternatively, it is possible to add individually placed splits which would allow to have greater detail only where needed. To add splits, select any of the three options in the warp menu - crosswise, horizontally or vertically. When one of them is selected, hovering the cursor over the Warp projection and clicking anywhere within it will add a new split. This will not alter the position of existing points.

  • Automatic adjustment of vertex orientation
    By default tangents of individual vertices are adjusted to the mesh's surface, which means they will always be correctly oriented in relation to the mesh no matter where they are dragged. This auto-tangent option can be turned off via a new button in the contextual toolbar, in which case the orientation will remain fixed at all times.

For more information on the Warp projection's settings and properties, see the dedicated documentation page.

New cylinder projection

This release adds a cylindrical projection method for fill layers and fill effects. The new projection allows to fit an image or texture around objects such as columns, pillars or more organics shapes like a character's arms.

  • Wrap an image around a mesh
    You can easily wrap an image around a cylindrical surface by using a fill layer or a fill effect and selecting Cylindrical projection in the Projection dropdown. If the image does not need to be repeated outside the projection gizmo, you need to select None for UV Wrapping and Cropped to Shape in Shape Crop to make sure that your image does not go out of bounds. Then you just need to use the manipulator to adjust the projection to the desired position.
  • Adjust the angle of projection
    Once your image is in place, there is a new Angle setting available. This setting can be used to adjust whether the image is projected all the way around the cylindrical shape, or is restricted to a certain angle. It does not crop the image, but rather reduces its width.

For more information, see the dedicated documentation page.

Improved color picker

This release brings several quality of life improvements to the color picker.

  • New window layout
    The improved color picker window has been reworked to accommodate a more vertical layout, similar to Sampler's latest release. It is divided into three sections - the main color field which includes the current and last selection, the hex field, eyedropper and the hue slider; the manual RGB/HSV sliders section; and the swatches.

  • New 0-255 RGB values
    Alongside porting the existing ways of entering color value, the improved color picker also allows to work in 0-255 RGB values. This option is available when Floating point values is unchecked in the sliders section dropdown menu.

  • Saving color swatches
    Color swatches can now be saved in Painter! Once the desired color is selected, it is possible to press the plus button in the Swatches section of the color picker, and the color will be stored across sessions and projects. A swatch can be cleared by right-clicking on it, or alternatively it is possible to bulk-delete all swatches at once via this section's dropdown menu. There is no limit to the number of swatches that can be saved.

  • Color picker window remains open
    The color picker window can be now be moved around and placed anywhere, even on a different screen, and it will remain open as long as there is no context switch, which means that when you are switching between paint layers while hand painting textures, you can keep the color picker window open for easier access.

  • More accessible eyedropper
    Now the color picking eyedropper can be found directly next to the color field, but you can still find it within the color picker as well. The more accessible eyedropper retain all previous functionalities - you can still click and hold to pick a color anywhere on your screen(s). This exposed eyedropper can be found next to all color fields in Painter, not just layer channels.

For more information, see the dedicated documentation page.

Other features and improvements

  • Asset drag and drop improvements
    With the introduction of the Warp, the decal feature where assets can be drag and dropped from the library into the viewport while maintaining ALT had seen some rework. Now, when a decal is created this way, it is no longer using the Planar projection, but the Warp projection. Automatic selection of the Warp projection should improve speed and efficiency of decal adjustments on the mesh.
    Moreover, it is now possible to drag and drop not only materials, but image-type assets into the viewport. When selecting an alpha, a texture or a procedural, there is no need to use the ALT modifier. It can be dropped onto the mesh - that would prompt a menu giving the option to select whether this image should be used within a mask or any of the layer's channels.

  • Autosave plugin improvement
    Autosave will no longer trigger during longer or heavier operations, such as mesh reloading, baking or export.
  • Performance improvements
    Some maintenance and optimization was done for slider manipulation and painting performance.
  • New functions in the python API
    The Python API had seen some recent additions, which allow to reload mesh, update resources, as well as set and query UV Tiles' resolution via scripting.
  • Substance engine update 8.3.0
    Alongside some fixes and general improvements, this Substance engine update now takes into account new graph types. It is also possible to verify the .sbsar file version, which should improve the use and download of the appropriate Substance 3D Assets versions.
  • Receiving Substance 3D Assets from CC Desktop
    It is now possible to access Substance 3D Assets, like Materials, Atlases and Decals, from the CC Desktop app. And moreover, they can be sent directly to the Painter library.

Release notes

7.3.0

(Released August 13, 2021)
Summary : Major release. It contains a new 3D warp projection, a new cylindrical projection, improvements of the color picker, new functions in Python API and bug fixes

Added:

  • [Projection][Warp] Expose 3D warp as a new projection mode
  • [Projection][Warp] Allow decal mode for Alphas, Textures and Procedurals with drag and drop in the viewport
  • [Projection][Warp] Use warp projection with decal shortcut (ALT)
  • [Projection][Warp][Toolbar] Transform warp as whole or per vertices
  • [Projection][Warp][Toolbar] Add grid points with split warp cross wise, horizontally or vertically options
  • [Projection][Warp][Toolbar] Dedicated menu for reset actions
  • [Projection][Warp][Toolbar] Option to automatically adjust tangents when moving points
  • [Projection][Warp][Toolbar] Dedicated menu for grid edition (size, reset, color and handle size)
  • [Projection][Warp] New keyboard shortcut to switch whole-vertices warp edition mode (SHIFT+V)
  • [Projection][Warp] Click + Ctrl allows to switch between surface tool and other tools
  • [Projection][Cylindrical] Expose the cylindrical projection mode
  • [Projection][Toolbar] Group manipulator settings (size, grid steps, angle steps)
  • [Color Picker] New color picker UI
  • [Color Picker] Use sRGB values in color picker widgets
  • [Color Picker] Allow to save and delete color swatches
  • [Color Picker] Eyedropper accessible from color and normal slots
  • [Color Picker] Allow to edit dynamic color between 0 and 255 values
  • [Color Picker] Make HSV/RGB state common across the app
  • [Color Picker] Color Picker window is semi-persistent
  • [Color Picker] Pressing Esc closes the color picker window
  • Performance improvement for UI interaction and while painting
  • [Engine] Update to new Substance engine version (8.3.0)
  • [Scripting][Python] Allow to reload the mesh of the current project
  • [Scripting][Python] Allow to update resources in projects
  • [Scripting][Python] Allow to set and query the resolution of UV Tiles
  • [Interoperability] Not available for Steam and Substance editions
  • [Interoperability] Receive multiple resources from Bridge

Fixed:

  • Color picker does not display the right color
  • [Baking] Texture set list are not ordered correctly
  • [FBX import] 3ds Max group pivot transformations are not taken into account
  • [Substance Engine] Crash with import of corrupted SBSAR
  • [MacOS] Project configuration option in different languages is not present
  • Autosaves can freeze Painter during long processes

Known Issues:

  • [Projection][Warp] Split option remains selected after splitting is done
  • [Projection][Warp] Flip does not work when transformation is set to world space
  • [Projection][Warp] Artifact lines between patches in some rare cases
  • [Projection][UV] Pivot point is reset when flipping projection
  • [Mac M1] Smart materials are not displayed correctly
  • [M1][Regression] Material layering not working

 Adobe

Get help faster and easier

New user?