User Guide Cancel

Shortcuts | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Substance 3D Assets
    3. Color picker
    4. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    5. History
    6. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    7. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    8. Project configuration
    9. Properties
    10. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    11. Shader settings
      1. Shader settings overview
      2. Updating a shader
    12. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    13. Toolbars
    14. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    15. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
      9. UV set to UV set projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (.svg & .ai)
    11. Text resource
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Library Issues
        1. Thumbnails in the shelf look incorrect
        2. Error when importing a Font
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 10.0
    4. Version 9.1
    5. Version 9.0
    6. Old versions
      1. Version 8.3
      2. Version 8.2
      3. Version 8.1
      4. Version 7.4
      5. Version 7.3
      6. Version 7.2
      7. Version 2021.1 (7.1.0)
      8. Version 2020.2 (6.2.0)
      9. Version 2020.1 (6.1.0)
      10. Version 2019.3
      11. Version 2019.2
      12. Version 2019.1
      13. Version 2018.3
      14. Version 2018.2
      15. Version 2018.1
      16. Version 2017.4
      17. Version 2017.3
      18. Version 2017.2
      19. Version 2017.1
      20. Version 2.6
      21. Version 2.5
      22. Version 2.4
      23. Version 2.3
      24. Version 2.2

Shortcuts

This page list all the keyboard and mouse shortcuts available.

Shortcuts overview

For a quick overview of all the Shortcuts available, take a look at our graphic available in our tutorials .

How to change a shortcut


Click on the "pen" icon next to a shortcut to edit it and enter the new combination.Pressing the last key will automatically exit the edit mode and change the shortcut.

List of editable shortcuts

To reset a shortcut back to its default value simply right-clicking on it.

Action

Shortcut (Windows)

Shortcut (MacOS) Description
Hide UI TabulationTabulationHide all the docks/windows of the interface to maximize the viewport(s).

Undo

Ctrl+Z

⌘+ZCancel the last action and go back to the previous state.
Redo

Ctrl+Y

⌘+YGo forward in the action list, redoing the action that has just been cancelled.
Painting
F9F9Switch the interface to the Painting mode.
Rendering (Iray) F10F10Switch the interface to the Rendering mode.
Open project

Ctrl+O

⌘+OOpen the file open dialog of the system to load a project.
Close project Ctrl+F4⌘+WClose the currently opened project.
Save project Ctrl+S⌘+SSave the currently opened project.
Save as project

Save the currently opened project under a new name.
New project Ctrl+N⌘+NOpen the new project creation window.
Quit application Alt+F4⌘+QClose the application.




Show/Hide manipulatorQQToggle the display of the manipulator used to control fill layer transforms.
Increase the manipulator size++Make the manipulator bigger in the viewports.
Decrease the manipulator size--Make the manipulator smaller in the viewports.
Cycle through manipulation spacesTTAlternate between Object and World space transformation for the manipulator.
Toggle warp edition modeShift+VShift+VSwitch between the Warp transform and Edit vertices modes when editing a warp projection.
Translate toolWWSet the manipulator mode to translation.
Rotate toolEESet the manipulator mode to rotation.
Scale toolRRSet the manipulator mode to scale.
Surface toolShift+WShift+WSet the manipulator mode to snap on the 3D model surface.
Symmetry LLEnable the symmetry along a given axis.
Pause engine computationShift+EscapeShift+EscapeToggle engine computations.




Select Paint tool 11
Select Paint tool + Particles Ctrl+1⌘+1
Select Eraser tool 22
Select Eraser tool + Particles Ctrl+2⌘+2
Select Projection tool 33
Select Projection tool + Particles Ctrl+3⌘+3
Select Polygon Fill 44
Select Smudge tool 55
Select Clone tool (relative source) 66
Select Clone tool (absolute source) Ctrl+6⌘+6
Bake Mesh MapsCtrl+Shift+B⌘+Shift+BOpen the Baking settings window.
Increase tool size ]]Increase the size of the brush for the painting tool.
Decrease tool size [[Decrease the size of the brush for the painting tool.
Bake Mesh MapsCtrl+Shift+B⌘+Shift+BOpen the Baking settings window.
Invert grayscale tool XXInvert the current grayscale value if the painting tool is on a mask.
Pick stroke material PPEnable the material picker tool.
Lazy Mouse DDEnable the lazy mouse behavior on the current tool.
Hide/ignore excluded geometryAlt+HOption+HHide 3D model parts that were excluded via the Geometry Mask.




Camera Perspective F5F5Change the camera of the viewport to a Perspective view.
Camera Orthographic F6F6Change the camera of the viewport to an Orthographic view.
Display next channel CCSwitch the viewport to the Solo view mode and display the next channel of the current Texture Set.
Display previous channel Shift+CShift+CSwitch the viewport to the Solo view mode and display the previous channel of the current Texture Set.
Display material MMSwitch the viewport display mode to Material.
Display next mesh map BBSwitch the viewport to the Solo view mode and display the next mesh map of the current Texture Set.
Display previous mesh map Shift+BShift+BSwitch the viewport to the Solo view mode and display the previous mesh map of the current Texture Set.
Toggle animation SpaceSpacePause/Unpause animation of the particles if a particle projection is in progress.
Export textures Ctrl+Shift+EShift+⌘+EOpen the export textures window.
Center the whole mesh FFCenter the whole mesh of the current project in the middle of the viewport.
Toggle quick mask edition UUEnter/Exit the quick mask edition.
Clear quick mask YYDisable and clean the quick mask.
Invert quick mask IIInvert the current values of the quick mask.
Viewport layout 3D/2D F1F1Change the viewport display to show both the 3D and 2D view at the same time.
Viewport layout 3D only F2F2Change the viewport display to show only the 3D view.
Viewport layout 2D only F3F3Change the viewport display to show only the 2D view.
Swap 2D / 3D view F4F4Swap between 2D and 3D view in viewport and 2D UV view.
Texture Set isolate

Alt+Q

Option+QIsolate the current Texture Set in the viewport by hiding the other.




Use tool / paint Mouse leftMouse left
Draw straight lines Shift+Mouse leftShift+Mouse left
Draw straight lines with snapping Ctrl+Shift+Mouse leftCtrl+Shift+Mouse left
Camera rotate Alt+Mouse leftOption+left
Camera snap rotate Alt+Shift+Mouse leftShift+⌘+Mouse leftSnap camera rotation every 90 degrees angle.
Camera translate Alt+Middle mouseOption+⌘+Mouse left
Camera translate (alternative) Ctrl+Alt+Mouse left

Camera zoom Alt+Mouse rightMouse middle
Stencil rotate S+Mouse leftS+Mouse left
Stencil snap rotate Shift+S+Mouse leftShift+S+Mouse left
Stencil translation S+Middle mouse

Stencil zoom S+Right mouseS+Right mouse
Change tool Size / Hardness Ctrl+Mouse right⌘+Mouse rightChange size by moving horizontally, change hardness of brush by moving vertically.
Change tool Flow / Rotation Ctrl+Mouse left⌘+Mouse leftChange flow of current brush by moving horizontally, change rotation of brush by moving vertically.
Rotate environment Shift+Mouse rightShift+Mouse rightRotate horizontally the environment map used for the lighting in the viewport.
Auto-Focus (Depth of Field)Ctrl+Middle mouse

Texture set selection Ctrl+Alt+Mouse RightOption+⌘+Mouse right
Context menu Mouse rightMouse rightQuick menu to access the properties window inside the viewport.
Set Clone tool source location V+Mouse leftV+Mouse left




Ignore stencil mask NNTemporarily disable the stencil (avoid to remove it entirely).
Resume previous stroke AAAllow to continue the previously created brush stroke to avoid discontinuities.

List of non-Editable shortcuts

Some shortcuts may only work if the mouse is over the specific window.

Example: copy and pasting requires that the mouse is over the layer stack.

Action Shortcut (Windows) Shortcut (MacOS) Description
Copy layer Ctrl+C⌘+CCopy the currently selected layer(s).
Cut layer Ctrl+X⌘+XCut the currently selected layer(s).
Paste layer Ctrl+V⌘+VPaste the layer in memory(s).
Delete layer DeleteDeleteDelete the currently selected layer(s).
Duplicate layer Ctrl+D⌘+DDuplicate the currently selected layer(s).
Group layer Ctrl+G⌘+GPut the currently selected layer(s) into a folder.
Copy layer content Ctrl+Shift+COption+⌘+CCopy the layer content (painting) and its effects.
Paste layer content Ctrl+Shift+VOption+⌘+VPaste the content (painting) and effects currently in memory.
Display mask in viewport Alt+Mouse leftOption+Mouse leftSwitch the viewport display mode to the mask of the specified layer.
Disable/Enable mask Shift+Mouse leftShift+Mouse leftToggle the state of the mask on a layer.




Drag & drop materialCTRL+Drag&Drop⌘+Drag&DropPress and maintain this key while drag and dropping a material (or smart material) into the viewport to only affect a specific part of the 3D model.




Manipulator constraint/snappingShiftShiftSnap transformation when adjusting the manipulator (translation or rotation) in 3D View. Constrain ratio when adjusting manipulator in 2D View.
Manipulator mirror transformationCtrlMirror manipulator points transformation around its pivot point in 2D View.

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online