User Guide Cancel

Version 2019.1 | Substance 3D Painter

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Project creation
    5. Export
      1. Export overview
      2. Export window
        1. Export window overview
        2. Export settings
        3. Output templates
        4. List of exports
      3. Export presets
        1. Export presets overview
        2. Predefined presets
          1. Predefined Presets
          2. USD PBR Metal Roughness Preset
          3. Default Presets
        3. Creating export presets
    6. Glossary
    7. Performance
  4. Interface
    1. Assets
      1. Assets overview
      2. Navigation
      3. Customizing the layout
      4. Filter by path
      5. Saved searches
      6. Advanced search queries
      7. Adding a new library
      8. Sub-library tab
    2. Color picker
    3. Display settings
      1. Display settings overview
      2. Environment settings
      3. Camera settings
      4. Viewport settings
    4. History
    5. Layer stack
      1. Layer stack overview
      2. Creating layers
      3. Managing layers
      4. Masking and effects
      5. Blending modes
      6. Layer instancing
      7. Geometry mask
    6. Main menu
      1. Main menu overview
      2. File menu
      3. Edit menu
      4. Mode menu
      5. Window menu
      6. Viewport menu
      7. Plugins menu
      8. Help menu
    7. Project configuration
    8. Properties
    9. Settings
      1. Settings overview
      2. General preferences
      3. Shortcuts
      4. Libraries configuration
    10. Shader settings
      1. Shader settings overview
      2. Updating a shader
    11. Texture Set
      1. Texture Set overview
      2. Texture Set list
      3. Texture Set settings
      4. Texture Set reassignment
    12. Toolbars
    13. Viewport
      1. Viewport overview
      2. 2D view
      3. 3D view
      4. Camera management
    14. Miscellaneous
      1. Sliders
      2. Log
      3. Update checker
  5. Painting
    1. Painting overview
    2. Tool list
      1. Paint brush
      2. Eraser
      3. Projection
      4. Polygon fill
      5. Smudge tool
      6. Clone Tool
      7. Quick mask
      8. Path tool
    3. Straight line   
    4. Lazy mouse 
    5. Symmetry
      1. Symmetry overview
      2. Mirror Symmetry
    6. Fill projections
      1. Fill projections overview
      2. Fill (match per UV Tile)
      3. UV projection
      4. Tri-planar projection
      5. Planar projection
      6. Spherical projection
      7. Cylindrical projection
      8. Warp projection
    7. Presets
      1. Presets overview
      2. Creating and saving presets
      3. Creating particles presets
        1. Creating particles overview
        2. Installing the particle editor
        3. Overview of the particle editor
        4. Creating a new particle script
      4. Photoshop brush presets (ABR)
        1. Photoshop brush presets overview
        2. Exporting Brush Presets from Photoshop
        3. Importing Photoshop Brush Presets
        4. Photoshop Brush Parameters Compatibility
    8. Dynamic strokes
      1. Dynamic strokes overview
      2. Enabling Dynamic Stroke feature
      3. Dynamic Stroke Performances
      4. Creating custom Dynamic Strokes
    9. Advanced channel painting
      1. Channel painting overview
      2. Ambient Occlusion
      3. Flow Map
      4. Height Map
      5. Normal Map
    10. Vector graphic (SVG)
  6. Effects
    1. Effects overview
    2. Generator
    3. Paint
    4. Fill
    5. Levels
    6. Compare Mask
    7. Filter
    8. Anchor Point
  7. Baking
    1. Baking overview
    2. How to bake mesh maps
    3. Baking visualization settings
  8. Content
    1. Creating custom effects
      1. Creating custom effects overview
      2. Generic filter
      3. Channel specific filter
      4. Generators
      5. Mesh map
      6. Mesh based input
      7. User data
    2. Importing assets
      1. Adding resources via drag and drop
      2. Adding resources via the import window
      3. Adding content on the hard drive
      4. Receiving assets from other Substance 3D applications
  9. Features
    1. Automatic UV Unwrapping
    2. Physical size
    3. Smart Materials and Masks
    4. Subsurface Scattering
      1. Subsurface Scattering overview
      2. Enabling Subsurface in a Project
      3. Subsurface Parameters
      4. Subsurface Material Type
    5. Dynamic Material Layering
    6. UV Reprojection
    7. UV Tiles
      1. UV Tiles overview
      2. Image Sequence
    8. Color Management
      1. Color management overview
      2. Color management with Adobe ACE - ICC
      3. Color management with OpenColorIO
    9. Post Processing
      1. Post Processing overview
      2. Color correction
      3. Depth of Field
      4. Glare
      5. Lens Distortion
      6. Tone Mapping
      7. Vignette
      8. Color Profile
    10. Iray Renderer
      1. Iray Renderer overview
      2. Iray Settings
      3. Viewer and MDL Settings
    11. Plugins
      1. Plugins overview
      2. Autosave
      3. Resources Updater
    12. Sparse Virtual Textures
    13. Custom Shaders
    14. SpaceMouse® by 3Dconnexion
    15. Universal Scene Description (USD)
    16. Send to
  10. Technical Support
    1. Performance Guidelines
      1. Performances guidelines overview
      2. Conflicts and background applications
      3. Mesh and UV setup
      4. GPU Drivers
      5. NVIDIA Drivers Settings
      6. GPU VRAM amount and bandwidth
      7. GPU VRAM and other applications
      8. Texture Sets amount
      9. Layer management
      10. Channels management
      11. Substance filters and materials
      12. Viewport display
    2. Configuring Pens and Tablets
    3. Exporting the log file
    4. Exporting a DXDiag
    5. Technical issues
      1. GPU Issues
        1. Crash when working with overclocked GPU
        2. Forcing the external GPU on Mac OS
        3. GPU drivers compatibility
        4. GPU drivers crash with long computations (TDR crash)
        5. GPU has outdated drivers
        6. GPU is not recognized
        7. GPU is not recognized and is mentionned as GDI Generic
        8. Issues with Nvidia GPUs on recent Mac OS versions
        9. Multi/Bi-GPU
        10. Running on integrated GPU
        11. Painter doesn't start on the right GPU
      2. Startup Issues
        1. Application failed to start because of Qt
        2. Crash or freeze during startup
        3. Software conflicts
      3. Rendering Issues
        1. Artifacts and glitches on Mac OS with Custom GPUs
        2. Blocky artifacts appear on textures in the viewport
        3. Mesh appears pink in the viewport
        4. Mesh flash to white when moving camera
        5. Some HDPI scaling values are not working
      4. Stability Issues
        1. Crash during export
        2. Crash when opening or saving a file
        3. Crash while baking
        4. Crash with low virtual memory
        5. Windows Blue Screens
      5. Miscellaneous Issues
        1. Corrupted texture error message
        2. Shelf resources are gone after 7.2 update
        3. Error there is no disk in the drive
        4. Error with missing api-ms-crt dll
        5. Impossible to drag and drop files into the shelf
        6. Impossible to use the ALT keyboard shortcut on Linux
        7. Assets (or shelf) previews are empty
    6. Workflow Issues
      1. Export Issues
        1. My exported opacity map is totally black
        2. Texture dilation or Padding
      2. Tools Issues
        1. Normal map looks incorrect when loaded in layer or tool properties
        2. Paint Tool bleeds on other UV islands
      3. Project Issues
        1. A project has been processed as a text file and is now corrupted
        2. Loading files from a network
        3. Preserve brush strokes setting stays disabled
        4. Projects are really big
      4. Shelf Issues
        1. Thumbnails in the shelf look incorrect
      5. Viewport Issues
        1. Mesh faces disappear when looking at them from behind
        2. Viewports and textures are blurry or lack sharpness
      6. Plugins Issues
        1. Substance Source plugin doesn't load
      7. License Issues
        1. Maintenance is expired dialog on startup
  11. Pipeline and integration
    1. Installation and preferences
      1. Preferences and application data location
      2. Automated installation
      3. Retrieving the installation path
    2. Configuration
      1. Command lines
      2. Environment variables
      3. Firewall Configuration
      4. Querying Current Software Version
      5. Remote Desktop
    3. Resource management
      1. Shelf and Assets location
      2. Resource paths
        1. Adding resource paths by editing preferences manually
        2. Editing resource paths manually
        3. Editing the Shelf Preferences with Python
      3. Adding saved searches manually
      4. Preferences and content migration
      5. Excluding resources in a resource path
  12. Scripting and development
    1. Scripts and plugins
      1. Creating a Javascript plugin
      2. Remote control with scripting
    2. Shader API Reference
      1. Shader API overview
      2. Changelog - Shader API
      3. Libraries - Shader API
        1. Lib Alpha - Shader API
        2. Lib Bayer - Shader API
        3. Lib Defines - Shader API
        4. Lib Emissive - Shader API
        5. Lib Env - Shader API
        6. Lib Normal - Shader API
        7. Lib PBR - Shader API
        8. Lib PBR Aniso - Shader API
        9. Lib Pom - Shader API
        10. Lib Random - Shader API
        11. Lib Sampler - Shader API
        12. Lib Sparse - Shader API
        13. Lib SSS - Shader API
        14. Lib Utils - Shader API
        15. Lib Vectors - Shader API
      4. Parameters - Shader API
        1. All Custom Params - Shader API
        2. All Engine Params - Shader API
        3. All Rendering States Params - Shader API
        4. Layering Bind Materials - Shader API
        5. Layering Declare Stacks - Shader API
      5. Shaders - Shader API
        1. PBR Material Layering - Shader API
        2. PBR Metal Rough - Shader API
        3. Pixelated - Shader API
        4. Surface Shader - Shader API
        5. Toon - Shader API
  13. Release notes
    1. Release notes overview
    2. All Changes
    3. Version 9.1
    4. Version 9.0
    5. Version 8.3
    6. Old versions
      1. Version 8.2
      2. Version 8.1
      3. Version 7.4
      4. Version 7.3
      5. Version 7.2
      6. Version 2021.1 (7.1.0)
      7. Version 2020.2 (6.2.0)
      8. Version 2020.1 (6.1.0)
      9. Version 2019.3
      10. Version 2019.2
      11. Version 2019.1
      12. Version 2018.3
      13. Version 2018.2
      14. Version 2018.1
      15. Version 2017.4
      16. Version 2017.3
      17. Version 2017.2
      18. Version 2017.1
      19. Version 2.6
      20. Version 2.5
      21. Version 2.4
      22. Version 2.3
      23. Version 2.2

Version 2019.1

Substance Painter 2019.1 expands upon its existing features and also introduces new artistic tools. This release focus as well on delivering lots of new content.

Release date : 23 April 2019

Major Features

Dynamic Strokes

With this release our brush engine now supports what we call Dynamic Strokes. These type of strokes create variations and new effects thanks to the generation of new Substance versions on the fly. Having a new Substance material or alpha for each new brush stroke painted on your asset is now possible.

When a Dynamic Stroke compatible resource is loaded in your Paint tool (Paint, Eraser, Smudge or Clone) a new parameter group will appear :

Dynamic Strokes supports the following properties (if exposed in the Substance graph) :

  • Stamp Index : ID / Number of a stamp inside a stroke.
  • Random Seed : Can change per stamp or per stroke.
  • Time : Elapsed painting time of a brush stroke, painting fast or slower produce different results.

The Stamp Index comes with two other parameters :

  • Stamp Start : From Beginning (always start the index from 0) or From Random Index (choose a random position between 0 and the maximum defined by Stamp Cycle Count).
  • Stamp Cycle Count : This parameter defines the total amount of Substance variations that will be generated. In order to optimize performances this parameter works as a limit. Substance Painter use it to recycle what has already been generated instead of creating something new.

You can find resources compatible with this new feature simply by browsing the shelf and looking at the new icons which are now sitting next to them :

Resources compatible with the feature also get automatically a new tag named "dynamicstroke" to make them easy to filter by keywords in the Shelf.

We also added a lot of new tool presets to play with :

Note:

To know more about this feature (and its performance impact) take a look at the dedicated documentation.

Displacement And Tesselation

Substance Painter now supports Displacement and mesh Tesselation in both its realtime viewport and in Iray. They can both be controlled in the Shader Settings window below the shader parameters.

  • Source Channel : Channel from which the mesh deformation is based on. Default is Height but can be set to Displacement as well.
  • Scale : Controls the amount of deformation applied to the mesh in the project.

  • Subdivision Mode : Uniform or Edge Length. Determines how the amount of subdivision is computed.
  • Subdivision Count : (Mode Uniform) From 1 to 32. A high value produce more polygons which gives more details but can introduce performance issues.
  • Max Length : (Mode Edge Length) 1 / Value. Every polygon edge is divided until each segment is equal to or shorter than this number, 1/1 being the size of the scene.

Load the "Tiling Material" sample project (via File > Load Sample) to quickly give a try at this new feature :

Note:

A new filter named "Height To Normal" has been added in the Shelf and can be used to get the final normal map (in case the native conversion by Substance Painter is not strong enough).

Compare Mask Effect

Creating and blending materials can be a bit tough sometimes which is why we created a new effect named "Compare Mask". This effect allows to quickly and easily compare two channels and produce a mask as a result.

The Compare Mask effect has the following properties :

  • Channel : The channel to compare between the source and the target to create a mask from.
  • Compare : Three parameters are available here to chose how the mask should be computed. The dropdown in the middle define the comparison operation (lesser than, within tolerance, greater than).
  • Constant : Value to compare against when the compare setting is set to "constant".
  • Hardness : Control the smoothness/hardness of the resulting mask comparison.
  • Histogram : Provide an histogram view of the source and the target. Useful to know if they overlap a bit or not at all (if they don't overlap the mask will be empty).

To make things even more easier to setup, you can right-click on a layer and choose the shortcut "Add mask with height combination" to quickly add this new mask on your layer. This shortcut will also switch your Height channel blending mode to "Normal" instead of the default "Linear Dodge (Add)".

Radial Symmetry

We expanded the capabilities of our symmetry tool to handle radial symmetry. There is now a new mode in the symmetry settings menu to enable it (available in the contextual toolbar).

The following settings are available :

  • X / Y / Z : Controls the direction of the symmetry axis used by the radial symmetry.
  • Count : The number of duplicated points.
  • Angle Span : The location of the duplicated points from the original one. This setting can be used to make a full circle or a quarter of it, etc.

We also added a little preview to make it easier to tweak the settings before starting to paint :

New Fill Layer Projection Modes

Two new projection modes have been added with fill layers and fill effects : Planar and Spherical. We also added a lot of new parameters to control further the behaviors of the 3D projections.

  • New Planar Projection mode
    Projecting a plane is now possible with this new mode. It can be useful for creating stripes on vehicles or placing decals at a specific location.

  • Surface Tool for Planar Projection
    To make the planar projection easy to manipulate we also added a new control for the 3D Manipulator that we call Surface Tool which can be accessed with the shortcut "Shift+W". It can also be accessed from the Contextual Toolbar. Note that this new mode is only available with the Planar Projection.

  • Planar Projection Culling / Fading
    Multiple settings are available to make the planar projection either continuous or finite. When a culling setting is enabled, the doted box around the manipulator indicates the bounding box for the projection and the middle line is where the projection starts. Scaling the projection allows to control how far it goes and when it starts to fade.

  • New Spherical projection mode
    Spherical projections are now doable with this new mode. With it you can achieve advanced patterns or follow more easily curved surfaces.

  • New Shape Crop settings
    3D projections now have a setting that controls the repetition of the projection. Very useful for example for a decal to repeat only on a specific area without having to mask it manually.

  • Moved and Renamed existing settings
    Because of these new projections we reworked a bit how some settings work. For example "Tiling" has been renamed has "UV Wrap". The tiling now can be set only vertically or horizontally. The Scale, Rotation and Offset are now part of a new parameter group named "UV Transformations" to be more consistent across projection modes.

  • Improved Rotation Manipulator all-axis mode
    Instead of drawing an explicit sphere, it is now hidden to avoid hiding the texturing below. Clicking in-between the axes will select the sphere which allows to rotate all the axes at once.

Various Improvements

  • Multi-Selection for Texture Set
    Selecting multiple Texture Sets to change their resolution all at once via the Texture Set settings is now possible.
    In multi-selection mode there is still the notion of a "main" Texture Set, which is why additional elements are selected in gray. If you need to switch to a different Texture Set while keeping the current selection, you can use the middle mouse button to do that.

  • Quick show/hide in Texture Set List
    You can now click and drag (like in the layer stack) to hide or show Texture Sets.

  • Improved UI for Layer Stack
    We changed the icon for the hidden/show state of a layer to be more consistent and easier to understand. We also changed the way selected layers are displayed to be easier to compare with the selection of their effects and other layers.

  • New effect position based on current selection
    Any new effect added on a layer will now be put just above the currently selected one.

  • Quick toggle of Material channel buttons
    You can now press ALT and click on a channel button to isolate it. Clicking again will enable back all the channels.

  • Dithering at export
    Dithering can now be disabled via a dedicated setting in the export window next to the file format and bit depth. For more information about how and when dithering is applied see the export documentation.

  • Better Histograms
    We reworked our histogram generator. Histograms should now display more accurate information and update properly after a change in the layer stack.

  • Better Instancing of layers
    Instanced layers now have their blending mode set to "Pass Through" instead of the default blending mode. This blending mode will improve the compatibility of some effects when layers are instanced across Texture Sets.

New Content

In this release we also added a lot of new content : from presets to alphas and even new powerful filters.

  • New Brush and Tool Presets
    This release introduces the new Dynamic Strokes feature and with it we added some Brush and Tool presets ready to use.

    • 10 new Brush presets :
      • Ink Dirty
      • Ink Random
      • Leaf Curved Heavy
      • Leaf Curved
      • Leaf Messy
      • Leaf Simple
      • Leaf Swirl
      • Zigzag Long
      • Zigzag Short
      • Zigzag Step
    • 11 new Tool presets :
      • Autumn Leaves
      • Cracks
      • Footprints
      • Gradient Hue
      • Nail
      • Pebbles
      • Scratches
      • Spray Colored
      • Spray Skin Light
      • Spray Skin Red
      • Zipper
  • 93 new Alphas
    There are too many to enumerate them all, so take a look at the "Alphas" section of the Shelf and you will see lots of new Arrows, Triangles, Signs and other kind of shapes.

  • 13 new Filters
    We have many new filters in this new version which can be very handy for a lost of situations :

    • Blur Slope : A new blur filter has been added to the family. This filter works in a similar way to the warp filter : use the existing input or a custom one to blur the target channel.
    • Bevel : Creates a gradient border around a shape, useful if you want to expand your mask for example.

    • Color Match : This filter tries to match a Source color to a Target color. Handy for adjusting colors on a material.

    • Gradient Curve : This filter provides a list of curve presets that can be applied on any grayscale input to change their look.

    • Gradient Dynamic : Remaps a grayscale input by a new input image (grayscale or color).
    • Height Adjust : This filter provides two settings to easily manipulate the height channel : Offset and Multiply.

    • Height to Normal : This filter converts the Height channel into a Normal and feeds it to the Normal channel. It has different intensity controls depending of the needs.

    • Mask Outline : This filter creates a white on black border around a grayscale input. This is most useful in Mask to create borders around shapes.

    • PBR Validate : We added this filter to check that your PBR material colors are in the right ranges. For more information check out the PBR Guide !

    • MatFX Peeling Paint : Simulates old paint starting to peel. This filter outputs alpha which makes it easy to blend with materials below it.

    • MatFx Water Drops : Simulates water drops on the surface of an object. Like water on a car after the rain.

  • 7 new Generators
    With this release we added a few new generators :

    • Ambient Occlusion : Mask Generator that offers controls over the Ambient Occlusion Mesh map. Based on the Mask Editor.

    • World Space Normals : Mask Generator that offers controls over the World Space Normals Mesh map. Based on the Mask Editor.

    • Position : Mask Generator that offers controls over the Position Mesh map. Based on the Mask Editor.

    • Curvature : Mask Generator that offers controls over the Curvature Mesh map. Based on the Mask Editor.

    • Auto Stitcher : Mask Generator that creates stitches near the UV borders, the Mesh Curvature or around a custom mask input.

    • UV Texel Density : Helper that outputs a colored gradient based on the Texel Density of the polygons of the mesh.

    • UV Random Color : Generate a random color per UV Island (or based on a custom gradient input).

  • 2 new environment maps

    • Autumn Forest

    • Canopus Ground

  • 5 new Procedurals

    • Gradient Hue

    • Gradient Builder

    • Color Jitter By Index

    • Color Jitter By Seed

    • Feather Stylized

Tutorials

Checkout our tutorial that cover our latest features :

We also have a tutorial on Substance Academy covering how to create a Dynamic Stroke : Creating a custom Dynamic Stroke for Substance Painter

Release Notes

2019.1.3

(Released July 01, 2019)
Summary : Bugfix with 2 new features

Fixed:

  • "Follow path" does not work all the time
  • Channel mapping doesn't work with SBSAR used in single channel slots
  • [Layer Stack] Low performance when scrolling with hidden layers
  • [TextureSet] Crash when clicking between masks
  • [SVT] Displacement in not displayed properly and flickers in some cases
  • [Alembic] Crash with mesh using point normals instead of vertex normals
  • [Alembic][Log] Report error in Log if Alembic file is not supported during import

2019.1.2

(Released May 21, 2019)
Summary : HotFix

Fixed:

  • Crash when selecting two resources with an image input

2019.1.1

(Released May 20, 2019)
Summary : HotFix

Added:

  • Update to latest version of Substance Engine with last release of Substance Designer 2019.1

Fixed:

  • [Substance] Visible If is not taken into account for Input Images
  • [SVT][Engine] Changing texture set resolution leads to a crash in some cases
  • [Engine] Random black textures appear in some cases
  • [Layer Stack][UI] Toggling a mask with SHIFT can select multiple layers at the same time
  • [Layer Stack] Opacity has no effect on Paint effect with Pass-Through blending mode
  • [Layer Stack] Height To Normal filter input doesn't update properly with eraser brush stroke
  • [LayersStack] Crash when undoing the drop of a smart mask
  • Wireframe flickering with shadows and temporal anti aliasing activated
  • [Displacement] Lag on AMD with some heavy meshes
  • [Windows] Crash when opening some projects via the file explorer
  • [Histogram] Crash when removing mask with anchor point in some cases
  • Crash in preview generation in some rare cases
  • [Crash] Can not reopen a project using too many clone and smudge tools
  • No mesh displayed in material mode after saving in some cases
  • [Scripting] alg.mapexport.documentStructure() returns incorrect values for folders

Known Issues:

  • Double clicking texture set name will select it before entering renaming mode

2019.1

(Released April 23, 2019)
Summary : Dynamic Stroke with dedicated new content, Displacement and Tessellation in real-time and Iray, Compare Mask effect, Radial symmetry, Planar and Spherical projection

Added:

  • [Tool] Dynamic stroke: Substance variation alongside a brush stroke
  • [Dynamic stroke] Expose new stamp index parameter with options
  • [Dynamic stroke] Take into account $time parameter
  • [Dynamic stroke] Generate new $randomseed parameter per stroke and per stamp
  • [Dynamic stroke] Start a dynamic stroke index from a random number
  • [Dynamic stroke][Shelf] Help finding a dynamic stroke resource with dedicated new icon
  • Displacement and tessellation in real-time viewport
  • Displacement and tessellation in Iray
  • [Shader settings][UI] New tab for controlling displacement and tessellation
  • [Layer stack] New CompareMask effect: generate a mask by comparing two channels
  • [Layer stack][UI] New entry in right-click menu "Add mask with height combination" to insert a CompareMask effect
  • [Symmetry] New symmetry mode: radial painting
  • [Symmetry settings] Expand both sections "Settings" and "Display"
  • [Symmetry settings][UI] Preview for radial painting
  • Expose two new projection modes: planar and spherical
  • [Proj] New shape crop mode for all projections
  • [Proj] Planar mode with new manipulator: Surface tool
  • [Proj][Shortcut] Shortcut SHIFT+W for Surface tool
  • [Proj] Planar projection masking with depth culling and backface culling
  • [Manipulator] Improvement of rotation manipulator on all three axes for triplanar
  • [Tool][UX] Alt-clicking on a channel focuses that channel (enables it or disables all others)
  • [Engine] Update to latest version of Substance Engine
  • [Texture set] Multiple selection and change resolution
  • [Texture set] Quick activation and deactivation of the texture sets
  • [Texture set] Combine solo and all options into a new menu
  • [Texture set][Layer stack] New icon for activation and deactivation
  • [Layer stack][UX] Insert effects above those already selected
  • [Layer stack][UI] Rework layer stack view selection style
  • [Layer Stack] Blending mode for instanced layers is now in Pass Through mode by default
  • [Export] Option to activate and deactivate dithering
  • [Plugin] Support precision modifier for sliders (SHIFT)
  • [Plugin][UI] New icon for autosave
  • [Scripting] List the contents of a folder
  • [Scripting] Allow deletion of files
  • [Scripting] Read all stack information including used resources
  • [Content][Dynamic stroke] New tools and brush presets
  • [Content][Dynamic stroke] Two new procedural gradients: Gradient Hue and Gradient Builder
  • [Content] 11 new Filters: MatFx Peeling Paint, MatFx Water Drops and more
  • [Content] 7 new generators: Auto Stitcher, UV Random Color, UV Texel Density and more
  • [Content] 93 new alphas: new texts, arrows and various other shapes
  • [Content] 2 new procedurals: Gradient Hue, Gradient Builder and more
  • [Content] 21 new Tool and Brush presets for Dynamic Strokes : Pebbles, Footprints, Spray and more
  • [Content] 2 New HDRis: Canopus Ground and Autumn Forest
  • [Content] Update content with random seed curation in shelf
  • [Content] New icon with exposed random seed parameter in shelf

Fixed:

  • [Layers stack] Layer stack keeps dragging forever
  • [Mac] "Show in Finder" can lead to freezing
  • [Scripting] Settings saved via Custom UI are lost if shader file is moved
  • [Scripting] API version number is incorrect and not up to date
  • [Effect] Histogram content is not displayed correctly
  • [Effect] Histogram effect does not update in some cases
  • [Shelf] Stitches are not properly aligned on material "Plastic Fabric Pyramid"

Known Issues:

  • Double clicking texture set name will select it before entering renaming mode
  • [Layer Stack][UI] Toggling a mask with SHIFT can select multiple layers at the same time

 Adobe

Get help faster and easier

New user?