Separating a foreground object, such as an actor, from a background is a crucial step in many visual effects and compositing workflows. When you’ve created a matte that isolates an object, you can replace the background, selectively apply effects to the foreground, and much more.

Roto Brush & Refine Edge tools

The Roto Brush tool and the Refine Edge tool provide an alternative, faster workflow for segmentation and creation of a matte.

Roto Brush and Refine Edge tools
A. Roto Brush B. Refine Edge 

Roto Brush

Use this tool to create the initial matte to separate an object from its background. With the Roto Brush tool, you draw strokes on representative areas of the foreground and background elements. Then After Effects uses that information to create a segmentation boundary between the foreground and background elements. The strokes that you make on one area helps After Effects differentiate between foreground and background on adjacent frames. Various techniques are used to track regions across time, and this information is used to propagate segmentation forward and backward in time. Each stroke that you make is used to improve the results on nearby frames. Even if an object moves or changes shape from one frame to the next, the segmentation boundary adapts to match the object.

Using the Roto Brush effect

Using the Roto Brush effect
With the addition of the Refine Edge tool in After Effects CC, the underlying Roto Brush effect has seen a few changes in parameter names and ranges. Chris Meyer explains.
Chris Meyer

Refine Edge tool

Use the Refine Edge tool to improve the existing matte by creating partial transparency along areas that contain fine details such as hair or fur.

Introduction to Refine Edge tool

Introduction to Refine Edge tool
This movie demonstrates the new Refine Edge Tool workflow, which is applied after the Roto Brush tool.
Chris Meyer

Roto Brush & Refine Edge effect

This effect is applied automatically when the first Roto Brush or Refine Edge stroke is drawn in the layer panel. Use this effect to control the settings for the Roto Brush & Refine Edge tools. After you have created a segmentation boundary and the boundary edges that need refining, use the Roto Brush Matte and Refine Edge Matte properties to improve the matte.

Strokes, spans, and base frames

When you first draw a Roto Brush stroke, the frame on which you are drawing becomes a base frame. The segmentation information is propagated forward and backward through time—20 frames forward and 20 frames backward. (Segmentation information is the information about what is defined as foreground and what is defined as background.) The range of frames thus influenced by this base frame is its Roto Brush & Refine Edge span. Little arrows in the span bar in the Layer panel show the direction in which the information is being propagated. If you draw a corrective stroke anywhere where the arrows point to the right, the information from that stroke is propagated forward; if you draw a corrective stroke anywhere where the arrows point to the left, information from that stroke is propagated backward. If you draw a stroke anywhere outside of a Roto Brush span, then you create a new base frame and span.

You can work your way forward a frame at a time from a base frame, making corrective strokes, and you don't have to worry about your strokes changing results on frames that you've already worked on. You can do the same thing going backward from a base frame.

The influence of each corrective stroke propagates forward or backward to affect all frames in that direction within the span, regardless of when the stroke is made. For example, if the base frame is at frame 10, you make a corrective stroke at frame 20, and then you make a corrective stroke at frame 15, then frame 20 will be affected by both of these corrective strokes—just as if you had made the corrective strokes in the other order.

Each time that you make a stroke within a span, the span grows, unless it can't because the span in which you're drawing is adjacent to another span.

  • To manually change a span duration, drag either end of a span.

  • To delete a span, right-click (Windows) or Control-click (Mac OS) a span and choose Remove Span.

  • To delete all spans, delete the instance of the Roto Brush & Refine Edge effect.

When you move to a frame within a span, After Effects must calculate how the stroke information from the other frames in the span affects the frame to which you've moved. The Info panel shows the message “Roto Brush propagating” as this calculation is being performed. This information is cached, so this propagation doesn't need to happen every time that you move to a frame. Green bars in a span indicate frames with cached information. Choosing Edit > Purge Image Caches purges Roto Brush & Refine Edge caches, too.

Tips for working with the Roto Brush and Refine Edge tools

  • When drawing strokes to define a foreground object with the Roto Brush tool, begin by drawing strokes along the center of the object’s features. For example, draw a stroke along the skeleton rather than along the outline of an arm. Unlike conventional rotoscoping, which requires precise manual definition of boundaries, using the Roto Brush tool works by defining representative regions. After Effects can then extrapolate from those regions to determine where the boundaries are. Before you draw a stroke along a boundary to attempt to get a precise segmentation, be sure that you've drawn foreground strokes down the center of the object and made at least some rough background strokes on the other side of the boundary.

  • If you draw a Roto Brush or Refine Edge stroke over the wrong area of the image, undo that stroke. However, if After Effects misinterprets your Roto Brush stroke and includes or excludes too much of the image, don’t undo; further teach Roto Brush by drawing additional strokes to include or exclude regions.

  • Work with resolution set to Full when using the Roto Brush or Refine Edge tools. Fast Previews modes, such as Adaptive Resolution, don’t work well with these tools, because switching resolutions requires a full recalculation of the segmentation and transparency information. For this reason, Fast Previews modes are turned off when you draw a Roto Brush or Refine Edge stroke. Both the Composition and Layer panels share the Fast Previews setting. 

  • Use the Roto Brush and Refine Edge tools in a composition with a frame rate set to match the frame rate of the layer's source footage item. A warning banner appears at the bottom of the frame in the Composition panel if the frame rate of the composition doesn't match the frame rate of the layer's source footage item. 

  • When you've gotten everything as good as you can with the Roto Brush & Refine Edge effect, you can touch up the matte further using other compositing features in After Effects—such as by painting on the alpha channel. 

Roto Brush & Refine Edge workflow

  1. Switch to the Roto Brush or Refine Edge tool by pressing Alt+W (Windows) or Option+W (Mac OS).

    Note: Once selected, you can press Alt+W (Windows) or Option+W (Mac OS) to toggle between these tools.

  2. Open the layer in the Layer panel.

    Note:

    When the Roto Brush or Refine Edge tool is active, double-clicking a layer in the Timeline or Composition panel opens the layer in the Layer panel by default. Uncheck Open Layer panel when Double-clicking with Paint, Roto Brush, and Refine Edge Tools option under General Preferences.

  3. Preview the movie in the Layer panel to find a frame in which the greatest amount of the foreground object is in the frame and in which the separation between the foreground and background is as clear as possible.

    The frame on which you draw your first stroke is a base frame. (See Roto Brush strokes, spans, and base frames.)

  4. Drag in the Layer panel to draw a foreground stroke on the object that you want to isolate from the background. When you are drawing a foreground stroke, the Roto Brush tool’s pointer is a green circle with a plus sign in the middle.

    Note:

    Draw the stroke down the center of the object, not along the edge. (See Tips for working with the Roto Brush tool.)

    Draw a stroke to select the foreground
    Draw a stroke to select the foreground

    The magenta outline that appears around the foreground object in Alpha Boundary view mode is the segmentation boundary, the rough line that separates the foreground from the background. You can also view the segmentation using other view modes. (See Layer panel view options.)

  5. Alt-drag (Windows) or Option-drag (Mac OS) to draw a background stroke on the area that you want to define as the background. When you are drawing a background stroke, the Roto Brush tool’s pointer is a red circle with a minus sign in the middle.

    Draw a background stroke to exclude an area
    Draw a background stroke to exclude an area

  6. Repeat the steps of drawing foreground and background strokes on the base frame until the segmentation is as precise and complete as possible. You should make the segmentation on the base frame as good as possible; the segmentation of other frames is based on the segmentation defined on the base frame.

    Try for a segmentation boundary that is within a couple of pixels of your desired edge. You can modify properties in the Roto Brush & Refine Edge effect, such as Feather and Contrast to refine the initial segmentation further. (See Roto Brush & Refine Edge, Refine Hard Matte, and Refine Soft Matte effect reference.)

    Note:

    You can resize the Roto Brush tool’s tip to make finer strokes. Broad strokes are best for initial work, but fine strokes are useful for details. (See Roto Brush strokes, spans, and base frames.)

  7. Press Page Down or 2 to move forward one frame.

    After Effects uses motion tracking, optical flow, and various other techniques to propagate the information from the base frame to the current frame to determine the segmentation boundary.

  8. If the segmentation boundary that After Effects calculates for the current frame is not where you want it to be, you can make corrective strokes to teach After Effects what is foreground and what is background. Draw foreground strokes and background strokes as needed to correct the segmentation. Corrective strokes propagate in one direction, away from the base frame.

    Note: You can also modify properties in the Roto Brush Propagation property group to affect how After Effects propagates the segmentation information from previous frames to the current frame. (See Roto Brush & Refine Edge, Refine Hard Matte, and Refine Soft Matte effect reference.)

  9. Repeat the steps of moving one frame at a time and making corrective strokes until you have created a segmentation boundary for the entire duration that you want to segment.

  10. If you have drawn Roto Brush strokes, the Fine-tune Roto Brush Matte option is enabled in the Roto Brush & Refine Edge effect properties. Modify properties in the Roto Brush Matte property group as needed. (See Roto Brush & Refine Edge, Refine Hard Matte, and Refine Soft Matte effect reference.)

  11. Go back to the base frame and switch to the Refine Edge tool. Draw Refine Edge strokes for areas that need partial transparency. Draw the strokes along or across the edge of the matte indicated by a magenta line. When you are drawing a Refine Edge stroke, the Refine Edge tool’s pointer is a blue circle with a plus sign in the middle. The first refine Edge stroke changes the view to Refine Edge X-ray view mode. See Layer panel view options.

    You should make the refinement strokes on the base frame as good as possible and cover all areas that contain a mixture of foreground and background; the refinement of other frames is based on the initial refinement areas defined on the base frame.

    Draw a Refine Edge stroke to mark areas of partial transparency
    Draw a Refine Edge stroke to mark areas of partial transparency

  12. Repeat and use the Refine Edge tool on other frames until the refinement is as precise and complete as possible. Press Alt/Option to erase Refine Edge strokes.

  13. If you've used the Refine Edge brush, the Fine-tune Refine Edge Matte option in the Roto Brush & Refine Edge effect properties is selected. Modify properties in the Refine Edge Matte property group as needed. (See Roto Brush & Refine Edge, Refine Hard Matte, and Refine Soft Matte effect reference.)

When you are done, click the Freeze button in the lower-tight corner of the Layer panel to cache, lock, and save the Roto Brush & Refine Edge propogation information. (See Freezing (caching, locking, and saving) Roto Brush segmentation.)

From an expert: Refine Edge Tool

From an expert: Refine Edge Tool
Josh Weiss

Freezing (caching, locking, and saving) Roto Brush segmentation

When the View menu in the Layer panel is set to Roto Brush & Refine Edge, a Freeze button appears in the lower-right corner of the Layer panel. Click this button to cache and lock segmentation for all Roto Brush & Refine Edge  spans for the layer within the composition work area. This preserves the matte and saves it with the project, preventing the Roto Brush & Refine Edge effect from re-propogating the segmentation when you open the project again or make changes.

If After Effects has already calculated segmentation information for a frame when you click the Freeze button, then this information is cached. If the segmentation has not been calculated for a frame within a Roto Brush & Refine Edge span, then After Effects must calculate the segmentation before freezing.

Frames with frozen (cached and locked) segmentation information are represented by blue bars in the Roto Brush & Refine Edge span view in the Layer panel.

Note:

If you click Stop in the dialog box, After Effects stops adding frames to the cache, but Roto Brush & Refine Edge segmentation is still locked with the segmentation information cached up until the point that you clicked Stop.

To unfreeze Roto Brush & Refine Edge segmentation, click the Freeze button again.

When Roto Brush & Refine Edge segmentation is frozen, you can place the pointer over the Freeze button to see a tooltip that tells you when the cached information was created.

When Roto Brush & Refine Edge segmentation is frozen, the pointer for the Roto Brush & Refine Edge tools has a slash through it. It indicates that new strokes won't affect the result untill you unfreeze.

The information that is cached and locked is the result of Roto Brush & Refine Edge strokes and the properties in the Roto Brush Propagation property group of the Roto Brush & Refine Edge effect. Making changes to any of these items (for example, by drawing new Roto Brush strokes or modifying properties in the Roto Brush Propagation property group) has no influence on the result of the Roto Brush & Refine Edge effect until you unfreeze segmentation. The properties in the Roto Brush Matte and Refine Edge Matte property groups are not frozen.

Frozen Roto Brush & Refine Edge segmentation information is cached and locked while the application is running, and the cached information is saved with the project.

Layer panel view options

You can choose these view modes from the Show Channel menu in the Layer panel, by clicking the buttons in the Layer panel, or by using keyboard shortcuts. You can use the controls at the bottom of the Layer panel to change the color and opacity of the overlays used in Alpha Boundary and Alpha Overlay mode.

Refine Edge X-ray

Shows areas of partial transparency created by the Refine Edge strokes as an X-ray. (Alt+X or Option+X). When you change Roto Brush & Refine Edge parameters that aren't visible in the X-ray view (for example, Chatter Reduction), the view switches back to the previous view so you can see the result of the change.

Alpha

Shows alpha channel of the layer (Alt+4 or Option+4).

Alpha Boundary

Shows source layer with foreground and background unchanged, with segmentation boundary overlaid as a colored outline (Alt+5 or Option+5).

Alpha Overlay

Shows source layer with foreground unchanged and background overlaid with a solid color (Alt+6 or Option+6).

Note:

The Refine Edge X-ray, Alpha Boundary, and Alpha Overlay view modes are turned off when the View menu in the Layer panel is changed to anything other than Roto Brush and Refine Edge tools.

Refine Hard Matte and Refine Soft Matte effects

Use the Refine Hard Matte and Refine Soft Matte effects to fine-tune a matte created using traditional methods such a creating masks or color keying. The properties and controls of these effects are similar to those in the Roto Brush & Refine Edge effect.

Refine Hard Matte

Use the Refine Hard Matte effect to improve the edges of an existing hard-edged alpha channel. The Refine Hard Matte effect is an updated version of the Refine Matte effect in After Effects CS5-CS6.

Refine Soft Matte

Use the new Refine Soft Matte effect to define a soft matte. This effect uses additional processing to automatically calculate finer edge details and transparent areas.

Roto Brush & Refine Edge, Refine Hard Matte, and Refine Soft Matte effect reference

The Roto Brush & Refine Edge effect properties in the Roto Brush Propagation property group affect segmentation between foreground and background and how that segmentation information is used for contiguous frames in a span. Other properties of the Roto Brush & Refine Edge effect affect the matte that is generated based on the initial segmentation. The Refine Hard Matte effect is similar to the Roto Brush Matte, with additional options such as Use Motion Blur and Decontaminate Edge Colors properties. The Refine Soft Mattte effect is similar to Refine Edge Matte with additional options such as Use Motion Blur and Decontaminate Edge Colors.

Roto Brush and Refine Edge effect

Property

Description

Roto Brush Propagation

Properties in the Roto Brush Propagation property group (except for View Search Region) affect all Roto Brush calculations. Any change to these properties requires a recalculation and propagation of the segmentation information from a base frame. Also, the results on a base frame itself are not affected by changes to these properties; therefore, it’s best to change these properties when the current-time indicator is a frame or two away from a base frame, so that you can see the result of the changes.

Search Radius

The radius of the area within which After Effects searches when looking for pixels that match from one frame to the next. You can change how the search radius adapts to regions with more or less motion using the Motion Threshold and Motion Damping properties. If the search radius is too small, some motion may be missed; if the search radius is too large, extraneous motion may be detected.

Motion Threshold and Motion Damping

These two properties control how the search region is constrained based on motion. Change Motion Threshold to set the motion level below which is considered no motion, where the search region will shrink to nothing. Motion Damping affects the remaining areas that are considered to be in motion. As you increase Motion Damping, the search region is tightened, with slow-moving areas tightening more than fast-moving areas. Constraining the search region in areas with little motion can reduce edge chatter in these regions. Constraining the search region too much will cause the automatic boundary detection to fall off the edge of the object.

View Search Region

Renders the search region as yellow, and the foreground and background as a grayscale image (with the background dimmer than the foreground). The value of this property affects the rendered output of the Roto Brush & Refine Edge effect, not just an intermediate stage of the effect's operation. Its main use is to help you pick values for Search Radius, Motion Threshold, and Motion Damping.

Edge Detection

Choose whether to favor the segmentation boundary calculated for the current frame in isolation or the segmentation calculated based on the previous frame when determining the edge between foreground and background. The Balanced option considers the current frame and surrounding frames equally. Foreground objects with colors that match the background will usually benefit from Favor Predicted Edges.

Use Alternate Color Estimation

Subtly changes the process by which the effect determines what is foreground and what is background. Sometimes checking it helps with segmentation; sometimes it doesn't.

Invert Foreground/Background

Inverts which strokes are considered foreground strokes and which strokes are considered background strokes in the segmentation phase.

Fine-tune Roto Brush Matte

 

Enable or disable finer adjustments for Roto Brush Matte. These controls are used to adjust the segmentation boundary defined by foreground and background strokes.

Roto Brush Matte

Properties under the Roto Brush Matte group affect the Roto Brush matte, and are used to adjust the segmentation boundary defined by foreground and background strokes. Areas marked by the Refine Edge tool are not affected by the properties in this group.

Feather

Increasing this value reduces the sharpness of the curves in the segmentation boundary by smoothing along the edge.

Contrast

Contrast of the segmentation boundary. This property does nothing if Feather is 0. Unlike the Feather property, Contrast applies across the edge.

Shift Edge

The amount of expansion of the matte relative to the value of the Feather property. The result is very similar to that of the Choke property in the Matte Choker effect, but the value is given from -100% to 100% (instead of -127 to 127).

Reduce Chatter

Increase this property to reduce erratic changes to edges from one frame to the next. This property determines how much influence the current frame should have when performing a weighted average across adjacent frames to make the matte edges not move erratically from one frame to the next. If the Reduce Chatter value is high, the chatter reduction is strong, and the current frame is considered less. If the Reduce Chatter value is low, the chatter reduction is weak, and the current frame is considered more. If the Reduce Chatter value is 0, only the current frame is considered for matte refinement.

Tip: If the foreground object isn’t moving, but the matte edges are moving and changing, increase the value of the Reduce Chatter property.

If the foreground object is moving, but the matte edge isn’t moving, decrease the value of the Reduce Chatter property.

Render Refine Edge

Determines if the result of the entire effect is rendered. Disable it to render results from Roto Brush only while excluding the results from the Refine Edge.

Base Refine Edge Radius

Adds a uniform band along the entire segmentation boundary that behaves like a hand-drawn stroke with the Refine Edge tool on each base frame. The width of the strokes is determined by this value.

If you use a non-zero Base Refine Edge Radius value, it effectively makes edges that were previously only defined by Roto Brush strokes as if they were drawn using Refine Edge Strokes.

Fine-tune Refine Edge Matte

Enable or disable the property group for Refine Edge Matte. These controls are used to control Refine Edge parameters.

Refine Edge Matte

The properties under this group determine the Refine Edge properties. The properties do not affect the entire layer, but only the area defined by the Refine Edge strokes.

Smooth

Smoothens along the alpha boundary, preserving semi-transparent detail across the boundary.

Feather

Blurs the alpha channel in the refined area.

Contrast

Contrast of the alpha channel in the refined area.

Shift Edge

The amount of expansion of the matte relative to the value of the Feather property. The result is very similar to that of the Choke property in the Matte Choker effect, but the value is given from -100% to 100% (instead of -127 to 127).

Chatter Reduction

Enable or disable Chatter Reduction. Choose More Detailed or Smoother (Slower).

Reduce Chatter

Increase this property to reduce erratic changes to edges from one frame to the next. Max of 100% for More Detailed, max of 400% for Smoother (Slower).

Use Motion Blur

Check this option to render the matte with motion blur. The high-quality option is slower, but generates a cleaner edge. You can also control the number of samples and the shutter angle, which have the same meaning as they do in the context of motion blur in the composition settings. 

Decontaminate Edge Colors

Check this option to decontaminate (clean) the color of edge pixels. The background color is removed from foreground pixels, which helps to fix halos and the contamination of motion-blurred foreground objects with background color. The strength of this cleaning is determined by Decontamination Amount.

Decontaminate Amount

Determines the strength of the Decontaminate Edge Colors.

Extend Where Smoothed

Only functional when Reduce Chatter is greater than 0 and Decontaminate Edge Colors is selected. Edges that are moved in order to reduce chatter are cleaned.

Increase Decontamination Radius

Amount (in pixels) by which to increase the radius value for the cleaning of edge colors, in addition to any cleaning that covers feather, motion blur, and extended decontamination.

View Decontamination Map

Shows which pixels will be cleaned by decontamination of edge colors (white pixels in the map).

Refine Hard Matte effect

Property

Description

Feather

Increasing this value reduces the sharpness of the curves in the matte by smoothing along the edge.

Contrast

Determines the contrast of the matte. This property does nothing if Feather is 0. Unlike the Feather property, Contrast applies across the edge.

Shift Edge

The amount of expansion of the matte relative to the value of the Feather property. The result is very similar to that of the Choke property in the Matte Choker effect, but the value is given from -100% to 100% (instead of -127 to 127).

Reduce Chatter

Increase this property to reduce erratic changes to edges from one frame to the next. This property determines how much influence the current frame should have when performing a weighted average across adjacent frames to make the matte edges not move erratically from one frame to the next. If the Reduce Chatter value is high, the chatter reduction is strong, and the current frame is considered less. If the Reduce Chatter value is low, the chatter reduction is weak, and the current frame is considered more. If the Reduce Chatter value is 0, only the current frame is considered for matte refinement.

Tip: If the foreground object isn’t moving, but the matte edges are moving and changing, increase the value of the Reduce Chatter property.

If the foreground object is moving, but the matte edge isn’t moving, decrease the value of the Reduce Chatter property.

Use Motion Blur

Check this option to render the matte with motion blur. The high-quality option is slower, but generates a cleaner edge. You can also control the number of samples and the shutter angle, which have the same meaning as they do in the context of motion blur in the composition settings. 

In the Refine Hard Matte effect, if you want any motion blur you'll need this on.

Decontaminate Edge Colors

Check this option to decontaminate (clean) the color of edge pixels. The background color is removed from foreground pixels, which helps to fix halos and the contamination of motion-blurred foreground objects with background color. The strength of this cleaning is determined by Decontamination Amount.

Decontaminate Amount

Determines the strength of decontamination.

Extend Where Smoothed

Only functional when Reduce Chatter is greater than 0 and Decontaminate Edge Colors is selected. Edges that are moved in order to reduce chatter are cleaned.

Increase Decontamination Radius

Amount (in pixels) by which to increase the radius value for the cleaning of edge colors, in addition to any cleaning that covers feather, motion blur, and extended decontamination.

View Decontamination Map

Shows which pixels will be cleaned by decontamination of edge colors (white pixels in the map).

Refine Soft Matte effect

Property

Description

Calculate Edge Details

Computes semi-transparent edges, pulling out details within the edge region.

Additional Edge Radius

Adds a uniform band along the entire refinement boundary that behaves like a hand-drawn stroke with the Refine Edge tool on each base frame. The width of the stroke is determined by this value.

View Edge Region

Renders the edge region as yellow, and the foreground and background as a grayscale image (with the background dimmer than the foreground).

Smooth

Smoothens along the alpha boundary, preserving semi-transparent detail across the boundary.

Feather

Blurs the alpha channel in the refined area.

Contrast

Contrast of the alpha channel in the refined area.

Shift Edge

The amount of expansion of the matte relative to the value of the Feather property. The result is very similar to that of the Choke property in the Matte Choker effect, but the value is given from -100% to 100% (instead of -127 to 127).

Chatter Reduction

Enable or disable Chatter Reduction. Choose More Detailed or Smoother (Slower).

Reduce Chatter

Increase this property to reduce erratic changes to edges from one frame to the next. Max of 100% for More Detailed, max of 400% for Smoother (Slower).

More Motion Blur

Check this option to render the matte with motion blur. The high-quality option is slower, but generates a cleaner edge. You can also control the number of samples and the shutter angle, which have the same meaning as they do in the context of motion blur in the composition settings. 

In Refine Soft Matte effect, any motion blur that's in the source image is already retained, you only need this option if you want more than what is in the footage.

Decontaminate Edge Colors

Check this option to decontaminate (clean) the color of edge pixels. The background color is removed from foreground pixels, which helps to fix halos and the contamination of motion-blurred foreground objects with background color. The strength of this cleaning is determined by Decontamination Amount.

Decontaminate Amount

Determines the strength of decontamination.

Extend Where Smoothed

Only functional when Reduce Chatter is greater than 0 and Decontaminate Edge Colors is selected. Edges that are moved in order to reduce chatter are cleaned.

Increase Decontamination Radius

Amount (in pixels) by which to increase the radius value for the cleaning of edge colors, in addition to any cleaning that covers feather, motion blur, and extended decontamination.

View Decontamination Map

Shows which pixels will be cleaned by decontamination of edge colors (white pixels in the map).

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy