用户指南 取消(C)

从图层生成图像资源

  1. Photoshop 用户指南
  2. Photoshop 简介
    1. 有梦想,去实现
    2. Photoshop 的新增功能
    3. 编辑第一张照片
    4. 创建文档
    5. Photoshop | 常见问题
    6. Photoshop 系统要求
    7. 迁移预设、动作和设置
    8. 了解 Photoshop
  3. Photoshop 和 Adobe 服务
    1. Photoshop 和 Adobe Stock
    2. Creative Cloud Libraries
    3. Photoshop 中的 Creative Cloud Libraries
    4. 将 Touch Bar 与 Photoshop 结合使用
    5. 在 Photoshop 中使用 Illustrator 图稿
    6. 在 Photoshop 中使用 Capture 应用程序内扩展
    7. 网格和参考线
    8. 创建动作
    9. 还原和历史记录
    10. 默认键盘快捷键
    11. 触摸功能和可自定义的工作区
  4. Photoshop iPad 版
    1. Photoshop iPad 版 | 常见问题
    2. 了解工作区
    3. 系统要求 | Photoshop iPad 版
    4. 创建、打开和导出文档
    5. 添加照片
    6. 处理图层
    7. 使用画笔进行绘图和绘画
    8. 建立选区并添加蒙版
    9. 修饰复合
    10. 使用调整图层
    11. 使用曲线调整复合图像的色调
    12. 应用变换操作
    13. 裁剪和旋转复合图像
    14. 旋转、平移、缩放和重置画布
    15. 使用文字图层
    16. 使用 Photoshop 和 Lightroom
    17. 在 Photoshop iPad 版中获取缺失字体
    18. Photoshop iPad 版中的日文文本
    19. 管理应用程序设置
    20. 触控快捷键和手势
    21. 键盘快捷键
    22. 编辑图像大小
    23. 在 Photoshop iPad 版上创作直播
    24. 使用修复画笔校正瑕疵
    25. 在 Capture 中创建画笔并将其用在 Photoshop 中
    26. 使用 Camera Raw 文件
    27. 创建和使用智能对象
    28. 使用减淡和加深调整图像中的曝光度
  5. Photoshop Web 测试版
    1. 常见问题 | Photoshop Web 测试版 
    2. 工作区简介
    3. 系统要求 | Photoshop Web 版Beta 版
    4. 键盘快捷键 | Photoshop Web 测试版
    5. 支持的文件类型 | Photoshop Web 测试版
    6. 打开并处理云文档
    7. 与利益干系人协作
    8. 对云文档应用有限编辑
  6. 云文档
    1. Photoshop 云文档 |常见问题
    2. Photoshop 云文档 | 工作流程问题
    3. 在 Photoshop 中管理和使用云文档
    4. 升级 Photoshop 的云存储空间
    5. 无法创建或保存云文档
    6. 解决 Photoshop 云文档错误
    7. 收集云文档同步日志
    8. 共享访问权限并编辑您的云文档
    9. 完成文件和应用程序内注释的共享
  7. 工作区
    1. 工作区基础知识
    2. 创建文档
    3. 将 Touch Bar 与 Photoshop 结合使用
    4. Photoshop 中的 Microsoft Dial 支持
    5. 工具库
    6. 性能首选项
    7. 使用工具
    8. 触控手势
    9. 触摸功能和可自定义的工作区
    10. 技术预览
    11. 元数据和注释
    12. 快速共享您的创作
    13. 将 Photoshop 图像置入其他应用程序
    14. 首选项
    15. 默认键盘快捷键
    16. 标尺
    17. 显示或隐藏不打印的额外内容
    18. 指定图像的列
    19. 还原和历史记录
    20. 面板和菜单
    21. 置入文件
    22. 使用对齐功能定位元素
    23. 用标尺工具定位
    24. 预设
    25. 自定义键盘快捷键
    26. 网格和参考线
  8. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 设备预览
    4. 从图层拷贝 CSS
    5. 将 Web 页切片
    6. 切片的 HTML 选项
    7. 修改切片版面
    8. 使用 Web 图形
    9. 创建 Web 照片画廊
  9. 图像和颜色基础知识
    1. 如何调整图像大小
    2. 处理栅格图像和矢量图像
    3. 图像大小和分辨率
    4. 从相机和扫描仪获取图像
    5. 创建、打开和导入图像
    6. 查看图像
    7. 无效的 JPEG 标记错误 | 打开图像
    8. 查看多个图像
    9. 自定拾色器和色板
    10. 高动态范围图像
    11. 匹配图像中的颜色
    12. 在颜色模式之间转换
    13. 颜色模式
    14. 抹除图像的部分内容
    15. 混合模式
    16. 选择颜色
    17. 自定索引颜色表
    18. 图像信息
    19. 扭曲滤镜不可用
    20. 关于颜色
    21. 使用通道进行颜色和单色调整
    22. 在“颜色”和“色板”面板中选择颜色
    23. 取样
    24. 颜色模式或图像模式
    25. 色调
    26. 向动作添加条件模式更改
    27. 从 HTML、CSS 和 SVG 添加色板
    28. 位深度和首选项
  10. 图层
    1. 图层基础知识
    2. 非破坏性编辑
    3. 创建和管理图层和组
    4. 选择、编组和链接图层
    5. 将图像置入图框中
    6. 图层不透明度和混合
    7. 蒙版图层
    8. 应用智能滤镜
    9. 图层复合
    10. 移动、堆叠和锁定图层
    11. 使用矢量蒙版遮盖图层
    12. 管理图层和组
    13. 图层效果和样式
    14. 编辑图层蒙版
    15. 抽出资源
    16. 显示带有剪贴蒙版的图层
    17. 从图层生成图像资源
    18. 使用智能对象
    19. 混合模式
    20. 将多个图像组合到人像组中
    21. 使用自动混合图层组合图像
    22. 对齐和分布图层
    23. 从图层拷贝 CSS
    24. 载入图层或图层蒙版边界上的选区
    25. 显示其他图层中内容的挖空效果
    26. 图层
    27. 拼合
    28. 复合
    29. 背景
  11. 选择
    1. “选择并遮住”工作区
    2. 快速建立选区
    3. 选区快速入门
    4. 使用选框工具进行选择
    5. 使用套索工具进行选择
    6. 选择图像中的颜色范围
    7. 调整像素选区
    8. 在路径和选区边界之间转换
    9. 通道基础知识
    10. 移动、拷贝和删除选定的像素
    11. 创建临时快速蒙版
    12. 存储选区和 Alpha 通道蒙版
    13. 选择位于焦点中的图像区域
    14. 复制,拆分,和合并通道
    15. 通道计算
    16. 选区
    17. 定界框
  12. 图像调整
    1. 透视变形
    2. 减少相机抖动模糊
    3. 修复画笔示例
    4. 导出颜色查找表
    5. 调整图像锐化程度和模糊程度
    6. 了解颜色调整
    7. 应用亮度/对比度调整
    8. 调整阴影和高光细节
    9. 色阶调整
    10. 调整色相和饱和度
    11. 调整自然饱和度
    12. 调整图像区域中的颜色饱和度
    13. 快速调整色调
    14. 对图像应用特殊颜色效果
    15. 通过色彩平衡调整增强图像
    16. 高动态范围图像
    17. 查看直方图和像素值
    18. 匹配图像中的颜色
    19. 如何裁剪并拉直照片
    20. 将彩色图像转换为黑白图像
    21. 调整图层和填充图层
    22. 曲线调整
    23. 混合模式
    24. 设置用于印刷的图像目标值
    25. 使用色阶和曲线吸管工具调整颜色和色调
    26. 调整 HDR 曝光度和色调
    27. 滤镜
    28. 模糊
    29. 减淡或加深图像区域
    30. 调整可选颜色
    31. 替换对象颜色
  13. Adobe Camera Raw
    1. Camera Raw 的系统要求
    2. Camera Raw 新增功能
    3. Camera Raw 简介
    4. 创建全景图
    5. 支持的镜头
    6. Camera Raw 中的晕影、颗粒和去除薄雾效果
    7. 默认键盘快捷键
    8. Camera Raw 中的自动透视校正功能
    9. 如何在 Camera Raw 中进行非破坏性编辑
    10. Camera Raw 中的径向滤镜
    11. 管理 Camera Raw 设置
    12. 在 Camera Raw 中打开、处理和保存图像
    13. 在 Camera Raw 中使用增强型污点去除工具修复图像
    14. 旋转、裁切和调整图像
    15. 在 Camera Raw 中调整颜色显示
    16. 功能摘要 | Adobe Camera Raw | 2018 版
    17. 新增功能摘要
    18. Camera Raw 中的处理版本
    19. 在 Camera Raw 中进行局部调整
  14. 图像修复和图像恢复
    1. 通过“内容识别填充”从照片中移去对象
    2. 内容识别修补和移动
    3. 修饰和修复照片
    4. 校正图像扭曲和杂色
    5. 用于修复大多数问题的基本故障排除步骤
  15. 图像变换
    1. 变换对象
    2. 调整裁剪、旋转和画布大小
    3. 如何裁剪并拉直照片
    4. 创建并编辑全景图图像
    5. 变形图像、外形和路径
    6. 消失点
    7. 使用液化滤镜
    8. 内容识别缩放
    9. 变换图像、形状和路径
    10. 变形
    11. 变换
    12. 全景图
  16. 绘图和绘画
    1. 绘制对称图案
    2. 绘制矩形并修改描边选项
    3. 关于绘图
    4. 绘制和编辑形状
    5. 绘画工具
    6. 创建和修改画笔
    7. 混合模式
    8. 为路径添加颜色
    9. 编辑路径
    10. 使用混合器画笔绘画
    11. 画笔预设
    12. 渐变
    13. 渐变插值
    14. 填充和描边选区、图层和路径
    15. 用钢笔工具绘图
    16. 创建图案
    17. 使用图案生成器创建图案
    18. 管理路径
    19. 管理图案库和预设
    20. 使用绘图板绘图或绘画
    21. 创建纹理画笔
    22. 将动态元素添加到画笔中
    23. 渐变
    24. 使用“历史记录艺术画笔”绘制风格化描边
    25. 使用图案进行绘画
    26. 在多个设备上同步预设
  17. 文本
    1. 使用 OpenType SVG 字体
    2. 设置字符格式
    3. 设置段落格式
    4. 如何创建文字效果
    5. 编辑文本
    6. 行距和字距
    7. 阿拉伯语和希伯来语文字
    8. 字体
    9. 解决字体问题
    10. 亚洲文字
    11. 创建文字
    12. 使用 Photoshop 中的文字工具时发生文本引擎错误 | Windows 8
    13. 适合亚洲脚本的全球通用书写器
    14. 如何在 Photoshop 中添加和编辑文本
  18. 视频和动画
    1. Photoshop 中的视频编辑
    2. 编辑视频和动画图层
    3. 视频和动画概述
    4. 预览视频和动画
    5. 在视频图层中绘制帧
    6. 导入视频文件和图像序列
    7. 创建帧动画
    8. Creative Cloud 3D 动画(预览)
    9. 创建时间轴动画
    10. 创建视频图像
  19. 滤镜和效果
    1. 使用液化滤镜
    2. 使用模糊画廊
    3. 滤镜基础知识
    4. 滤镜效果参考
    5. 添加光照效果
    6. 使用自适应广角滤镜
    7. 使用油画滤镜
    8. 图层效果和样式
    9. 应用特定的滤镜
    10. 涂抹图像区域
  20. 存储和导出
    1. 在 Photoshop 中存储文件
    2. 在 Photoshop 中导出文件
    3. 支持的文件格式
    4. 以图形格式存储文件
    5. 在 Photoshop 和 Illustrator 之间移动设计
    6. 存储和导出视频和动画
    7. 存储 PDF 文件
    8. Digimarc 版权保护
  21. 打印
    1. 打印 3D 对象
    2. 从 Photoshop 打印
    3. 使用色彩管理进行打印
    4. 联系表和 PDF 演示文稿
    5. 以图片包版面的形式打印照片
    6. 打印专色
    7. 双色调
    8. 将图像打印到商业印刷机
    9. 改进 Photoshop 中的色彩打印
    10. 解决打印问题 | Photoshop
  22. 自动化
    1. 创建动作
    2. 创建数据驱动图形
    3. 脚本
    4. 处理一批文件
    5. 播放和管理动作
    6. 添加条件动作
    7. 关于动作和“动作”以显示“动作”面板
    8. 记录动作中的工具
    9. 向动作添加条件模式更改
    10. Photoshop 中有关增效工具和脚本的 UI 工具包
  23. 色彩管理
    1. 了解色彩管理
    2. 保持颜色一致
    3. 颜色设置
    4. 使用颜色配置文件
    5. 对要联机查看的文档进行色彩管理
    6. 打印时对文档进行色彩管理
    7. 对导入的图像进行色彩管理
    8. 校样颜色
  24. 内容真实性
    1. 了解内容凭据
    2. NFT 的身份和来源
    3. 连接帐户进行创意归因
  25. 3D 和技术成像
    1. Photoshop 3D | 围绕即将中断的 3D 功能的常见问题
    2. Creative Cloud 3D 动画(预览)
    3. 打印 3D 对象
    4. 3D 绘画
    5. 3D 面板增强功能 | Photoshop
    6. 基本的 3D 概念和工具
    7. 3D 渲染和存储
    8. 创建 3D 对象和动画
    9. 图像堆栈
    10. 3D 工作流程
    11. 测量
    12. DICOM 文件
    13. Photoshop 和 MATLAB
    14. 对图像中的对象计数
    15. 合并和转换 3D 对象
    16. 3D 纹理编辑
    17. 调整 HDR 曝光度和色调
    18. 3D 面板设置

JPEG、PNG、GIF 或 SVG 图像资源可以从 PSD 文件图层或图层组中的内容生成。将受支持的图像格式扩展添加到图层名称或图层组名称时,会自动生成资源。(可选)您也可以指定所生成图像资源的品质和大小参数。

从 PSD 文件生成图像资源对于多设备 Web 设计来说尤其有用。

有关如何创建和导出 Web 图形,请参阅如何从 Photoshop 导出各种格式的文件。

从图层或图层组生成图像资源

要更好地了解图像资源生成器,请考虑具有以下图层层次结构的简单 PSD 文件(从此链接下载)

Photoshop 生成图像资源
示例 PSD 文件及其图层层次结构

此文件的图层层次结构具有两个图层组:Rounded_rectanglesEllipses。每个图层组均包含 5 个图层。

按照以下步骤从此 PSD 文件生成图像资源:

  1. 打开 PSD 文件后,选择“文件”>“生成”>“图像资源”
  2. 将适当的文件格式扩展名(.jpg.png.gif .svg)添加到您要从中生成图像资源的图层或图层组的名称中。例如,将图层组 Rounded_rectanglesEllipses 重命名为 Rounded_rectangles.jpgEllipses.png;将图层 Ellipse_4 重命名为 Ellipse_4.gif
注意:

图层名称不支持特殊字符 :*

Photoshop 生成图像资源并将它们与源 PSD 文件一起保存在子文件夹中。如果源 PSD 文件尚未保存,Photoshop 会将生成的资源保存在桌面上的新文件夹中。

Photoshop 图像资源名称
图像资源名称从图层名称/图层组名称中生成。

注意:

图像资源生成功能针对当前文档启用。启用后,无论何时再次打开该文档,功能仍然可用。要禁用当前文档的图像资源生成功能,请取消选择“文件”>“生成”>“图像资源”

为云文档生成资源

如果您使用的是云文档,则资源将保存在“Photoshop Cloud Associates”目录中:

  • Windows: C:\Users\yourname\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users/yourname/Documents/Adobe/Photoshop Cloud Associates

从一个图层或图层组生成多个资源

若要从一个图层/图层组生成多个资源,请用半角逗号分隔资源名称。例如,以下图层名称生成三个资源:

Ellipse_4.jpg, Ellipse_4b.png, Ellipse_4c.png

将资产保存在子文件夹中

您可以选择将特定图层/图层组生成的图像资源直接保存在资源文件夹下的子文件夹中。包括图层/图层组名称下的子文件夹名称;例如:

[子文件夹]/Ellipse_4.jpg 

Web 设计使用案例

从 PSD 文件生成图像资源对于多设备 Web 设计来说尤其有用。考虑以下 Web 设计及其图层结构:

Web 设计及其图层层次结构

将顶部的图标和“全球热点”图像网格的顶行提取为图像资源:

  • 将图像格式扩展名添加到适当的图层名称中。
Photoshop 为适当的图层/图层组重命名

Photoshop 为适当的图层/图层组重命名

为适当的图层/图层组重命名

注意:

将从图层/图层组的内容中生成一个图像资源。例如,上面屏幕抓图中的 AdventureCo Logo 图层组包含一个形状图层和一个活动文本图层。当从图层组生成图像资源时,这些图层会进行拼合。

Photoshop 生成资源,并将它们保存在与源 PSD 文件相同的位置。

Photoshop 生成的图像资源
生成的图像资源

指定品质和大小参数

默认情况下,JPEG 资源会以 90% 品质生成。默认情况下,PGN 资源会以 32 位图像生成。GIF 资源会以基本 Alpha 透明度生成。

当重命名图层或图层组以便为资源生成做准备时,您可以自定品质和大小。

JPEG 资源的参数

  • 添加所需的输出品质作为该资源名称后缀:jpg(1-10) 或 jpg(1-100%)。例如:
    • Ellipse_4.jpg5
    • Ellipse_4.jpg50%
  • 添加所需的输出图像大小(相对大小或以支持的格式:pxincmmm)作为该资源名称前缀。Photoshop 会相应地缩放图像。例如:
    • 200% Ellipse_4.jpg
    • 300 x 200 Rounded_rectangle_3.jpg
    • 10in x 200mm Rounded_rectangle_3.jpg

注:请记得在前缀和资源名称之间添加一个空格字符。如果要指定像素大小,则可以省略单位。例如,300 x 200。

注意:

根据说明,当指定所需输出图像大小时,可以混合使用不同的单位和像素。例如,4in x 100 Rounded_rectangle_3.jpg 是资源生成的有效图层名称。

PNG 资源的参数

  • 添加所需的输出品质作为该资源名称后缀:82432。例如:
    • Ellipse_4.png24
  • 添加所需的输出图像大小(相对大小或以支持的格式:pxincmmm)作为该资源名称前缀。Photoshop 会相应地缩放图像。例如:
    • 42% Ellipse_4.png
    • 300mm x 20cm Rounded_rectangle_3.png
    • 10in x 50cm Rounded_rectangle_3.png

注:请记得在前缀和资源名称之间添加一个空格字符。如果要指定像素大小,则可以省略单位。例如,300 x 200。

注意:

根据说明,当指定所需输出图像大小时,可以混合使用不同的单位和像素。例如,4in x 100 Rounded_rectangle_3.png 是资源生成的有效图层名称。

GIF 资源的参数

  • 添加所需的输出图像大小(相对大小或以支持的格式:pxincmmm)作为该资源名称前缀。例如:
    • 42% Ellipse_4.gif
    • 300mm x 20cm Rounded_rectangle_3.gif
    • 20in x 50cm Rounded_rectangle_3.gif

注:请记得在前缀和资源名称之间添加一个空格字符。如果要指定像素大小,则可以省略单位。例如,300 x 200。

注意:

根据说明,当指定所需输出图像大小时,可以混合使用不同的单位和像素。例如,4in x 100 Rounded_rectangle_3.gif 是资源生成的有效图层名称。

品质参数对 GIF 资源不可用。

构建复杂图层名称

为资源生成命名图层时,您可以使用参数指定多个资源名称。例如:

120% Delicious.jpg, 42% Delicious.png24, 100x100 Delicious_2.jpg90%, 250% Delicious.gif

Photoshop 从该图层生成以下资源:

  • Delicious.jpg(缩放 120% 的 8 品质 JPG 图像)
  • Delicious.png(缩放 42% 的 24 位 PNG 图像)
  • Delicious_2.jpg(100x100 像素绝对大小的 90% 品质 JPG 图像)
  • Delicious.gif(缩放 250% 的 GIF 图像)

绝对缩放示例

绝对缩放的正确示例

  • 100x80 foo.png(简单绝对缩放)
  • 80 x 100px foo.png(长度之间的空格)
  • 4in x100 foo.png(单位和无单位的混合)
  • 90mm x120cm foo.png(不同单位混合)
  • 100x? Foo.png(通配符)
  • ?x60in foo.png(开头为通配符)

绝对缩放的错误示例

  • 100x100foo.png(文件名前没有空格)
  • 80x100 60% foo.png(绝对缩放和相对缩放混合)
  • 50% 80x100 foo.png(绝对缩放和相对缩放混合)
  • 20in cm x50cm foo.png(多个单位)
  • 30nm x20 nano.png(无效单位)

格式化并分隔多个文件

正确示例

  • Layer 1.png(允许在文件名中使用空格 -- 生成名为“Layer 1.png”的单个文件)
  • Layer 1.png,Layer 2.jpg(逗号作为分隔符)
  • Layer 1.png, Layer 2.jpg(逗号后跟空格作为分隔符)
  • Layer 1.png+Layer 2.jpg(加号作为分隔符)
  • Layer 1.png + Layer 2.jpg(加号后跟空格作为分隔符)

整合在一起

100% Delicious, 42% Layer 1.png24 + 100x100 Layer.jpg-90% , 250% Quux/Foo Bar Baz.gif 生成三个文件(忽略“100% Delicious”字符串,因为它不是文件名):

  • Layer 1.png,缩放率 42%,24 位 png 图像
  • Layer.jpg,100x100 像素绝对大小,90% 品质 jpg 图像
  • Quux 子文件夹中的 Foo Bar Baz.gif,缩放率 250%,gif 图像。

为资源指定默认设置

可以为生成的资源指定文件默认设置。请按以下步骤进行操作:

  1. 创建空图层。
  2. 图层的名称以默认的关键字开始。现在,输入您将应用于从文档生成的所有图像资源的设置。例如:

默认 hi-res/

在名为 hi-res 的子文件夹中生成所有图像资源。例如,[asset_folder]/hi-res/Delicious.jpg

默认 hi-res/@2x

在名为 hi-res 的子文件夹中生成所有图像资源。此外,资源名称在后缀为 @2x。例如,[asset_folder]/hi-res/Delicious@2x.jpg

默认 50% lo-res/

将缩小 50% 的图像资源保存在文档资源文件夹下的子文件夹 lo-res 中 

默认 hi-res/@2x + 50% lo-res/

从图层生成两个图像资源:

  • hi-res 子文件夹中,图像资源名称的后缀为 @2x
  • lo-res 子文件夹中,图像资源缩小 50%
注意:

默认缩放系数由各个图层指定的缩放系数覆盖。

禁用所有文档的图像资源生成

您可以通过修改“首选项”,在全局范围禁用所有 Photoshop 文档的图像资源生成。

  1. 选择“编辑”>“首选项”>“增效工具”。
  2. 取消选择“启用生成器”。
  3. 单击确定
注意:

当您在“首选项”中禁用图像资源生成时,“文件”>“生成”菜单命令不可用。该功能仅能在“首选项”对话框中再次启用。

常见问题解答

资源名称在文档级别必须唯一。

默认情况下,JPG 资源会以 90% 品质生成。默认情况下,PGN 资源会以 32 位图像生成。GIF 资源会以基本 Alpha 透明度生成。

是。应用到图层的透明度和其他效果会反映在从该图层生成的资源中。但是,这些效果可能在生成的资源中拼合。

资源会被剪辑至文档边界。如果图像位于文档边界之外,则生成器不会创建与之相关的图像资源。

除了逗号 (,) 之外,您还可以使用加号 (+) 作为图像资源名称之间的分隔符。例如:

42% Rounded_rectangle_1.png24 + 100x100 Rounded_rectangle_1.jpg90%

等同于:

42% Rounded_rectangle_1.png24, 100x100 Rounded_rectangle_1.jpg90%

更多此类内容

Adobe 徽标

登录到您的帐户