注意:

对于 Photoshop CC 之前的 Photoshop 版本,只有当您拥有 Photoshop Extended 时,本文所讨论的某些功能才可能可用。Photoshop CC 不提供单独的 Extended 版本。Photoshop Extended 中的所有功能是 Photoshop CC 的一部分。

打开或导入视频文件

在 Photoshop 中,可以直接打开视频文件或向打开的文档添加视频。导入视频时,将在视频图层中引用图像帧。

  1. 执行下列操作之一:
    • 要直接打开视频文件,请选择“文件”>“打开”。

    • 要将视频导入到打开的文档中,请选择“图层”>“视频图层”>“从文件新建视频图层”。

  2. 在“打开”对话框中,对于“文件类型”(Windows) 或“启用”(Mac OS) 选项,选择“所有可读文档”或“QuickTime 影片”。
  3. 选择一个视频文件,然后单击“打开”。

注意:

也可以从 Bridge 直接打开视频:选择视频文件并选取“文件”>“打开方式”>“Adobe Photoshop”。

导入图像序列

在 Photoshop 中,当导入包含序列图像文件的文件夹时,每个图像都会成为视频图层中的帧。

  1. 确保图像文件位于一个文件夹中并按顺序命名。

    此文件夹应只包含要用作帧的图像。如果所有文件具有相同的像素尺寸,则可更成功地创建动画。要为帧正确排序以便制作动画,请按照字母或数字顺序命名文件。例如,filename001filename002filename003 等等。

  2. 执行下列操作之一:
    • 要直接打开图像序列,请选择“文件”>“打开”。

    • 要将图像序列导入到打开的文档中,请选择“图层”>“视频图层”>“从文件新建视频图层”。

  3. 在“打开”对话框中,导航到包含图像序列文件的文件夹。
  4. 选择一个文件,选择“图像序列”选项,然后单击“打开”。

    注意:

    在一个图像序列中选择多个文件将停用“图像序列”选项。

  5. 指定帧速率,然后单击“确定”。

置入视频或图像序列

在 Photoshop 中,如果要在将视频或图像序列导入文档时进行变换,请使用“置入”命令。一旦置入,视频帧就包含在智能对象中。当视频包含在智能对象中时,可以使用“动画”面板浏览各个帧,也可以应用智能滤镜。

注意:

不能在智能对象中包含的视频帧上直接绘制或仿制。不过,可以在智能对象的上方添加空白视频图层,并在空白帧上绘制。也可以使用仿制工具并结合“对所有图层取样”选项在空白帧上绘制。这可让您使用智能对象中的视频作为仿制源。

  1. 在文档处于打开状态时,选取“文件”>“置入”。

  2. 在“置入”对话框中,执行下列操作之一:
    • 选择一个视频文件并单击“置入”。

    • 选择一个图像序列文件,选择“图像序列”选项,然后单击“置入”。

    注意:

    确保所有图像序列文件都在一个文件夹中。

  3. (可选)使用控制点来缩放、旋转、移动导入内容或使其变形。
  4. 单击选项栏中的“提交变换”按钮 以置入文件。

注意:

也可以直接从 Adobe Bridge 置入视频。选择视频文件,然后选择“文件”>“置入”>“在 Photoshop 中”。

在视频图层中重新载入素材

如果在不同的应用程序中修改视频图层的源文件,则当您打开包含引用更改的源文件的视频图层的文档时,Photoshop 通常会重新载入并更新素材。如果已打开文档并且已修改源文件,则使用“重新载入帧”命令可以在“动画”面板中重新载入和更新当前帧。使用“动画”面板中的“上一帧”/“下一帧”或“播放”按钮浏览视频图层时,也应重新载入并更新素材。

替换视频图层中的素材

即使您移动或重命名源,Photoshop 也会试图保持视频图层和源文件之间的链接。如果链接由于某种原因断开,图层面板中的图层上会出现警告图标 。要重新建立视频图层与源文件之间的链接,请使用“替换素材”命令。该命令还可以用其它视频或图像序列源中的帧替换视频图层中的视频或图像序列帧。

  1. 在“时间轴”或“图层”面板中,选择要重新链接到源文件或替换内容的视频图层。

  2. 选取“图层”>“视频图层”>“替换素材”。
  3. 在“打开”对话框中,选择视频或图像序列文件,然后单击“打开”。

解释视频素材

解释视频素材

可以指定 Photoshop 如何解释已打开或导入的视频的 Alpha 通道和帧速率。

  1. 在“时间轴”或“图层”面板中,选择要解释的视频图层。

  2. 选择“图层”>“视频图层”>“解释素材”。
  3. 在“解释素材”对话框中,执行下列任一操作:
    • 要指定解释视频图层中的 Alpha 通道的方式,请选择“Alpha 通道”选项。素材必须包含 Alpha 通道,此选项才可用。如果已选择“预先正片叠加 - 杂边”,则可以指定对通道进行预先正片叠底所使用的杂边颜色。

    • 要指定每秒播放的视频帧数,请输入“帧速率”。

    • 要对视频图层中的帧或图像进行色彩管理,请从“颜色配置文件”菜单中选择一个配置文件。

视频和图像序列中的 Alpha 通道解释

带有 Alpha 通道的视频和图像序列可以是直接的或预先正片叠底的。如果使用包含 Alpha 通道的视频或图像序列,则一定要指定 Photoshop 如何解释 Alpha 通道以获得所需结果。当预先正片叠底的视频或图像位于带有某些背景色的文档中时,可能会产生不需要的重影或光晕。可以指定杂边颜色,以便半透明像素与背景混合(正片叠底),而不会产生光晕。

忽略

忽略视频中的 Alpha 通道。

直接 - 无杂边

将 Alpha 通道解释为直接 Alpha 透明度。如果用于创建视频的应用程序不会对颜色通道预先进行正片叠底,请选择此选项。

预先正片叠加 - 杂边

使用 Alpha 通道来确定有多少杂边颜色与颜色通道混合。如有必要,请单击“解释素材”对话框中的色板来指定杂边颜色。

含预先正片叠加通道的 Photoshop 图像
在解释为“直接-无杂边”时,含预先正片叠底通道(顶部)的项目会显示为带黑色晕圈(左下图)。在解释为黑色指定为背景色的“预先正片叠加 - 杂边”时,不会出现晕圈(右下图)。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略