用户指南 取消(C)

创建数据驱动图形

  1. Photoshop 用户指南
  2. Photoshop 简介
    1. 有梦想,去实现
    2. Photoshop 的新增功能
    3. 编辑第一张照片
    4. 创建文档
    5. Photoshop | 常见问题
    6. Photoshop 系统要求
    7. 迁移预设、动作和设置
    8. 了解 Photoshop
  3. Photoshop 和 Adobe 服务
    1. Photoshop 和 Adobe Stock
    2. Creative Cloud Libraries
    3. Photoshop 中的 Creative Cloud Libraries
    4. 将 Touch Bar 与 Photoshop 结合使用
    5. 在 Photoshop 中使用 Illustrator 图稿
    6. 在 Photoshop 中使用 Capture 应用程序内扩展
    7. 网格和参考线
    8. 创建动作
    9. 还原和历史记录
    10. 默认键盘快捷键
    11. 触摸功能和可自定义的工作区
  4. Photoshop iPad 版
    1. Photoshop iPad 版 | 常见问题
    2. 了解工作区
    3. 系统要求 | Photoshop iPad 版
    4. 创建、打开和导出文档
    5. 添加照片
    6. 处理图层
    7. 使用画笔进行绘图和绘画
    8. 建立选区并添加蒙版
    9. 修饰复合
    10. 使用调整图层
    11. 使用曲线调整复合图像的色调
    12. 应用变换操作
    13. 裁剪和旋转复合图像
    14. 旋转、平移、缩放和重置画布
    15. 使用文字图层
    16. 使用 Photoshop 和 Lightroom
    17. 在 Photoshop iPad 版中获取缺失字体
    18. Photoshop iPad 版中的日文文本
    19. 管理应用程序设置
    20. 触控快捷键和手势
    21. 键盘快捷键
    22. 编辑图像大小
    23. 在 Photoshop iPad 版上创作直播
    24. 使用修复画笔校正瑕疵
    25. 在 Capture 中创建画笔并将其用在 Photoshop 中
    26. 使用 Camera Raw 文件
    27. 创建和使用智能对象
    28. 使用减淡和加深调整图像中的曝光度
  5. Photoshop Web 测试版
    1. 常见问题 | Photoshop Web 测试版 
    2. 工作区简介
    3. 系统要求 | Photoshop Web 版Beta 版
    4. 键盘快捷键 | Photoshop Web 测试版
    5. 支持的文件类型 | Photoshop Web 测试版
    6. 打开并处理云文档
    7. 与利益干系人协作
    8. 对云文档应用有限编辑
  6. 云文档
    1. Photoshop 云文档 |常见问题
    2. Photoshop 云文档 | 工作流程问题
    3. 在 Photoshop 中管理和使用云文档
    4. 升级 Photoshop 的云存储空间
    5. 无法创建或保存云文档
    6. 解决 Photoshop 云文档错误
    7. 收集云文档同步日志
    8. 共享访问权限并编辑您的云文档
    9. 完成文件和应用程序内注释的共享
  7. 工作区
    1. 工作区基础知识
    2. 创建文档
    3. 将 Touch Bar 与 Photoshop 结合使用
    4. Photoshop 中的 Microsoft Dial 支持
    5. 工具库
    6. 性能首选项
    7. 使用工具
    8. 触控手势
    9. 触摸功能和可自定义的工作区
    10. 技术预览
    11. 元数据和注释
    12. 快速共享您的创作
    13. 将 Photoshop 图像置入其他应用程序
    14. 首选项
    15. 默认键盘快捷键
    16. 标尺
    17. 显示或隐藏不打印的额外内容
    18. 指定图像的列
    19. 还原和历史记录
    20. 面板和菜单
    21. 置入文件
    22. 使用对齐功能定位元素
    23. 用标尺工具定位
    24. 预设
    25. 自定义键盘快捷键
    26. 网格和参考线
  8. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 设备预览
    4. 从图层拷贝 CSS
    5. 将 Web 页切片
    6. 切片的 HTML 选项
    7. 修改切片版面
    8. 使用 Web 图形
    9. 创建 Web 照片画廊
  9. 图像和颜色基础知识
    1. 如何调整图像大小
    2. 处理栅格图像和矢量图像
    3. 图像大小和分辨率
    4. 从相机和扫描仪获取图像
    5. 创建、打开和导入图像
    6. 查看图像
    7. 无效的 JPEG 标记错误 | 打开图像
    8. 查看多个图像
    9. 自定拾色器和色板
    10. 高动态范围图像
    11. 匹配图像中的颜色
    12. 在颜色模式之间转换
    13. 颜色模式
    14. 抹除图像的部分内容
    15. 混合模式
    16. 选择颜色
    17. 自定索引颜色表
    18. 图像信息
    19. 扭曲滤镜不可用
    20. 关于颜色
    21. 使用通道进行颜色和单色调整
    22. 在“颜色”和“色板”面板中选择颜色
    23. 取样
    24. 颜色模式或图像模式
    25. 色调
    26. 向动作添加条件模式更改
    27. 从 HTML、CSS 和 SVG 添加色板
    28. 位深度和首选项
  10. 图层
    1. 图层基础知识
    2. 非破坏性编辑
    3. 创建和管理图层和组
    4. 选择、编组和链接图层
    5. 将图像置入图框中
    6. 图层不透明度和混合
    7. 蒙版图层
    8. 应用智能滤镜
    9. 图层复合
    10. 移动、堆叠和锁定图层
    11. 使用矢量蒙版遮盖图层
    12. 管理图层和组
    13. 图层效果和样式
    14. 编辑图层蒙版
    15. 抽出资源
    16. 显示带有剪贴蒙版的图层
    17. 从图层生成图像资源
    18. 使用智能对象
    19. 混合模式
    20. 将多个图像组合到人像组中
    21. 使用自动混合图层组合图像
    22. 对齐和分布图层
    23. 从图层拷贝 CSS
    24. 载入图层或图层蒙版边界上的选区
    25. 显示其他图层中内容的挖空效果
    26. 图层
    27. 拼合
    28. 复合
    29. 背景
  11. 选择
    1. “选择并遮住”工作区
    2. 快速建立选区
    3. 选区快速入门
    4. 使用选框工具进行选择
    5. 使用套索工具进行选择
    6. 选择图像中的颜色范围
    7. 调整像素选区
    8. 在路径和选区边界之间转换
    9. 通道基础知识
    10. 移动、拷贝和删除选定的像素
    11. 创建临时快速蒙版
    12. 存储选区和 Alpha 通道蒙版
    13. 选择位于焦点中的图像区域
    14. 复制,拆分,和合并通道
    15. 通道计算
    16. 选区
    17. 定界框
  12. 图像调整
    1. 透视变形
    2. 减少相机抖动模糊
    3. 修复画笔示例
    4. 导出颜色查找表
    5. 调整图像锐化程度和模糊程度
    6. 了解颜色调整
    7. 应用亮度/对比度调整
    8. 调整阴影和高光细节
    9. 色阶调整
    10. 调整色相和饱和度
    11. 调整自然饱和度
    12. 调整图像区域中的颜色饱和度
    13. 快速调整色调
    14. 对图像应用特殊颜色效果
    15. 通过色彩平衡调整增强图像
    16. 高动态范围图像
    17. 查看直方图和像素值
    18. 匹配图像中的颜色
    19. 如何裁剪并拉直照片
    20. 将彩色图像转换为黑白图像
    21. 调整图层和填充图层
    22. 曲线调整
    23. 混合模式
    24. 设置用于印刷的图像目标值
    25. 使用色阶和曲线吸管工具调整颜色和色调
    26. 调整 HDR 曝光度和色调
    27. 滤镜
    28. 模糊
    29. 减淡或加深图像区域
    30. 调整可选颜色
    31. 替换对象颜色
  13. Adobe Camera Raw
    1. Camera Raw 的系统要求
    2. Camera Raw 新增功能
    3. Camera Raw 简介
    4. 创建全景图
    5. 支持的镜头
    6. Camera Raw 中的晕影、颗粒和去除薄雾效果
    7. 默认键盘快捷键
    8. Camera Raw 中的自动透视校正功能
    9. 如何在 Camera Raw 中进行非破坏性编辑
    10. Camera Raw 中的径向滤镜
    11. 管理 Camera Raw 设置
    12. 在 Camera Raw 中打开、处理和保存图像
    13. 在 Camera Raw 中使用增强型污点去除工具修复图像
    14. 旋转、裁切和调整图像
    15. 在 Camera Raw 中调整颜色显示
    16. 功能摘要 | Adobe Camera Raw | 2018 版
    17. 新增功能摘要
    18. Camera Raw 中的处理版本
    19. 在 Camera Raw 中进行局部调整
  14. 图像修复和图像恢复
    1. 通过“内容识别填充”从照片中移去对象
    2. 内容识别修补和移动
    3. 修饰和修复照片
    4. 校正图像扭曲和杂色
    5. 用于修复大多数问题的基本故障排除步骤
  15. 图像变换
    1. 变换对象
    2. 调整裁剪、旋转和画布大小
    3. 如何裁剪并拉直照片
    4. 创建并编辑全景图图像
    5. 变形图像、外形和路径
    6. 消失点
    7. 使用液化滤镜
    8. 内容识别缩放
    9. 变换图像、形状和路径
    10. 变形
    11. 变换
    12. 全景图
  16. 绘图和绘画
    1. 绘制对称图案
    2. 绘制矩形并修改描边选项
    3. 关于绘图
    4. 绘制和编辑形状
    5. 绘画工具
    6. 创建和修改画笔
    7. 混合模式
    8. 为路径添加颜色
    9. 编辑路径
    10. 使用混合器画笔绘画
    11. 画笔预设
    12. 渐变
    13. 渐变插值
    14. 填充和描边选区、图层和路径
    15. 用钢笔工具绘图
    16. 创建图案
    17. 使用图案生成器创建图案
    18. 管理路径
    19. 管理图案库和预设
    20. 使用绘图板绘图或绘画
    21. 创建纹理画笔
    22. 将动态元素添加到画笔中
    23. 渐变
    24. 使用“历史记录艺术画笔”绘制风格化描边
    25. 使用图案进行绘画
    26. 在多个设备上同步预设
  17. 文本
    1. 使用 OpenType SVG 字体
    2. 设置字符格式
    3. 设置段落格式
    4. 如何创建文字效果
    5. 编辑文本
    6. 行距和字距
    7. 阿拉伯语和希伯来语文字
    8. 字体
    9. 解决字体问题
    10. 亚洲文字
    11. 创建文字
    12. 使用 Photoshop 中的文字工具时发生文本引擎错误 | Windows 8
    13. 适合亚洲脚本的全球通用书写器
    14. 如何在 Photoshop 中添加和编辑文本
  18. 视频和动画
    1. Photoshop 中的视频编辑
    2. 编辑视频和动画图层
    3. 视频和动画概述
    4. 预览视频和动画
    5. 在视频图层中绘制帧
    6. 导入视频文件和图像序列
    7. 创建帧动画
    8. Creative Cloud 3D 动画(预览)
    9. 创建时间轴动画
    10. 创建视频图像
  19. 滤镜和效果
    1. 使用液化滤镜
    2. 使用模糊画廊
    3. 滤镜基础知识
    4. 滤镜效果参考
    5. 添加光照效果
    6. 使用自适应广角滤镜
    7. 使用油画滤镜
    8. 图层效果和样式
    9. 应用特定的滤镜
    10. 涂抹图像区域
  20. 存储和导出
    1. 在 Photoshop 中存储文件
    2. 在 Photoshop 中导出文件
    3. 支持的文件格式
    4. 以图形格式存储文件
    5. 在 Photoshop 和 Illustrator 之间移动设计
    6. 存储和导出视频和动画
    7. 存储 PDF 文件
    8. Digimarc 版权保护
  21. 打印
    1. 打印 3D 对象
    2. 从 Photoshop 打印
    3. 使用色彩管理进行打印
    4. 联系表和 PDF 演示文稿
    5. 以图片包版面的形式打印照片
    6. 打印专色
    7. 双色调
    8. 将图像打印到商业印刷机
    9. 改进 Photoshop 中的色彩打印
    10. 解决打印问题 | Photoshop
  22. 自动化
    1. 创建动作
    2. 创建数据驱动图形
    3. 脚本
    4. 处理一批文件
    5. 播放和管理动作
    6. 添加条件动作
    7. 关于动作和“动作”以显示“动作”面板
    8. 记录动作中的工具
    9. 向动作添加条件模式更改
    10. Photoshop 中有关增效工具和脚本的 UI 工具包
  23. 色彩管理
    1. 了解色彩管理
    2. 保持颜色一致
    3. 颜色设置
    4. 使用颜色配置文件
    5. 对要联机查看的文档进行色彩管理
    6. 打印时对文档进行色彩管理
    7. 对导入的图像进行色彩管理
    8. 校样颜色
  24. 内容真实性
    1. 了解内容凭据
    2. NFT 的身份和来源
    3. 连接帐户进行创意归因
  25. 3D 和技术成像
    1. Photoshop 3D | 围绕即将中断的 3D 功能的常见问题
    2. Creative Cloud 3D 动画(预览)
    3. 打印 3D 对象
    4. 3D 绘画
    5. 3D 面板增强功能 | Photoshop
    6. 基本的 3D 概念和工具
    7. 3D 渲染和存储
    8. 创建 3D 对象和动画
    9. 图像堆栈
    10. 3D 工作流程
    11. 测量
    12. DICOM 文件
    13. Photoshop 和 MATLAB
    14. 对图像中的对象计数
    15. 合并和转换 3D 对象
    16. 3D 纹理编辑
    17. 调整 HDR 曝光度和色调
    18. 3D 面板设置

利用数据驱动图形,可以快速准确地生成图像的多个版本以用于印刷项目或 Web 项目。例如,以模板设计为基础,使用不同的文本和图像来制作 100 种不同的 Web 横幅。

请按照以下常规步骤操作,使用模板和数据组来创建图形:

创建用作模板的基本图形。

使用图层分离出要在图形中更改的图素。

在图形中定义变量。

变量指定在图像中更改的部分。(请参阅定义变量。)

创建或导入数据组。

可以在模板中创建数据组,也可以从文本文件中导入它们。(请参阅定义数据组在外部文件中创建数据组。)

使用每个数据组预览文档。

要查看最终图形的外观,可以先进行预览,然后再导出所有文件。(请参阅预览或应用数据组。)

将图形与数据一起导出来生成图形。

可以将图形导出为 Photoshop (PSD) 文件。(请参阅使用数据组生成图形。)

Photoshop 使用变量创建图像的不同版本
使用变量创建图像的不同版本

A. 源文件模板 B. 用户将图层定义为变量。 C. 可以创建图像的不同版本,每个版本都具有不同的变量数据组。 

定义变量

可以使用变量来定义模板中的哪些元素将发生变化。可以定义三种类型的变量。“可见性”变量显示或隐藏图层的内容。“像素替换”变量用其它图像文件中的像素来替换图层中的像素。“文本替换”变量替换文字图层中的文本字符串。

注意:

GoLive 可以识别所有的“文本”变量和“可见性”变量,但不能识别“像素替换”变量。

Photoshop 定义变量
基于同一模板的两个图像版本

A. “可见性”变量 B. “像素替换”变量 C. “文本替换”变量 

不能为“背景”图层定义变量。

  1. 选取“图像”>“变量”>“定义”。
  2. 从“图层”弹出式菜单中选择一个图层,它包含要定义为变量的内容。

  3. 选择一个或多个类型的变量:

    可见性

    显示或隐藏图层或图层组的内容。

    像素替换

    使用其它图像文件中的像素替换图层中的像素。

    文本替换

    替换文字图层中的文本字符串。

  4. 执行下列操作之一:
    • 选择“名称”,然后输入变量的名称。变量名必须以字母、下划线或冒号开头,并且不能包含空格或特殊字符(句点、连字符、下划线和冒号除外)。

    • 从“名称”弹出式菜单中,选取要将此图层链接到的现有变量。链接到同一变量的图层连同链接图标显示在“名称”菜单旁边。

  5. 对于“像素替换”变量,请设置下列选项。
    • 选择一种用于缩放替换图像的方法:“限制”选项缩放图像以将其限制在定界框内(这可能会使定界框的一部分是空的);“填充”选项缩放图像以使其完全填充定界框(这可能会导致图像超出定界框的范围);“保持原样”选项不缩放图像;“一致”选项以不成比例的方式缩放图像以将其限制在定界框内。

    • 单击对齐图标 上的手柄,可以选取在外框内放置图像的对齐方式。(该选项不适用于“一致”。)

    • 选择“剪切到外框”可以剪切未在外框内的图像区域。只有在选择了“填充”或“保持原样”替换方法时,此选项才可用。(该选项不适用于“一致”。)

  6. 要为其它图层定义变量,请从“图层”弹出式菜单中选取一个图层。包含变量的图层的名称旁边会显示星号。可以使用导航箭头在图层间移动。
  7. 单击“确定”。

重命名变量

  1. 选取“图像”>“变量”>“定义”。
  2. 从“图层”弹出式菜单中选取包含该变量的图层。
  3. 要重命名变量,请在“名称”文本框中输入名称。变量名必须以字母、下划线或冒号开头,并且不能包含空格或特殊字符(句点、连字符、下划线和冒号除外)。
  4. 要删除变量,请取消对它的选择。

定义数据组

数据组 是变量及其相关数据的集合。为要生成的每个图形版本定义一个数据组。

  1. 执行下列操作之一:
    • 选取“图像”>“变量”>“数据组”。

    • 如果“变量”对话框已打开,请从对话框顶部的弹出式菜单中选取“数据组”,或者单击“下一步”。

    注意:

    必须至少定义一个变量,才能编辑默认数据组。

  2. 单击“新建数据组”按钮
  3. 从“名称”弹出式菜单中或对话框底部的列表中选择一个变量。
  4. 编辑变量数据:
    • 对于可见性变量 ,选择“可见”可以显示图层的内容;选择“不可见”可以隐藏图层的内容。

    • 对于“像素替换”变量 ,单击“选择文件”并选择替换图像文件。如果在应用数据组前单击“不替换”,将使图层保持其当前状态。

    注意:

    如果此前已应用了一次替换,单击“不替换”不会将文件复位到其原始状态。

    • 对于“文本替换”变量 ,在“值”文本框中输入一个文本字符串。
  5. 为要生成的每个图形版本定义其它数据组。

可在以后对数据组执行编辑、重命名或删除操作,方法是:先从“数据组”弹出式菜单中选取数据组,然后对其选项进行编辑。使用箭头图标在数据组间移动。单击“删除”图标可以将数据组删除。

预览或应用数据组

您可以将数据组的内容应用于基本图像,同时将所有变量和数据组保持不变。这会将 PSD 文档的外观更改为包含数据组的值。还可以预览每个图形版本在使用各数据组时的外观。

注意:

应用数据组将覆盖原始文档。

  1. 选取“图像”>“应用数据组”。从列表中选择数据组,然后在文档窗口中预览图像。要应用数据组,请单击“应用”。如果是进行预览,而不想更改基本图像,请单击“取消”。

    也可以在“变量”对话框的“数据组”页中应用和预览数据组。

使用数据组生成图形

在定义变量及一个或多个数据组后,可按批处理模式使用数据组值输出图像。可以将图像输出为 PSD 文件。

  1. 选取“文件”>“导出”>“数据组作为文件”。
  2. 为生成的所有文件输入基本名称。如果需要,您可以创建自己的文件命名方案。
  3. 单击“选择文件夹”按钮,为文件选择一个目标目录。
  4. 选取要导出的数据组。
  5. 单击“确定”。

在外部文件中创建数据组

通过创建包含所有变量信息的外部文本文件并将该文件载入到包含变量的 PSD 文档中,可以快速创建大量的数据组。有一种方法是在文本文件或 Microsoft Excel 电子表格中输入数据,然后将其导出到一个制表符分隔文件或逗号分隔文件。

外部文本文件的语法如下(其中以“Variable”或“Value”开头的每行本身在文件中都是完整的一行):

VariableName1<sep>VariableName2<sep> <sep>VariableNameN <nl> 
Value1-1<sep>Value2-1<sep><sep>ValueN-1<nl> 
Value1-2<sep>Value2-2<sep><sep>ValueN-2<nl> 
Value1-M<sep>Value2-M<sep><sep>ValueN-M<nl>

所有变量名称都列在第一行中,其顺序为变量值在后续行中的出现顺序。每个后续行都表示一个数据组,并给出每个变量的值。

注意:

要在数据组的单个文本行中创建多个文本行,请在制表符分隔或逗号分隔文件中用双引号将文本括起来,然后在需要换行的位置插入硬回车。 

外部文本文件语法元素

<sep>

分隔各个变量名或变量值的逗号分隔 (CSV) 文件或制表符(制表符分隔)文件。

<nl>

结束每个数据组的换行符,它可以是换行符、回车符或两者。

“true”和“false”

可见性变量的允许值。

空格

在解析文件时删除分隔符前后的空格;保留值字符串中单词之间的空格(例如,two of a kind),并保留括在双引号中的前导空格和尾随空格(例如,"one kind ")。

双引号

如果一个双引号前面有另一双引号,则前者可能是值的一部分(例如,""B"" 在数据组中是 "B")。

如果 <sep> 或 <nl> 是变量值的一部分,则必须用双引号将整个值括起来。

在 PSD 文档中定义的所有变量都必须在文本文件中进行定义。如果文本文件中的变量数与文档中的变量数不匹配,将显示一个错误。

数据组示例:

通过使用容纳 tulip(郁金香)和 sunflower(向日葵)的变量的花卉模板,可以建立类似如下的文本文件:

{contents of FlowerShow.txt} 
Variable 1, Variable 2, Variable 3 
true, TULIP, c:\My Documents\tulip.jpg 
false, SUNFLOWER, c:\My Documents\sunflower.jpg 
false, CALLA LILY, c:\My Documents\calla.jpg 
true, VIOLET, c:\My Documents\violet.jpg
注意:

如果文本文件与图像文件在同一文件夹中,则可以使用相对路径来表示图像位置。例如,示例中的最后一项可以是:true、VIOLET、violet.jpg。

导入数据组

  1. 执行下列操作之一:
    • 选取“文件”>“导入”>“变量数据组”。

    • 选取“图像”>“变量”>“数据组”,然后单击“导入”按钮。

  2. 通过浏览找到要导入的文本文件。
  3. 设置导入选项。

    将第一列用作数据组名称

    使用文本文件第一列的内容(列出的第一个变量的值)命名每个数据组。否则,将数据组命名为“数据组 1、数据组 2,等等”。

    替换现有的数据组

    导入前删除所有现有的数据组。

  4. 设置文本文件的编码或保留设置“自动”。
  5. 单击“确定”。
Adobe 徽标

登录到您的帐户