载入滤镜的图像和纹理

为了生成滤镜效果,有些滤镜会载入和使用其它图像,如纹理和置换图。这些滤镜包括“炭精笔”、“置换”、“玻璃”、“光照效果”、“粗糙蜡笔”、“纹理化”、“底纹效果”和“自定”滤镜。这些滤镜并非都以相同的方式载入图像或纹理。

  1. 从相应的子菜单中选取想要的滤镜。
  2. 在“滤镜”对话框中,从“纹理”弹出式菜单中选取“载入纹理”,找到并打开纹理图像。

    所有纹理必须是 Photoshop 格式。大多数滤镜只使用颜色文件的灰度信息。

设置纹理与玻璃表面控制

“粗糙蜡笔”、“底纹效果”、“玻璃”、“炭精笔”和“纹理化”滤镜都包含纹理化选项。这些选项使图像看起来像是画在纹理(如画布和砖块)上,或是像透过表面(如玻璃块或磨砂玻璃)看到的。

  1. 从“滤镜”菜单中,选取“艺术效果”>“粗糙蜡笔”、“艺术效果”>“底纹效果”、“扭曲”>“玻璃”、“素描”>“炭精笔”或“纹理”>“纹理化”。
  2. 对于“纹理”,选取一种纹理类型,或选取“载入纹理”指定一个 Photoshop 文件。
  3. 拖动“缩放”滑块以增大或减小纹理图案的大小。
  4. 拖动“凸现”滑块(如果可用)以调整纹理表面的深度。
  5. 选择“反相”以反转纹理中的阴影和高光。
  6. 对于“光照方向”(如果可用),指示光源照射纹理的方向。

定义未扭曲的区域

“扭曲”子菜单中的“置换”、“切变”和“波浪”滤镜以及“其它”子菜单中的“位移”滤镜使您可以用下列方式处理滤镜未定义(未保护)的区域:

折回

用图像另一边的内容填充未定义的空间。

重复边缘像素

按指定的方向沿图像边缘扩展像素的颜色。如果边缘像素颜色不同,则可能产生条纹。

设置为背景(仅限位移滤镜)

用当前背景色填充所选区域。

应用蒙尘与划痕滤镜

  1. 选取“滤镜”>“杂色”>“蒙尘与划痕”。
  2. 如果需要,可以调整预览缩放比例,直到包含杂色的区域可见。
  3. 将“阈值”滑块向左拖动到 0 以关闭此值,这样就可以检查选区或图像中的所有像素了。

    “阈值”确定像素具有多大差异后才应将其消除。

    注意:

    “阈值”滑块对 0 到 128 之间的值(图像的常用范围)可以提供比 128 到 255 之间的值更好的控制。

  4. 向左或向右拖动“半径”滑块,或在文本框中输入 1 到 16 的像素值。“半径”值确定在其中搜索不同像素的区域大小。

    增加半径将使图像模糊。使用消除瑕疵的最小值。

  5. 通过输入值来逐渐增大阈值,或通过将滑块拖动到消除瑕疵的可能的最高值来逐渐增大阈值。

应用置换滤镜

“置换”滤镜使用置换图中的颜色值改变选区。0 是最大的负向改变值,255 是最大的正向改变值,灰度值 128 不产生置换。如果置换图有一个通道,则图像沿着由水平比例和垂直比例所定义的对角线改变。如果置换图有多个通道,则第一个通道控制水平置换,第二个通道控制垂直置换。

此滤镜使用以 Adobe Photoshop 格式存储的拼合文件创建置换图。(位图模式的图像不受支持。)

  1. 选取“滤镜”>“扭曲”>“置换”。
  2. 输入置换幅度的比例。

    当水平比例和垂直比例都设置为 100% 时,最多置换 128 个像素(因为中间的灰色不生成置换)。

  3. 如果置换图的大小与选区的大小不同,则指定置换图适合图像的方式:选择“伸展以适合”调整置换图的大小;或者选择“拼贴”,通过在图案中重复使用置换图来填充选区。
  4. 选取“折回”或“重复边缘像素”,确定处理图像中未扭曲区域的方法。
  5. 单击“确定”。
  6. 选择并打开置换图。对图像应用扭曲效果。

应用彩色半调滤镜

  1. 选取“滤镜”>“像素化”>“彩色半调”。
  2. 为半调网点的最大半径输入一个以像素为单位的值,范围为 4 到 127。
  3. 为一个或多个通道输入网角值(网点与实际水平线的夹角):
    • 对于灰度图像,只使用通道 1。

    • 对于 RGB 图像,使用通道 1、2 和 3,分别对应于红色、绿色和蓝色通道。

    • 对于 CMYK 图像,使用所有四个通道,对应于青色、洋红、黄色和黑色通道。

    • 单击“默认”,将所有网角恢复默认值。

  4. 单击“确定”。

应用凸出滤镜

  1. 选取“滤镜”>“风格化”>“凸出”。
  2. 选取一种 3D 类型:
    • “块”创建具有一个方形的正面和四个侧面的对象。要用该块的平均颜色填充每个块的正面,请选择“立方体正面”。要用图像填充正面,请取消选择“立方体正面”。

    • “金字塔”创建具有相交于一点的四个三角形侧面的对象。

  3. 在“大小”文本框中输入 2 到 255 之间的像素值,以确定对象基底任一边的长度。
  4. 在“深度”文本框中输入 1 到 255 之间的值以表示最高的对象从挂网上凸起的高度。
  5. 选取深度选项:
    • “随机”为每个块或金字塔设置一个任意的深度。

    • “基于色阶”使每个对象的深度与其亮度对应:越亮凸出得越多。

  6. 选择“蒙版不完整块”可以隐藏所有延伸出选区的对象。

应用等高线滤镜

  1. 选取“滤镜”>“风格化”>“等高线”。
  2. 选取一个“边缘”选项以勾勒选区中的区域:“较低”勾勒像素的颜色值低于指定色阶的区域;“较高”勾勒像素的颜色值高于指定色阶的区域。
  3. 输入一个介于 0 和 255 之间的阈值(级别)以便计算颜色值(色调级别)。反复试验,找出能够在图像中获得最佳细节的数值。

    在灰度模式下,可以使用“信息”面板来标识想要描画的颜色值。然后在“色阶”文本框中输入此值。

创建自定滤镜

  1. 选取“滤镜”>“其它”>“自定”。“自定”对话框显示由文本框组成的网格,您可以在这些文本框中输入数值。
  2. 选择正中间的文本框,它代表要进行计算的像素。输入要与该像素的亮度值相乘的值,值范围是 -999 到 +999。
  3. 选择代表相邻像素的文本框。输入要与该位置的像素相乘的值。

    例如,要将紧邻当前像素右侧的像素亮度值乘 2,可在紧邻中间文本框右侧的文本框中输入 2。

  4. 对所有要进行计算的像素重复步骤 2 和 3。不必在所有文本框中都输入值。
  5. 对于“缩放”,输入一个值,用该值去除计算中包含的像素的亮度值的总和。
  6. 对于“位移”,输入要与缩放计算结果相加的值。
  7. 单击“确定”。自定滤镜随即逐个应用到图像中的每一个像素。

    使用“存储”和“载入”按钮存储和重新使用自定滤镜。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略