关于通道

通道是存储不同类型信息的灰度图像:

  • 颜色信息通道 是在打开新图像时自动创建的。图像的颜色模式决定了所创建的颜色通道的数目。例如,RGB 图像的每种颜色(红色、绿色和蓝色)都有一个通道,并且还有一个用于编辑图像的复合通道。

  • Alpha 通道 将选区存储为灰度图像。可以添加 Alpha 通道来创建和存储蒙版,这些蒙版用于处理或保护图像的某些部分(请参阅关于蒙版和 Alpha 通道)。

  • 专色通道 指定用于专色油墨印刷的附加印版(请参阅关于专色)。

    一个图像最多可有 56 个通道。所有的新通道都具有与原图像相同的尺寸和像素数目。

    通道所需的文件大小由通道中的像素信息决定。某些文件格式(包括 TIFF 和 Photoshop 格式)将压缩通道信息并且可以节约空间。当从弹出菜单中选择“文档大小”时,未压缩文件的大小(包括 Alpha 通道和图层)显示在窗口底部状态栏的最右边。

 

注意:

只要以支持图像颜色模式的格式存储文件,即会保留颜色通道。只有当以 Photoshop、PDF、TIFF、PSB、或 Raw 格式存储文件时,才会保留 Alpha 通道。DCS 2.0 格式只保留专色通道。以其它格式存储文件可能会导致通道信息丢失。

“通道”面板概述

“通道”面板列出图像中的所有通道,对于 RGB、CMYK 和 Lab 图像,将最先列出复合通道。通道内容的缩览图显示在通道名称的左侧;在编辑通道时会自动更新缩览图。

Photoshop 通道类型
通道类型

A. 颜色通道 B. 专色通道 C. Alpha 通道 

显示“通道”面板

  1. 选取“窗口”>“通道”。

调整通道缩览图的大小或隐藏通道缩览图

  1. 从“通道”面板菜单中选取“面板选项”。单击缩览图大小,或单击“无”关闭缩览图显示。

    查看缩览图是一种跟踪通道内容的简便方法;不过,关闭缩览图显示可以提高性能.

显示或隐藏通道

可以使用“通道”面板来查看文档窗口中的任何通道组合。例如,可以同时查看 Alpha 通道和复合通道,观察 Alpha 通道中的更改与整幅图像是怎样的关系。

  1. 单击通道旁边的眼睛列即可显示或隐藏该通道。(单击复合通道可以查看所有的默认颜色通道。只要所有的颜色通道可见,就会显示复合通道。)

    注意:

    要显示或隐藏多个通道,请在“通道”面板中的眼睛列中拖动。

用相应的颜色显示颜色通道

各个通道以灰度显示。在 RGB、CMYK 或 Lab 图像中,您可以看到用原色显示的各个通道。(在 Lab 图像中,只有 ab 通道是用原色显示。) 如果有多个通道处于现用状态,则这些通道始终用原色显示。

可以更改默认设置,以便用原色显示各个颜色通道。当通道在图像中可见时,在面板中该通道的左侧将出现一个眼睛图标

  1. 执行下列操作之一:
    • 在 Windows 中,选择“编辑”>“首选项”>“界面”。

    • 在 Mac OS 中,选择“Photoshop”>“首选项”>“界面”。

  2. 选择“用原色显示通道”,然后单击“确定”。

选择和编辑通道

可以在“通道”面板中选择一个或多个通道。将突出显示所有选中或现用的通道的名称。

Photoshop 选择多个通道
选择多个通道

A. 不可见或不可编辑的 B. 可见但未选定以进行编辑 C. 已选定以进行查看和编辑 D. 可以选择进行编辑,但不能进行查看 
  • 要选择一个通道,请单击通道名称。按住 Shift 键单击可选择(或取消选择)多个通道。
  • 要编辑某个通道,请选择该通道,然后使用绘画或编辑工具在图像中绘画。一次只能在一个通道上绘画。用白色绘画可以按 100% 的强度添加选中通道的颜色。用灰色值绘画可以按较低的强度添加通道的颜色。用黑色绘画可完全删除通道的颜色。

重新排列和重命名 Alpha 通道和专色通道

仅当图像处于“多通道”模式(“图像”>“模式”>“多通道”)时,才可以将 Alpha 通道或专色通道移到默认颜色通道的上面。要了解该模式的限制,请参阅多通道模式

  • 要更改 Alpha 通道或专色通道的顺序,请在“通道”面板中向上或向下拖动通道。当在您需要的位置上出现一条线条时,释放鼠标按钮。

注意:

专色按照在“通道”面板中显示的顺序从上到下压印。

  • 要重命名 Alpha 通道或专色通道,请在“通道”面板中双击该通道的名称,然后输入新名称。

有关更多信息,请参阅创建新的专色通道

删除通道

存储图像前,可能想删除不再需要的专色通道或 Alpha 通道。复杂的 Alpha 通道将极大增加图像所需的磁盘空间。

  1. 在 Photoshop 中,在“通道”面板中选择该通道,然后执行下列操作之一:
    • 按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击“删除”图标

    • 将面板中的通道名称拖动到“删除”图标。

    • 从“通道”面板菜单中选取“删除通道”。

    • 单击面板底部的“删除”图标,然后单击“是”。

    注意:

    在从带有图层的文件中删除颜色通道时,将拼合可见图层并丢弃隐藏图层。之所以这样做,是因为删除颜色通道会将图像转换为多通道模式,而该模式不支持图层。当您删除 Alpha 通道、专色通道或快速蒙版时,不对图像进行拼合。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略