对图层和组进行管理可以确保项目组织有序。您可以对图层和颜色代码进行重命名,以便轻松地找到类似的图层并根据需要删除和导出图层。

重命名图层或图层组

将图层或图层组添加到图像时,为图层指定反映其内容的名称会很有帮助。使用说明性的名称会让图层在图层面板中更易于识别。

  1. 执行下列操作之一:
    • 图层面板中,双击图层名称或组名称,然后输入新名称。按 Enter (Windows) 或 Return (Mac OS)。
    • 选择图层/组,然后按照以下步骤执行操作:
      • 选取“图层”>“重命名图层”“图层”>“重命名组”
      • 图层面板中为图层/组输入新名称。
      • 按 Enter (Windows) 或 Return (Mac OS)。

为图层或组指定颜色

通过使用颜色对图层和组进行标记,可帮助您在“图层”面板中找到相关图层。只需右键单击图层或组并选择颜色即可。

栅格化图层

在包含矢量数据(如文字图层、形状图层、矢量蒙版或智能对象)和生成的数据(如填充图层)的图层上,您不能使用绘画工具或滤镜。但是,您可以栅格化这些图层,将其内容转换为平面的光栅图像。

  1. 选择要栅格化的图层,并选取“图层”>“栅格化”,然后从子菜单中选取一个选项:

    文字

    栅格化文字图层上的文字。该操作不会栅格化图层上的任何其他矢量数据。

    形状

    栅格化形状图层。

    填充内容

    栅格化形状图层的填充,同时保留矢量蒙版。

    矢量蒙版

    栅格化图层中的矢量蒙版,同时将其转换为图层蒙版。

    智能对象

    将智能对象转换为栅格图层。

    视频

    将当前视频帧栅格化为图像图层。

    3D(仅限 Extended)

    将 3D 数据的当前视图栅格化成平面栅格图层。

    图层

    栅格化选定图层上的所有矢量数据。

    所有图层

    栅格化包含矢量数据和生成的数据的所有图层。

    注意:

    要栅格化链接图层,请选择一个链接图层,然后选取“图层”>“选择链接图层”,然后栅格化选定的图层。

删除图层或组

删除不再需要的图层可以减小图像文件的大小。

注意:

要快速删除空图层,请选择“文件”>“脚本”>“删除所有空图层”。

  1. 从“图层”面板中选择一个或多个图层或组。
  2. 执行下列操作之一:
    • 要进行删除并看到确认消息,请单击“删除”图标 。还可以选取“图层”>“删除”>“图层”,或从“图层”面板菜单中选择“删除图层”或“删除组”。
    • 要删除图层或组而不进行确认,请将其拖动到“删除”图标 中,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 的同时单击“删除”图标,或按 Delete 键。
    • 要删除隐藏的图层,请选取“图层”>“删除”>“隐藏图层”。

    注意:

    要删除链接图层,请选择一个链接图层,然后选取“图层”>“选择链接图层”,然后删除图层。

导出图层

您可以将所有图层或可见图层导出到单独的文件。

  1. 选取“文件”>“脚本”>“将图层导出到文件”。

合并图层

最终确定了图层的内容后,您可以合并图层以缩小图像文件的大小。在合并图层时,顶部图层上的数据替换它所覆盖的底部图层上的任何数据。在合并后的图层中,所有透明区域的交迭部分都会保持透明。

注意:

不能将调整图层或填充图层用作合并的目标图层。

除了合并图层外,您还可以盖印图层。盖印可以将多个图层的内容合并为一个目标图层,同时使其它图层保持完好。

注意:

存储合并的文档后,将无法恢复到未合并时的状态;图层的合并是永久行为。

合并两个图层或组

  1. 确保想要合并的图层和组处于可见状态。
  2. 选择想要合并的图层和组。
  3. 选取“图层”>“合并图层”。

注意:

通过选择顶层项目,然后选取“图层”>“合并图层”可以合并两个相邻的图层或组。通过选取“图层”>“选择链接图层”,然后合并选定的图层可以合并链接的图层。可以通过选择“图层” > “合并图层”来合并两个 3D 图层;它们将共享同一个场景,并且顶部图层将继承底部图层的 3D 属性(相机视图必须相同才能实现)。

在剪贴蒙版中合并图层

  1. 隐藏任何不想合并的图层。
  2. 选择剪贴蒙版中的基底图层。基底图层必须是一个栅格图层。
  3. 从“图层”菜单或“图层”面板菜单中选取“合并剪贴蒙版”。

有关剪贴蒙版的更多信息,请参阅使用剪贴蒙版遮盖图层

合并图像中的所有可见图层和组

  1. 从“图层”面板或“图层”面板菜单中选取“合并可见图层”。将合并所有显示眼睛图标 的图层。

    注意:

    必须选定可见图层才启用“合并可见图层”命令。

盖印多个图层或链接图层

当您盖印多个选定图层或链接的图层时,Photoshop 将创建一个包含合并内容的新图层。

  1. 选择多个图层。
  2. 按 Ctrl+Alt+E 组合键 (Windows) 或 Command+Option+E 组合键 (Mac OS)。

要盖印所有可见图层,请执行以下操作:

  1. 打开要合并的图层的可见性。
  2. 按 Shift+Ctrl+Alt+E 组合键 (Windows) 或 Shift+Command+Option+E 组合键 (Mac OS)。

    Photoshop 将创建包含合并内容的新图层。

拼合所有图层

拼合操作可以缩小文件大小,方法是将所有可见图层合并到背景中并扔掉隐藏的图层。将使用白色填充其余的任何透明区域。在存储拼合的图像后,将不能恢复到未拼合时的状态;图层的合并是永久行为。

注意:

在某些颜色模式间转换图像将拼合文件。如果要在转换后编辑原始图像,请存储一份所有图层都保持不变的文件。

  1. 一定要确保所有要保留的图层都处于可视状态。
  2. 选取“图层”>“拼合图像”,或从“图层”面板菜单中选取“拼合图像”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略