路径段、组件和点

路径由一个或多个直线段或曲线段组成。锚点标记路径段的端点。在曲线段上,每个选中的锚点显示一条或两条方向线,方向线以方向点结束。方向线和方向点的位置决定曲线段的大小和形状。移动这些图素将改变路径中曲线的形状。

Photoshop 路径段
路径

A. 曲线段 B. 方向点 C. 方向线 D. 选中的锚点 E. 未选中的锚点 

路径可以是闭合的,没有起点或终点(例如,圆圈);也可以是开放的,有明显的端点(例如,波浪线)。

平滑曲线由称为平滑点的锚点连接。 锐化曲线路径由角点连接。

Photoshop 平滑点和角点
平滑点和角点

当在平滑点上移动方向线时,将同时调整平滑点两侧的曲线段。相比之下,当在角点上移动方向线时,只调整与方向线同侧的曲线段。

Photoshop 调整平滑点和角点
调整平滑点和角点

路径不必是由一系列段连接起来的一个整体。它可以包含多个彼此完全不同而且相互独立的路径组件。形状图层中的每个形状都是一个路径组件,如图层的剪贴路径所示。

Photoshop 选择单独的路径组件
选中的不同路径组件

选择路径

选择路径组件或路径段将显示选中部分的所有锚点,包括全部的方向线和方向点(如果选中的是曲线段)。方向手柄显示为实心圆,选中的锚点显示为实心方形,而未选中的锚点显示为空心方形。

  1. 执行下列操作之一:
    • 要选择路径组件(包括形状图层中的形状),请选择路径选择工具 ,并单击路径组件中的任何位置。如果路径由几个路径组件组成,则只有指针所指的路径组件被选中。

    • 要选择路径段,请选择“直接选择”工具 ,并单击段上的某个锚点,或在该段的一部分上方拖动选框。

    Photoshop 直接选择工具
    拖动选框以选择段。

  2. 要选择其它的路径组件或段,请选择路径选择工具或直接选择工具,然后按住 Shift 键并选择其它的路径或段。

    注意:

    当选中直接选择工具时,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并在路径内单击可以选择整条路径或路径组件。要在选中大多数其它工具的情况下启动直接选择工具,请将指针定位在锚点上,并按 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

选择多个路径 | Photoshop CC

您可以在同一图层或跨不同图层选择多个路径。

  1. 路径面板中,执行以下任何操作以使路径可见:

    • 按住 Shift 键并单击可选择多个连续路径。
    • 按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并单击以选择非连续路径.
  2. 选择路径选择工具或直接选择工具,并执行以下任一操作:

    • 在路径段上拖动。
    • 按住 Shift 键并单击路径。
  3. 要选择其它的路径组件或段,请选择路径选择工具或直接选择工具,然后按住 Shift 键并选择其它的路径或段。

    注意:

    您可以选择在隔离模式中处理路径。若要只隔离包含路径的图层,并使路径处于活动状态,请使用选择工具执行双击操作。您还可以使用选择/隔离图层菜单项或将图层过滤设置为选定,来隔离一个或多个图层。

    您可以通过数种方法退出隔离模式,如:

    • 关闭图层过滤
    • 图层过滤转换为选定以外的设置。
    • 使用路径选择工具双击偏离路径的地方 

重新排序路径

您可以在路径面板中对不属于“形状”、“类型”或“矢量蒙版”路径的已存储路径进行重新排序。

  1. 路径面板中,将路径拖到所需要的位置。在 Photoshop CC 中,您可以同时选择并拖动多个路径。

复制路径

  1. 路径面板中,选择要复制的路径。在 Photoshop CC 中,您可以选择多个路径。

  2. 请执行下列任一操作:

    • 按住 Alt 键 (Windows) 或 Option 键并拖动路径。
    • 从面板菜单中选择复制路径

指定路径选项

您可以定义路径线的颜色和粗细,使其更符合自己的审美且更加清晰可见。在创建路径时(例如使用钢笔工具),请单击选项栏中的齿轮图标 ()。现在指定路径线的颜色和粗细。另外,指定在点击之间移动指针时(橡皮带效果)是否需要预览路径段。

path-options
路径选项:粗细和颜色

调整路径段

您可以随时编辑路径段,但是编辑现有路径段与绘制路径段之间存在些许差异。请在编辑路径段时记住以下提示:

  • 如果锚点连接两条线段,移动该锚点将同时更改两条线段。

  • 当使用钢笔工具绘图时,可以临时启用“直接选择”工具,以便您能够调整已绘制的线段;在绘图时,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

  • 当您最初使用钢笔工具绘制平滑点时,拖动方向点将更改平滑点两侧方向线的长度。但当您使用直接选择工具编辑现有平滑点时,将只更改所拖动一侧的方向线的长度。

移动直线段

  1. 使用直接选择工具 ,选择要调整的线段。
  2. 将段拖动到它的新位置。

调整直线段的长度或角度

  1. 使用直接选择工具 ,在要调整的线段上选择一个锚点。

  2. 将锚点拖动到所需的位置。按住 Shift 键拖动可将调整限制为 45 度的倍数。

调整曲线段的位置或形状

  1. 使用“直接选择”工具 ,选择一条曲线段或该曲线段两端上的一个锚点。如果存在任何方向线,则将显示这些方向线。(某些曲线段只使用一条方向线。)
  2. 请执行下列任一操作:
    • 要调整段的位置,请拖移此段。按住 Shift 键拖动可将调整限制为 45 度的倍数。

    Photoshop 单击以选择此曲线段
    点按以选择此曲线段。然后通过拖移对其进行调整。

    • 要调整所选锚点任意一侧线段的形状,拖移此锚点或方向点。按住 Shift 键拖动可将移动约束到 45 度的倍数。

    Photoshop 拖动锚点,或拖动方向点
    拖动锚点,或拖动方向点。

    注意:

    调整路径段也调整相关段,让您可以直观地变换路径形状。要仅仅编辑类似于早期 Photoshop 版本的选中的锚点之间的段,请选择“约束硬扯入选项栏的路径”。

    注意:

    也可以对段或锚点应用某种变换,如缩放或旋转。

删除段

  1. (可选)如果要在某个闭合路径中创建一个开口,请选择“添加锚点”工具 ,然后在要剪切的位置添加两个点。
  2. 选择直接选择工具 ,然后选择要删除的线段。
  3. 按 Backspace 键 (Windows) 或 Delete 键 (Mac OS) 删除所选段。再次按 Backspace 键或 Delete 键可抹除路径的其余部分。

删除锚点的方向线

扩展开放路径

  1. 使用钢笔工具将指针定位到要扩展的开放路径的端点上。当将指针准确地定位到端点上方时,指针将发生变化。
  2. 单击此端点。
  3. 执行下列操作之一:
    • 要创建角点,将钢笔工具定位到所需的新段终点,然后单击。如果要扩展一个以平滑点为终点的路径,则新段将被现有方向线创建为曲线。

    • 要创建平滑点,将钢笔工具定位到所需的新曲线段的终点,然后拖动。

连接两条开放路径

  1. 使用钢笔工具将指针定位到要连接到另一条路径的开放路径的端点上。当将指针准确地定位到端点上方时,指针将发生变化。
  2. 单击此端点。
  3. 执行下列操作之一:
    • 要将此路径连接到另一条开放路径,请单击另一条路径上的端点。如果将钢笔工具精确地放在另一个路径的端点上,指针旁边将出现小合并符号

    • 若要将新路径连接到现有路径,可在现有路径旁绘制新路径,然后将钢笔工具移动到现有路径(未所选)的端点。当看到指针旁边出现小合并符号时,单击该端点。

使用键盘移动或轻移锚点或段

  1. 选择锚点或路径段。
  2. 单击或按下键盘上的任一方向键,可向箭头方向一次移动 1 个像素。

在按下方向键的同时按住 Shift 键可一次移动 10 个像素。

添加或删除锚点

添加锚点可以增强对路径的控制,也可以扩展开放路径。但是尽量不要添加不必要的点。点数较少的路径更易于编辑、显示和打印。可以通过删除不必要的点来降低路径的复杂性。

工具箱包含用于添加或删除点的三种工具:钢笔工具 、添加锚点工具 和删除锚点工具

默认情况下,当您将钢笔工具定位到所选路径上方时,它会变成添加锚点工具;当您将钢笔工具定位到锚点上方时,它会变成删除锚点工具。必须在选项栏中选择“自动添加/删除”选项,“钢笔”工具才能自动变为“添加锚点”工具或“删除锚点”工具。

您可以同时选择和编辑多通路。 添加锚点时,通过单击并拖动操作还可以在添加锚点的同时调整路径形状。

注意:

不要使用 Delete 或 Backspace 键,或“编辑”>“剪切”、“编辑”>“清除”命令来删除锚点。这些键和命令会删除连接该点的点和线段。

添加或删除锚点

  1. 选择要修改的路径。
  2. 选择钢笔工具、添加锚点工具或删除锚点工具。
  3. 若要添加锚点,请将指针定位到路径段的上方,然后单击。若要删除锚点,请将指针定位到锚点上,然后单击。

停用或临时忽略自动钢笔工具切换

可以忽略钢笔工具的自动切换(切换到添加锚点工具或删除锚点工具)。当希望在现有路径顶部开始新路径时这样很有用。

  • 在 Photoshop 中,在选项栏中取消选择“自动添加/删除”。

在平滑点和角点之间进行转换

  1. 选择要修改的路径。
  2. 选择转换点工具,或使用钢笔工具并按住 Alt 键 (Windows) 或 Option 键 (Mac OS)。

    注意:

    要在已选中直接选择工具的情况下启动转换锚点工具,请将指针放在锚点上,然后按 Ctrl+Alt 组合键 (Windows) 或 Command+Option 组合键 (Mac OS)。

  3. 将转换点工具放置在要转换的锚点上方,然后执行以下操作之一:
    • 要将角点转换成平滑点,请向角点外拖动,使方向线出现。

    Photoshop 在平滑点和角点之间进行转换
    将方向点拖动出角点以创建平滑点

    • 如果要将平滑点转换成没有方向线的角点,请单击平滑点。

    Photoshop 单击平滑点以创建角点
    单击平滑点以创建角点

    • 要将没有方向线的角点转换为具有独立方向线的角点,请首先将方向点拖动出角点(成为具有方向线的平滑点)。仅松开鼠标按钮(不要松开激活转换锚点工具时按下的任何键),然后拖动任一方向点。

    • 如果要将平滑点转换成具有独立方向线的角点,请拖动任一方向点。

    Photoshop 将平滑点转换为角点
    将平滑点转换为角点

调整路径组件

可以将路径组件(包括形状图层中的形状)重新放在图像中的任意位置。可以在一幅图像中或两个 Photoshop 图像之间拷贝组件。通过使用路径选择工具,可以将重叠组件合并为单个组件。所有的矢量对象,无论是用存储的路径、工作路径还是矢量蒙版描述的,都可以移动、整形、拷贝或删除。

也可以使用“拷贝”和“粘贴”命令在 Photoshop 图像和其它应用程序(如 Adobe Illustrator)的图像之间拷贝矢量对象。

更改所选路径组件的重叠模式

  1. 使用路径选择工具 ,拖动选框以选择现有路径区域。
  2. 从选项栏的“路径操作”下拉菜单中选择形状区域选项:

    合并形状

    将路径区域添加到重叠路径区域。

    从形状区域减去

    将路径区域从重叠路径区域中移去。

    交叉形状区域

    将区域限制为所选路径区域和重叠路径区域的交叉区域。

    排除重叠形状区域

    排除重叠区域。

显示或隐藏所选路径组件

执行下列操作之一:

  • 选取“视图”>“显示”>“目标路径”。
  • 选择“视图”>“显示额外内容”。该命令也显示或隐藏网格、参考线、选区边缘、批注和切片。

移动路径或路径组件

  1. 在“路径”面板中选择路径名,并使用路径选择工具 在图像中选择路径。要选择多个路径组件,请按住 Shift 键并单击每个其它路径组件,将其添加到选区。
  2. 将路径拖动到新位置。如果将路径的一部分拖动出了画布边界,则路径的隐藏部分仍然是可用的。
    Photoshop 将路径拖动到新位置
    将路径拖动到新位置

    注意:

    如果您拖动路径,使移动指针位于另一幅打开的图像上,则会将该路径拷贝到此图像中。

对路径组件进行整形

  1. 在“路径”面板中选择路径名,并使用直接选择工具 选择路径中的锚点。
  2. 将该点或其手柄拖动到新位置。

合并重叠路径组件

  1. 在“路径”面板中选择路径名,并选择路径选择工具 
  2. 要使用所有的重叠组件创建单个组件,请从选项栏的“路径操作”下拉菜单中选择“合并形状组件”。

拷贝路径组件或路径

请执行下列任一操作:

  • 要在移动路径组件时拷贝它,请在“路径”面板中选择路径名,并使用路径选择工具 单击路径组件。然后按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并拖动所选路径。
  • 要拷贝路径但不重命名它,可将“路径”面板中的路径名拖动到面板底部的“新建路径”按钮
  • 要拷贝并重命名路径,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS),将“路径”面板中的路径拖动到面板底部的“新建路径”按钮。或选择要拷贝的路径,然后从“路径”面板菜单中选取“复制路径”。在“复制路径”对话框中输入路径的新名称,并单击“确定”。
  • 要将路径或路径组件拷贝到另一路径中,请选择要拷贝的路径或路径组件并选取“编辑”>“拷贝”。然后选择目标路径,并选取“编辑”>“粘贴”。

在两个 Photoshop 文件之间拷贝路径组件

  1. 将两个图像都打开。
  2. 在源图像中,使用路径选择工具 选择要拷贝的整条路径或路径组件。
  3. 要拷贝路径组件,请执行下列任一操作:
    • 将源图像中的路径组件拖动到目标图像。路径组件会被拷贝到“路径”面板的现用路径中。

    • 在源图像中,在“路径”面板中选择路径名,并选取“编辑”>“拷贝”以拷贝该路径。在目标图像中,选取“编辑”>“粘贴”。也可以使用该方法来组合同一图像中的路径。

    • 要将路径组件粘贴到目标图像,请在源图像中选择路径组件并选取“编辑”>“拷贝”。在目标图像中,选取“编辑”>“粘贴”。

删除路径组件

  1. 在“路径”面板中选择路径名,并用路径选择工具  单击路径组件。
  2. 按 Backspace 键 (Windows) 或 Delete 键 (Mac OS) 删除所选路径组件。

对齐和分布路径组件

您可以对齐和分布在单个路径中描述的路径组件。例如,可以使单个图层所包含的多个形状左对齐,或使工作路径中的多个组件水平居中分布。

注意:

要对齐不同图层上的形状,请使用移动工具。

  • 要对齐组件,请使用路径选择工具来选择您想对齐的组件。 然后从选项栏的“路径对齐”下拉菜单中选择一个选项。
Photoshop 对齐选项
对齐选项

  • 要分发组件,请选择您想分发的至少三个组件。 然后从选项栏的“路径排列”下拉菜单中选择一个选项。
Photoshop 分布选项
分布选项

视频教程:在 Photoshop 中处理矢量的相关提示

视频教程:在 Photoshop 中处理矢量的相关提示
在 The Complete Picture 这一集中,Julieanne 会展示她在 Photoshop 中处理矢量时最爱使用的五个功能。
Julieanne Kost

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略