关于高动态范围图像

可见世界中的动态范围(暗区和亮区之间的比例)远远超过了人类视觉可及的范围以及显示器上显示的图像或打印的图像的范围。尽管人眼可以适应差异很大的亮度级别,但大多数相机和计算机显示器只能还原固定的动态范围。摄影师、电影艺术家和其他使用数字图像的人必须对场景中的重要元素精挑细选,因为他们所能使用的动态范围很有限。

高动态范围 (HDR) 图像为我们呈现了一个充满无限可能的世界,因为它们能够表示现实世界的全部可视动态范围。由于可以在 HDR 图像中按比例表示和存储真实场景中的所有明亮度值,因此,调整 HDR 图像的曝光度的方式与在真实环境中拍摄场景时调整曝光度的方式类似。

Photoshop 合并图像
合并不同曝光度的图像来创建 HDR 图像

A. 具有阴影细节但剪切了高光的图像 B. 具有高光细节但剪切了阴影的图像 C. 包含场景动态范围的 HDR 图像 

在 Photoshop 中,使用 32 位长(32 位/通道)的浮点数字表示来存储 HDR 图像的明亮度值。HDR 图像中的明亮度值与场景中的光量有直接的关系。相比之下,非浮点型 16 位/通道和 8 位/通道的图像文件仅存储从黑色到纸张白的明亮度值,从而反映真实世界中极小段的动态范围。

在 Photoshop 中,“合并到 HDR Pro”命令可让您通过组合在不同的曝光度下拍摄的多张照片来创建 HDR 图像。由于 HDR 图像包含远远超出标准 24 位显示器显示范围的亮度级别,Photoshop 允许您调整 HDR 预览。如果您需要打印或使用不适用于 HDR 图像的工具和滤镜,则可以将这些图像转换为 16 位/通道或 8 位/通道的图像。

拍摄 HDR 图像的照片

拍摄要使用“合并到 HDR Pro”命令合并的照片时,请牢记下列几点:

  • 将相机固定在三角架上。

  • 拍摄足够多的照片以覆盖场景的整个动态范围。可以尝试拍摄至少五到七张照片,视场景的动态范围不同,可能需要进行更多次的曝光。最少应拍摄三张照片。

  • 改变快门速度以获得不同的曝光度。调整光圈会使每次曝光的景深发生变化,可能导致图像品质降低。调整 ISO 或光圈还可能导致图像中出现杂色或晕影。

  • 一般来说,不要使用相机的自动包围曝光功能,因为曝光度的变化通常非常小。

  • 照片的曝光度差异应在一两个 EV(曝光度值)级(相当于差一两级光圈左右)。

  • 不要改变光照条件;例如,在这次曝光时不使用闪光灯,而在下次曝光时却使用闪光灯。

  • 确保场景中没有移动的物体。曝光合并功能只能用于处理场景相同但曝光度不同的图像。

支持 32 位/通道 HDR 图像的功能

使用下列工具、调整和滤镜可以处理 32 位/通道的 HDR 图像。(要使用 Photoshop 的更多功能,可以将 32 位/通道的图像转换为 16 位/通道或 8 位/通道的图像。要保留原始图像,可以使用“存储为”命令创建一份副本。)

调整

色阶、曝光度、色相/饱和度、通道混合器、照片滤镜。

注意:

虽然可以使用“曝光度”命令来处理 8 位/通道和 16 位/通道的图像,但它是专为对 32 位/通道的 HDR 图像进行曝光度调整而设计的。

混合模式

正常、溶解、变暗、色彩增殖、变亮、深色、线性减淡(添加)、浅色、差异、减色、划分、色相、饱和度、颜色和明度。

创建新的 32 位/通道的文档

在“新建”对话框中,32 位是“颜色模式”弹出式菜单右侧的“位深度”弹出菜单中的一个选项。

编辑菜单命令

包括“填充”、“描边”、“自由变换”和“变换”命令在内的所有命令。

文件格式

Photoshop(PSD、PSB)、Radiance (HDR)、便携位图 (PBM)、OpenEXR 和 TIFF。

注意:

尽管 Photoshop 无法以 LogLuv TIFF 文件格式存储 HDR 图像,但可以打开和读取 LogLuv TIFF 文件。

滤镜

平均、方框模糊、高斯模糊、动感模糊、径向模糊、形状模糊、表面模糊、添加杂色、云彩、分层云彩、镜头光晕、智能锐化、USM 锐化、浮雕效果、逐行、NTSC 颜色、高反差保留、最大值、最小值以及位移。

图像命令

图像大小、画布大小、图像旋转、裁剪、裁切、复制、应用图像、计算和变量。

视图

像素长宽比(自定像素长宽比、删除像素长宽比、复位像素长宽比等。)

图层

新建图层、复制图层、调整图层(色阶、自然饱和度、色相/饱和度、通道混合器、照片滤镜和曝光度)、填充图层、图层蒙版、图层样式、支持的混合模式和智能对象。

模式

RGB 颜色、灰度、转换为 8 位/通道或 16 位/通道。

像素长宽比

支持方形和非方形文档。

选择

反相、修改边界、变换选区、存储选区和载入选区。

工具

除下列工具之外的工具箱中的所有工具:磁性套索、魔棒、污点修复画笔、修复画笔、红眼、颜色替换、历史记录艺术画笔、魔术橡皮擦、背景橡皮擦、油漆桶、减淡、加深和海绵。某些工具只能用于支持的混合模式。

将图像合并到 HDR

“合并到 HDR Pro”命令可以将同一场景的具有不同曝光度的多个图像合并起来,从而捕获单个 HDR 图像中的全部动态范围。您可以将合并后的图像输出为 32 位/通道、16 位/通道或 8 位/通道的文件。但是,只有 32 位/通道的文件可以存储全部 HDR 图像数据。

当照片已针对合并进行过优化时,HDR 合并运行效果最佳。有关建议,请参阅拍摄 HDR 图像的照片

  1. 执行下列操作之一:
    • (Photoshop) 选择“文件”>“自动”>“合并到 HDR Pro”。

    • (Bridge) 选择要使用的图像并选择“工具”>“Photoshop”>“合并到 HDR Pro”。跳到第 5 步。

  2. 在“合并到 HDR Pro”对话框中,单击“浏览”以选择特定图像,然后单击“添加打开的文件”或选择“使用”>“文件夹”。(要移去某个特定的项目,请在文件列表中将其选中,然后单击“移去”。)
  3. (可选)如果手持相机拍摄图像,请选择“尝试自动对齐源图像”。
  4. 单击“确定”。

    注意:

    如果图像缺少曝光度元数据,则在“手动设置曝光值”对话框中输入曝光值。

    这时会出现另一个“合并到 HDR Pro”对话框,显示源图像的缩览图以及合并结果的预览。

  5. 在预览的右上角,请为合并后的图像选择一个位深度。

    注意:

    如果希望合并后的图像存储 HDR 图像的全部动态范围,请选择 32 位。8 位和(非浮点型)16 位的图像文件不能存储 HDR 图像中所有范围的明亮度值。

  6. (可选)要存储色调设置供以后使用,请选择“预设”>“存储预设”。(如果以后要重新应用这些设置,可以选取“载入预设”。)

适用于 32 位图像的选项

移动直方图下方的滑块可以调整合并后图像的白场预览。移动滑块只会调整图像预览;所有 HDR 图像数据都会保留在合并后的文件中。

预览调整将存储在 HDR 文件中,并在您每次在 Photoshop 中打开该文件时应用。要随时重新调整白场预览,请选取“视图”>“32 位预览选项”。

注意:

在以下产品版本中,Camera Raw 滤镜不再处理 32 位文件:

  • Adobe Camera Raw 9.10
  • Photoshop CC 2017

如果您使用的是以上任一产品版本,请参阅 Camera Raw 滤镜不再处理 32 位文件以查看此问题的解决方法。

适用于 16 或 8 位图像的选项

HDR 图像包含的亮度级别远远超过了 16 或 8 位/通道图像所能存储的动态范围。要生成具有所需动态范围的图像,请在从 32 位/通道转换为较低位深度时调整图像的曝光度和对比度。

选择下列色调映射方法之一:

局部适应

通过调整图像中的局部亮度区域来调整 HDR 色调。

边缘光

半径指定局部亮度区域的大小。强度指定两个像素的色调值相差多大时,它们属于不同的亮度区域。

色调和细节

“灰度系数”设置为 1.0 时动态范围最大;较低的设置会加重中间调,而较高的设置会加重高光和阴影。曝光度值反映光圈大小。拖动“细节”滑块可以调整锐化程度,拖动“阴影”和“高光”滑块可以使这些区域变亮或变暗。

颜色

“自然饱和度”可调整细微颜色强度,同时尽量不剪切高度饱和的颜色。“饱和度”调整从 –100(单色)到 +100(双饱和度)的所有颜色的强度。

色调曲线

在直方图上显示一条可调整的曲线,从而显示原始的 32 位 HDR 图像中的明亮度值。横轴的红色刻度线以一个 EV(约为一级光圈)为增量。

注意:

默认情况下,“色调曲线和直方图”可以从点到点限制您所做的更改并进行色调均化。要移去该限制并应用更大的调整,请在曲线上插入点之后选择“边角”选项。在插入并移动第二个点时,曲线会变为尖角。

Photoshop 色调曲线和直方图调整
使用“边角”选项进行色调曲线和直方图调整

A. 插入点并选定“边角”选项。 B. 调整新插入的点时,曲线会在使用“边角”选项的点处显示尖角。 

色调均化直方图

在压缩 HDR 图像动态范围的同时,尝试保留一部分对比度。无需进一步调整;此方法会自动进行调整。

曝光度和灰度系数

允许手动调整 HDR 图像的亮度和对比度。移动“曝光度”滑块可以调整增益,移动“灰度系数”滑块可以调整对比度。

高光压缩

压缩 HDR 图像中的高光值,使其位于 8 位/通道或 16 位/通道的图像文件的亮度值范围内。无需进一步调整;此方法会自动进行调整。

补偿移动的对象

如果图像因为移动的对象(如汽车、人物或树叶)而具有不同的内容,请选择“合并到 HDR Pro”对话框中的“移去重影”。

Photoshop 会在具有最佳色调平衡的缩览图周围显示一个绿色轮廓,以标识基本图像。其他图像中找到的移动对象将被移去。(如果移动对象出现在非常亮或非常暗的区域,请单击移动对象的具有较好曝光效果的其他缩览图。这样通常可以改善质量。)

注意:

有关“移去重影”选项的教程,请观看该视频。(对“移去重影”的讨论从 3:00 开始。)

存储或载入相机响应曲线

响应曲线表示相机传感器解释不同级别的入射光的方式。默认情况下,“合并到 HDR Pro”对话框会根据要合并的图像的色调范围自动计算相机响应曲线。您可以存储当前响应曲线,并在以后将其应用于其他合并图像组。

  • 在“合并到 HDR Pro”对话框的右上角,单击响应曲线菜单 ,然后选择“存储响应曲线”。(如果以后要重新应用该曲线,请选择“载入响应曲线”。)

从 32 位/通道转换为 16 位/通道或 8 位/通道

如果您原先在“合并到 HDR Pro”过程中创建的是 32 位图像,则可以在以后将其转换为 16 位或 8 位图像。

  1. 在 Photoshop 中打开 32 位/通道的图像,然后选取“图像”>“模式”>“16 位/通道”或“8 位/通道”。
  2. 调整曝光度和对比度以生成具有所需动态范围的图像。(请参阅适用于 16 或 8 位图像的选项。)
  3. 单击“确定”以转换 32 位图像。

调整 32 位 HDR 图像显示的动态范围

HDR 图像的动态范围超出了标准计算机显示器的显示范围。在 Photoshop 中打开 HDR 图像时,图像可能会非常暗或出现褪色现象。Photoshop 提供了预览调整功能,以使显示器显示的 HDR 图像的高光和阴影不会太暗或出现褪色现象。预览设置存储在 HDR 图像文件(仅 PSD、PSB 和 TIFF)中,在 Photoshop 中打开该文件时,便会应用这些设置。预览调整不会编辑 HDR 图像文件;所有 HDR 图像信息都保持不变。使用曝光度调整(“图像”>“调整”>“曝光度”)以编辑 32 位/通道的 HDR 图像的曝光度。

注意:

要在“信息”面板中查看 32 位信息,请单击“信息”面板中的吸管工具图标,然后从弹出式菜单中选取“32 位”。

  1. 在 Photoshop 中,打开一个 32 位/通道的 HDR 图像,然后选择“视图”>“32 位预览选项”。
  2. 在“32 位预览选项”对话框中,从“方法”菜单中选取一个选项:

    曝光度和灰度系数

    调整亮度和对比度。

    高光压缩

    压缩 HDR 图像中的高光值,使其位于 8 位/通道或 16 位/通道的图像文件的亮度范围内。

  3. 如果选取“曝光度和灰度系数”,请移动“曝光度”和“灰度系数”滑块来调整图像预览的亮度和对比度。
  4. 单击“确定”。

    注意:

    还可以调整 Photoshop 中打开的 HDR 图像的预览效果,方法是:单击文档窗口状态栏中的三角形,然后从弹出式菜单中选取“32 位曝光”。可以移动滑块来设置用于查看 HDR 图像的白场。双击滑块以返回到默认的曝光度设置。由于调整是针对每个视图进行的,因此可以在多个窗口中打开同一 HDR 图像,对每个窗口进行不同的预览调整。使用此方法进行的预览调整不会存储到 HDR 图像文件中。

关于 HDR 拾色器

使用 HDR 拾色器可以准确查看和选择要在 32 位 HDR 图像中使用的颜色。如同使用常规 Adobe 拾色器一样,可通过单击色域并调整颜色滑块来选择颜色。使用“强度”滑块可以调整颜色的亮度以便与您所处理的 HDR 图像中的颜色强度匹配。“预览”区域可让您查看选定颜色的色板,以查看该颜色在不同的曝光度和强度下的显示情况。

Photoshop HDR 拾色器
HDR 拾色器

A. 预览区域 B. 调整后的颜色 C. 原稿颜色 D. 32 位浮点值 E. 强度滑块 F. 拾取的颜色 G. 颜色滑块 H. 颜色值 

显示 HDR 拾色器

在 32 位/通道的图像处于打开状态的情况下,执行下列操作之一:

  • 在工具箱中,单击前景色或背景色选择框。

  • 在“颜色”面板中,单击“设置前景色”或“设置背景色”选择框。

当某些功能可让您选取颜色时,也可使用拾色器。例如,通过单击一些工具的“选项”栏中的色板,或通过单击一些颜色调整对话框中的吸管工具。

选取用于 HDR 图像的颜色

HDR 拾色器下半部分的功能与常规拾色器处理 8 位/通道或 16 位/通道的图像时的功能类似。在色域中单击以选择一种颜色,并移动颜色滑块以改变色相,或使用 HSB 或 RGB 字段以输入特定颜色的数值。在色域中,从下往上移动将增加亮度;从左向右移动将增加饱和度。

使用“强度”滑块可调整颜色的亮度。在 HDR 文档中,颜色值和强度值将转换为 32 位浮点型数值。

  1. 与使用 Adobe 拾色器一样,通过单击色域并移动颜色滑块来选择颜色,或输入 HSB 或 RGB 数值来选择颜色。
  2. 调整“强度”滑块可以增加或减少颜色的亮度。拾色器顶部的预览栏中的新色板将显示增加或减少选定颜色的色标所产生的效果。

    强度色标与曝光度设置色标反向对应。如果将 HDR 图像的曝光度设置增加两个色标,则将强度减少两个色标可以保持相同的颜色外观,这就如同将 HDR 图像曝光度和颜色强度都设置为 0。

    如果您知道所需颜色的准确的 32 位 RGB 值,则可以在 32 位值 RGB 字段中直接输入这些值。

  3. (可选)调整“预览”区域的设置。

    预览色标大小

    设置每个预览色板的色标增量。例如,设置为 3 会得到 -9、-6、-3、+3、+6、+9 这六个色标。这些色板可让您按照不同的曝光度设置预览选定颜色的外观。

    相对于文档

    选择此选项可调整预览色板以反映图像的当前曝光度设置。例如,如果将文档曝光度设置得较高,新的预览色板将比在拾色器色域中选定的颜色亮一些,以显示较高曝光度对选定颜色产生的效果。如果将当前曝光度设置为 0(默认值),则选中或取消选中此选项都将不会改变新色板。

  4. (可选)单击“添加到色板”以将选定颜色添加到“色板”面板。
  5. 单击“确定”。

在 HDR 图像上绘画

可以使用下列任意 Photoshop 工具编辑 HDR(32 位/通道)图像并为其添加效果:画笔、铅笔、钢笔、形状、仿制图章、图案图章、橡皮擦、渐变、模糊、锐化、涂抹和历史记录画笔。也可以使用文本工具向 HDR 图像添加 32 位/通道的文本图层。

在 HDR 图像上进行编辑或绘画时,通过使用文档信息区域中的“32 位曝光”滑块或使用“32 位预览选项”对话框(“视图”>“32 位预览选项”),可以按照不同的曝光度设置预览您的工作。HDR 拾色器还可让您按照不同的强度设置预览选定的前景色,以匹配 HDR 图像中不同的曝光度设置。

  1. 打开 HDR 图像。
  2. (可选)设置图像的曝光度。请参阅调整 32 位 HDR 图像显示的动态范围
  3. 对于画笔工具或铅笔工具,单击前景色以打开 HDR 拾色器并选择一种颜色。对于文本工具,单击文本工具选项栏中的色卡以设置文本颜色。

    HDR 拾色器的“预览”区域可帮助您选择和调整与 HDR 图像中不同的曝光度设置相关的前景色。请参阅关于 HDR 拾色器

    注意:

    默认情况下,“色调曲线和直方图”可以从点到点限制您所做的更改并进行色调均化。要移去该限制并应用更大的调整,请在曲线上插入点之后选择“边角”选项。在插入并移动第二个点时,曲线会变为尖角。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略