Korjaa Generator-virhe Adobe Photoshopin käynnistyksessä

Päivitetty viimeksi 29. lokakuuta 2026

Lue, miten Generator-virhe korjataan Adobe Photoshopissa tarkistamalla turvallisuusasetukset, poistamalla ristiriitaiset liitännäiset ja tarkastelemalla lokeja.

Generator on Node.js-sovellus, joka hoitaa Photoshopin ja Generator-liitännäisten välisen viestinnän. Se tarjoaa resurssien luomislogiikan toiminnoille Vie nimellä ja Kuvaresurssit.

Kun käynnistät Photoshopin tai valitset Tiedosto > Vie > Vie nimellä, näyttöön tulee valintaikkuna, jossa sanotaan: "Generatorin kanssa on ongelma. Sulje Photoshop ja yritä uudelleen. Jos ongelma jatkuu, poista kaikki kolmannen osapuolen liitännäiset tai asenna Photoshop uudelleen."

Kokeile seuraavia ratkaisuja annetussa järjestyksessä.

Suojausohjelmisto estää Generatorin toiminnan

Suojaus- tai virustorjuntaohjelmisto voi estää Generatorin viestinnän portissa 8010 tai estää node-prosessin käynnistymisen.

Avaa suojaus- tai virustorjuntaohjelmiston asetukset.

Lisää Photoshop sallittujen sovellusten luetteloon.

Varmista, että portti 8010 on auki Generatoria varten.

Lisää node.exe sallittujen sovellusten luetteloon kohdassa C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe Windowsissa.

Salli macOS-käyttöjärjestelmässä node-prosessi kohdassa /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

Salli Windowsissa Photoshopin käyttää valvottuja kansioita.

Käynnistä Photoshop uudelleen ja testaa Generator valitsemalla Tiedosto > Vie > Vie nimellä.

Kolmannen osapuolen liitännäinen on ristiriidassa Generatorin kanssa

Photoshopin Generator-kansiossa olevat kolmannen osapuolen liitännäiset eivät välttämättä ole yhteensopivia käytössä olevan versiosi kanssa tai ne voivat olla ristiriidassa oletusarvoisen Kuva-resurssit-liitännäisen kanssa.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Luo tietokoneelle väliaikainen kansio nimeltä Käytöstä poistetut Generator-liitännäiset.

Siirrä kolmannen osapuolen liitännäiskansiot väliaikaiseen kansioon. Jätä oletusarvoinen Image Assets-liitännäinen Generator-kansioon.

Käynnistä Photoshop ja valitse Tiedosto > Vie > Vie nimellä.

Jos virhe on poistunut, lisää liitännäiset takaisin yksi kerrallaan ja käynnistä Photoshop uudelleen joka lisäyksen jälkeen, kunnes virhe palaa.

Jätä oletusarvoinen Image Assets -laajennus Generator-kansioon. Siirrä vain erikseen asentamasi laajennukset.

generator ei käynnisty, etkä tarvitse sitä

Jos et käytä Export As- tai Image Assets -toimintoa, poista Generator käytöstä väliaikaisena ratkaisuna.

Käynnistä Photoshop.

Valitse Windowsissa Muokkaa > Asetukset > Laajennukset. Valitse macOS:ssä Photoshop > Asetukset > Laajennukset.

Poista valinta kohdasta Ota luontitoiminto käyttöön.

Valitse OK ja käynnistä sitten Photoshop uudelleen.

Kun valitset Tiedosto > Vie > Export As, Generator otetaan uudelleen käyttöön. Jos tarvitset Export As -toimintoa, ratkaise Generator-virhe sen sijaan, että jättäisit Generatorin pois käytöstä.

Generator-lokeissa näkyy käynnistysvirheitä

Generator-lokit voivat sisältää tietoja laajennuksista, joita ei voi ladata, tai järjestelmäongelmista, jotka estävät Generatorin käynnistymisen.

Siirry Windowsissa kohteeseen C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

Siirry macOS:ssä kohteeseen /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Avaa uusin Generator-loki ja etsi virheilmoituksia.

Jos Generator-kansiota ei ole, varmista, että sinulla on kirjoitusoikeus ylätason kansioon.

Jos tarvitset lisäapua, kerää diagnostiikkalokit Adobe Log Collector Tool -työkalulla.

Windowsin AppData- ja macOS:n Library-kansiot on oletusarvoisesti piilotettu. Ohjeet piilotettujen tiedostojen ja kansioiden näyttämiseen Windowsissa voivat auttaa sinua löytämään Windows-lokit.

Generator-virheitä ilmenee Apple Siliconissa

Jos generator ei vieläkään toimi Applen sirua käyttävässä Macissa, Photoshopin suorittaminen Rosettalla voi auttaa selvittämään, johtuuko ongelma natiivin tilan yhteensopivuudesta.

Sulje Photoshop.

Avaa Finder, avaa Ohjelmat ja etsi Adobe Photoshop.

Control-osoita Adobe Photoshopia ja valitse sitten Näytä tietoja.

Valitse Avaa Rosettan avulla, käynnistä sitten Photoshop ja testaa Generator.

Jos virhe jatkuu, toimita Generator-lokit, kun otat yhteyttä Adobe-tukeen saadaksesi apua. Jos Export As -ongelmat eivät liity Generatoriin, käytä viennin ja tallennustoimintojen vianmääritysohjeita.