Korjaa vahingoittuneet tai vioittuneet Photoshop-tiedostot

Päivitetty viimeksi 29. lokakuuta 2026

Opi korjaamaan tiedostovioittumat Adobe Photoshopissa varmuuskopion palautuksen, koostekuvan avauksen ja tiedostopäätteen tarkistuksen avulla.

Kun Photoshop-tiedostot vahingoittuvat tai eivät avaudu, syynä on tavallisesti tiedoston vioittuminen, väärä tiedostopääte tai näytönohjaimen ongelma. Tiedostojen vioittuminen on harvinaista, mutta sen selvittäminen, vaikuttaako vioittuminen yhteen tiedostoon vai useampaan, auttaa määrittämään syyn ja oikean palautustavan.

Kun yrität avata PSD-, PSB- tai muuta Photoshop-yhteensopivaa tiedostoa, saatat nähdä virheilmoituksia, kuten "Pyyntöä ei voitu suorittaa loppuun, koska kyseessä ei ole kelvollinen Photoshop-asiakirja.", "Pyyntöä ei voitu suorittaa loppuun, koska tiedostosta löytyi tunnistamaton tai virheellinen JPEG-merkintätyyppi.", "Pyyntöä ei voitu suorittaa loppuun, koska tiedostomuotomoduuli ei pysty jäsentämään tiedostoa.", "Pyyntöä ei voitu suorittaa loppuun ohjelmavirheen vuoksi." tai "Tämä ei ole kelvollinen PDF-tiedosto (Portable Document File)."Sitä ei voi avata."Tiedosto ei välttämättä avaudu lainkaan, se voi näkyä näytöllä virheellisesti tai siinä voi esiintyä visuaalista vioittumista, kuten sekoittuneita pikseleitä tai puuttuvaa sisältöä.

Selvitä ennen palautuksen yrittämistä, vaikuttaako vioittuminen yhteen tiedostoon vai useampaan. Jos useita tiedostoja on vioittunut, etsi yhteisiä tekijöitä: tallennettiinko ne samaan sijaintiin, luotiinko ne samaan aikaan tai muokattiinko niitä järjestelmätapahtuman, kuten sähkökatkoksen tai ohjelmistopäivityksen, aikana? Tämä auttaa selvittämään, onko kyseessä kertaluonteinen häiriö vai jatkuva laitteisto- tai ohjelmisto-ongelma.

Seuraavat ratkaisut käsittelevät tiedostojen vioittumisen yleisimpiä syitä todennäköisyysjärjestyksessä:

Palauta tiedosto varmuuskopiosta

Etsi kuvan varmuuskopioituja kopioita Creative Cloudista, Time Machine -sovelluksesta (macOS), File History -toiminnosta (Windows) tai muista varmuuskopiointipaikoista.

Avaa varmuuskopioitu tiedosto ja tarkista, ettei se ole vioittunut.

Valitse Tiedosto > Tallenna nimellä ja tallenna palautettu tiedosto uudella nimellä.

Valitse tallennuspaikaksi sisäinen kiintolevy verkkoaseman tai siirrettävän aseman sijaan.

Avaa tiedosto koosteena

Tason tiedot ovat vioittuneet, mutta litistetty koosteen esikatselu on ehjä. Tämä palautustapa toimii vain, jos Maksimoi PSD- ja PSB-tiedostojen yhteensopivuus -asetus oli käytössä, kun tiedosto alun perin tallennettiin.

Pidä Shift + Option (macOS) tai Shift + Alt (Windows) painettuna, kun käynnistät Photoshopin.

Valitse Tiedosto > Avaa ja valitse vioittunut tiedosto.

Pidä näppäimiä painettuna, kunnes tiedosto avautuu.

Tallenna palautettu koostekuva uudella nimellä.

Muistiinpano

Palautettu tiedosto litistetään, ja kaikki tasot yhdistetään. Jotta vastaavilta ongelmilta vältytään jatkossa, ota käyttöön Maksimoi PSD- ja PSB-tiedostojen yhteensopivuus -asetus kohdassa Asetukset > Tiedostonkäsittely.

Korjaa tiedostopääte

Jos tiedosto ei vieläkään avaudu, tiedostopääte ei välttämättä vastaa tiedoston todellista muotoa:

Tiedostopääte ei vastaa tiedoston todellista tyyppiä, minkä takia Photoshop ei pysty tunnistamaan tiedostomuotoa oikein.

Napsauta tiedostoa hiiren kakkospainikkeella ja tarkista sen koko tiedostonimi, mukaan lukien tiedostopääte.

Jos tiedostossa on useita tiedostopäätteitä (esimerkiksi tiedostonimi.pdf.jpg), poista kaikki paitsi oikea tiedostopääte.

Varmista, että tiedostopääte vastaa todellista tiedostomuotoa: .psd Photoshop-asiakirjoille, .jpg JPEG-kuville ja .png PNG-tiedostoille.

Yritä avata korjattu tiedosto Photoshopissa.

Jos tämä ei onnistu, kokeile avata tiedosto Preview-sovelluksessa (macOS) tai Photos-sovelluksessa (Windows) ja tallenna se sitten oikeassa muodossa.

Saat ohjeita todellisen tiedostotyypin määrittämiseen artikkelista Asiakirjan tiedostotyypin määrittäminen.

Poista grafiikkasuoritin käytöstä

Jos kuva näyttää vioittuneelta näytöllä, mutta sen vienti tai tulostus onnistuu oikein, syynä on todennäköisesti näytönohjain:

Näytönohjain tai sen ajuri aiheuttaa näytön vioittumisen, joka ei vaikuta itse tiedoston dataan.

Valitse Photoshop > Asetukset > Suorituskyky (macOS) tai Muokkaa > Asetukset > Suorituskyky (Windows).

Poista valinta kohdasta Käytä grafiikkasuoritinta.

Valitse OK ja käynnistä Photoshop uudelleen.

Avaa tiedosto ja tarkista, näkyykö vioittuma edelleen.

Jos vioittuma katoaa, päivitä näytönohjaimen ajuri ja ota GPU-kiihdytys käyttöön uudelleen. Katso täydelliset grafiikkaongelmien vianmääritysohjeet kohdasta Photoshopin grafiikkasuorittimen (GPU) ja näytönohjaimen ongelmien vianmääritys.

Kun useita tiedostoja on vioittunut tai palautustavat eivät toimi, syynä voi olla laitteisto- tai ohjelmisto-ongelma. Tarkista, viittaavatko havaitut kuviot yhteiseen laitteistoon (sama asema, verkkosijainti tai siirrettävä tallennusväline), suorita laitteistodiagnostiikka RAM- tai kiintolevyongelmien varalta ja tarkista äskettäin asennetut ohjelmistot, jotka voivat häiritä tiedoston tallentamista. Käytä järjestelmätason ongelmien järjestelmällistä vianmääritystä varten ohjetta Yleisten ongelmien perusvianmääritysohjeet.

Jos itse tehty palautus ei onnistu, kolmannen osapuolen palautustyökalut voivat auttaa tiedoston pelastamisessa. Adobe ei testaa tai tue näitä työkaluja virallisesti, mutta jotkut käyttäjät ovat onnistuneet palauttamaan tiedostoja käyttämällä PSD Parse Online-, PSD Recover- tai PSD Repair-työkaluja.

Estä tiedostojen häviäminen jatkossa ottamalla automaattinen tiedostojen palautus käyttöön kohdassa Asetukset > Tiedostojen käsittely ja valitsemalla Tallenna palautustiedot automaattisesti aina 5 tai 10 minuutin välein.Tallenna tiedostot turvallisimpiin paikkoihin, kuten Creative Cloudiin (joka säilyttää useita varmuuskopioversioita), APFS/HFS+-muotoon alustetuille sisäisille kiintolevyille (macOS) tai NTFS-muotoon alustetuille kiintolevyille (Windows) tai viimeisenä vaihtoehtona USB-asemiin.Vältä tallentamista suoraan verkkopalvelimille tai jaettuihin kansioihin, koska ne ovat alttiimpia vioittumiselle tallennuksen aikana.Lue täydelliset ennaltaehkäisystrategiat artikkelista Tiedostojen tallennusasetusten määrittäminen.

Katso lisää virhekohtaisia vianmääritysohjeita artikkeleista Ohjelmavirhe .psd-tiedostoja avattaessa ja Virheellinen JPEG-merkki -virhe.