Learn what's new in the latest release of After Effects CC.
after-effects

The October 2018 release of After Effects CC (version 16.0) rolls out exciting new features for visual effects artists, graphic editors, and animators. Read on for a quick introduction to these features and links to resources offering more information.


Note:

After Effects version 16.0.1 fixes issues found in the latest version of After Effects. This update is recommended for all users. Projects saved in After Effects 16.0.1 are compatible with After Effects 16.0.

For more information on the bugs fixed in this version of After Effects, see Fixed issues in After Effects CC.

Advanced Puppet Tool: New Advanced Pins and Bend Pins

Explore new ways to animate with new Advanced and Bend pins in the Puppet Tool.

FM_Banners_Ae_WhatsNew

With better precision, and the ability to switch between pin types, control your animations with the Advanced pin that enables you to scale and rotate your mesh to detailed precision. The Bend pin lets you create different deformations by curving and bending your animations. The bend pin rotates or scales the puppet mesh, but follows the position of the other pins in the mesh.

For more information, see Types of pins in the Advanced Puppet Tool.

Depth Passes for 3D Compositions

Z-depth can now be extracted by the 3D channel extract effects from a nested composition that contains 3D layers.


This and other depth related effects can be found in the 3D channel effect option. These can be used to apply 3D depth effects to the composition layer, such as a depth of field blur, or to generate a matte for depth compositing or color correction.

Depth passes can be generated by the Classic 3D or Cinema 4D Renderer for 3D layers. A depth pass lets you combine objects behind others or apply effects that change with distance, such as depth of field.

For more information, see Depth passes for 3D compositions.

Expressions enhancements

New JavaScript engine for expressions

After Effects uses an updated JavaScript engine that allows modern programming techniques. Performance of evaluating expressions can be up to 5x faster, depending on the expression. Though the new JavaScript engine is compatible with the Legacy ExtendScript engine, there are differences between them. You may need to rewrite some expressions for the new JavaScript engine. You can select between the two engines in Project Settings.

For more information, see Expressions: JavaScript engine.

Editor and UX improvements

  • Editor improvements: The expression field in the Timeline panel has the following enhancements:
    • Monospace font: The expression editor field now uses Source Code Pro.
    • Auto-resizing: The expression editor field now automatically adjusts when you click into the field to display maximum part of the expression.
  • Enable or disable all expressions on selected layers: All expressions on a layer can now be disabled or enabled with two new menu commands in the Layer > Switches submenu, or by right-clicking a layer and opening the Switches submenu.
  • Expression error banner improvements: The expression error banner (the orange bar that appears in the Composition panel when an expression fails to evaluate) is updated:
    • Darker buttons in the banner.
    • A Hide Expression Error Banner button that hides the banner. This button disables the Show Warning Banner When Project Contains Expression Errors option in Preferences > General. To show the expression error banner again, re-enable the preference.

New methods and attributes

This release introduces the following expression reference methods and attributes:

Responsive Design - Time


Motion graphics involve keyframes and when the length of a composition changes, the keyframes must be adjusted as well, involving repetitive work when iterating. The Responsive Design features in After Effects, allow you to author graphics that adapt to later changes. Responsive Design – Time in After Effects enables adaptive time-stretching when a composition is nested or exported as a Motion Graphics template. When the in and out points of the composition are adjusted, the duration of protected regions is preserved and unprotected regions are time-stretched.

For more information, see Add responsive design to your graphics.

Motion Graphics templates enhancements

Infographics and Motion Graphics templates (53 sec)

The Essential Graphics panel allows you to group controls together, control font properties, and add controls for CSV and TSV spreadsheet data sources to a Motion Graphics template. You can attach spreadheet data to your composition and add the data to the Essential Graphics panel. You can edit this data within the panel and also export them as Motion Graphics templates to Premiere Pro. 

In Premiere Pro, you can now add your own spreadsheet to a data driven After Effects Motion Graphic template (MOGRT) and drive the animation or make changes to the data in the MOGRT.

For more information, see Motion Graphics templates in After Effects.

Lumetri Color Curves controls

Use the Hue Saturation curves to color grade images
Use the Hue Saturation curves to color grade images

Innovative new curve adjustment tools make selective color grading simple and straightforward. Two axes allow you to adjust Hue to Hue and Hue to Luma values with a clear visual representation. This provides precision to take the guess work out of curve adjustment.

For more information, see Selective color adjustment with the color correction curves.

Adobe Animate and Adobe XD integration

Import from Adobe Animate

Adobe Animate CC documents (.fla) can now be imported into After Effects as a composition of layered .swf files. Ensure that the Animate 19.0 version is installed on the same computer.

For more information, see Importing FLA files into After Effects.

Export to After Effects from Adobe XD

Export to After Effects from Adobe XD
Export to After Effects from Adobe XD

This release of Adobe XD CC can export layers and artboards to your After Effects project. This feature provides seamless transfer of assets between XD and After Effects. The process includes native mapping of layers, artboards, vectors, text, and artwork.

For more information, see Working with Adobe XD and After Effects.

VR enhancements

Support for VR 180

With this release of After Effects, you can create and preview immersive content with a 180-degree field of view. There are two new 180 stereoscopic modes to preview your composition in an HMD:

  • 180 Over/Under
  • 180 Side-by-Side

New Theater mode and 180 Stereoscopic modes in Adobe Immersive Environment

This release of After Effects introduces the Theater Mode (Rectilinear) that previews the composition as a flat rectangle in an empty room, simulating the view of looking at a movie screen.

For more information, see Preview footage in your headset.

New properties to control Immersive effects

The Immersive Video effects (except VR Converter and VR Sphere to Plane) include new options to control how they are applied:

  • Stereoscopic Side-by-Side: The Frame Layout parameter can be set to Stereoscopic Side-by-Side, in addition to the existing Monoscopic, and Stereoscopic Over/Under options.
  • Horizontal and Vertical Field of View: The horizontal and vertical field of view can be independently set. By default, the values are 360x180. For VR 180 content, set both values to 180.

For more information, see Apply immersive video effects.

Performance enhancements

New GPU-accelerated effects

The following effects now render using your computer GPU when the Project Settings > Video Rendering and Effects > Use option is set to Mercury GPU Acceleration:

  • Color Balance (HLS)
  • Curves
  • Fill
  • Exposure
  • Linear Wipe
  • Noise
  • Tritone
  • Set Matte
  • Venetian Blinds

Wave Warp effect CPU improvement

The Wave Warp effect is multi-threaded and renders upto 3x faster by using multiple CPU cores.

Median effect algorithm improvement

The Median effect has been updated to a new algorithm that renders faster than the previous median algorithm. The new algorithm supports 32-bpc color. It renders differently at layer edges, so After Effects retains the previous algorithm as a separate effect, Median (Legacy). Projects saved in previous versions of After Effects apply the Median (Legacy) effect to preserve the rendering result.

Video and Audio Format Support enhancements

Native decoding of HAP codecs in QuickTime files

After Effects 16.0 can now natively decode HAP, HAP Alpha, HAP Q, and HAP Q Alpha codec footage in QuickTime files.

For more information, see Supported File formats | After Effects CC.

New Mocha AE CC plug-in

After Effects 16.0 includes the Mocha AE CC plug-in from Imagineer Systems - Boris FX. This replaces the stand-alone Mocha AE application that was included with previous releases of After Effects. The new plug-in includes the same accurate planar tracking , but features a new interface and is now GPU-accelerated.

For more information, see Work with the Mocha AE plug-in.

Other enhancements

UI enhancements

  • After Effects now uses Adobe Clean UX for the user interface.
  • The disclosure triangle (twirly arrow) is updated to an open-triangle design.
  • It is now easier to find and identify GPU-accelerated effects, or to determine whether Mercury GPU Acceleration is enabled for the open project.
    • In the Effects & Presets panel, you can filter the list of effects to show only GPU-accelerated effects. Click the panel menu and choose Show GPU Capable Effects Only.
    • In the Effect Controls panel, GPU-accelerated effects display the GPU acceleration badge next to the effect name.
    • At the bottom of the Project panel, a rocket ship icon indicates whether the project is set to use Mercury GPU Acceleration. If the rocket ship icon is bright, the project is set to Mercury GPU Acceleration. If the rocket ship icon is dim with a power button icon, the project is set to Mercury Software Only. Click the rocket ship icon to open the Project Settings > Video Rendering and Effects tab, where you can choose whether Mercury GPU Acceleration is enabled and which GPU technology is used.

Set guide lines position

Guide lines can be set to a precise pixel position. After you create a guide line (drag from the horizontal or vertical ruler), right-click and choose Edit Position, then enter the new position as a number of horizontal or vertical pixels from the composition origin (upper-left corner).

Install scripts and ScriptUI panels from the UI

You can install After Effects scripts or ScriptUI panels by selecting new commands from the File > Scripts panel, or by dragging script files into the Project panel while you hold down the modifier keys. Scripts installed through these methods are copied to the current user preferences folder, and appear in the File > Scripts menu or Window menu (for ScriptUI panels) after you restart After Effects.

This release introduces changes to the drag and drop method. When you drag a .jsx file into the Project panel without holding a modifier key, it imports that file as a data source footage item, instead of installing it as a script. The ability to install scripts to the preferences folder by drag and drop was introduced in After Effects 12.2. However, the functionality was disabled in After Effects 15.1 when support was added for custom expression function libraries in .jsx files.

New Home screen and Home button

The After Effects Home screen when you first launch it
The After Effects Home screen when you first launch it

When you launch After Effects, it now displays a Home screen, which includes option to create a project or open an existing project.

You can also view the Home Screen at any time by pressing the new Home button on the toolbar, which is displayed to the left of the Selection tool.

The options on the Home screen evolve as you keep using After Effects. The contents of the Home screen are tailored based on your familiarity with After Effects and your Creative Cloud membership plan.

For more information, see Navigate and use the Home screen.

New Learn panel and Learn workspace

The Learn panel is designed for new users to help them create a composition quickly while introducing them to panels, timeline, and effects.

Learn panel and the Learn workspace
Learn panel and the Learn workspace

The panel includes the following information:

  • After Effects overview
  • Learn the basics

The new Learn workspace offers a simpler interface with only four panels (Learn panel, Composition panel, Project panel, and the Timeline panel) to help new users get started with After Effects. The Learn panel is docked to the side so that you can follow the instructions while you still have clear access to the rest of workspace.

For more information, see Use the Learn workspace and Learn panel.

Other changes

  • Saving a project file as a previous version is updated to Save a Copy As CC (15.x) or Save a Copy As CC (14.x). To save a project as 13.x from After Effects 16.0, first save it as 15.x or 14.x, then open the project in one of those versions and save a copy as 13.x.
  • Deleting multiple empty folders in the Project panel no longer asks you to confirm the deletion if all of the folders are empty.
  • The Match Legacy After Effects QuickTime Gamma Adjustments option in Project Settings > Color has been removed.
  • The Create Nulls From Paths panel now creates nulls directly above the layers containing the selected paths, instead of at the top of the layer stack.
  • After Effects does not include the Synthetic Aperture Color Finesse plug-in.
  • The Ray-traced 3D composition renderer has been deprecated. For better performance, create 3D compositions with only the CINEMA 4D or Classic 3D renderers.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy