Para crear contenido de diapositivas que se pueda reproducir en Flash Player, exporte a SWF o FLA. La principal diferencia es que los archivos SWF se pueden visualizar directamente pero no editarse mientras que los archivos FLA se deben editar en Adobe Flash Professional para visualizarse en Adobe Flash Player.

SWF

Un archivo SWF exportado se puede visualizar directamente en Adobe Flash Player y puede tener elementos interactivos como transiciones de página, hipervínculos, películas, clips de sonido, animaciones y botones de navegación.

FLA

Un archivo FLA exportado solo incluye algunos elementos interactivos. El archivo FLA se puede abrir en Flash Pro, desde donde podrá añadir por sí mismo o con ayuda de un desarrollador Flash efectos avanzados antes de exportarlo a SWF.

Exportación a Flash
Exportación a Flash

A. Exportar directamente a SWF B. Exportar a FLA para editar en Flash Professional 

Creación de archivos SWF (Flash) interactivos para la Web

Al exportar a SWF, se crea un archivo interactivo que se puede visualizar directamente en Adobe Flash Player o en un navegador web. El archivo SWF puede incluir botones, transiciones de página, películas, archivos de audio, animaciones e hipervínculos agregados en InDesign. Exportar a SWF es una buena alternativa para, a partir de un documento InDesign, crear una proyección de diapositivas interactiva o un libro animado.

Si desea editar el documento en Flash Pro antes de crear el archivo SWF, exporte a FLA en lugar de SWF. Consulte Creación de archivos SWF (Flash) interactivos para la Web.

Exportación a SWF
Exportación a SWF

A. Documento en InDesign antes de ser exportado a SWF B. Archivo SWF interactivo en un navegador web 
  1. Cree o edite el documento InDesign antes de exportarlo a Flash. Para obtener información detallada sobre cómo configurar el documento para exportarlo, consulte Aspectos sobre la exportación a Flash.

    • Añada botones de navegación para que los usuarios puedan moverse entre las páginas del archivo SWF exportado. Dibuje un objeto y conviértalo en un botón usando el panel Botones (elija Ventana > Interactivo > Botones). También puede usar el panel Botones de muestra para arrastrar hasta el documento botones de navegación predefinidos. Consulte Botones.

    • Añada transiciones de página con efectos como Limpiar o Disolver desde el panel Transiciones de página (elija Ventana > Interactivo > Transiciones de página). Cuando exporte a SWF, también puede seleccionar la opción Incluir doblez de página interactivo, que permite pasar de página arrastrando una esquina de la página.

    • Añada ajustes preestablecidos de movimiento en el panel Animación (elija Ventana > Interactivo > Animación). Consulte Animación.

  2. Para exportar el documento a formato SWF, elija Archivo > Exportar. En el menú Guardar como tipo (Windows) o Formato (Mac OS), elija Flash Player (SWF) y haga clic en Guardar.

  3. En el cuadro de diálogo Exportar SWF, especifique las opciones y, a continuación, haga clic en OK. Consulte Opciones de exportación a SWF.

Al exportar archivos SWF, se crean archivos HTML y SWF independientes. Si el archivo SWF incluye clips de audio o películas, se crea una carpeta denominada Recursos. Para transferir o cargar archivos en la Web, asegúrese de que envía todos los elementos.

Opciones de exportación SWF

En el cuadro de diálogo Exportar SWF encuentra las siguientes opciones en las pestañas General y Avanzado.

Exportar

Indique si se incluirá la selección actual, todas las páginas del documento o un intervalo de páginas. La opción Selección es especialmente útil si desea guardar el archivo SWF exportado para su uso en un archivo PDF exportado. Si selecciona Rango, especifique un intervalo de páginas, por ejemplo 1-7, 9 para imprimir las páginas de la 1 a la 7 y la 9. Consulte Especificación de las páginas que se van a imprimir.

Generar archivo HTML

Seleccione esta opción para generar una página HTML que reproduzca el archivo SWF. Está opción resulta especialmente útil para previsualizar rápidamente el archivo SWF en el navegador web.

Ver SWF después de exportar

Seleccione esta opción para reproducir el archivo SWF en el navegador web predeterminado. Para que está opción esté disponible, es necesario generar un archivo HTML.

Tamaño (píxeles)

Especifique si el archivo SWF se escala de manera porcentual, se ajusta al tamaño de un monitor específico o si adopta una altura y anchura especificadas por el usuario.

Fondo

Especifique si el fondo del archivo SWF es transparente o si usa el color del papel seleccionado en el panel Muestras. Si selecciona Transparente, se desactivan las opciones Transiciones de página e Incluir doblez de página interactivo.

Interactividad y multimedia

Seleccione Incluir todo para que las películas, las animaciones los sonidos y los botones exportados al archivo SWF sean interactivos. Seleccione Solo apariencia para incluir el estado normal de los botones y los pósters de vídeo como elementos estáticos. Si selecciona Solo apariencia, las animaciones se exportan como se estén visualizando en el momento de exportarse. Si en el panel Avanzado selecciona Acoplar transparencia, la opción Solo apariencia estará seleccionada.

Transiciones de página

Especifique una transición de página para aplicarla a todas las páginas durante la exportación. Si especifica las transiciones en el panel Transiciones de página, elija la opción Desde documento para usar estos ajustes.

Incluir doblez de página interactivo

Si esta opción está seleccionada, los usuarios que reproduzcan un archivo SWF pueden arrastrar una esquina de la página para pasarla, dando así la impresión de estar hojeando un libro real.

Frecuencia de imagen

Con velocidades de fotograma altas se crean animaciones más fluidas pero se aumenta el tamaño de archivo. Si cambia la velocidad de los fotogramas, la duración de la reproducción no se ve afectada.

Texto

Especifique el tipo de salida de texto de InDesign. Seleccione Texto clásico de Flash para crear un texto en el que se puedan realizar búsquedas y con el menor tamaño de archivo. Seleccione Convertir en contornos para crear el texto como una serie de líneas rectas suaves, como si convirtiese el texto en contornos. Seleccione Convertir en píxeles para crear el texto en una imagen de mapa de bits. El texto convertido en píxeles podría parecer irregular al aplicarle el zoom.

Rasterizar página

Esta opción convierte todos los elementos de página de InDesign en mapas de bits. Si selecciona esta opción aumentará el tamaño del archivo SWF y es posible que, al aumentarlos, los elementos de página no se visualicen correctamente.

Acoplar transparencia

Esta opción elimina la transparencia interactiva del archivo SWF y conserva la apariencia de transparencia. Sin embargo, si esta opción está seleccionada, el archivo SWF exportado pierde toda la interactividad.

Compresión

Seleccione Automática para que InDesign determine la mejor calidad para las imágenes en color y en escala de grises. En la mayoría de los archivos, esta opción produce resultados satisfactorios. La opción JPEG (con pérdida) es adecuada para imágenes de escala de grises o en color. La compresión JPEG es una técnica que produce pérdida de datos, es decir, elimina datos de la imagen y puede reducir su calidad; sin embargo, intenta reducir el tamaño del archivo con la mínima pérdida de información. Puesto que este tipo de compresión elimina datos, puede reducir mucho más el tamaño de archivo. Seleccione PNG (sin pérdida) para no aplicar la compresión con pérdida al exportar el archivo.

Nota:

Si advierte que las imágenes transparentes han perdido calidad al exportarlas a SWF, elija PNG (sin pérdida) para mejorar la calidad.

Calidad JPEG

Especifica la cantidad de detalles de la imagen exportada. Cuanto mejor es la calidad, más grande es el tamaño del archivo. Esta opción está atenuada si elige PNG (sin pérdida) como método de compresión.

Resolución

Especifique la resolución de las imágenes de mapa de bits del archivo SWF exportado. Una resolución alta es muy importante para que se pueda aplicar el zoom y aumentar el contenido pixelado del archivo SWF exportado. Si elige una resolución alta, el tamaño del archivo puede aumentar considerablemente.

Creación de archivos FLA para la Web

Si exporta un documento de InDesign a un formato de archivo FLA, puede abrir el archivo con Adobe Flash®CS5 Professional para editar el contenido. La exportación a FLA en formato de InDesign CS5 sustituye a la exportación de XFL en InDesign CS4. Use el entorno de creación de Flash para editar o añadir vídeo, audio, animación y otro contenido interactivo complejo.

Si desea exportar el documento de InDesign directamente a un formato que se pueda abrir en un navegador web, use el formato SWF en lugar de FLA. Consulte Creación de archivos SWF (Flash) interactivos para la Web.

Exportación a FLA
Exportación a FLA

A. Documento en InDesign antes de su exportación a FLA B. Archivo FLA abierto con Flash Pro 
  1. Cree o edite el documento InDesign antes de exportarlo a Flash. Para obtener información detallada sobre cómo configurar el documento para exportarlo, consulte Aspectos sobre la exportación a Flash.

  2. Para exportar el documento a formato FLA, elija Archivo > Exportar. En el menú Guardar como tipo (Windows) o Formato (Mac OS), elija Flash CS5 Professional (FLA) y haga clic en Guardar.

  3. En el cuadro de diálogo Exportar Flash CS5 Professional (FLA), especifique las siguientes opciones y, a continuación, haga clic en OK. Para obtener más información sobre las opciones de exportación, consulte Opciones de exportación a FLA.

  4. En Flash Professional, abra el archivo FLA exportado.

Opciones de exportación a FLA

El cuadro de diálogo Exportar a Flash CS5 Professional (FLA) presenta las siguientes opciones.

Exportar

Indique si se incluirá la selección actual, todas las páginas del documento o un intervalo de páginas. Si selecciona Rango, especifique un intervalo de páginas, por ejemplo 1-7, 9 para imprimir las páginas de la 1 a la 7 y la 9. Consulte Especificación de las páginas que se van a imprimir.

Rasterizar página

Esta opción convierte todos los elementos de página de InDesign en mapas de bits. Si selecciona esta opción aumentará el tamaño del archivo FLA y, al aplicarle el zoom para aumentarlo, los elementos de página no se visualizarán correctamente.

Acoplar transparencia

Si selecciona esta opción, se acoplará una transparencia a todos los objetos. Es posible que resulte más complicado animar los objetos acoplados en Adobe Flash Pro.

Tamaño (píxeles)

Especifique si el archivo FLA se escala porcentualmente, se ajusta al tamaño de un monitor específico o si adopta una altura y anchura especificadas por el usuario.

Interactividad y multimedia

Seleccione Incluir todo para que las películas, las animaciones, los sonidos y los botones se puedan incluir en el archivo FLA exportado. Si el documento incluye un objeto de varios estados, éste se convierte en un símbolo de clip de película y cada uno de sus estados se muestra en un fotograma específico de la línea de tiempo.

Seleccione Solo apariencia para incluir el estado normal de los botones y los pósters de vídeo como elementos estáticos. Si selecciona Solo apariencia, las animaciones se exportan como se estén visualizando en el momento de exportarse. La opción Solo apariencia estará seleccionada si se elige Acoplar transparencia.

Texto

Especifique el tipo de salida de texto de InDesign. Seleccione Texto TLF de Flash para utilizar todos los atributos de Text Layout Framework de Flash Professional. Si esta opción está seleccionada, seleccione Insertar puntos opcionales de separación por sílabas para permitir la separación. Seleccione Texto clásico de Flash para crear un texto en el que se puedan realizar búsquedas y con un tamaño de archivo pequeño. Seleccione Convertir en contornos para crear el texto como una serie de líneas rectas suaves, como si convirtiese el texto en contornos. Seleccione Convertir en píxeles para crear el texto en una imagen de mapa de bits. El texto convertido en píxeles podría parecer irregular al aplicarle el zoom.

Compresión

Seleccione Automática para que InDesign determine la mejor calidad para las imágenes en color y en escala de grises. En la mayoría de los archivos, esta opción produce resultados satisfactorios. La opción JPEG (con pérdida) es adecuada para imágenes de escala de grises o en color. La compresión JPEG es una técnica que produce pérdida de datos, es decir, elimina datos de la imagen y puede reducir su calidad; sin embargo, intenta reducir el tamaño del archivo con la mínima pérdida de información. Puesto que este tipo de compresión elimina datos, puede reducir mucho más el tamaño de archivo. Seleccione PNG (sin pérdida) para no aplicar la compresión con pérdida al exportar el archivo.

Calidad JPEG

Especifica la cantidad de detalles de la imagen exportada. Cuanto mejor es la calidad, más grande es el tamaño del archivo. Esta opción está atenuada si elige PNG (sin pérdida) como método de compresión.

Resolución

Especifique la resolución de las imágenes de mapa de bits del archivo FLA exportado. Una resolución alta es particularmente importante para que se pueda aplicar el zoom y aumentar el contenido pixelado. Si elige una resolución alta, el tamaño del archivo puede aumentar considerablemente.

Aspectos sobre la exportación a Flash

Tenga en cuenta los siguientes factores al diseñar el documento InDesign para exportarlo a SWF o FLA.

Aspectos sobre la configuración del documento

Cómo se convierten las páginas de InDesign

Al exportar a SWF o FLA, los pliegos de InDesign se convierten en clips independientes en una línea de tiempo al igual que ocurre con las diapositivas de una proyección. Cada pliego se asigna a un nuevo marco completo. En Flash Player, se avanza a través de los pliegos del documento exportado pulsando las teclas de dirección o haciendo clic en los botones interactivos.

Nota:

Al crear un documento para la Web, en el cuadro de diálogo Nuevo documento, en el menú Propósito, elija Web.

Tamaño de página

Al crear un documento, es posible seleccionar una resolución específica, como 800 x 600, en el menú Tamaño de página en el cuadro de diálogo Nuevo documento. Durante la exportación, también se puede ajustar la escala o la resolución del archivo SWF o FLA exportado.

Funciones relacionadas con la interactividad

En los archivos SWF y FLA exportados se pueden incluir botones, transiciones de página, hipervínculos, animaciones y archivos multimedia.

Botones

Entre los botones de un archivo SWF o FLA exportado, los de Página siguiente y Página anterior le resultarán especialmente útiles para controlar la reproducción con Flash Player. Sin embargo, algunas acciones que funcionan con los archivos PDF interactivos, no lo hacen con Flash Player. Si elige una acción del panel Botones, no realice ninguna selección en Solo PDF.

Nota:

Puede añadir botones de navegación que ya incluyan las acciones Ir a la página siguiente e Ir a la página anterior. En el menú del panel Botones, elija Botones de muestra. Consulte Añadir un botón del panel Botones de muestra.

Transiciones de página

Todas las transiciones de página funcionan correctamente en Flash Player. Además de las transiciones de página que aparecen al pasar una página, durante la exportación también es posible incluir un doblez de página interactivo que le permita arrastrar las esquinas de las páginas para pasarlas.

Hipervínculos

Cree vínculos a sitios web u otras páginas del documento. Los hipervínculos de los archivos FLA están rotos.

Clips de película y sonido

Los clips de película y sonido se incluyen en los archivos SWF exportados si tienen un formato compatible: SWF, FLV, F4V y MP4 para las películas, y MP3 para el sonido.

Al exportar a FLA, en el archivo resultante solo se incluye la imagen de póster. Los archivos multimedia admitidos aparecen en una carpeta de recursos guardada en la misma ubicación que el archivo FLA exportado.

Aspectos sobre la conversión

Color

Los archivos SWF y FLA usan color RGB. Cuando se exporta un documento a SWF o FLA, InDesign convierte todos los espacios de color (como CMYK o LAB) a sRGB. InDesign convierte las tintas planas en colores de cuatricromía RGB equivalentes.

Para evitar cambios de colores no deseados en las ilustraciones con texto y transparencia, seleccione Edición > Espacio de fusión de transparencia > RGB de documento. Para evitar cambios no deseados en el color de las imágenes con transparencia, no utilice la compresión con pérdida al exportar.

Texto

Al exportar a SWF o FLA, puede optar por convertir el contenido en texto Flash o en contornos o píxeles. El texto que se exporta como texto clásico de Flash se puede seguir editando al abrir el archivo FLA con Adobe Flash CS5 Professional, y cuando se guarda como archivo SWF se puede buscar en navegadores web.

Imágenes

Durante la exportación de imágenes a SWF o FLA, puede cambiar la compresión de la imagen, la calidad JPEG y la configuración de la resolución.

Cuando exporta imágenes a FLA, si alguna se ha colocado varias veces en el documento de InDesign, se guardará como un solo recurso de imagen con una ubicación compartida. Tenga en cuenta que un número elevado de imágenes vectoriales dentro del documento de InDesign puede causar problemas de funcionamiento en el archivo exportado.

Para reducir el tamaño del archivo, coloque imágenes repetidas en las páginas maestras y evite copiar y pegar imágenes. Si la misma imagen se coloca varias veces en un documento y no se recorta ni se modifica, solo se exportará una copia de la imagen al archivo FLA. Las imágenes copiadas y pegadas se tratan como objetos independientes.

Por defecto, un archivo de Illustrator colocado se trata como una única imagen en el archivo XFL, mientras que un archivo de Illustrator que se ha copiado y pegado genera muchos objetos individuales. Para obtener mejores resultados, coloque la imagen como un archivo PDF en lugar de copiar y pegar desde Illustrator. La acción de copiar y pegar se traduce en varias rutas editables.

Nota:

Puede cambiar las opciones de preferencia para asegurarse de que los objetos de Illustrator se pegan como un objeto en vez de como una colección de pequeños vectores. En las preferencias de Manejo de archivos y portapapeles de Illustrator, seleccione PDF y deseleccione AICB (no admite transparencia). En las preferencias de Administración del Portapapeles de InDesign, seleccione Preferir PDF al pegar y Copiar PDF al Portapapeles.

Efectos de

Antes de exportar a SWF, asegúrese de que los objetos transparentes no se superponen a ningún elemento interactivo, como un botón o un hipervínculo. Si un objeto con transparencia se superpone a un elemento interactivo, es posible que éste pierda su interactividad durante la exportación. Es aconsejable acoplar la transparencia antes de exportar a FLA.

En ocasiones, elegir un método de compresión con pérdida reduce la calidad de las imágenes con transparencia. Al exportar, elija PNG (sin pérdida) para mejorar la calidad.

Atributos 3D

Los archivos SWF y FLA exportados no admiten los atributos 3D.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea