Création d’un calque de caméra et modification des paramètres de caméra

Vous pouvez afficher les Calques 3D à partir de n’importe quel angle et de n’importe quelle distance à l’aide des calques de caméra. Dans le monde réel, il est plus simple de déplacer des caméras à l’intérieur et autour d’une scène que de déplacer ou de faire pivoter la scène elle-même. De même, il est souvent plus simple d’obtenir des vues différentes d’une composition en configurant un calque de caméra et en le déplaçant dans la composition.

Vous pouvez configurer et animer les paramètres de la caméra pour la configurer conformément à une caméra réelle et aux paramètres d’enregistrement du métrage utilisé pour le montage. Vous pouvez également utiliser ces paramètres pour ajouter des comportements de type caméra (flou de profondeur de champ, panoramiques et travellings) aux animations et aux effets synthétiques.

Les caméras affectent seulement les Calques 3D et 2D avec un effet par attribut Caméra de composition. Avec les effets assortis d’un attribut Caméra de composition, vous pouvez utiliser la caméra ou les lumières de la composition active pour visualiser ou éclairer un effet à partir d’angles différents et simuler des effets 3D plus complexes.

Vous pouvez visualiser une composition à travers la caméra active ou à travers une autre caméra personnalisée. La caméra active est la caméra située tout en haut du panneau Montage pour lequel l’option Vidéo est sélectionnée à l’instant courant. La vue de la caméra active correspond au point de vue utilisé pour créer le résultat final et imbriquer des compositions. Si vous n’avez pas créé de caméra personnalisée, la caméra active est la vue par défaut de la composition.

Toutes les caméras sont répertoriées dans le menu Vue 3D en bas du panneau Composition. Vous pouvez y accéder à tout moment.

Il est souvent préférable de régler une caméra depuis l’une des vues 3D personnalisées. Bien évidemment, vous ne pouvez pas voir la caméra lorsque vous regardez à travers pour la manœuvrer.

Exemple de caméra
Exemple de caméra

A. Point ciblé B. Image C. Caméra 

Création d’un calque de caméra

  1. Choisissez Calque > Créer > Caméra ou appuyez sur les touches Ctrl + Alt + Maj + C (Windows) ou Commande + Option + Maj + C (Mac OS).

    Remarque :

    par défaut, les nouveaux calques commencent au début de la durée de la composition. Si vous préférez que les nouveaux calques commencent à l’instant présent, désactivez la préférence Créer des calques à l’instant de début de la composition (Édition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS)).

Modification des paramètres de la caméra

Vous pouvez modifier les paramètres de la caméra à tout moment.

  1. Cliquez deux fois sur le calque de caméra dans le panneau Montage ou sélectionnez le calque avant de choisir Calque > Paramètres de la caméra.

Remarque :

l’option Prévisualisation est sélectionnée par défaut dans la boîte de dialogue Paramètres de la caméra. Cette option présente les modifications de la composition au fur et à mesure que vous les apportez dans la boîte de dialogue Paramètres de la caméra.

Paramètres de caméra

Pour modifier à tout moment les paramètres de caméra, cliquez deux fois sur le calque dans le panneau Montage ou sélectionnez le calque, puis choisissez Calque > Paramètres de la caméra.

Remarque :

Sélectionnez Prévisualisation dans la boîte de dialogue Paramètres de la caméra pour afficher, de manière dynamique, les résultats de vos changements dans le panneau Composition.

Remarque :

la distance focale, l’ouverture et la distance de mise au point sont les trois facteurs ayant une incidence sur la profondeur de champ. Une petite profondeur de champ résulte d’une distance focale longue, d’une distance de mise au point courte et d’une grande ouverture (F-stop plus petit). Plus la profondeur de champ est petite, plus le fond est flou. Le contraire d’une petite profondeur de champ est une mise au point profonde : le fond est moins flou, car la mise au point couvre une zone plus large.  

Les propriétés relatives au flou objectif appareil photo et à la forme sont notamment Forme, Rotation, Arrondi, Format, Frange de diffraction du diaphragme, Gain des tons clairs, Seuil des tons clairs et Saturation des tons clairs.

Type

Caméra à un ou à deux nœuds. Une caméra à un nœud s’oriente autour d’elle-même, tandis qu’une caméra à deux nœuds a un point ciblé autour duquel elle s’oriente. La configuration d’une caméra en caméra à deux nœuds revient à définir l’option d’orientation automatique d’une caméra (Calque > Transformer > Orientation automatique) sur Orienter vers le point ciblé (voir Options d’orientation automatique).

Nom

Nom de la caméra. Par défaut, Caméra 1 est le nom de la première caméra créée dans une composition. Le nom des autres caméras est attribué dans l’ordre croissant. Chaque caméra doit avoir un nom distinct qui permet de l’identifier.

Paramètre prédéfini

Type de paramètres de caméra à utiliser. Ces paramètres prédéfinis sont nommés d’après les longueurs focales. Chaque paramètre prédéfini représente le comportement d’une caméra 35 mm avec une lentille d’une certaine distance focale. Il définit également l’angle d’ouverture, le zoom, la distance de mise au point, la distance focale et l’ouverture. Le paramètre prédéfini par défaut est 50 mm. Vous pouvez également créer une caméra personnalisée en spécifiant de nouvelles valeurs pour ces paramètres.

Zoom

Distance entre l’objectif et le plan de l’image. En d’autres termes, un calque se trouvant à une distance égale à la distance de l’objectif est affiché en grandeur réelle, un calque se trouvant à une distance égale à deux fois la distance de l’objectif apparaît en demi-format (demi-hauteur et demi-largeur), etc.

Angle d’ouverture

Largeur de la scène capturée dans l’image. La distance focale, le format du film et le zoom déterminent l’angle d’ouverture. Un angle d’ouverture large crée un résultat identique à celui d’un objectif grand angle.

Profondeur de champ

Applique des variables personnalisées aux paramètres Distance de mise au point, Ouverture, F-Stop et Niveau de flou. Ces variables vous permettent de manipuler la profondeur de champ pour créer des effets réalistes de mise au point de la caméra. (La profondeur de champ est l’étendue de la distance utilisée pour la mise au point de l’image. Les images à l’extérieur de l’étendue de la distance sont floues.)

Distance de mise au point

Distance entre la caméra et le plan de mise au point parfaite.

Remarque :

Pour verrouiller le plan focal sur le point ciblé de la caméra, de telle sorte que la mise au point soit effectuée sur celui-ci, ajoutez cette expression à la propriété « Distance de mise au point » : length (position, pointOfInterest)

Verrouillage zoom

Met en adéquation la valeur de zoom et la valeur de distance de mise au point.

Remarque :

si vous modifiez les paramètres des options de zoom ou de distance de mise au point dans le panneau Montage, la valeur de distance de mise au point devient indépendante de la valeur de zoom. Si vous modifiez ces valeurs et voulez qu’elles restent verrouillées, utilisez la boîte de dialogue Paramètres de la caméra au lieu du panneau Montage. Une autre solution consiste à ajouter une expression à la propriété Distance de mise au point dans le panneau Montage. Pour cela, sélectionnez la propriété Distance de mise au point, puis choisissez Animation > Ajouter l’expression et faites glisser l’icône de sélection d’expression vers la propriété Zoom (voir Principes de base des expressions).

Ouverture

Taille de l’ouverture de la lentille. Le paramètre d’ouverture affecte également la profondeur du champ : plus l’ouverture est grande, plus la profondeur de flou du champ augmente. Lorsque vous modifiez ce paramètre, les valeurs F-Stop sont modifiées en conséquence.

Remarque :

avec une vraie caméra, l’augmentation de l’ouverture laisse entrer davantage de lumière dans l’objectif, ce qui affecte l’exposition. Comme la plupart des applications de montage et d’animation 3D, After Effects ignore le résultat des modifications des valeurs d’ouverture.

F-Stop

Représente le rapport entre la distance focale et l’ouverture. Sur la plupart des caméras, la taille d’ouverture est exprimée en unités F-Stop. La plupart des photographes utilisent ainsi la mesure F-Stop pour définir la taille de l’ouverture. Lorsque vous modifiez les valeurs F-Stop, les valeurs d’ouverture sont modifiées en conséquence.

Niveau de flou

Niveau de profondeur du flou dans une image. 100 % crée un flou naturel, conforme aux paramètres de la caméra. Une valeur inférieure réduit le flou.

Format du film

Format de la zone d’exposition du film, directement associé au format de la composition. Lorsque vous modifiez les valeurs de format du film, la valeur de zoom change pour adopter la perspective d’une caméra réelle.

Distance focale

Distance entre le plan du film et l’objectif de la caméra. Dans After Effects, la position de la caméra représente le centre de l’objectif. Lorsque vous modifiez le format du film, la valeur de zoom change pour adopter la perspective d’une caméra réelle. Les valeurs des options Paramètre prédéfini, Angle de vue et Ouverture sont également modifiées en conséquence.

Unités

Unités de mesure utilisées pour exprimer les valeurs des paramètres de caméra.

Mesurer le format du film

Dimensions utilisées pour représenter le format du film.

Remarque :

pour obtenir de meilleurs résultats, utilisez le mode 32 bpc en activant l’option Espace de travail linéaire dans les paramètres du projet.

Commandes de caméra

After Effects s’accompagne de commandes de caméra qui peuvent être utilisées indépendamment ou conjointement avec la fonction Créer système 3D stéréo. Pour les utiliser, sélectionnez un calque de caméra, puis cliquez sur Calque > Caméra.

Lier la distance de mise au point au point ciblé

Crée une expression sur la propriété Distance de mise au point d’un calque de caméra sélectionné, en définissant la valeur de la propriété sur la distance entre la caméra et son point ciblé.

Lier la distance de mise au point au calque

Crée une expression sur la propriété Distance de mise au point d’un calque de caméra sélectionné pour qu’elle corresponde à la distance entre la position de la caméra et un autre calque. Cette méthode permet à la mise au point de suivre automatiquement l’autre calque.

Définir la distance de mise au point sur Calque

Définit la valeur de la propriété Distance de mise au point à l’instant présent sur la distance à l’instant présent entre la caméra et le calque sélectionné.

Ressources en ligne relatives aux caméras

Pour visionner un didacticiel vidéo qui explique comment créer et modifier une caméra et comment utiliser les outils Caméra, rendez-vous sur le site Web d’Adobe.

Dale Bradshaw met à disposition, sur le site Web Creative Workflow Hacks, un script et un projet-type permettant d’automatiser la manipulation de la caméra.

Mark Christiansen propose des conseils et des techniques détaillées sur l’utilisation de caméras dans le chapitre « Virtual Cinematography in After Effects » de son livre After Effects Studio Techniques, disponible sur le site web Press de Peachpit. Ce chapitre contient des informations sur la correspondance de distorsion optique, l’exécution de mouvements de caméra, la réalisation d’une projection de caméra (mappage), l’utilisation d’un plan de mise au point suivie, la création d’un flou « bokeh », l’utilisation de grain et la sélection d’une cadence d’images correspondant à la narration.

Trish et Chris Meyer proposent un didacticiel illustrant l’utilisation des Calques 3D, des lumières et des caméras dans un extrait de leur livre After Effects Apprentice, disponible au format PDF sur le site Web Focal Press.

Sur son site Web Vidéo Copilot, Andrew Kramer présente dans un didacticiel vidéo en deux parties le mappage et la projection de base de caméras. Il y explique comment projeter une image sur des calques 3D à l’aide de lumières et des propriétés de transmission de la lumière.

Création d’une lumière et modification des paramètres de lumière

Un calque de lumière peut, en fonction des paramètres de lumière et des propriétés des options de surface des Calques 3D, modifier les couleurs des Calques 3D qu’il éclaire. Par défaut, chaque lumière est dirigée vers son point ciblé.

Des lumières peuvent être utilisées pour illuminer des calques 3D et pour projeter des ombres. Vous pouvez utiliser des lumières pour recréer les conditions de luminosité de la scène dans laquelle vous composez ou pour créer des effets visuels plus intéressants. Par exemple, vous pouvez utiliser des calques de lumière pour créer l’apparence d’un flux de lumière à travers un calque vidéo comme s’il s’agissait d’un vitrail.

Vous pouvez animer tous les paramètres d’une lumière, à l’exception du type de lumière et de la propriété « Projette une ombre ».

Types de lumière : Concentrée (en haut à gauche) ; Point (en haut à droite) ; Parallèle (en bas à gauche) ; Ambiante (en bas à droite)
Types de lumière : Concentrée (en haut à gauche) ; Point (en haut à droite) ; Parallèle (en bas à gauche) ; Ambiante (en bas à droite)

A. Point ciblé B. Icône de la lumière 

Vous pouvez choisir les Calques 3D qui seront affectés par une lumière en désignant le calque de lumière comme calque d’effets : dans le panneau Montage, placez la lumière au-dessus des calques que vous souhaitez éclairer. Tous les calques situés au-dessus du calque d’effets de lumière dans l’ordre d’empilement des calques du panneau Montage ne sont pas éclairés, quelle que soit la position des calques dans le panneau Composition.

Création d’une lumière

  1. Sélectionnez Calque > Créer > Lumière ou appuyez sur les touches Ctrl + Alt + Maj + L (Windows) ou Commande + Option + Maj + L (Mac OS).

    Lorsque vous créez une lumière, son type d’éclairage est inclus dans son nom. Par exemple, si vous ajoutez un projecteur, il est nommé « Projecteur 1 ».

    Si vous changez de type d’éclairage, son nom est automatiquement modifié. C’est le cas même s’il n’est pas modifié manuellement et à la condition que le type d’éclairage ne soit pas modifié dans le panneau Montage. Par exemple, si « Projecteur 1 » devient un éclairage Ponctuel, After Effects le renomme automatiquement « Eclairage Ponctuel 1 ».

    Remarque :

    par défaut, les nouveaux calques commencent au début de la durée de la composition. Si vous préférez que les nouveaux calques commencent à l’instant présent, désactivez la préférence Créer des calques à l’instant de début de la composition (Édition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS)).

Modification des paramètres de lumière

  1. Cliquez deux fois sur un calque de lumière dans le panneau Montage ou sélectionnez le calque et choisissez Calque > Paramètres de lumière.

    Remarque :

    Sélectionnez Prévisualisation dans la boîte de dialogue Paramètres de lumière pour afficher, de manière dynamique, les résultats de vos changements dans le panneau Composition.

Paramètres de lumière

Type de lumière

« Parallèle » émet une lumière directionnelle, libre à partir d’une source à distance infinie, telle que le soleil. « Concentrée » émet une lumière provenant d’une source limitée par un cône, comme une lampe de poche ou les projecteurs utilisés dans les productions en studio. Une lumière point émet une lumière omnidirectionnelle libre, comme les rayons d’une ampoule. Une lumière ambiante n’a aucune source, mais contribue à la luminosité générale d’une scène et ne projette aucune ombre.

Remarque :

comme la position dans l’espace d’une lumière ambiante n’affecte pas son influence sur les autres calques, une lumière ambiante n’a pas d’icône dans le panneau Composition.

Intensité

Luminosité de la lumière. Une valeur négative crée un état sans lumière. Cette option soustrait la couleur d’un calque. Par exemple, si un calque est déjà éclairé, la création d’une lumière directionnelle pointant sur ce calque avec des valeurs négatives assombrit une zone du calque.

Couleur

Couleur de la lumière.

Angle du cône

Angle du cône entourant la source de lumière, qui détermine la largeur du faisceau à une certaine distance. Cette option est active uniquement si vous avez spécifié le type de lumière Concentrée. L’angle du cône d’une lumière Concentrée est indiquée par la forme de l’icône de lumière dans le panneau Composition.

Remarque :

dans After Effects CS6 ou version ultérieure, le cône d’un projecteur sélectionné peut être étendu vers le point ciblé.

Contour du cône

Douceur du contour d’une lumière concentrée. Cette option est active uniquement si vous avez spécifié le type de lumière Concentrée.

Retrait

Type de retrait pour une lumière parallèle, fixe ou directionnelle. Le retrait décrit de quelle manière l’intensité d’une lumière s’amoindrit en fonction de la distance.

Pour plus de détails, des didacticiels et des ressources sur l’affaiblissement de lumière, reportez-vous à cet article sur le site Web d’Adobe.

Les types de retrait sont les suivants :

Aucun

La luminosité ne diminue pas à mesure que la distance augmente entre le calque et la lumière.

Lisse

Correspond à un retrait linéaire lisse commençant au rayon de départ du retrait et s’étendant sur la longueur spécifiée par la distance de retrait.

Intervertir carré encastré

Indique un retrait physiquement précis commençant au rayon de départ du retrait et décroissant proportionnellement jusqu’au carré inverse de la distance.

Rayon

Définit le rayon du retrait issu d’une lumière. La lumière est constante à l’intérieur de cette distance. Au-delà, la lumière décroît.

Distance de retrait

Définit la distance à laquelle tombe une lumière.

Projette une ombre

Indique si la source de lumière génère la projection d’une ombre par le calque. L’option de surface Accepte les ombres doit être activée si vous voulez qu’une ombre soit projetée sur un calque. Il s’agit du paramètre par défaut. L’option de surface Projette une ombre doit être activée si vous voulez qu’un calque projette des ombres. Il ne s’agit pas du paramètre par défaut.

Remarque :

Appuyez sur les touches Alt + Maj + C (Windows) ou Option + Maj + C (Mac OS) pour activer/désactiver l’option Projette une ombre pour les calques sélectionnés. Pour afficher les propriétés des options de surface dans le panneau Montage, appuyez sur AA.

Obscurité de l’ombre

Définit l’intensité de l’ombre. Cette option est active uniquement si l’option Projette une ombre est sélectionnée.

Diffusion de l’ombre

Définit l’atténuation d’une ombre en fonction de sa distance apparente à partir du calque d’ombre. Plus sa valeur est élevée, plus l’ombre est diffuse. Cette option est active uniquement si l’option Projette une ombre est sélectionnée.

Ressources en ligne sur les lumières

Sur le site Web Creative COW, Eran Stern propose un didacticiel vidéo illustrant l’utilisation de lumières comme calques d’effets, dans le but de contrôler avec précision les calques affectés par les différentes lumières.

Dans un article sur le site Web ProVideo Coalition, Chris et Trish Meyer proposent des conseils sur les ombres et les lumières en 3D.

Trish et Chris Meyer proposent un didacticiel illustrant l’utilisation des Calques 3D, des lumières et des caméras dans un extrait de leur livre After Effects Apprentice, disponible au format PDF sur le site Web Focal Press.

Sur le site Web Artbeats, Chris et Trish Meyer proposent un didacticiel qui explique comment projeter une vidéo sur d’autres calques (un mur par exemple) à l’aide de lumières et de Calques 3D.

Réglage d’une vue 3D ou déplacement d’une caméra, d’une lumière ou d’un point ciblé

Les calques de caméra et de lumière comportent une propriété Point ciblé qui représente le point sur lequel la caméra ou la lumière pointe dans la composition. Par défaut, le point ciblé pointe sur le centre de la composition. Vous pouvez déplacer le point ciblé à tout moment.

Une caméra à un nœud ignore le point ciblé (voir Paramètres de la caméra).

Pour qu’une lumière ignore son point ciblé, sélectionnez une option autre qu’Orienter vers le point ciblé dans les options d’orientation automatique de la lumière (voir Options d’orientation automatique).

Remarque :

vous pouvez modifier les propriétés d’une caméra ou d’une lumière directement dans le panneau Montage, tout comme n’importe quelle autre propriété.

Déplacement d’une caméra, d’une lumière ou d’un point ciblé à l’aide des outils Sélection et Rotation

  1. Sélectionnez un calque de caméra ou de lumière.
  2. A l’aide de l’outil Sélection ou Rotation, Utilisez l’une des méthodes suivantes :
    • Pour déplacer la caméra ou la lumière et son point ciblé, placez le pointeur sur l’axe que vous souhaitez régler et faites-le glisser.

    • Pour déplacer la caméra ou la lumière le long d’un seul axe sans déplacer le point ciblé, faites glisser l’axe tout en maintenant enfoncée la touche Ctrl (Windows) ou Commande (Mac OS).

    • Pour déplacer la caméra ou la lumière librement sans déplacer le point ciblé, faites glisser l’icône de la caméra  ou l’icône de la lumière.

    • Pour déplacer le point ciblé, faites glisser son icône .

Déplacement ou réglage d’une caméra ou utilisation de la vue 3D avec les outils Caméra

Vous pouvez régler les propriétés Position et Point ciblé d’une caméra à l’aide des outils Caméra du panneau Composition.

Vous pouvez également utiliser des outils Caméra pour ajuster une vue 3D de travail, une vue 3D qui n’est pas associée à un calque de caméra. Vous pouvez considérer les vues 3D comme des caméras virtuelles qui vous permettent de visualiser et de prévisualiser une composition. Les vues 3D de travail incluent les vues personnalisées et les vues orthographiques fixes (Avant, Gauche, Haut, Arrière, Droite ou Bas). Les vues 3D de travail sont utiles pour placer et prévisualiser des éléments dans une scène 3D. Si vous utilisez un outil Caméra pour régler une vue 3D de travail, aucune valeur de propriété de calque n’est affectée.

Une fois que vous avez modifié une vue 3D, vous pouvez la réinitialiser en choisissant Vue > Réinitialiser la vue 3D.

Vous ne pouvez pas utiliser d’outil Orbite caméra sur les vues orthographiques fixes.

Pour plus d’informations sur la sélection et l’utilisation de vues 3D, voir Choix d’une vue 3D.

  1. Dans le menu Vue 3D en bas du panneau Composition, choisissez la vue de caméra ou la vue 3D à ajuster.
  2. Activez un outil Caméra.

    Vous pouvez activer un outil Caméra en le sélectionnant dans le panneau Outils ou en appuyant sur C pour parcourir les outils Caméra. La manière la plus simple d’alterner entre les divers outils Caméra consiste à sélectionner l’outil Caméra unifiée et à utiliser les boutons d’une souris à trois boutons.

    Orbite caméra

    Fait pivoter la vue 3D ou la caméra autour du point ciblé (pour activer temporairement l’outil Orbite caméra lorsque l’outil Caméra unifiée est sélectionné, maintenez le bouton gauche de la souris enfoncé).

    Remarque :

    Le fait de faire glisser la souris en maintenant le bouton Maj enfoncé lorsque l’outil Caméra unifiée est sélectionné active temporairement l’outil Orbite caméra et contraint la rotation sur un axe.

    Approche caméra XY

    Ajuste la vue 3D ou la caméra horizontalement ou verticalement (pour activer temporairement l’outil Approche caméra XY lorsque l’outil Caméra unifiée est sélectionné, maintenez le bouton central de la souris enfoncé).

    Approche caméra Z

    Ajuste la vue 3D ou la caméra le long de l’axe vers le point ciblé. Si vous utilisez une vue orthographique, cet outil ajuste l’échelle de la vue (pour activer temporairement l’outil Approche caméra Z lorsque l’outil Caméra unifiée est sélectionné, maintenez le bouton droit de la souris enfoncé).

  3. Faites glisser l’outil dans le panneau Composition. Vous pouvez poursuivre en dehors du panneau une opération de glissement commencée dans le panneau.

Une fois que vous avez modifié une vue 3D, vous pouvez la réinitialiser en choisissant Vue > Réinitialiser la vue 3D.

Déplacement ou réglage d’une caméra ou utilisation d’une vue 3D pour afficher les calques

Il est également possible de déplacer une caméra ou d’ajuster une vue 3D afin d’afficher les calques sélectionnés ou tous les calques. After Effects modifie la perspective et l’orientation de la vue afin d’inclure les calques sélectionnés.

  • Sélectionnez Affichage > Afficher les calques sélectionnés afin d’ajuster une vue 3D ou de déplacer une caméra pour afficher les calques sélectionnés.
  • Sélectionnez Affichage > Afficher tous les calques afin d’ajuster une vue 3D ou de déplacer une caméra pour afficher tous les calques.

Pour connaître les raccourcis clavier pour ces commandes, voir Calques 3D (raccourcis clavier).

Conseils et ressources en ligne sur le déplacement et l’animation de caméras et de lumières

Choisissez une vue autre que Caméra active avant de déplacer une caméra. Avec la vue Caméra active, vous regardez par l’intermédiaire de la caméra, ce qui rend la gestion plus complexe.

L’image filaire d’une caméra est par défaut visible uniquement lorsque la caméra est sélectionnée. Pour que l’image filaire s’affiche toujours, définissez les options d’affichage du panneau Composition (Affichage > Options d’affichage) (voir Affichage ou masquage des options du calque dans le panneau Composition).

Lors de l’utilisation d’un calque de caméra ou de lumière, créez un calque d’objet nul et utilisez une expression pour lier la propriété Point ciblé de la caméra ou de la lumière à la propriété Position du calque nul. Ensuite, vous pouvez animer la propriété Point ciblé en déplaçant l’objet nul. Il est souvent plus simple de sélectionner et de voir un objet nul que de sélectionner et de voir un point ciblé.

After Effects propose une commande de caméra appelée « Créer orbite nulle ». Elle apparente le calque de caméra sélectionné à un nouveau calque nul. Le nouveau calque nul est renommé, en fonction du nom de la caméra annexé à Orbite nulle.

Trish et Chris Meyer vous expliquent comment utiliser la commande de caméra Créer orbite nulle dans ce didacticiel vidéo sur Adobe TV.

Pour visionner un didacticiel vidéo qui explique comment créer et modifier une caméra et comment utiliser les outils Caméra, rendez-vous sur le site Web d’Adobe.

Trish et Chris Meyer proposent un didacticiel illustrant l’utilisation des calques 3D, des lumières et des caméras dans un extrait de leur livre After Effects Apprentice, disponible au format PDF sur le site Web Focal Press.

Mark Christiansen propose des conseils et des techniques détaillées sur l’utilisation de caméras dans le chapitre « Virtual Cinematography in After Effects » de son livre After Effects Studio Techniques, disponible sur le site web Press de Peachpit. Ce chapitre contient des informations sur la correspondance de distorsion optique, l’exécution de mouvements de caméra, la réalisation d’une projection de caméra (mappage), l’utilisation d’un plan de mise au point suivie, la création d’un flou « bokeh », l’utilisation de grain et la sélection d’une cadence d’images correspondant à la narration.

Sur son site Web AE Portal, Rich Young propose un ensemble d’expressions qui utilisent la méthode toWorld pour lier une caméra et la lumière à un calque avec l’effet CC Sphere.

Andrew Devis de Creative COW a créé une série de 3 didacticiels traitant de l’animation d’une caméra :

Cette vidéo de Video2Brain illustre la commande permettant de créer une caméra à orbite nulle.

Propriétés des options de surface

Les Calques 3D ont des propriétés d’options de surface, qui déterminent l’interaction d’un calque 3D avec la lumière et les ombres.

Projette une ombre

Indique si un calque projette une ombre sur d’autres calques. La direction et l’angle des ombres sont déterminés par la direction et l’angle des sources de lumière. Choisissez l’option Projette une ombre Seul(e) pour faire en sorte que le calque soit invisible, mais projette quand même une ombre.

Remarque :

Pour projeter les couleurs d’un calque invisible sur un autre calque, utilisez l’option Seul(e) et définissez le paramètre Transmission de la lumière sur une valeur autre que zéro. Steve Holmes propose, sur le site Web Artbeats, un didacticiel dans lequel il explique comment utiliser des calques en définissant la propriété Projeter une ombre sur Seul(e) pour projeter des ombres de formes spécifiques dans une scène 3D.

Transmission de la lumière

Pourcentage de lumière qui perce à travers le calque et qui projette la couleur du calque sur d’autres calques comme une ombre. 0 % signifie qu’aucune lumière ne traverse le calque, que l’ombre projetée est noire. 100 % spécifie que les valeurs complètes des couleurs du calque d’ombre portée sont projetées sur le calque acceptant l’ombre.

Remarque :

Une transmission partielle de la lumière permet de donner l’illusion d’une lumière qui traverse un vitrail.

Accepte les ombres

Indique si le calque fait apparaître les ombres projetées par les autres calques. Une option « Uniquement » est disponible pour « Accepte les ombres » lorsque vous souhaitez simplement effectuer le rendu d’une ombre sur un calque.

Utilise les lumières

Indique si la lumière affecte la couleur d’un calque lorsqu’elle le frappe. Les ombres ne sont pas concernées par ce paramètre.

Ambiant

Niveau réflectif ambiant (non directionnel) du calque. 100 % correspond à une réflectivité maximale ; 0 % correspond à aucune réflectivité ambiante.

Diffus

Niveau de réflectivité diffuse (omnidirectionnelle) du calque. La réflectivité diffuse produit l’effet d’une feuille de plastique monotone recouvrant le calque. La lumière qui atteint ce calque est reflétée dans des proportions égales dans toutes les directions. 100 % correspond à une réflectivité maximale ; 0 % correspond à aucune réflectivité diffuse.

Spéculaire

Niveau de réflectivité spéculaire (directionnelle) du calque. La lumière est réfléchie à partir du calque comme s’il s’agissait d’un miroir. 100 % correspond à une réflectivité maximale ; 0 % correspond à aucune réflectivité spéculaire.

Brillance

Définit la taille du reflet spéculaire. Cette valeur est active uniquement si le paramètre spéculaire est supérieur à zéro. 100 % correspond à une réflexion avec un petit reflet spéculaire. 0 % correspond à une réflexion avec un grand reflet spéculaire.

Métal

Contribution de la couleur du calque à la couleur du reflet spéculaire. 100 % signifie que la couleur du reflet correspond à celle du calque. Par exemple, avec un paramètre Métal de 100 %, l’image d’un anneau d’or reflète une lumière dorée. 0 % signifie que la couleur du reflet spéculaire est celle de la source de lumière. Par exemple, avec un paramètre Métal de 0 %, un calque placé sous une lumière blanche présente un reflet blanc.

Définition de la résolution à utiliser pour le rendu des ombres

Le module de rendu 3D avancé permet d’effectuer le rendu des compositions contenant des calques d’intersection 3D. Pour effectuer le rendu des ombres, le module utilise des matrices d’ombre, c’est-à-dire des images rendues à partir de la perspective de chaque source de lumière. Normalement, la résolution de l’ombre est calculée automatiquement en fonction de la résolution de la composition et les paramètres de qualité des calques. Si la résolution normale ne produit pas la qualité escomptée ou si elle donne un rendu trop lent, vous pouvez régler la résolution du calque d’ombre. Par exemple, si les ombres sont floues et que l’option de surface Diffusion de l’ombre est définie sur 0, augmentez la résolution de la matrice d’ombre. Si le rendu des ombres est trop long, réduisez la résolution de la matrice d’ombre.

Lorsqu’un calque avec une ombre projetée croise un autre calque, un petit espace apparaît parfois derrière l’intersection censée se trouver dans l’ombre. Pour réduire la taille de cet espace, augmentez la résolution de la matrice des ombres.

3D stéréoscopique

Vous pouvez créer des vidéos 3D stéréoscopiques avec Adobe After Effects.

Pour obtenir des didacticiels, des détails et des ressources sur la 3D, consultez cet article sur le site Web d’Adobe.

Pour en savoir plus sur le workflow 3D stéréoscopique dans After Effects, consultez l’article Understanding Stereoscopic 3D in After Effects (Présentation de l’effet 3D stéréoscopique dans After Effects).

Mark Christiansen présente un métrage 3D stéréoscopique (en utilisantdes clipsgratuits d’Artbeats).

Système caméra stéréoscopique 3D

After Effects dispose d’une commande de menu Créer système 3D stéréo qui vous permet de transformer une composition 3D normale en une composition 3D stéréoscopique. Cette fonction crée tous les éléments à votre place, y compris l’effet Lunettes 3D.

Pour créer un système caméra 3D stéréoscopique, vous devez d’abord créer une composition contenant des éléments 3D. Une composition contenant des éléments tels qu’une précomposition 3D réduite ou des éléments 3D de la composition proprement dite convient parfaitement. Si une caméra est déjà en cours d’utilisation, vous pouvez la sélectionner lors de la création du système caméra 3D stéréoscopique. Si aucune caméra n’est sélectionnée, le système en crée une (qu’il nomme Caméra principale). Sélectionnez Calque > Caméra > Créer système 3D stéréo. Le système fonctionne uniquement avec des caméras à deux nœuds.

Le système est généré en créant une caméra principale ou en utilisant la caméra existante sélectionnée dans la composition. Il existe des compositions de type œil gauche [comparaison œil gauche] et œil droit [comparaison œil droit]. Chacune d’elles possède une caméra liée à la caméra principale, la composition d’origine imbriquée et une composition 3D stéréo de sortie [comparaison 3D stéréo]. La composition 3D stéréo de sortie imbrique les deux compositions « œil » et contient un calque nommé Options 3D stéréo. Ce calque comporte un effet Options 3D stéréo qui contrôle le système, ainsi qu’un effet Lunettes 3D qui combine les deux compositions « œil droit » et « œil gauche » en une seule image stéréo (voir Effet Lunettes 3D.)

Remarque :

Options 3D stéréo est un effet intégré dans le système 3D stéréo. Il ne réside pas dans le panneau Effets et paramètres prédéfinis.

L’effet Options 3D stéréo se compose des paramètres suivants pour la Séparation de la caméra et la Convergence :

Configuration

Centre positionne les caméras gauche et droite de chaque côté de la caméra principale. Directeur gauche positionne la caméra gauche au même emplacement que la caméra principale, avec la caméra droite à droite. A l’inverse, Directeur droit positionne la caméra droite à l’emplacement de la caméra principale, avec la caméra gauche à gauche.

Profondeur de scène stéréo

Contrôle la séparation interaxiale entre les caméras, sous la forme d’un pourcentage de la largeur de composition. De cette manière, si la composition est redimensionnée, le degré de séparation reste constant. Ce paramètre démarre à une valeur faible de 3 %, ce qui garantit un effet léger. Il est recommandé de ne pas dépasser une valeur de 14 % à 30 % afin de bénéficier d’un métrage 3D de qualité acceptable. Elle peut toutefois être plus élevée en fonction du contenu de la scène (objets très rapprochés) et du champ de vision de la caméra, par exemple.

Remarque :

La modification de cette valeur affecte la profondeur de la 3D stéréo par rapport à la scène. La sélection d’une valeur trop élevée peut entraîner une fatigue oculaire.  

Converger caméras

Si cette option est désactivée, les caméras restent parallèles à la caméra principale, mais décalées de chaque côté. Si elle est activée, la position reste décalée. Cependant, les points ciblés des caméras gauche et droite se rejoignent à un emplacement sur la base des deux propriétés suivantes.

Converger vers et Décalage Z de convergence

Ces options déterminent la distance Z par rapport à la caméra à laquelle semble se trouver l’écran lorsque l’on regarde à travers des lunettes 3D. Tout élément situé plus loin dans l’espace Z semble être « enfoncé » dans l’écran, tandis que les éléments rapprochés donnent l’impression d’en ressortir. Lorsque vous travaillez sans activer la case Converger caméras, et que les caméras sont parallèles, la modification de la convergence de scène revient à changer le décalage Z. Dans ce cas, utilisez le mode Différence pour définir différents éléments de la scène sur la surface de l’écran (voir Effet Lunettes 3D.)

Présentation de l’effet 3D stéréoscopique

Si vous utilisez l’effet 3D stéréoscopique, vous ne devez pas nécessairement disposer d’un téléviseur 3D. Vous pouvez, par exemple, utiliser des lunettes 3D anaglyphes (rouge/cyan) et visionner directement le métrage stéréoscopique 3D dans le panneau Composition. Cependant, vous pouvez également utiliser un téléviseur 3D pour procéder à du montage en direct à l’aide d’un téléviseur de ce type et de lunettes à obturateur électronique actives. Dans ce cas, l’utilisation des éléments suivants est nécessaire :

  • Moniteur ou téléviseur prenant en charge l’affichage stéréoscopique 3D.
  • Lunettes pour regarder la télévision 3D stéréoscopique.

Remarque :

pour ce workflow, utilisez des lunettes à obturateur actives nécessitant un dispositif de transmission. Veillez à utiliser les lunettes recommandées par le fabricant du téléviseur.

  • Métrage stéréoscopique ou composition 3D.

Dès que vous disposez de ces éléments, procédez comme suit :

  1. Connectez le téléviseur 3D à l’ordinateur à l’aide d’un câble HDMI (un câble DVI est acceptable en l’absence de connexion HDMI).

  2. Créez une composition 3D dans After Effects. Assurez-vous que la taille de la composition correspond à la résolution actuelle de votre moniteur de sortie.

  3. Créez un panneau Composition pour votre composition 3D stéréo. Verrouillez la composition, puis faites-la glisser vers votre moniteur ou téléviseur 3D.

  4. Assurez-vous que le panneau Composition est réglé sur 100 %.

  5. Appuyez deux fois sur Ctrl + \ (barre oblique inverse) pour définir la composition sur le mode plein écran pour le téléviseur 3D. Réglez des dimensions identiques pour la composition et le téléviseur 3D.

  6. Faites basculer la vue 3D de l’effet Lunettes 3D sur l’une des options suivantes :

    • Paire stéréo

    • Dessus Dessous

    • Entrelacé

  7. Activez le mode 3D de votre téléviseur 3D et faites correspondre le format à celui défini dans la vue 3D pour l’effet Lunettes 3D. (Les fonctions Paire stéréo et Dessus Dessous sont prises en charge sur la plupart des téléviseurs 3D.)

  8. Mettez vos lunettes 3D et modifiez votre composition en 3D stéréoscopique authentique.

Conseils relatifs à la 3D stéréoscopique

  • Si vous traitez du métrage stéréoscopique 3D dans le panneau Composition, mais ne disposez pas d’un téléviseur 3D, vous pouvez utiliser le format anaglyphe. Les lunettes 3D anaglyphes rouge et cyan standard fonctionnent de manière optimale avec ce workflow stéréoscopique 3D.

  • Augmentez ou diminuez la valeur Profondeur de scène stéréo pour modifier la profondeur de l’environnement 3D.

  • Cochez la case Converger caméras et modifiez la valeur Décalage Z de convergence pour déplacer différents objets à l’arrière et à l’avant de l’écran. Les objets plus proches de la caméra que le décalage Z apparaissent à l’avant-plan, tandis que les objets plus éloignés apparaissent à l’arrière-plan.

  • Vous pouvez faire correspondre la profondeur de champ de votre composition à la convergence de votre caméra stéréoscopique en effectuant l’une des opérations suivantes :

    • Si vous utilisez l’option « Lier la distance de mise au point au point ciblé » sur la caméra principale et convergez les caméras pour le système, la profondeur de champ correspond à la convergence 3D stéréoscopique.

    • Si vous souhaitez que la profondeur de champ change graduellement, vous pouvez animer la distance de mise au point de la caméra principale. Réglez ensuite le point de convergence pour qu’il converge à partir de « Position de la caméra » et définissez une expression qui lie le décalage Z de convergence à la distance de mise au point de la caméra principale

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne