Guide d'utilisation Annuler

Amélioration des performances

  1. Guide de lʼutilisateur dʼAfter Effects
  2. Versions Beta
    1. Présentation du programme Beta
    2. Accueil After Effects Beta
    3. Fonctionnalités de la version Beta
      1. Panneau Propriétés (Beta)
      2. Calques cache de piste sélectionnables (Bêta)
      3. Codage H.264 natif (Bêta)
  3. Prise en main
    1. Prise en main dʼAfter Effects
    2. Nouveautés dʼAfter Effects
    3. Notes de mise à jour | After Effects
    4. Configuration requise pour After Effects
    5. Raccourcis clavier dans After Effects
    6. Formats de fichier pris en charge | After Effects
    7. Recommandations matérielles
    8. After Effects pour puce Apple
    9. Planification et configuration
    10. Configuration et installation
  4. Espaces de travail
    1. Eléments généraux de lʼinterface utilisateur
    2. Familiarisation avec lʼinterface dʼAfter Effects
    3. Workflows
    4. Espaces de travail, panneaux et visualiseurs
  5. Projets et compositions
    1. Projets
    2. Notions de base relatives aux compositions
    3. Précomposition, imbrication et prérendu
    4. Affichage dʼinformations détaillées sur les performances avec le Profileur de composition
    5. Moteur de rendu de composition CINEMA 4D
  6. Importation de métrage
    1. Préparation et importation dʼimages fixes
    2. Importation à partir dʼAfter Effects et dʼAdobe Premiere Pro
    3. Importation et interprétation vidéo et audio
    4. Préparation et importation de fichiers images 3D
    5. Importation et interprétation de métrages
    6. Utilisation des métrages
    7. Détecter les points de montage à l’aide de la détection de montage de scène
    8. Métadonnées XMP
  7. Texte et images
    1. Texte
      1. Mise en forme des caractères et panneau Caractère
      2. Effets de texte
      3. Création et modification des calques de texte
      4. Mise en forme des paragraphes et panneau Paragraphe
      5. Extrusion de calques de texte et de forme
      6. Animation de texte
      7. Exemples et ressources dʼanimation de texte
      8. Modèles Live Text
    2. Animations graphiques
      1. Utilisation de modèles dʼanimations graphiques dans After Effects
      2. Utilisation des expressions pour créer des listes déroulantes dans les modèles dʼanimations graphiques
      3. Utilisation des propriétés essentielles pour créer des modèles dʼanimations graphiques
      4. Remplacement d’images et de vidéos dans les modèles dʼanimations graphiques et les propriétés essentielles
  8. Dessin, peinture et tracés
    1. Présentation des calques de forme, des tracés et des images vectorielles
    2. Outils de peinture : Pinceau, Cloner et Gomme
    3. Effilage des contours de forme
    4. Attributs de forme, opérations de peinture et opérations de tracé pour les calques de forme
    5. Utilisation de lʼeffet de forme Décaler les tracés pour modifier des formes
    6. Création de formes
    7. Création de masques
    8. Suppression dʼobjets de vos vidéos avec le panneau Remplissage dʼaprès le contenu
    9. Roto-pinceau et Améliorer le cache
  9. Calques, marqueurs et caméra
    1. Sélection et disposition de calques
    2. Modes de fusion et styles de calques
    3. Calques 3D
    4. Propriétés du calque
    5. Création de calques
    6. Gestion des calques
    7. Repères de calque et repères de composition
    8. Caméras, lumières et points ciblés
  10. Animation, images clés, suivi de cible et incrustations
    1. Animation
      1. Principes de base de l’animation
      2. Animation avec les outils Marionnette
      3. Gestion et animation de tracés de forme et de masques
      4. Animation de formes Sketch et Capture à lʼaide dʼAfter Effects
      5. Outils dʼanimation divers
      6. Utilisation dʼanimations orientées données
    2. Image clé
      1. Interpolation des images clés
      2. Définition, sélection et suppression dʼimages clés
      3. Modification, déplacement et copie dʼimages clés
    3. Suivi de cible
      1. Suivi et stabilisation du mouvement
      2. Suivi du visage
      3. Suivi de masque
      4. Référence de masque
      5. Vitesse
      6. Extension temporelle et remappage temporel
      7. Code temporel et unités temporelles
    4. Masquage
      1. Incrustations
      2. Effets de masquage
  11. Transparence et montage
    1. Présentation et ressources du montage et de la transparence
    2. Couches alpha et masques
  12. Réglage de la couleur
    1. Principes de base de la couleur
    2. Gestion des couleurs
    3. Effets de correction colorimétrique
  13. Effets et animations prédéfinies
    1. Présentation des effets et animations prédéfinies
    2. Liste dʼeffets
    3. Effets de simulation
    4. Effets esthétiques
    5. Effets audio
    6. Effets de déformation
    7. Effets de perspective
    8. Effets de couches
    9. Effets de rendu
    10. Effets de transition
    11. Effet Réparation dʼobturateur déroulant
    12. Effets de flou et de netteté
    13. Effets de couches 3D
    14. Effets Utilité
    15. Effets de cache
    16. Effets de bruit et de grain
    17. Effet Conservation des détails-Amélioration
    18. Effets obsolètes
  14. Expressions et automatisation
    1. Expression
      1. Principes de base des expressions
      2. Compréhension du langage dʼexpression
      3. Utilisation des options pour expressions
      4. Différences de syntaxe entre le moteur dʼexpressions JavaScript et lʼancien moteur dʼexpressions ExtendScript
      5. Modification des expressions
      6. Erreurs dans les expressions
      7. Utilisation de lʼéditeur dʼexpressions
      8. Utilisation d’expressions pour accéder aux propriétés du texte et les modifier
      9. Référence au langage dʼexpression
      10. Exemples dʼexpressions
    2. Automatisation
      1. Automatisation
      2. Scripts
  15. Vidéo immersive, VR et 3D
    1. Création dʼenvironnements VR dans After Effects
    2. Application d’effets de vidéo immersive
    3. Outils de composition pour les vidéos VR/360
    4. Suivi du mouvement de la caméra 3D
    5. Utilisation de lʼespace de conception 3D
    6. Widgets de transformation 3D
    7. En faire plus avec l’animation 3D
    8. Aperçu des modifications apportées aux conceptions 3D en temps réel avec le moteur en temps réel
    9. Ajout de Responsive Design à vos images
  16. Vues et prévisualisations
    1. Prévisualisation
    2. Prévisualisation vidéo à lʼaide de Mercury Transmit
    3. Modification et utilisation des vues
  17. Rendu et exportation
    1. Notions de base relatives au rendu et à lʼexportation
    2. Exportation dʼun projet After Effects en tant que projet Adobe Premiere Pro
    3. Conversion de films
    4. Rendu multi-images
    5. Rendu automatisé et rendu en réseau
    6. Rendu et exportation dʼimages fixes et de séquences dʼimages fixes
    7. Utilisation du codec GoPro CineForm dans After Effects
  18. Utilisation dʼautres applications
    1. Dynamic Link et After Effects
    2. Utilisation dʼAfter Effects et dʼautres applications
    3. Synchronisation des paramètres dans After Effects
    4. Bibliothèques Creative Cloud dans After Effects
    5. Plug-ins
    6. CINEMA 4D et Cineware
  19. Collaboration : Frame.io et Projets d’équipe
    1. Collaboration dans Premiere Pro et After Effects
    2. Frame.io
      1. Installer et activer Frame.io
      2. Utiliser Frame.io avec Premiere Pro et After Effects
      3. Foire aux questions
    3. Projets dʼéquipe
      1. Prise en main des projets d’équipe
      2. Créer un projet d’équipe
      3. Collaborer sur les projets d’équipe
  20. Mémoire, stockage et performances
    1. Mémoire et stockage
    2. Comment After Effects gère les problèmes de mémoire insuffisante lors de la prévisualisation    
    3. Amélioration des performances
    4. Préférences
    5. Configuration requise du GPU et du pilote GPU pour After Effects

Vous pouvez améliorer les performances en optimisant votre système informatique, After Effects, votre projet et votre workflow. Certaines des suggestions présentées ici améliorent les performances non pas en augmentant la vitesse de rendu, mais en réduisant la durée des autres opérations (l’ouverture d’un projet, par exemple).

Remarque :

La meilleure façon d’optimiser les performances globales consiste encore à planifier votre travail, à exécuter des tests préliminaires de votre workflow et de votre structure de sortie, ainsi qu’à confirmer que le produit que vous livrez est conforme aux attentes et aux exigences de votre client. (Consultez la section Planifier votre travail).

Optimiser les performances avant le lancement d’After Effects

  • Assurez-vous que la dernière version en date d’After Effects est installée, y compris les mises à jour disponibles. Pour rechercher et installer des mises à jour, sélectionnez Aide > Mises à jour.
  • Assurez-vous d’avoir installé les versions les plus récentes des pilotes et modules externes, plus particulièrement des pilotes de carte vidéo. Pour télécharger les mises à jour des pilotes et modules externes, rendez-vous sur le site Web de leurs éditeurs respectifs.
  • Assurez-vous que le système dispose d’une mémoire vive suffisante. Des performances optimales sont atteintes avec des systèmes informatiques disposant d’au moins 2 Go de RAM installée par cœur de processeur. Consultez la documentation accompagnant votre système d’exploitation et votre ordinateur pour connaître la quantité de mémoire vive installée et savoir comment en installer davantage.
  • Fermez les applications dont vous n’avez pas besoin dans l’immédiat. Si vous exécutez des applications autres que celles avec lesquelles After Effects partage un pool de mémoire et que vous n’allouez pas suffisamment de mémoire aux autres applications, les performances risquent d’être considérablement amoindries lorsque le système d’exploitation échange la mémoire vive sur le disque.
  • Arrêtez ou interrompez les opérations gourmandes en ressources dans les autres applications, telles que les prévisualisations vidéo dans Adobe Bridge.
  • Dans la mesure du possible, conservez les fichiers de métrage sources de votre projet sur un disque local rapide. Si vos fichiers de métrage sources sont stockés sur un disque lent (ou accessibles par une connexion réseau ralentie), vos performances seront médiocres. Il est recommandé d’utiliser des disques locaux rapides pour les fichiers de métrage source et la sortie du rendu.
  • L’idéal est de disposer d’un disque (ou d’une unité multidisque) rapide distinct pour affecter le dossier de cache disque. En raison de leur vitesse, les unités SSD sont, elles aussi, parfaitement adaptées à cette fonction.

Améliorer les performances en optimisant les paramètres de mémoire cache

  • Allouez suffisamment de mémoire aux autres applications.
  • Activez la mise en cache des images sur le disque pour les prévisualisations en sélectionnant la préférence Activer le cache de disque. Dans After Effects, affectez autant d’espace que possible au dossier Cache de disque (sur un disque rapide distinct) afin de bénéficier de performances optimales.

Pour obtenir des informations supplémentaires, consultez la section Préférences de mémoire.

Améliorer les performances à l’aide du Cache performances globales | CC, CS6

Importez des projets d’Adobe After Effects 5.5 ou versions antérieures dans After Effects CS afin de tirer parti du Cache performances globales.

Le cache persistant de disque améliore les performances en conservant les images stockées dans le cache disque d’une session à l’autre, ce qui se traduit par un rendu plus rapide lorsque vous travaillez sur un ou plusieurs autres projets susceptibles d’utiliser les mêmes images en cache.

Optimiser les performances en simplifiant le projet

Vous pouvez éviter qu’After Effects utilise de la mémoire et d’autres ressources pour le traitement d’éléments que vous ne manipulez pas actuellement en simplifiant et en divisant votre projet. Vous pouvez, de même, optimiser les performances globales de manière significative en déterminant quand After Effects effectue certains traitements. Vous pouvez, par exemple, éviter de répéter une action qui n’est requise qu’une seule fois, ou différer une action à un moment plus opportun.

  • Supprimez les éléments inutilisés du projet. Consultez la section Supprimer des éléments d’un projet.
  • Divisez les projets complexes en projets plus simples et reconstituez-les avant le rendu du film finalisé. Pour recombiner les projets, importez-les tous dans un seul projet. Consultez la section Importer un projet After Effects.
  • Avant d’effectuer le rendu, placez tous les fichiers sources du métrage sur un disque local rapide (pas sur celui sur lequel vous effectuez le rendu et vers lequel vous exportez des documents). L’option Rassemblement de fichiers vous permet d’effectuer facilement cette opération. (voir la section Rassemblement des fichiers dans un emplacement unique).
  • Effectuez le prérendu des compositions imbriquées. Effectuez le rendu d’une composition finalisée sous forme de film de sorte qu’After Effects n’effectue pas de rendu chaque fois que vous affichez la composition. Consultez la section Effectuer le prérendu d’une composition imbriquée.
  • Quand vous n’utilisez pas directement un élément source, remplacez-le par un proxy d’image fixe ou à faible résolution. Consultez la section Espaces réservés et proxys.
  • Abaissez la résolution de la composition. Consultez la section Résolution.
  • Isolez le calque en cours de manipulation à l’aide de l’option Solo. Consultez la section Isoler un calque.

Optimiser les performances en modifiant la sortie à l’écran

Vous pouvez optimiser les performances de nombreuses façons sans affecter la manière dont After Effects traite les données du projet, mais en affectant uniquement la manière dont la sortie s’affiche à l’écran tout au long de votre travail. Bien qu’il soit souvent utile de visualiser certains éléments et informations en cours de travail, After Effects utilise de la mémoire et des ressources processeur pour mettre à jour ces informations. Choisissez donc avec soin les éléments à afficher lors de votre travail. Si vous souhaitez visualiser différents aspects de votre projet au cours des diverses étapes du workflow, les suggestions suivantes peuvent s’avérer utiles.

  • Désactivez la gestion des couleurs d’affichage et la simulation de la sortie si cela n’est pas nécessaire. Voir la section Simulation de l’apparence des couleurs sur un périphérique de sortie différent. La vitesse et la qualité de la gestion des couleurs pour les prévisualisations sont contrôlées par les préférences Qualité du visualiseur. Consultez la section Préférences de qualité du visualiseur.
  • Activez l’accélération matérielle des prévisualisations à l’aide du GPU pour faciliter la prévisualisation à l’écran. Choisissez Édition > Préférences > Affichage (Windows) ou After Effects > Préférences > Affichage (macOS) et sélectionnez Accélération matérielle pour les panneaux Composition, Calque et Métrage.
  • Fermez les panneaux superflus. After Effects utilise de la mémoire et des ressources processeur pour mettre à jour les panneaux ouverts, ce qui peut ralentir les manipulations effectuées dans un autre panneau.
  • Créez une zone ciblée. Si vous n’utilisez qu’une petite partie de la composition, limitez le rendu à l’écran à cette portion de la composition lors des prévisualisations. Consultez la section Zone ciblée.
  • Désélectionnez l’option Afficher les indicateurs du cache dans le menu du panneau Montage afin d’empêcher After Effects d’afficher des barres vertes et bleues dans l’échelle de temps pour indiquer les images mises en cache.
  • Désélectionnez l’option Afficher l’avancement du rendu dans le panneau Info et organigramme pour empêcher l’affichage à l’écran des détails de chaque opération de rendu pour chaque image. Consultez la section Préférences d’affichage.
  • Masquez l’option Détails du rendu en cours dans le panneau File d’attente de rendu en cliquant sur le triangle situé en regard de cette même option. Consultez la section Informations relatives aux opérations de rendu en cours.
  • Appuyez sur la touche Verr. maj pour empêcher After Effects d’actualiser les panneaux Métrage, Calque ou Composition. Lorsque vous apportez une modification, au lieu de l’afficher, After Effects ajoute une barre rouge complétée d’un texte de rappel au bas du panneau. After Effects continue d’actualiser les options de panneaux telles que les trajectoires, les points d’ancrage et les contours de masque, au fur et à mesure que vous les déplacez. Appuyez de nouveau sur la touche Verr. maj pour rétablir les mises à jour de panneau et l’affichage de toutes les modifications apportées.
Remarque :

Appuyez sur Verr. maj pour suspendre les mises à jour (désactive l’actualisation) de prévisualisations dans les visualiseurs pendant le rendu de la sortie finale, même si aucune barre rouge de rappel ne s’affiche.

  • Diminuez la qualité d’affichage d’un calque sur Ébauche. Voir la section Qualité d’image d’un calque et positionnement des sous-pixels.
  • Sélectionnez Ébauche 3D dans le menu du panneau Montage. Cela désactive l’ensemble des lumières et ombres appliquées aux calques 3D. Cette opération désactive également le flou de profondeur de champ pour un appareil photo.
  • Utilisez le mode Ébauche rapide pendant la mise en forme et la prévisualisation d’une composition 3D avec lancer de rayon en sélectionnant une option autre que « Désactivé » à partir du bouton Prévisualisations rapides.
  • Désélectionnez l’option Mise à jour automatique dans le menu du panneau Montage pour empêcher After Effects de mettre à jour les compositions de manière dynamique. Consultez la section Modes de prévisualisation et préférences de prévisualisations rapides.
  • Affichez les signaux audio dans le panneau Montage uniquement si nécessaire. Consultez la section Afficher les propriétés et les groupes dans le panneau Montage (raccourcis clavier).
  • Désactivez la correction du format des pixels en cliquant sur le bouton Activer/désactiver la correction du format des pixels au bas du panneau Composition, Calque ou Métrage. La vitesse et la qualité de la correction du format des pixels et d’autres mises à l’échelle des prévisualisations sont contrôlées par les préférences Qualité du visualiseur. Consultez la section Préférences de qualité du visualiseur.
  • Désélectionnez l’option Miroir sur le moniteur de l’ordinateur lors de la prévisualisation d’une vidéo sur un moniteur vidéo externe. Consultez la section Prévisualiser sur un moniteur vidéo externe.
  • Masquez les contrôles de calque, tels que les masques, les axes de référence 3D et les poignées de calque. Consultez la section Afficher ou masquer les options du calque dans le panneau Composition.
  • Diminuez l’agrandissement d’une composition. Lorsqu’After Effects affiche les panneaux Composition, Calque et Métrage selon un agrandissement supérieur à 100 %, la vitesse de réaffichage de l’écran diminue. (Consultez la section Zoom sur une image pour prévisualisation).
  • Définissez la valeur Résolution/Sous-échantillonnage de la composition sur Auto dans le panneau Composition, ce qui empêche un rendu inutile des rangées ou des colonnes de pixels qui ne sont pas dessinées à l’écran à des faibles niveaux de zoom. Consultez la section la section Résolution.

Optimiser les performances lors de l’utilisation d’effets

Certains effets, tels que les flous et les déformations, nécessitent une grande quantité de mémoire et de ressources processeur. Vous pouvez optimiser les performances de manière significative en choisissant avec soin comment appliquer ces effets et à quel moment.

  • Appliquez en dernier les effets nécessitant beaucoup de mémoire et de ressources processeur. Animez les calques et réalisez les tâches nécessitant des prévisualisations en temps réel avant d’appliquer les effets gourmands en mémoire et ressources processeur (par exemple, les lueurs et les effets de flou) pour éviter un ralentissement.
  • Désactivez temporairement les effets afin d’accélérer la prévisualisation. Consultez la section Supprimer ou désactiver des effets et des animations prédéfinies.
  • Limitez le nombre de particules générées par les effets Particules. Consultez la section Effets de simulation.
  • Plutôt qu’appliquer le même effet avec les mêmes paramètres à plusieurs calques, mieux vaut appliquer l’effet à un calque d’effets. Un effet appliqué à un calque d’effets est traité une seule fois, sur le composite de tous les calques situés en dessous Consultez la section Créer un calque d’ajustement.
Logo Adobe

Accéder à votre compte