Esportare e importare contenuto modificabile come xml in Dreamweaver. Esportare contenuto basato su modelli da un sito all'altro.

Potete considerare un documento basato su un modello come contenente dati rappresentati da coppie nome/valore. Ogni coppia è composta dal nome e dal contenuto di un'area modificabile.

Potete esportare le coppie nome-valore in un file XML in modo da poter lavorare con i dati all'esterno di Dreamweaver (ad esempio, in un editor XML o un editor di testo o un'applicazione di database). Al contrario, se disponete di un documento XML strutturato in modo appropriato, potete importare i dati da questo documento in un documento basato su un modello di Dreamweaver.

Esportare le aree modificabili di un documento in formato XML

  1. Aprite un documento basato sul modello che contiene aree modificabili.
  2. Selezionate File > Esporta > Esporta dati modello in XML.
  3. Selezionate una delle opzioni Notazione:
    • Se il modello contiene aree ripetute o parametri di modello, selezionate Usa tag XML standard di Dreamweaver.

    • Se il modello non contiene aree ripetute o parametri di modello, selezionate Usa nomi di aree modificabili come tag XML.

  4. Fate clic su OK.
  5. Nella finestra di dialogo che viene visualizzata, selezionate il percorso di una cartella, inserite un nome per il file XML, quindi fate clic su Salva.

    Viene generato un file XML che contiene il materiale dei parametri e delle aree modificabili del documento, comprese le aree modificabili che si trovano all'interno di aree ripetute o opzionali. Il file XML comprende il nome del modello originale, nonché il nome e il contenuto di ciascuna area.

    Nota:

    il contenuto delle aree non modificabili non viene esportato nel file XML.

Importare contenuto XML

  1. Selezionate File > Importa > Importa XML in modello.
  2. Selezionate il file XML e fate clic su Apri.

    Dreamweaver crea un nuovo documento basato sul modello specificato nel file XML. quindi definisce il contenuto delle singole aree modificabili del documento utilizzando i dati del file XML. Il documento così ottenuto viene visualizzato in una nuova finestra.

    Nota:

    se il file XML non è impostato esattamente come previsto in Dreamweaver, potreste non essere in grado di importare i dati. Una soluzione a questo problema consiste nell'esportare un file XML fittizio da Dreamweaver, in modo da avere un file XML con la struttura giusta. quindi copiate i dati del file XML originale in quello esportato. In questo modo ottenete un file XML che presenta la struttura corretta e contiene i dati appropriati e può essere quindi importato senza problemi.

Esportare un sito senza il codice del modello

Potete esportare i documenti basati sui modelli di un sito a un altro sito senza includere il codice del modello.

  1. Selezionate Strumenti > Modelli > Esporta senza codice.

  2. Nella casella Cartella, inserite il percorso della cartella in cui desiderate esportare il file o fate clic su Sfoglia per selezionarlo.

    Nota:

    dovete selezionare una cartella al di fuori del sito corrente.

  3. Per salvare una versione in formato XML dei documenti esportati basati sul modello, selezionate Mantieni i file di dati del modello.
  4. Se desiderate aggiornare le modifiche apportate ai file precedentemente esportati, selezionate Estrai solo i file modificati e fate clic su OK.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online