Creare voci di libreria in Dreamweaver e inserire e modificare le voci di libreria nei documenti.

Una libreria è un file speciale di Dreamweaver contenente una raccolta di risorse singole o copie di risorse che possono essere inserite nelle pagine web. Le risorse di una libreria vengono definite voci di libreria. In una libreria potete archiviare immagini, tabelle, suoni e file creati con Adobe Flash. Potete aggiornare automaticamente tutte le pagine che utilizzano una voce di libreria ogni volta che la modificate.

Ad esempio, supponete di dover realizzare un sito di grandi dimensioni per una società che desidera visualizzare uno slogan su tutte le pagine. Potete creare una voce di libreria contenente lo slogan e utilizzarla in ogni pagina. Se lo slogan cambia, è sufficiente modificare la voce di libreria e aggiornare automaticamente tutte le pagine in cui è inserita.

Dreamweaver archivia le voci di libreria nella sottocartella Library della cartella principale locale del sito. Ogni sito dispone di una libreria distinta.

Per creare una voce di libreria potete utilizzare qualunque elemento contenuto nella sezione body di un documento, ad esempio testo, tabelle, moduli, applet Java, plugin, elementi ActiveX, barre di navigazione e immagini.

Per gli elementi collegati, ad esempio le immagini, la libreria archivia solo un riferimento all'elemento e la voce di libreria può funzionare correttamente solo se il file originale rimane nella posizione specificata.

In alcuni casi, tuttavia, può essere comunque utile archiviare un'immagine in una voce di libreria. Se archiviate un tag img completo in una voce di libreria, ad esempio, potete modificare facilmente il testo alt o addirittura l'attributo src dell'immagine in tutto il sito. Potete utilizzare questo metodo per modificare gli attributi width e height di un'immagine solo se utilizzate un editor di immagini per cambiare le dimensioni effettive dell'immagine.

Nota:

gli eventuali collegamenti contenuti nella voce di libreria potrebbero non funzionare nel nuovo sito. Inoltre, le immagini presenti in una voce di libreria non vengono copiate nel nuovo sito.

Quando usate una voce di libreria, Dreamweaver inserisce nella pagina web un collegamento ad essa, anziché l'elemento vero e proprio. In altre parole, Dreamweaver colloca una copia del codice di origine HTML della voce nel documento e aggiunge un commento HTML contenente un riferimento alla voce originale esterna. È questo riferimento esterno che rende possibile l'aggiornamento automatico.

Quando create una voce di libreria che contiene un elemento a cui è stato applicato un comportamento di Dreamweaver, l'elemento viene copiato e il relativo gestore di eventi (l'attributo che specifica l'evento che attiva l'azione, ad esempio, onClick, onLoad o onMouseOver e l'azione che deve essere chiamata quando si verifica tale evento) nel file della voce di libreria. Dreamweaver non copia le funzioni JavaScript associate nella voce di libreria. Al contrario, quando si inserisce la voce di libreria in un documento, Dreamweaver inserisce automaticamente le funzioni JavaScript appropriate nella sezione intestazione del documento (se non sono già presenti).

Nota:

se create il codice JavaScript manualmente (ovvero senza utilizzare i comportamenti di Dreamweaver), potete includerlo in una voce di libreria se per la sua esecuzione si utilizza il comportamento Chiama JavaScript. Se non utilizzate un comportamento di Dreamweaver per l'esecuzione, il codice non viene mantenuto nella voce di libreria.

La modifica dei comportamenti nelle voci di libreria è soggetta a regole speciali. Le voci di libreria non possono contenere fogli di stile perché il codice associato a questi elementi fa parte della sezione head.

Creare una voce di libreria sulla base di una selezione

  1. Nella finestra del documento, selezionate la parte di documento interessata.
  2. Selezionate Strumenti > Libreria > Aggiungi oggetto alla libreria.

  3. Digitate un nome per la nuova voce di libreria, quindi premete Invio.

    Dreamweaver salva ogni voce come un file separato (con estensione .lbi) nella sottocartella Library della cartella principale locale del sito.

Creare una voce di libreria vuota

  1. Verificate che nella finestra del documento non sia selezionato alcun elemento.

    Gli eventuali elementi selezionati verranno inseriti nella nuova voce di libreria.

  2. Nel pannello Risorse, selezionate la categoria Libreria.

  3. Fate clic sul pulsante Nuova voce di libreria nella parte inferiore del pannello.

  4. Con la voce ancora selezionata, assegnatele un nome, quindi premete Invio.

Inserire una voce di libreria in un documento

Quando aggiungete una voce di libreria a una pagina, nel documento viene inserito il contenuto vero e proprio insieme a un riferimento alla voce.

  1. Spostate il punto di inserimento nella finestra del documento.
  2. Nel pannello Risorse, selezionate la categoria Libreria.

  3. Effettuate una delle operazioni seguenti:
    • Trascinate una voce di libreria dal pannello Risorse alla finestra del documento.

    Nota:

    per inserire il contenuto di una voce di libreria senza includere un riferimento alla voce nel documento, tenete premuto il tasto Ctrl (Windows) oppure Opzione (Macintosh) mentre trascinate la voce fuori dal pannello Risorse. Se inserite una voce di libreria in questo modo, potete modificare la voce all'interno del documento, ma il documento non viene aggiornato quando si aggiornano le pagine che utilizzano questa voce.

    • Selezionate una voce di libreria e fate clic su Inserisci.

Modificare le voci di libreria e aggiornare i documenti

Quando modificate una voce di libreria, potete aggiornare tutti i documenti che la utilizzano. Se scegliete di non eseguire l'aggiornamento, i documenti rimangono comunque associati alla voce e possono essere aggiornati in un secondo momento.

Potete rinominare le voci di libreria per interrompere il collegamento con documenti o modelli, eliminare delle voci dalla libreria del sito e ricreare una voce di libreria mancante.

Modificare una voce di libreria

  1. Nel pannello Risorse, selezionate la categoria Libreria.

  2. Selezionate una voce di libreria.
  3. Fate clic sul pulsante Modifica oppure doppio clic sulla voce di libreria.

    Dreamweaver apre una nuova finestra, simile a quella del documento, che consente di modificare la voce. Lo sfondo grigio indica che state modificando una voce di libreria invece di un documento.

  4. Effettuate le modifiche e salvatele.
  5. Specificate se i documenti del sito locale che utilizzano la voce di libreria modificata devono essere aggiornati. Selezionate Aggiorna per aggiornarli immediatamente. Se invece selezionate Non aggiornare, i documenti non vengono aggiornati fino a quando non si seleziona Strumenti > Libreria > Aggiorna pagina corrente o Aggiorna pagine.

Aggiornare il documento corrente in base alla versione più recente di tutte le voci di libreria

  1. Selezionate Strumenti > Libreria > Aggiorna pagina corrente.

Aggiornare l'intero sito o tutti i documenti che utilizzano una voce di libreria particolare

  1. Selezionate Strumenti > Libreria > Aggiorna pagine.

  2. Nel menu a comparsa Cerca in, specificate cosa deve essere aggiornato:
    • Per aggiornare tutte le pagine del sito selezionato con la versione corrente di tutte le voci di libreria, selezionate Intero sito, quindi selezionate il nome del sito dal menu a comparsa adiacente.

    • Per aggiornare tutte le pagine del sito corrente che utilizzano una voce di libreria, selezionate File che usano, quindi selezionate il nome della voce di libreria dal menu a comparsa adiacente.

  3. Verificate che per l'opzione Aggiorna sia stata selezionata la casella di controllo Voci di libreria.

    Nota:

    per aggiornare i modelli allo stesso tempo, selezionate anche Modelli.

  4. Fate clic su Avvia.

    Dreamweaver aggiorna i file in base alle impostazioni specificate. Se avete selezionato l'opzione Mostra registro, Dreamweaver genera un rapporto che indica se i file sono stati aggiornati correttamente e fornisce altre informazioni.

Modificare il nome di una voce di libreria

  1. Nel pannello Risorse, selezionate la categoria Libreria.

  2. Selezionate la voce di libreria, attendete un istante, quindi fate clic di nuovo. (Se fate doppio clic sul nome, la voce di libreria viene aperta.)
  3. Inserite un nuovo nome.
  4. Fate clic in un altro punto dello schermo o premete Invio.
  5. Specificate se desiderate aggiornare i documenti che utilizzano questa voce selezionando Aggiorna o Non aggiornare.

Eliminare una voce da una libreria

Quando eliminate una voce di libreria, Dreamweaver rimuove la voce dalla libreria ma non modifica il contenuto dei documenti che la utilizzano.

  1. Nel pannello Risorse, selezionate la categoria Libreria.

  2. Selezionate la voce di libreria.
  3. Fate clic sul pulsante Elimina o premete il tasto Canc, quindi confermate l'eliminazione.

    Nota:

    le voci di libreria eliminate non possono essere recuperate con il comando Annulla. Possono tuttavia essere ricreate.

Ricreare una voce di libreria mancante o eliminata

  1. Selezionate un'occorrenza della voce in un documento.
  2. Fate clic sul pulsante Ricrea nella finestra di ispezione Proprietà (Finestra > Proprietà).

Personalizzare l'evidenziazione delle voci di libreria

Le preferenze Evidenziazione consentono di visualizzare, nascondere e personalizzare il colore di evidenziazione delle voci di libreria.

Modificare il colore di evidenziazione delle voci di libreria

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).
  2. Selezionate la categoria Evidenziazione dall'elenco visualizzato sulla sinistra della finestra di dialogo Preferenze.
  3. Fate clic sulla casella del colore delle voci di libreria, quindi selezionate un colore di evidenziazione utilizzando l'apposito selettore, oppure inserite il valore esadecimale corrispondente nella casella di testo.
  4. Fate clic su Mostra per visualizzare il colore di evidenziazione nella finestra del documento.
  5. Fate clic su OK.

Per visualizzare o nascondere i colori di evidenziazione nella finestra del documento

  1. Per visualizzare l'evidenziazione, selezionate Visualizza > Opzioni vista Progettazione > Riferimenti visivi > Elementi invisibili. Per nascondere l'evidenziazione, deselezionate Elementi invisibili.

Modificare le proprietà di una voce di libreria

La finestra di ispezione Proprietà consente di aprire una voce di libreria da modificare, scollegare una voce di libreria selezionata dal file di origine o sovrascrivere una voce con la voce di libreria selezionata.

  1. Selezionate una voce di libreria in un documento.
  2. Selezionate una delle seguenti opzioni nella finestra di ispezione Proprietà (Finestra > Proprietà):

    Orig.

    Visualizza il nome e il percorso del file di origine della voce. Queste informazioni non possono essere modificate.

    Apri

    Apre il file di origine della voce per consentirne la modifica. Questa operazione può essere eseguita anche selezionando la voce nel pannello Risorse e facendo clic sul pulsante Modifica.

    Scollega dall'originale

    Interrompe il collegamento tra la voce selezionata e il rispettivo file di origine. Una voce scollegata può essere modificata all'interno del documento, ma non appartiene più alla libreria e non viene aggiornata quando si modifica l'originale.

    Ricrea

    Sostituisce la voce di libreria originale con la selezione corrente. Questa opzione può essere utilizzata per ricreare le voci di libreria che risultano mancanti o che sono state eliminate accidentalmente.

Definire voci di libreria modificabili in un documento

Se, dopo aver aggiunto una voce di libreria a un documento, desiderate modificarla nella pagina in cui è stata inserita, è necessario interrompere il collegamento tra la voce contenuta nel documento e la libreria. Le occorrenze delle voci di libreria che sono state rese modificabili non vengono più aggiornate quando si modificano le voci corrispondenti.

  1. Selezionate la voce nel documento corrente.
  2. Fate clic su Scollega dall'originale nella finestra di ispezione Proprietà (Finestra > Proprietà).

Modificare un comportamento in una voce di libreria

Per modificare un comportamento in una voce di libreria, è necessario inserire la voce in un documento e renderla modificabile all'interno di tale documento. Dopo avere apportato le modifiche, potete ricreare la voce di libreria per sostituire la voce contenuta nella libreria con quella modificata nel documento.

  1. Aprite un documento che contiene la voce.

    Prendete nota del nome della voce e dei tag che contiene. Queste informazioni saranno utili successivamente.

  2. Selezionate la voce di libreria, quindi fate clic su Scollega dall'originale nella finestra di ispezione Proprietà (Finestra > Proprietà).
  3. Selezionate l'elemento a cui è applicato il comportamento.
  4. Nel pannello Comportamenti (Finestra > Comportamenti), fate doppio clic sull'azione da modificare.
  5. Nella finestra di dialogo visualizzata, apportate le modifiche, quindi fate clic su OK.
  6. Nel pannello Risorse, selezionate la categoria Libreria.

  7. Registrate il nome esatto (con maiuscole e minuscole) della voce di libreria, quindi selezionatela e fate clic sul pulsante Elimina.
  8. Nella finestra del documento, selezionate tutti gli elementi che compongono la voce di libreria.

    È importante selezionare esattamente gli stessi elementi che facevano parte della voce di libreria originale.

  9. Nel pannello Risorse, fate clic sul pulsante Nuova voce di libreria e assegnate alla nuova voce lo stesso nome della voce eliminata con le stesse maiuscole e minuscole.

  10. Per aggiornare la voce di libreria negli altri documenti del sito, scegliete Strumenti > Libreria > Aggiorna pagine.

  11. Nel menu a comparsa Cerca in, selezionate File che usano.
  12. Nel menu a comparsa adiacente, selezionate il nome della voce di libreria appena creata.
  13. Verificate che per l'opzione Aggiorna sia stata selezionata la casella di controllo Voci di libreria, quindi fate clic su Avvio.
  14. Al termine dell'aggiornamento, fate clic su Chiudi.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online