Guida utente Annulla

Operazioni con Fireworks e Dreamweaver

  1. Guida utente di Dreamweaver
  2. Introduzione
    1. Nozioni di base sul design responsive
    2. Novità di Dreamweaver
    3. Sviluppo Web con Dreamweaver - Panoramica
    4. Dreamweaver / Domande frequenti
    5. Scelte rapide da tastiera
    6. Requisiti di sistema di Dreamweaver
    7. Riepilogo delle funzioni
  3. Dreamweaver e Creative Cloud
    1. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    2. Creative Cloud Libraries in Dreamweaver
    3. Utilizzare i file Photoshop in Dreamweaver
    4. Operazioni con Adobe Animate e Dreamweaver
    5. Estrarre file SVG ottimizzati per il Web da Libraries
  4. Aree di lavoro e viste di Dreamweaver
    1. Area di lavoro di Dreamweaver
    2. Ottimizzare l'area di lavoro di Dreamweaver per lo sviluppo visivo
    3. Eseguire ricerche nei file in base al nome file o al contenuto | Mac OS
  5. Configurare i siti
    1. Siti di Dreamweaver
    2. Configurare una versione locale del sito
    3. Collegamento a un server di pubblicazione
    4. Configurare un server di prova
    5. Importare ed esportare le impostazioni di un sito Dreamweaver
    6. Passaggio di siti Web esistenti da un server remoto alla cartella principale del sito locale
    7. Funzioni di accessibilità in Dreamweaver
    8. Impostazioni avanzate
    9. Impostazione delle preferenze del sito per il trasferimento dei file
    10. Specificare le Impostazioni del server proxy in Dreamweaver
    11. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    12. Utilizzo di Git in Dreamweaver
  6. Gestire i file
    1. Creare e aprire file
    2. Gestire file e cartelle
    3. Scaricamento e caricamento dei file da e verso il server
    4. Depositare e ritirare i file
    5. Sincronizzare i file
    6. Confrontare file per verificare le differenze
    7. Applicare la maschera file a file e cartelle del sito Dreamweaver
    8. Attivare le Design Notes per i siti di Dreamweaver
    9. Impedire un potenziale attacco exploit del Gatekeeper
  7. Layout e progettazione
    1. Usare i riferimenti visivi per il layout
    2. Informazioni sull'utilizzo di CSS per creare il layout della pagina
    3. Progettazione di siti Web reattivi con Bootstrap
    4. Creazione e utilizzo di media query in Dreamweaver
    5. Presentare il contenuto mediante le tabelle
    6. Colori
    7. Responsive design con i layout a griglia fluida
    8. Extract in Dreamweaver
  8. CSS
    1. Nozioni sui fogli di stile CSS
    2. Creazione del layout delle pagine con CSS Designer
    3. Utilizzare i preprocessori CSS in Dreamweaver
    4. Impostare le preferenze di stile CSS in Dreamweaver
    5. Spostare le regole CSS in Dreamweaver
    6. Convertire CSS in linea in una regola CSS in Dreamweaver
    7. Utilizzare i tag div
    8. Applicare sfumature allo sfondo
    9. Creare e modificare effetti di transizione CSS3 in Dreamweaver
    10. Formattazione del codice
  9. Contenuto e risorse delle pagine
    1. Impostare le proprietà di pagina
    2. Impostare le proprietà dei collegamenti CSS e le proprietà dei collegamenti CSS
    3. Lavorare con il testo
    4. Ricercare e sostituire testo, tag e attributi
    5. Pannello DOM
    6. Modifica nella vista Dal vivo
    7. Codifica dei documenti in Dreamweaver
    8. Selezionare e visualizzare gli elementi nella finestra del documento
    9. Definire le proprietà del testo nella finestra di ispezione Proprietà
    10. Eseguire il controllo ortografico di una pagina Web
    11. Utilizzo dei filetti orizzontali in Dreamweaver
    12. Aggiungere e modificare le combinazioni di caratteri in Dreamweaver
    13. Operazioni con le risorse
    14. Inserire e aggiornare le date in Dreamweaver
    15. Creare e gestire le risorse preferite in Dreamweaver
    16. Inserire e modificare le immagini in Dreamweaver
    17. Aggiungere oggetti multimediali
    18. Aggiunta di video in Dreamweaver
    19. Inserire video HTML5
    20. Inserire file SWF
    21. Aggiungere effetti audio
    22. Inserire l'audio HTML5 in Dreamweaver
    23. Operazioni con le voci di libreria
    24. Utilizzare testo in arabo e in ebraico in Dreamweaver
  10. Collegamenti e navigazione
    1. Informazioni sui collegamenti e sulla navigazione
    2. Collegamenti
    3. Mappe immagine
    4. Risoluzione dei problemi di collegamenti
  11. Widget ed effetti jQuery
    1. Utilizzare i widget jQuery UI e Mobile in Dreamweaver
    2. Usare effetti jQuery in Dreamweaver
  12. Programmazione dei siti Web
    1. Programmazione in Dreamweaver
    2. Ambiente di codifica in Dreamweaver
    3. Impostare le preferenze di codifica
    4. Personalizzare la colorazione del codice
    5. Scrivere e modificare codice
    6. Suggerimenti sul codice e completamento del codice
    7. Comprimere ed espandere codice
    8. Riutilizzo del codice con gli snippet
    9. Comando Lint
    10. Ottimizzare il codice
    11. Modificare il codice nella vista Progettazione.
    12. Utilizzo del contenuto dell'intestazione delle pagine
    13. Inserimento di server-side include in Dreamweaver
    14. Uso delle librerie di tag in Dreamweaver
    15. Importazione di tag personalizzati in Dreamweaver
    16. Utilizzare i comportamenti JavaScript (istruzioni generali)
    17. Applicare comportamenti JavaScript incorporati
    18. Informazioni su XML e XSLT
    19. Eseguire trasformazioni XSL server-side in Dreamweaver
    20. Esecuzione di trasformazioni XSL client-side in Dreamweaver
    21. Aggiungere entità di carattere per XSLT in Dreamweaver
    22. Formattazione del codice
  13. Flussi di lavoro di interazione con altri prodotti
    1. Installazione e uso delle estensioni in Dreamweaver
    2. Aggiornamenti in app in Dreamweaver
    3. Inserire documenti Microsoft Office in Dreamweaver (solo Windows)
    4. Operazioni con Fireworks e Dreamweaver
    5. Modificare il contenuto nei siti Dreamweaver mediante Contribute
    6. Integrazione tra Dreamweaver e Business Catalyst
    7. Creare campagne e-mail personalizzate
  14. Modelli
    1. Informazioni sui modelli di Dreamweaver
    2. Riconoscere i modelli e i documenti basati sui modelli
    3. Creare un modello di Dreamweaver
    4. Creare aree modificabili nei modelli
    5. Creare aree e tabelle ripetute nei modelli in Dreamweaver
    6. Usare le aree opzionali nei modelli
    7. Definire attributi di tag modificabili in Dreamweaver
    8. Creare modelli nidificati in Dreamweaver
    9. Modificare, aggiornare ed eliminare modelli
    10. Esportare e importare contenuti xml in Dreamweaver
    11. Applicare o rimuovere un modello da un documento esistente
    12. Modificare il contenuto nei modelli di Dreamweaver
    13. Regole di sintassi per i tag di modello in Dreamweaver
    14. Impostare le preferenze di evidenziazione per le aree dei modelli
    15. Vantaggi dell'uso dei modelli in Dreamweaver
  15. Dispositivi mobili e multischermo
    1. Creare media query
    2. Cambiamento dell'orientamento della pagina per i dispositivi mobili
    3. Creare web app per dispositivi mobili utilizzando Dreamweaver
  16. Siti, pagine e moduli Web dinamici
    1. Applicazioni Web
    2. Configurare il computer per lo sviluppo di applicazioni
    3. Risoluzione dei problemi relativi alle connessioni di database
    4. Rimozione di script di connessione in Dreamweaver
    5. Progettare pagine dinamiche
    6. Panoramica sulle origini di contenuto dinamico
    7. Definire le origini di contenuto dinamico
    8. Aggiungere contenuto dinamico alle pagine
    9. Modifica del contenuto dinamico in Dreamweaver
    10. Visualizzare i record di database
    11. Fornire dati dal vivo e risoluzione dei problemi in Dreamweaver
    12. Aggiungere comportamenti server personalizzati in Dreamweaver
    13. Creazione di moduli con Dreamweaver
    14. Usare moduli per raccogliere informazioni dagli utenti
    15. Creare e attivare i moduli ColdFusion in Dreamweaver
    16. Creare moduli Web
    17. Supporto HTML5 avanzato per gli elementi modulo
    18. Sviluppare un modulo con Dreamweaver
  17. Sviluppo visivo delle applicazioni
    1. Creare pagine principali e di dettaglio in Dreamweaver
    2. Creare pagine di ricerca e di risultati
    3. Creare una pagina di inserimento record
    4. Costruire una pagine di aggiornamento record in Dreamweaver
    5. Costruzione di pagine di eliminazione record in Dreamweaver
    6. Utilizzare comandi ASP per modificare un database in Dreamweaver
    7. Creare una pagina di registrazione
    8. Creare una pagina di login
    9. Creare una pagina accessibile solo agli utenti autorizzati
    10. Protezione delle cartelle in ColdFusion utilizzando Dreamweaver
    11. Utilizzo di componenti ColdFusion in Dreamweaver
  18. Verifica, anteprima e pubblicazione dei siti Web
    1. Anteprima delle pagine
    2. Visualizzare in anteprima pagine web di Dreamweaver su più dispositivi
    3. Verificare il sito Dreamweaver

 

Usate Fireworks e Dreamweaver per creare un flusso di lavoro ottimizzato per modificare, ottimizzare e collocare file di grafica per il web nelle pagine HTML.

Nota:

La funzione non è supportata nelle versioni di Adobe Dreamweaver.

Inserire un'immagine di Fireworks

Dreamweaver e Fireworks riconoscono e condividono molte procedure di modifica dei file, comprese le modifiche ai collegamenti, alle mappe immagine, alle porzioni di tabella e altro. Le due applicazioni offrono insieme un flusso di lavoro ottimizzato per modificare, ottimizzare e collocare file di grafica per il web nelle pagine HTML.

Potete inserire un'immagine esportata da Fireworks direttamente in un documento di Dreamweaver mediante il comando Inserisci immagine oppure creare una nuova immagine Fireworks da un segnaposto immagine di Dreamweaver.

  1. Nel documento di Dreamweaver, portate il cursore nel punto in cui desiderate visualizzare l'immagine ed effettuate una delle seguenti operazioni:
    • Selezionate Inserisci > Immagine.

    • Nella categoria Comune del pannello Inserisci, fate clic sul pulsante Immagine o trascinatelo sul documento.

  2. Scorrere fino al file di Fireworks esportato desiderato e fate clic su OK (Windows) o su Apri (Macintosh).
    Nota:

    Se il file di Fireworks non si trova nel sito corrente di Dreamweaver, viene visualizzato un messaggio che richiede all'utente se desidera copiare il file nella cartella principale. Fate clic su Sì.

Modificare un'immagine o una tabella di Fireworks da Dreamweaver

Quando aprite e modificate un'immagine o una porzione di immagine che fa parte di una tabella di Fireworks, Dreamweaver avvia Fireworks, che a sua volta apre il file PNG da cui era stata esportata l'immagine o la tabella.

Nota:

Quanto segue presuppone che Fireworks sia impostato come editor di immagini esterne principale per i file PNG. Spesso Fireworks viene anche configurato come editor predefinito per i file JPEG e GIF, anche se può essere utile impostare Photoshop come editor predefinito per questi tipi di file.

Se l'immagine fa parte di una tabella di Fireworks, potete aprire l'intera tabella per effettuare modifiche, a condizione che nel codice HTML sia presente il commento <!--fw table-->. Se il file PNG di origine è stato esportato da Fireworks in un sito Dreamweaver mediante l'impostazione di HTML e immagini stile di Dreamweaver, il commento della tabella di Fireworks viene inserito automaticamente nel codice HTML.

  1. In Dreamweaver, aprite la finestra di ispezione Proprietà (Finestra > Proprietà), se non è già aperta.
  2. Fate clic sull'immagine o sulla porzione d'immagine per selezionarla.

    Quando selezionate un'immagine esportata da Fireworks, la finestra di ispezione Proprietà identifica la selezione come un'immagine o una tabella di Fireworks e visualizza il nome del file di origine PNG.

  3. Per avviare Fireworks per apportare le modifiche, effettuate una delle seguenti operazioni:
    • Nella finestra di ispezione Proprietà, fate clic su Modifica.

    • Tenendo premuto il tasto Ctrl (Windows) o Comando (Macintosh), fate doppio clic sull'immagine selezionata.

    • Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sull'immagine selezionata e selezionate Modifica con Fireworks dal menu di scelta rapida.

    Nota:

    se Fireworks non è in grado di trovare il file di origine, viene richiesto di specificare il percorso del file PNG di origine. Se lavorate con il file di origine di Fireworks, le modifiche vengono salvate sia nel file di origine sia in quello esportato; in caso contrario, viene aggiornato soltanto il file esportato.  

  4. In Fireworks, modificate il file PNG di origine e fate clic su Fine.

    Fireworks salva le modifiche nel file PNG ed esporta l'immagine aggiornata (o l'HTML e le immagini), quindi restituisce lo stato attivo Dreamweaver. In Dreamweaver, viene visualizzata l'immagine o la tabella aggiornata.

    Per un'esercitazione sull'integrazione di Dreamweaver e Fireworks, consultate www.adobe.com/go/vid0188_it.

Ottimizzare un'immagine di Fireworks da Dreamweaver

Potete utilizzare Dreamweaver per effettuare modifiche rapide alle immagini e alle animazioni di Fireworks. Da Dreamweaver, potete modificare le impostazioni di ottimizzazione, le impostazioni di animazione e le dimensioni e l'area dell'immagine esportata.

  1. In Dreamweaver, selezionare l’immagine desiderata ed effettuare una delle seguenti operazioni:
    • Selezionate Comando > Ottimizza immagine.

    • Fate clic sul pulsante Modifica impostazioni immagine nella finestra di ispezione Proprietà dell'immagine.

  2. Effettuate le modifiche nella finestra di dialogo Anteprima immagine:
    • Per modificare le impostazioni di ottimizzazione, fate clic sulla scheda Opzioni.

    • Per modificare le dimensioni e l'area dell'immagine esportata, fate clic sulla scheda File.

  3. Al termine, fate clic su OK.

Usare Fireworks per modificare i segnaposto immagine di Dreamweaver

Potete creare un segnaposto immagine in un documento di Dreamweaver e quindi avviare Fireworks per creare un'immagine o una tabella di Fireworks per sostituirla.

Per creare una nuova immagine da un segnaposto immagine, sul sistema devono essere installati sia Dreamweaver che Fireworks.

  1. Accertatevi di avere già impostato Fireworks come editor di immagini per i file PNG.
  2. Nella finestra del documento, fate clic sul segnaposto immagine per selezionarlo.
  3. Avviate Fireworks nella modalità Modifica da Dreamweaver effettuando una delle seguenti operazioni:
    • Nella finestra di ispezione Proprietà, fate clic su Crea.

    • Tenendo premuto il tasto Ctrl (Windows) o Comando (Macintosh), fate doppio clic sul segnaposto immagine.

    • Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul segnaposto immagine, quindi selezionate Crea immagine in Fireworks.

  4. Utilizzate le opzioni di Fireworks per progettare l'immagine.

    Fireworks riconosce le seguenti impostazioni dei segnaposto immagine che è possibile configurare quando lavorate con il segnaposto immagine in Dreamweaver: dimensione dell'immagine (correlata alle dimensioni dell'area di lavoro di Fireworks), ID immagine (utilizzato da Fireworks come nome predefinito del documento per il file di origine e per il file di esportazione creato), allineamento del testo. Fireworks riconosce anche i collegamenti e determinati comportamenti (ad esempio immagine di scambio, menu a comparsa e imposta testo) che potete associare al segnaposto immagine mentre lavorate in Dreamweaver.

    Nota:

    Anche se non possono essere visualizzati in Fireworks, i collegamenti aggiunti a un segnaposto immagine vengono mantenuti. Se disegnate un punto attivo e aggiungete un collegamento in Fireworks, il programma non elimina il collegamento aggiunto al segnaposto immagine in Dreamweaver. Tuttavia, se ritagliate una porzione nella nuova immagine in Fireworks, il programma elimina il collegamento nel documento di Dreamweaver al momento della sostituzione del segnaposto immagine.

    Fireworks non riconosce le seguenti impostazioni dei segnaposto immagine: allineamento immagine, colore, spazio verticale e spazio orizzontale e mappe. Queste impostazioni sono disattivate nella finestra di ispezione Proprietà del segnaposto immagine.

  5. Al termine dell'operazione, fate clic su Fine per visualizzare la richiesta di salvataggio.
  6. Nella casella di testo Salva in, selezionate la cartella definita come cartella locale del sito Dreamweaver.

    Se al momento dell'inserimento nel documento di Dreamweaver avete assegnato un nome al segnaposto immagine, Fireworks inserisce tale nome nella casella Nome file. Il nome può essere modificato.

  7. Fate clic su Salva per salvare il file PNG.

    Viene visualizzata la finestra di dialogo Esporta. Utilizzate questa finestra di dialogo per esportare l'immagine in un file GIF o JPEG, oppure, nel caso di porzioni di immagine, come HTML e immagini.

  8. In Salva in, selezionate la cartella locale del sito Dreamweaver.

    La casella Nome visualizza automaticamente il nome utilizzato per il file PNG. Il nome può essere modificato.

  9. Nel campo Tipo file, selezionate il tipo di file da esportare, ad esempio Solo immagini o HTML e immagini.
  10. Fate clic su Salva per salvare il file esportato.

    Il file viene salvato, quindi ritorna attivo Dreamweaver. Nel documento di Dreamweaver, il file o la tabella di Fireworks esportati sostituiscono automaticamente il segnaposto immagine.

I menu a comparsa di Fireworks

Fireworks consente di creare rapidamente e facilmente menu a comparsa basati su CSS.

Oltre a essere estensibili e veloci da scaricare, i menu a comparsa creati con Fireworks forniscono i vantaggi seguenti:

  • Le voci di menu possono essere indicizzate tramite motori di ricerca.

  • Le voci di menu possono essere lette da screen reader, rendendo le pagine più accessibili.

  • Il codice generato da Fireworks è conforme agli standard e può essere convalidato.

    Potete modificare i menu a comparsa di Fireworks con Dreamweaver o con Fireworks, ma non con entrambi. Le modifiche apportate in Dreamweaver non vengono mantenute in Fireworks.

Modificare menu a comparsa di Fireworks in Dreamweaver

Potete creare un menu a comparsa in Fireworks 8 o versioni successive e quindi modificarlo in Dreamweaver o in Fireworks (utilizzando la funzione di modifica Roundtrip), ma non in entrambi. Se modificate i menu prima in Dreamweaver e quindi in Fireworks, verranno perdute tutte le modifiche precedenti tranne il contenuto testuale.

Se preferite modificare i menu con Dreamweaver, potete utilizzare Fireworks per creare il menu a comparsa e quindi utilizzare Dreamweaver solo per modificare e personalizzare il menu.

Se preferite modificare i menu in Fireworks, potete utilizzare la funzione di modifica Roundtrip in Dreamweaver, ma è sconsigliabile modificare i menu direttamente in Dreamweaver.

  1. In Dreamweaver, selezionate la tabella Fireworks che include il menu a comparsa, quindi fate clic su Modifica nella finestra di ispezione Proprietà.

    Il file PNG di origine viene aperto in Fireworks.

  2. In Fireworks, modificate il menu tramite l'Editor menu a comparsa, quindi fate clic su Fine nella barra degli strumenti di Fireworks.

    Fireworks invia nuovamente il menu a comparsa modificato a Dreamweaver.

    Se avete creato un menu a comparsa in Fireworks MX 2004 o una versione precedente, potete modificarlo in Dreamweaver mediante la finestra di dialogo Mostra menu popup, disponibile nel pannello Comportamenti.

Modificare un menu a comparsa creato in Fireworks MX 2004 o versioni precedenti

  1. In Dreamweaver, selezionate il punto attivo o l'immagine che attiva il menu a comparsa.
  2. Nel pannello Comportamenti (Maiusc+F3), fate doppio clic su Mostra menu a comparsa nell'elenco Azioni.
  3. Apportare le modifiche desiderate nella finestra di dialogo Menu popup e fate clic su OK.

Impostare le preferenze di avvio e modifica per i file di origine di Fireworks

Quando utilizzate Fireworks per la modifica delle immagini, le immagini inserite nelle pagine Web vengono normalmente esportate da Fireworks da un file di origine PNG. Quando aprite un file di immagine in Dreamweaver per modificarlo, Fireworks apre automaticamente il file di origine PNG. Se il file non viene individuato automaticamente, viene richiesto di specificarne il percorso. Se preferite, potete impostare le preferenze in Fireworks in modo tale che Dreamweaver apra l'immagine inserita, oppure potete fare in modo che Fireworks offra l'opzione di utilizzare il file di immagine inserito o il file di origine Fireworks ogni volta che viene aperta un'immagine in Dreamweaver.

Nota:

Dreamweaver è in grado di riconoscere le preferenze di avvio e modifica di Fireworks soltanto in determinati casi. Più specificamente, è necessario avviare e ottimizzare un'immagine che non faccia parte di una tabella di Fireworks e che contenga un percorso di Design Notes corretto relativo a un file di origine PNG.

  1. In Fireworks, selezionate Modifica > Preferenze (Windows) o Fireworks > Preferenze (Macintosh), quindi fate clic sulla scheda Lancia e modifica (Windows) oppure selezionate Lancia e modifica dal menu a comparsa (Macintosh).
  2. Specificate le opzioni delle preferenze da utilizzare per la modifica o l'ottimizzazione di immagini Fireworks collocate in un'applicazione esterna:

    Usa sempre PNG sorgente

    Apre automaticamente il file PNG di Fireworks definito nella Design Note come origine per l'immagine collocata. Gli aggiornamenti vengono applicati sia al PNG di origine sia all'immagine collocata corrispondente.

    Non usare mai PNG sorgente

    Apre automaticamente l'immagine collocata di Fireworks, indipendentemente dal fatto che esista un file PNG di origine o meno. Gli aggiornamenti vengono applicati esclusivamente all'immagine inserita.

    Richiedi al lancio

    Visualizza un messaggio che chiede se deve essere aperto il file PNG di origine e consente inoltre di specificare le preferenze generali di avvio e modifica.

Inserire codice HTML di Fireworks in un documento di Dreamweaver

Il comando Esporta di Fireworks consente di esportare e salvare immagini e file HTML ottimizzati in una cartella del sito Dreamweaver. Il file può quindi essere inserito in Dreamweaver. Dreamweaver consente di inserire in un documento codice HTML generato da Fireworks, completo di immagini associate, porzioni e JavaScript.

  1. Nel documento Dreamweaver, spostate il punto di inserimento nella posizione in cui desiderate inserire il codice HTML di Fireworks.
  2. Effettuate una delle operazioni seguenti:
    • Selezionate Inserisci > Oggetti immagine > HTML di Fireworks.

    • Nella categoria Comune del pannello Inserisci, fate clic sul pulsante Immagini e selezionate Inserisci HTML di Fireworks dal menu a comparsa.

  3. Fate clic su Sfoglia per selezionare un file HTML di Fireworks.
  4. Se non prevedete di utilizzare il file per un altro scopo, selezionate Cancella il file dopo l'inserimento. Questa opzione non influisce sul file PNG di origine associato al file HTML.
    Nota:

    Se il file HTML si trova su un'unità di rete, esso viene eliminato in modo permanente, anziché spostato nel Cestino.

  5. Fate clic su OK per inserire nel documento di Dreamweaver il codice HTML assieme alle immagini, alle porzioni e al codice JavaScript associati.

Incollare codice HTML di Fireworks in Dreamweaver

Un modo rapido per posizionare immagini e tabelle generate da Fireworks in Dreamweaver consiste nel copiare e incollare il codice HTML di Fireworks direttamente in un documento di Dreamweaver.

Copiare e incollare codice HTML di Fireworks in Dreamweaver

  1. In Fireworks, selezionate Modifica > Copia codice HTML.
  2. Seguite le istruzioni della procedura guidata relative alle impostazioni per esportare HTML e immagini. Quando viene richiesto, specificate la cartella del sito di Dreamweaver come cartella di destinazione per le immagini esportate.

    La procedura guidata consente di esportare le immagini nella destinazione specificata e copiare negli Appunti il codice HTML.

  3. Nel documento Dreamweaver, posizionate il cursore nel punto in cui desiderate incollare il codice HTML, quindi selezionate Modifica > Incolla HTML di Fireworks.

    Tutto il codice HTML e JavaScript associato ai file di Fireworks esportati viene copiato nel documento di Dreamweaver e tutti i collegamenti alle immagini vengono aggiornati.

Esportare e incollare codice HTML di Fireworks in Dreamweaver

  1. In Fireworks, selezionate File > Esporta.
  2. Specificate la cartella del sito di Dreamweaver come cartella di destinazione per le immagini esportate.
  3. Nel menu a comparsa Esporta, selezionate HTML e immagini.
  4. Nel menu a comparsa HTML, selezionate Copia negli Appunti, quindi fate clic su Esporta.
  5. Nel documento Dreamweaver, posizionate il cursore nel punto in cui desiderate incollare il codice HTML esportato, quindi selezionate Modifica > Incolla HTML di Fireworks.

    Tutto il codice HTML e JavaScript associato ai file di Fireworks esportati viene copiato nel documento di Dreamweaver e tutti i collegamenti alle immagini vengono aggiornati.

Aggiornare il codice HTML di Fireworks inserito in Dreamweaver

In Fireworks, il comando File > Aggiorna HTML rappresenta un'alternativa alla tecnica di avvio e modifica per l'aggiornamento dei file di Fireworks inseriti in Dreamweaver. Il comando Aggiorna HTML consente di modificare in Fireworks un'immagine di origine PNG e quindi di aggiornare automaticamente il codice HTML esportato e i file di immagine inseriti in un documento di Dreamweaver. Questo comando consente di aggiornare i file di Dreamweaver anche quando non è in esecuzione.

  1. In Fireworks, aprite il file PNG di origine ed effettuate le modifiche desiderate.
  2. Selezionate File > Salva.
  3. In Fireworks, selezionate File > Aggiorna HTML.
  4. Individuare il file di Dreamweaver contenente il codice HTML da aggiornare, quindi fare clic su Apri.
  5. Spostatevi nella cartella di destinazione in cui desiderate inserire i file di immagine aggiornati e fate clic su Seleziona (Windows) o su Scegli (Macintosh).

    Fireworks aggiorna il codice HTML e JavaScript nel documento di Dreamweaver. Fireworks consente anche di esportare le immagini aggiornate associate al codice HTML e di inserire le immagini nella cartella di destinazione specificata.

    Se Fireworks non è in grado di trovare un codice HTML corrispondente da aggiornare, viene offerta la possibilità di inserire un nuovo codice HTML nel documento di Dreamweaver. La sezione JavaScript del nuovo codice viene inserita all'inizio del documento, mentre la tabella HTML o il collegamento all'immagine vengono inseriti alla fine.

Creare un album fotografico Web

La funzione Crea album fotografico Web è stata dichiarata obsoleta a partire da Dreamweaver CS5.

Logo Adobe

Accedi al tuo account