Uwaga:

Pełna lista artykułów na temat zabezpieczeń znajduje się na stronie Przegląd funkcji zabezpieczeń w programie Acrobat i materiałach PDF.

Dlaczego trzeba cenzurować lub usuwać niektóre treści?

Przed udostępnieniem dokumentu PDF innym osobom może wystąpić konieczność usunięcia z niego informacji poufnych i osobistych. Aby usunąć poufne obrazy i tekst, które są widoczne w dokumencie PDF, użyj narzędzi Zaciemnij i usuń zawartość (zwanych także narzędziami Redakcji).

Aby odszukać i usunąć zawartość ukrytą z dokumentu PDF, skorzystaj z funkcji Usuń ukryte informacje. Przykład: Jeśli użytkownik jest twórcą dokumentu PDF, jego dane znajdą się w metadanych pliku przy pozycji „autor”. Niekiedy z dokumentu warto usunąć elementy, które mogą spowodować nieoczekiwaną zmianę jego wyglądu. Przykładowymi elementami tego typu są skrypty JavaScript, operacje i pola formularzy.

Redagowanie (zaciemnianie i usuwanie) poufnej zawartości (Acrobat Pro)

Redakcja to proces całkowitego usuwania widocznego tekstu i grafiki z dokumentu. Narzędzi Zaciemnij i Usuń (zwanych również narzędziami redakcyjnymi) używa się do usuwania zawartości. W miejscu usuniętych elementów można umieścić specjalne znaczniki redakcyjne (kolorowe prostokąty) lub puste pola. Nad znacznikami redakcyjnymi można umieścić odpowiednie opisy lub kody redakcyjne.

Uwaga:

Do wyszukiwania i usuwania konkretnych słów, znaków lub fraz należy używać narzędzia Wyszukaj i usuń tekst  .

Tekst oznaczony do redakcji (po lewej) i tekst zredagowany (po prawej)
Tekst oznaczony do redakcji (po lewej) i tekst zredagowany (po prawej)

  1. Wybierz polecenie Narzędzia > Ochrona > Oznacz do redakcji . (Jeśli panel Ochrona jest niewidoczny, wybierz polecenie Widok > Narzędzia > Ochrona).

  2. (Opcjonalnie) Aby określić wygląd znaczników redakcyjnych, kliknij przycisk Właściwości redakcji. (Zobacz Zmiana wyglądu znaczników redakcyjnych).

  3. Wskaż elementy do usunięcia, wykonując jedną z następujących czynności:
    • Kliknij dwukrotnie, aby zaznaczyć wyraz lub obraz.
    • Przeciągnij, aby zaznaczyć linię, blok tekstu, obiekt lub obszar.
    • Naciśnij klawisz Ctrl podczas przeciągania, aby zaznaczyć obszary strony w skanowanym dokumencie.

    Uwaga:

    Aby sprawdzić, jak będą wyglądać znaczniki redakcyjne, ustaw kursor nad oznaczonym obszarem.

  4. Aby zastosować wiele kodów w pojedynczej redakcji, kliknij prawym przyciskiem myszy znak redakcji i wybierz daną opcję. Aby uzyskać więcej informacji, zobacz Użycie kodów przy redakcji.
  5. (Opcjonalnie) Aby powtórzyć znak redakcji, kliknij go prawym przyciskiem myszy i wybierz polecenie Powtórz znak na stronach. To wygodna funkcja, jeśli konkretny nagłówek, stopka lub znak wodny pojawiają się w tym samym miejscu na wielu stronach.

  6. Po zakończeniu oznaczania elementów przeznaczonych do zredagowania, wybierz polecenie Narzędzia > Ochrona > Zastosuj redakcje, aby usunąć elementy, a następnie kliknij przycisk OK.

    Elementy zostaną usunięte na stałe dopiero po zapisaniu dokumentu.

  7. Jeśli chcesz wyszukać w dokumencie informacje ukryte i usunąć je za pomocą funkcji Usuń ukryte informacje, kliknij Tak w oknie dialogowym. W przeciwnym razie kliknij Nie.

  8. Wybierz polecenie Plik > Zapisz, po czym określ nazwę i położenie pliku. Do nazwy pliku zostanie dodany przyrostek „_Redacted”. Jeśli nie chcesz zastąpić oryginalnego pliku, zapisz plik pod inną nazwą lub w innym miejscu.

Wyszukiwanie i usuwanie tekstu (Acrobat Pro)

Korzystając z narzędzia Wyszukaj i usuń tekst, można wyszukiwać i usuwać wyrazy lub wyrażenia w jednym lub wielu plikach PDF zawierających tekst, który można przeszukiwać.

Uwaga:

Narzędzia Wyszukaj i usuń tekst nie można używać do przeszukiwania zabezpieczonych (zaszyfrowanych) plików PDF.

  1. Wybierz polecenie Narzędzia > Ochrona i wybierz narzędzie Wyszukaj i usuń tekst . (Jeśli panel Ochrona jest niewidoczny, wybierz polecenie Widok > Narzędzia > Ochrona).

  2. Określ, czy przeszukiwanie ma dotyczyć bieżącego pliku PDF, czy wszystkich plików PDF znajdujących się w innym położeniu.
  3. Wykonaj jedną z następujących czynności:
    • Aby wyszukać tylko jeden wyraz lub jedno wyrażenie, wybierz opcję Jeden wyraz lub fraza i wpisz wraz lub frazę do znalezienia w polu tekstowym.
    • Aby wyszukać kilka wyrazów, wybierz opcję Wiele wyrazów lub fraza, a następnie kliknij przycisk Wybierz wyrazy. Wpisz każdy wyraz w polu tekstowym Nowy wyraz lub fraza i kliknij przycisk Dodaj. Można też zaimportować plik tekstowy zawierający listę wyrazów lub fraz do wyszukania.
    • Aby wyszukać wzorzec (np. numer telefonu, numer karty kredytowej, adres e-mail, numer PESEL lub datę), kliknij przycisk Wzorce. Wybierz jeden z dostępnych wzorców. Wersję językową wzorców można zmienić. (Zobacz Wybór innej wersji językowej dla wzorców).
  4. Kliknij Wyszukaj i usuń tekst.

  5. Na liście wyników wyszukiwania kliknij znak plus (+) obok nazwy dokumentu, aby wyświetlić wszystkie wystąpienia szukanego wyrazu lub szukanej frazy. Następnie zaznacz wystąpienia, które chcesz oznaczyć do zredagowania.
    • Aby zaznaczyć wszystkie wystąpienia na liście, kliknij przycisk Zaznacz wszystko.
    • Aby zaznaczyć pojedyncze wystąpienia, kliknij odpowiadające im pola wyboru. Kliknij tekst obok pola wyboru, aby wyświetlić dane wystąpienie na stronie.
    • Aby nie oznaczać żadnych wystąpień, zamknij okno Wyszukaj lub kliknij przycisk Nowe wyszukiwanie (aby rozpocząć wyszukiwanie od nowa).
    • Aby oznaczyć do redakcji całe słowa lub części słów (znaków), wybierz opcję w Opcjach znaczników redakcyjnych. W przypadku części słów, kliknij Ustawienia i określ liczbę i położenie znaków do redakcji. Redakcja znaków jest przydatna, gdy szuka się wzoru, takiego jak numery kart kredytowych, i nie chce zasłaniać całego numeru dla celów identyfikacyjnych.
  6. Jeśli pewne wystąpienia oznaczono do redakcji, kliknij przycisk Oznacz zaznaczone wyniki do redakcji.

    Elementy zaznaczone na liście zostaną oznaczone do zredagowania.

    Uwaga:

    Jeśli plik nie został jeszcze zapisany, nadal można zaznaczać poszczególne znaczniki redakcyjne i usuwać je (za pomocą klawisza Delete). Po zapisaniu pliku znaczniki redakcyjne pozostają w nim na stałe.

  7. Aby usunąć oznaczone elementy, wybierz polecenie Narzędzia > Ochrona > Zastosuj redakcje, a następnie kliknij OK.

    Elementy zostaną usunięte na stałe dopiero po zapisaniu dokumentu.

  8. Jeśli chcesz wyszukać w dokumencie informacje ukryte i usunąć je za pomocą funkcji Usuń ukryte informacje, kliknij Tak. W przeciwnym razie kliknij Nie.

  9. Wybierz polecenie Plik > Zapisz, po czym określ nazwę i położenie pliku. Jeśli nie chcesz zastąpić oryginalnego pliku, zapisz plik pod inną nazwą lub w innym miejscu.

Wyszukiwanie i usuwanie ukrytej zawartości

Funkcja Usuń ukryte informacje pozwala odszukać i usunąć niepożądane elementy dokumentu, takie jak ukryty tekst, metadane, komentarze i załączniki. Podczas usuwania z dokumentu elementów automatycznie usuwane są także dodatkowe elementy. Usuwane elementy to m.in. podpisy elektroniczne, informacje dotyczące dokumentu dodane przez wtyczki i aplikacje zewnętrzne oraz funkcje specjalne umożliwiające użytkownikom programu Adobe Reader recenzowanie, podpisywanie i wypełnianie dokumentów PDF.

Uwaga:

Aby przed zamknięciem lub wysłaniem pocztą e-mail każdy z dokumentów był badany pod kątem ukrytej zawartości, należy ustawić odpowiednią opcję w preferencjach dokumentu, używając okna dialogowego Preferencje.

  1. Wybierz polecenie Narzędzia > Ochrona > Usuń ukryte informacje. (Jeśli panel Ochrona jest niewidoczny, wybierz polecenie Widok > Narzędzia > Ochrona).

    W przypadku znalezienia elementów ukrytych trafią na listę w panelu Usuń ukryte informacje z zaznaczonym polem wyboru obok każdego z nich.

  2. Upewnij się, że ptaszki widnieją tylko obok tych elementów, które mają być usunięte z dokumentu. (Zobacz Opcje Usuwania ukrytych informacji).
  3. Aby usunąć z pliku zaznaczone elementy, kliknij Usuń, a następnie kliknij OK.

  4. Wybierz polecenie Plik > Zapisz, po czym określ nazwę i położenie pliku. Jeśli nie chcesz zastąpić oryginalnego pliku, zapisz plik pod inną nazwą lub w innym miejscu.

W momencie zapisania pliku zaznaczone elementy są usuwane na stałe. Jeśli zamkniesz plik bez zapisania go, powtórz całą procedurę i koniecznie zapisz plik.

Opcje Usuwania ukrytych informacji

Metadane

Metadane zawierają informacje dotyczące dokumentu i jego zawartości, na przykład nazwisko autora, słowa kluczowe lub informacje dotyczące praw autorskich. Aby wyświetlić metadane, należy wybrać polecenie Plik > Właściwości.

Załączniki

Do pliku PDF można załączyć plik w dowolnym formacie. Aby wyświetlić załączniki, wybierz polecenie Widok > Pokaż/Ukryj > Panele nawigacji > Załączniki.

Zakładki

Zakładki to opisane łącza umożliwiające otwieranie konkretnych stron pliku PDF. Aby wyświetlić zakładki, wybierz polecenie Widok > Pokaż/Ukryj > Panele nawigacji > Zakładki.

Komentarze i oznaczenia

Ten element obejmuje wszystkie komentarze dodane do pliku PDF za pomocą narzędzi do komentowania i oznaczania, w tym pliki załączone jako komentarze. Aby wyświetlić komentarze, przejdź do panelu Komentarz.

Pola formularza

Ten element zawiera pola formularzy (w tym pola Podpis) oraz wszystkie Operacje oraz obliczenia związane z tymi polami. Po usunięciu tego elementu wszystkie pola formularzy zostaną spłaszczone i nie będzie można ich ani wypełniać, ani edytować, ani podpisywać.

Tekst ukryty

Ten element dotyczy tekstu, który jest przezroczysty, zasłonięty przez inny tekst lub ma taki sam kolor, jak tło.

Ukryte warstwy

Pliki PDF mogą zawierać warstwy, które są ukryte lub niewidoczne. Usunięcie ukrytych warstw skutkuje ich usunięciem z pliku PDF oraz spłaszczeniem pozostałych warstw do postaci pojedynczej warstwy. Aby wyświetlić warstwy, wybierz polecenie Widok > Pokaż/Ukryj > Panele nawigacji > Warstwy.

Osadzony indeks wyszukiwania

Osadzony indeks wyszukiwania przyspiesza przeszukiwanie pliku. Aby sprawdzić, czy plik PDF zawiera indeks wyszukiwania, należy wybrać polecenie Widok > Narzędzia >Przetwarzanie dokumentu > Zarządzaj osadzonym indeksem. Usunięcie indeksu skutkuje zmniejszeniem rozmiaru pliku, ale także wydłużeniem czasu jego przeszukiwania.

Usunięta lub przycięta zawartość

Pliki PDF zawierają czasami elementy, które z nich usunięto, np. przycięte lub usunięte strony oraz usunięte obrazy.

Łącza, operacje i skrypty JavaScript

Element ten obejmuje łącza internetowe, operacje dodawane przez kreatora operacji oraz skrypty JavaScript w danym dokumencie.

Nakładające się obiekty

Element ten obejmuje obiekty, które nakładają się na siebie. Mogą to być obrazy (złożone z pikseli), grafika wektorowa (złożona ze ścieżek), gradienty lub wzorki.

Wybór innej wersji językowej dla wzorców (Acrobat Pro)

Zlokalizowane wzorce wyświetlane są w panelu Szukaj (Ochrona > Wyszukaj i usuń tekst).

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Acrobat > Preferencje (Mac OS).

  2. W sekcji Kategorie po lewej wybierz Dokumenty.

  3. W obszarze Redakcja wybierz język z menu Wybierz lokalizację dla wzorców wyszukiwania i Usuń wzorce tekstowe. Następnie kliknij przycisk OK.

Zmiana wyglądu znaków redakcyjnych (Acrobat Pro)

Domyślnie cienki, czerwony kontur pojawia się wokół obrazów i tekstu oznaczonego do redakcji. Z kolei na miejscu zredagowanych obrazów i tekstu pojawiają się czarne pola. Przed oznakowaniem elementów do redakcji można ustawić wygląd domyślnych znaków redakcyjnych. Można również zmienić wygląd znaków redakcyjnych przed zastosowaniem redakcji.

Określanie domyślnego wyglądu wszystkich znaczników

  1. Wybierz polecenie Narzędzia > Ochrona > Właściwości redakcji. (Jeśli panel Ochrona jest niewidoczny, wybierz polecenie Widok > Narzędzia > Ochrona).

  2. Przejdź na kartę Wygląd, zaznacz odpowiednie opcje i kliknij przycisk OK.
    • Kliknij ikonę Kolor wypełnienia zredagowanego obszaru, przywołaj paletę kolorów i wybierz kolor wypełnienia pól zastępujących usunięte elementy. Wybierz opcję Brak koloru, aby zredagowany obszar pozostał pusty.
    • Zaznacz opcję Użyj tekstu nakładki, jeśli chcesz ustawić opcje własnego tekstu lub kodu redakcyjnego. Zaznacz czcionkę, rozmiar i opcję wyrównania tekstu.
    • Zaznacz opcję Własny tekst i wpisz tekst, który ma być wyświetlany w zredagowanym obszarze.
    • Zaznacz opcję Kod redakcyjny, a następnie wybierz kod z istniejącego zestawu albo kliknij przycisk Edytuj w celu zdefiniowania nowego zestawu kodów lub utworzenia nowego kodu. (Zobacz Tworzenie kodów redakcyjnych i zestawów kodów).
    • Na obszarze Wygląd znaków redakcyjnych kliknij ikonę Kolor konturu lub ikonę Kolor wypełnienia, lub obydwie. Wybierz kolor z palety kolorów dla obrazów i tekstu, który oznaczasz do redakcji. Przesuń suwak, aby dostosować krycie koloru. Wybierz opcję Brak koloru, aby wybrany obszar pozostał pusty.

Właściwości dla tekstu redakcyjnego (Acrobat Pro)

Tekst niestandardowy

Nad znacznikiem redakcyjnym jest wyświetlany tekst wpisany w polu Tekst własny.

Czcionka

Tekst niestandardowy jest wyświetlany przy użyciu zaznaczonej czcionki.

Rozmiar czcionki

Tekst niestandardowy jest wyświetlany przy użyciu wybranego rozmiaru czcionki.

Automatycznie dopasuj rozmiar tekstu do obszaru redakcyjnego

Rozmiar tekstu niestandardowego jest dopasowywany do wielkości zredagowanego obszaru. Jeśli opcja jest zaznaczona, jej ustawienie jest nadrzędne względem ustawienia opcji Rozmiar czcionki.

Kolor czcionki

Tekst niestandardowy jest wyświetlany w zaznaczonym kolorze (który można zmienić, klikając próbkę koloru).

Powtórz tekst nakładki

Zredagowany obszar jest wypełniany odpowiednią liczbą powtórzeń tekstu własnego (bez zmiany rozmiaru czcionki). Jeśli na przykład jako tekst własny zostanie wybrana litera x lub dywiz (-), te znaki będą powtarzane w całym zredagowanym obszarze.

Wyrównanie tekstu

Wyrównuje tekst do lewej, do prawej lub do środka.

Kody redakcyjne (Acrobat Pro)

Program Acrobat używa tekstu nakładki do zadrukowania obszarów wybranych do redakcji. Jednym z przykładów tekstu nakładki jest kod redakcyjny, który składa się z jednego lub więcej wpisów kodów zawartych w zestawie kodów. Program Acrobat zawiera przeznaczone dla użytkownika zestawy kodów U.S. FOIA i U.S. Privacy Act. Możesz używać obydwu lub tekstu niestandardowego, aby utworzyć tekst nakładki. Różnica polega na tym, że kody redakcyjne są to elementy, które można zapisywać, eksportować i importować. Jeden zestaw redakcyjny może zawierać wiele kodów.

Uwaga:

Kody redakcyjne nie zawierają informacji o bieżących atrybutach tekstu nakładki, takich jak kolory, ustawienia czcionki czy ustawienia dotyczące powtarzania lub rozmiaru tekstu. Kody opisują sam tekst nakładki. Tekst ten można wykorzystywać w przyszłych sesjach, a także udostępniać innym użytkownikom. Inne atrybuty kodu ustawia się w oknie dialogowym Właściwości narzędzia Redakcja.

Tworzenie kodów redakcyjnych i zestawów kodu

  1. Wybierz polecenie Narzędzia > Ochrona > Właściwości redakcji . (Jeśli panel Ochrona jest niewidoczny, wybierz polecenie Widok > Narzędzia > Ochrona).

  2. Zaznacz opcję Użyj tekstu nakładki.
  3. Wybierz kod redakcyjny.
    • Aby dodać do kodu redakcyjnego wiele kodów, wybierz wpis z listy Kodów i kliknij Dodaj wybrany wpis. Powtórz czynność, jeśli to konieczne. Aby usunąć kod, wybierz opcję Usuń wybrany wpis.
    • Aby wprowadzić dodatkowe zmiany, kliknij opcję Edytuj kody.
  4. W oknie dialogowym Edytor kodu redakcyjnego kliknij Dodaj zestaw.

  5. (Opcjonalnie) Wpisz nową nazwę zestawu w polu tekstowym pod listą zestawów, po czym kliknij przycisk Zmień nazwę zestawu.
  6. Kliknij przycisk Dodaj kod, a następnie wpisz tekst nakładki w polu tekstowym pod listą kodów, po czym kliknij przycisk Zmień nazwę kodu.

  7. Powtórz poprzedni krok w celu dodania do zestawu innego kodu; albo powtórz poprzednie trzy kroki w celu utworzenia kolejnych zestawów kodów i kodów.

Edycja kodów redakcyjnych i zestawów kodu (Acrobat Pro)

  1. Wybierz polecenie Narzędzia > Ochrona > Właściwości redakcji . (Jeśli panel Ochrona jest niewidoczny, wybierz polecenie Widok > Narzędzia > Ochrona).

  2. Zaznacz opcję Użyj tekstu nakładki, a następnie opcję Kod redakcyjny.
  3. Zaznacz zestaw kodów na liście po lewej stronie, po czym kliknij przycisk Edytuj kody.

  4. W oknie dialogowym Edytor kodu redakcyjnego wykonaj jedną z następujących czynności:

    • Aby usunąć zestaw kodów i wszystkie kody w nim zawarte, zaznacz zestaw kodów i kliknij przycisk Usuń zestaw.
    • Aby wyeksportować zestaw kodu do odrębnego pliku XML w celu ponownego wykorzystania w innych plikach PDF lub udostępnienia pozostałym użytkownikom, wybierz zestaw kodu. Następnie kliknij opcję Eksportuj zestaw, podaj nazwę i lokalizację pliku, a na koniec kliknij Zapisz.
    • Aby zaimportować zapisany uprzednio zestaw kodów, kliknij na przycisk Importuj zestaw, odszukaj i zaznacz plik, po czym kliknij przycisk Otwórz.
    • Aby zmienić nazwę zestawu kodów, wpisz nową nazwę w polu pod listą, po czym kliknij przycisk Zmień nazwę zestawu.
  5. Po zaznaczeniu zestawu kodów wybierz wpis kodu przeznaczony do edycji, a następnie wykonaj jedną z następujących czynności:

    • Aby usunąć kod, zaznacz go i kliknij przycisk Usuń kod.
    • Aby zmienić nazwę kodu, wpisz nową nazwę w polu pod listą, po czym kliknij przycisk Zmień nazwę kodu.

Użycie wielu kod przy pojedynczej redakcji

  1. Kliknij prawym przyciskiem myszy znacznik redakcyjny. Wybierz zestaw kodu lub kod z listy w dolnej części menu kontekstowego.

  2. Wybierz zestaw kodu z listy w dolnej części menu kontekstowego, a następnie wybierz kod z rozwijanego menu. Obok użytego kodu pojawi się znak zapytania.

  3. Potwórz poprzednią czynność, aby dodać do redakcji kolejny kod.

Przytrzymaj wskaźnik nad znakiem redakcyjnym, aby zobaczyć kody rozdzielone przecinkami.

Uwaga:

Aby zastosować ten sam kod do wielu redakcji, przed oznaczeniem zawartości ustaw Właściwości redakcji. W panelu Ochrona kliknij pozycję Właściwości redakcji. Zaznacz opcję Użyj tekstu nakładki, a następnie opcję Kod redakcyjny. Wybierz Zestaw kodów oraz wpis kodów, a następnie kliknij pozycję Dodaj wybrany wpis.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online