Problem

Brak ikony PDFMaker (Konwertuj na Adobe PDF) oraz menu Acrobat w aplikacjach pakietu Microsoft Office 2003, XP lub 2000 (np. Access, Excel czy Word).

Rozwiązanie

Zastosuj jedno lub kilka z następujących rozwiązań:

Rozwiązanie 1: Usunięcie Adobe PDF z listy Elementy wyłączone w aplikacji Microsoft Office.

  1. Otwórz program Microsoft Office (Word, Excel, Publisher lub Access).
  2. Przejdź do opcji Pomoc > [nazwa programu] — informacje.
  3. Kliknij opcję Elementy wyłączone.
  4. Wybierz Adobe PDF z listy i kliknij opcję Włącz.
  5. Zakończ program Microsoft Office, a następnie uruchom go ponownie.

Uwaga: Aplikacje pakietu Microsoft Office wyłączają dodatki w ramach zabezpieczenia, jeśli aplikacja została przedwcześnie zamknięta (np. system nie został prawidłowo zamknięty lub aplikacja przestała działać).

Rozwiązanie 2: Upewnienie się, że składniki PDFMaker zostały zainstalowane.

  1. Wybierz polecenia Start > Uruchom, w polu tekstowym Otwórz wpisz appwiz.cpl, a następnie kliknij przycisk OK, aby otworzyć okno dialogowe Dodaj lub usuń programy.
  2. Znajdź program Adobe Acrobat 7 lub Adobe Acrobat 8 i kliknij opcję Zmień/Usuń.
  3. Po wyświetleniu kreatora kliknij Dalej.
  4. Wybierz opcję Zmień i kliknij ponownie Dalej.
  5. Rozwiń drzewo Utwórz Adobe PDF, a następnie kliknij strzałkę w dół na obiekcie Acrobat PDFMaker.
  6. Wybierz opcję „Ta funkcja zostanie zainstalowana na lokalnym dysku twardym”, kliknij Dalej, a następnie kliknij opcję Aktualizuj.

Rozwiązanie 3: Włączenie pliku dodatku COM w aplikacji pakietu Office.

  1. Uruchom aplikację pakietu Office.
  2. Wybierz opcję Pomoc > [nazwa aplikacji] — informacje.
  3. Kliknij opcję Elementy wyłączone.
  4. Sprawdź, czy na liście znajduje się pozycja PDFMakerOfficeAddin:
    • Jeśli tak, wybierz tę pozycję i kliknij Włącz. Zamknij wszystkie okna dialogowe i uruchom ponownie aplikację pakietu Office.
    • Jeśli pozycja nie znajduje się na liście, upewnij się, że plik PDFMOfficeAddin.dll znajduje się w folderze Acrobat 7.0/PDFMaker/Office (Acrobat 7, Acrobat 3D) lub Acrobat 8.0/PDFMaker/Office (Acrobat 8). Jeśli nie ma tego pliku, ponownie zainstaluj program Acrobat.

Rozwiązanie 4: Zmień nazwę pliku Normal.dot.

Aby zapisane w szablonie globalnym (Normal.dot) formatowanie, autotekst i makra nie wpływały na pracę programu Microsoft Word i innych aplikacji, należy zmienić nazwę szablonu globalnego (Normal.dot). Po wykonaniu tej czynności można szybko określić, czy szablon globalny powoduje problem.

Ważne: Zmiana nazwy szablonu Normal.dot powoduje zresetowanie kilku opcji do ustawień domyślnych, między innymi niestandardowych stylów, niestandardowych pasków narzędzi, makr oraz wpisów narzędzia autotekst. Dlatego firma Microsoft zdecydowanie zaleca nieusuwanie pliku Normal.dot.

Niektóre konfiguracje mogą spowodować utworzenie więcej niż jednego pliku Normal.dot. Na przykład: ten problem może wystąpić, jeśli na komputerze zainstalowanych jest kilka wersji programu Word lub jeśli kilka instalacji stacji roboczych istnieje na tym samym komputerze.

Zmiana nazwy pliku Normal.dot:

Uwaga: Następujące czynności są typowe dla programu Microsoft Word, ale po wprowadzeniu drobnych zmian można ich użyć dla innych aplikacji pakietu Microsoft Office. Po wykonaniu tych czynności nie należy używać parametru /a do ponownego uruchamiania programu Word lub innej aplikacji.

W systemie Windows 2000:

  1. Zakończ wszystkie instancje programu Word, łącznie z programem Outlook, jeśli do edycji wiadomości e-mail używany jest program Word.
  2. Wybierz opcję Start > Wyszukaj > Pliki lub foldery.
  3. W polu „Wyszukaj pliki i foldery o nazwie” wpisz: Normal.dot.
  4. W polu „Szukaj w” wybierz lokalny dysk twardy.
  5. Kliknij opcję Szukaj teraz, aby wyszukać plik.
  6. Dla każdego wystąpienia pliku Normal.dot wyszczególnionego w oknie dialogowym Wyniki wyszukiwania wykonaj następujące czynności:
    • Kliknij plik prawym przyciskiem myszy i wybierz opcję Zmień nazwę.
    • Nadaj plikowi nową nazwę (np. StaryNormal.dot czy Normal-1.dot), a następnie naciśnij klawisz Enter.
  7. W menu Plik kliknij opcję Zamknij, aby zakończyć wyszukiwanie, a następnie uruchom ponownie program Word.

W systemie Windows XP:

  1. Zakończ wszystkie instancje programu Word, łącznie z programem Outlook, jeśli do edycji wiadomości e-mail używany jest program Word.
  2. Wybierz polecenia Start > Szukaj.
  3. W obszarze Zakres wyszukiwania zaznacz opcję Wszystkie pliki i foldery.
  4. W polu „Całość lub część nazwy pliku” wpisz: Normal.dot.
  5. W polu „Szukaj w” wybierz lokalny dysk twardy (lub alternatywną lokalizację szablonu użytkownika w przypadku korzystania z programu Word przez serwer sieciowy).
  6. Kliknij przycisk Szukaj.
  7. Dla każdego wystąpienia pliku Normal.dot wyszczególnionego w oknie dialogowym Wyniki wyszukiwania wykonaj następujące czynności:
    • Kliknij plik prawym przyciskiem myszy i wybierz opcję Zmień nazwę.
    • Nadaj plikowi nową nazwę (np. StaryNormal.dot czy Normal-1.dot), a następnie naciśnij klawisz Enter.
  8. W menu Plik kliknij opcję Zamknij, a następnie uruchom ponownie program Word.

Jeśli zmiana nazwy szablonu globalnego pozwoliła rozwiązać problem, oznacza to, że problem powoduje uszkodzony szablon Normal.dot.

Rozwiązanie 5: Zmiana poziomu zabezpieczeń makr w aplikacji pakietu Office.

Aby plik dodatku COM został załadowany do systemu Windows, w karcie Zaufani wydawcy musi znajdować się pozycja Adobe Inc. lub należy zmienić ustawienia zabezpieczeń.

W aplikacjach pakietu Office 2000, XP lub 2003:

  1. Z menu Narzędzia wybierz polecenie Makro > Zabezpieczenia.
  2. Kliknij kartę Zaufani Wydawcy:
    1. Jeśli na liście znajduje się pozycja Adobe Inc., żadne zmiany nie są wymagane.

    2. Jeśli pozycja Adobe Inc. nie znajduje się na liście, przejdź do czynności 3.

  3. Wybierz jedno z następujących ustawień:
    • W karcie Zabezpieczenia ustaw poziom zabezpieczeń na Bardzo wysoki; w karcie Zaufani wydawcy zaznacz opcję Ufaj wszystkim zainstalowanym dodatkom i szablonom.
    • W karcie Zabezpieczenia ustaw poziom zabezpieczeń na Wysoki; w karcie Zaufani wydawcy anuluj zaznaczenie opcji Ufaj wszystkim zainstalowanym dodatkom i szablonom.
  4. Zamknij wszystkie okna dialogowe i uruchom ponownie aplikację.

Rozwiązanie 6: Dodanie pliku dodatku COM do rejestru systemu Windows.

  1. W programie Eksplorator Windows znajdź plik dodatku COM (PDFMOfficeAddin.dll) i zapisz dokładną ścieżkę (może ona zawierać spacje).
  2. Wybierz polecenia Start > Uruchom.
  3. Wpisz regsvr32 i spację, a następnie wprowadź ścieżkę zapisaną w kroku 1 w cudzysłowie. Na przykład:

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. Kliknij przycisk OK, a następnie uruchom aplikację pakietu Office.

Rozwiązanie 7: Uruchomienie opcji Wykrywanie i naprawianie, upewniwszy się, że wszystkie inne aplikacje są wyłączone.

  1. Zamknij wszystkie aplikacje i uruchom ponownie system Windows.
  2. Uruchom program Acrobat.
  3. Wybierz opcje Pomoc > Wykrywanie i naprawianie i postępuj zgodnie z instrukcjami na ekranie.
  4. Po zakończeniu naprawy uruchom ponownie komputer.

Rozwiązanie 8: Usunięcie i ponownie zainstalowanie programu Acrobat w trybie uproszczonym.

Sterowniki urządzenia i oprogramowanie ładujące się automatycznie z systemem Windows (np. wygaszacze ekranu i narzędzia zapewniające ochronę antywirusową) mogą powodować konflikt z instalatorem programu Acrobat i być źródłem problemów. Aby zapobiec konfliktowi, zainstaluj ponownie program Acrobat, gdy system Windows jest uruchomiony w trybie uproszczonym. W trybie uproszczonym niestandardowe sterowniki urządzeń i oprogramowanie startowe są wyłączone.

Aby usunąć program Acrobat:

  1. Przenieś wszystkie osobiste pliki z folderu aplikacji Acrobat i jej podfolderów.
  2. Wybierz polecenie Start > Ustawienia > Panel sterowania i kliknij dwukrotnie ikonę Dodaj lub usuń programy.
  3. Wybierz pozycję Adobe [produkt Acrobat] i kliknij opcję Usuń. Postępuj zgodnie z instrukcjami wyświetlanymi na ekranie, aby usunąć aplikację.
  4. Uruchom ponownie komputer.

Aby ponownie zainstalować program Acrobat w trybie uproszczonym:

  1. Zakończ działanie otwartych aplikacji.
  2. W Eksploratorze Windows przenieś wszystkie ikony i skróty z następujących folderów do innego folderu:
    • Documents and Settings/All Users/Start Menu/Programs/Startup
    • Documents and Settings/ [profil użytkownika] /Start Menu/Programs/Startup
  3. Uruchom system Windows ponownie.
  4. Kliknij prawym przyciskiem myszy pasek zadań i wybierz opcję Menedżer zadań.
  5. Kliknij kartę Aplikacje.
  6. Zaznacz wszystkie uruchomione aplikacje i kliknij opcję Zakończ zadanie.
  7. Kliknij dwukrotnie plik Setup.exe na nośniku instalacyjnym i postępuj zgodnie ze wskazówkami wyświetlanymi na ekranie w celu ukończenia instalacji.
  8. Aby ponownie włączyć elementy uruchamiane przy włączeniu systemu po zakończeniu instalacji, przenieś ikony i skróty przeniesione w kroku 2 z powrotem do odpowiednich folderów Startup.

Rozwiązanie 9: Usuwanie makr z programu Word.

  1. Wybierz opcje Narzędzia > Szablony i dodatki.
  2. Zaznacz każdy element i kliknij opcję Usuń.
  3. Zakończ program Word i uruchom go ponownie.



    Uwaga:
    Jeśli wciąż nie ma ikony Konwertuj do pliku PDF, wybierz opcje Narzędzia > Szablony i dodatki i upewnij się, że usunięte elementy nie są wyświetlone. Jeśli usunięte elementy będą wyświetlane, usuń makro z programu Word lub usuń aplikację, która spowodowała zainstalowanie makra w programie Word.

Rozwiązanie 10: Usunięcie innych plików dodatków COM z programu Word.

  1. Uruchom program Word.
  2. Wybierz kolejno opcje Narzędzia > Dostosuj.
  3. Kliknij kartę Polecenia i wybierz pozycję Narzędzia z listy Kategorie.
  4. Wybierz dodatki COM i przeciągnij je do paska narzędzi w programie Word.
  5. Kliknij menu Dodatki COM na pasku narzędzi programu Word.
  6. Wybierz i usuń wszystkie dodatki poza Web Page Wizard i Microsoft Word Fonts Tool.
  7. Zakończ program Word i uruchom go ponownie.

Rozwiązanie 11: Naprawa programu Access. (dotyczy tylko programu Access)

Jeśli po zainstalowaniu pakietu Office XP lub Office 2003 zainstalowano program Access 2000, należy przeprowadzić naprawę instalacji pakietu Office, aby menu modułu PDFMaker było wyświetlane.

  1. Wybierz kolejno opcje Start > Ustawienia > Panel Sterowania > Dodaj/usuń programy (Windows 2000) lub Start > Panel Sterowania > Dodaj lub usuń programy (Windows XP).
  2. Wybierz pozycję Microsoft Office i kliknij opcję Zmień.
  3. W oknie dialogowym Konfiguracja wybierz opcję Zainstaluj ponownie (Office 2003) lub Napraw (Office XP), a następnie kliknij przycisk Dalej.
  4. Wybierz opcję Wykryj i napraw błędy w mojej instalacji Office, a następnie kliknij opcję Zainstaluj.

Rozwiązanie 12: Dostosowanie opcji paska narzędzi. (dotyczy tylko programu Access)

  1. Wybierz kolejno opcje Widok > Paski narzędzi > Dostosuj.
  2. Na karcie Paski narzędzi wybierz opcje Narzędzie 1 i Pasek menu.
  3. Kliknij opcję Właściwości.
  4. Wybierz opcję Zezwalaj na pokazywanie/ukrywanie.

Rozwiązanie 13: Usunięcie plików poprzedniej wersji modułu PDFMaker z systemu.

  1. Wybierz polecenia Start > Szukaj.
  2. Wybierz opcję Wszystkie pliki i foldery.
  3. W polu tekstowym oznaczonym „Cała nazwa pliku lub jej część:” wpisz PDFMaker.* .
  4. Kliknij przycisk Szukaj.

    Uwaga: To wyszukiwanie może zająć kilka minut w zależności od szybkości działania systemu.
  5. Usuń wszystkie pliki systemowe wyświetlone w wynikach wyszukiwania (np. PDFMaker.DOT czy PDFMaker.XLA). Nie ma konieczności usuwania samodzielnie utworzonych dokumentów o nazwie PDFMaker (np. PDFMaker.doc czy PDFMaker.pdf).

Rozwiązanie 14: Usuwanie programu Microsoft Works.

Firma Adobe ustaliła, że program Microsoft Works powoduje konflikt z programem Microsoft Word i uniemożliwia wyświetlanie menu Konwertuj na Adobe PDF w programie Word. Program Microsoft Works jest wstępnie zainstalowany na wielu komputerach.

Aby usunąć program Microsoft Works:

  1. Wybierz kolejno opcje Start > Uruchom, wpisz appwiz.cpl w polu tekstowym Otwórz, a następnie kliknij przycisk OK, aby otworzyć okno dialogowe Dodaj lub usuń programy.
  2. Znajdź pozycję Microsoft Works i zaznacz ją, a następnie kliknij opcję Zmień/Usuń.
  3. Po wyświetleniu kreatora kliknij Dalej.
  4. Wybierz opcję Usuń, kliknij przycisk Dalej, a następnie postępuj zgodnie z instrukcjami wyświetlanymi w monitach na ekranie.

Dodatkowe informacje

Program Acrobat 7.0–8.0 instaluje plik dodatku COM w folderze Acrobat 7.0/PDFMaker/Office lub Acrobat 8.0/PDFMaker/Office. Ten plik zawiera ikony i polecenia menu PDFMaker dla programów Word, Excel, PowerPoint, Access, Publisher oraz Project. Aby zawartość dodatku była wyświetlana w aplikacjach, plik dodatku COM należy zarejestrować w rejestrze systemu Windows.

Ikony PDFMaker nie są wyświetlane w pasku narzędzi, jeśli aplikacja pakietu Office przestanie działać i wyłączy plik dodatku COM.

Inne pliki dodatku COM i makra mogą powodować konflikt z plikiem dodatku COM dla modułu PDFMaker i mogą uniemożliwiać wyświetlanie ikon Konwertuj na PDF w pasku narzędzi.

Jeśli wyświetlanie paska narzędzi Narzędzie1 jest wyłączone w programie Access, ikony modułu PDFMaker nie będą wyświetlane.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online