Выделение контуров, сегментов и опорных точек

Прежде чем можно будет перерисовать или отредактировать контур, необходимо выделить опорные точки и сегменты контура.

Выделение опорных точек

  • Если точки видны, их можно выбрать с помощью инструмента «Частичное выделение» . Для выбора нескольких точек удерживайте клавишу Shift.
  • Выберите инструмент «Частичное выделение» и перетаскиванием обозначьте границу вокруг опорных точек. Удерживая клавишу Shift, выберите дополнительные опорные точки.
  • Вы можете выбрать опорные точки в выделенном и невыделенном контуре. Перемещайте инструмент «Частичное выделение» над опорной точкой до тех пор, пока не отобразится пустой квадрат для невыделенного контура и заполненный квадрат для выделенного контура в увеличенном масштабе, затем нажмите на опорную точку. Удерживая клавишу Shift, выделите дополнительные опорные точки щелчком.
  • Выберите инструмент «Лассо» и перетащите его вокруг опорных точек (только в Illustrator). Удерживая клавишу Shift, выберите дополнительные опорные точки.

Выделение сегментов контура

Выполните одно из следующих действий:

  • Выберите инструмент «Частичное выделение»  и щелкните мышью в пределах 2 пикселов сегмента или перетащите выделенную область через часть сегмента. Для того чтобы выделить дополнительные сегменты контура, щелкните их или перетащите на них инструмент, удерживая клавишу Shift.
  • (Только для Illustrator) Выберите инструмент «Лассо»  и перетащите его вокруг части сегмента контура. Удерживая клавишу Shift, выделите дополнительные сегменты контура путем перетаскивания инструмента вокруг них.

Выделение всех опорных точек и сегментов в контуре

  1. Выберите инструмент «Частичное выделение»  или инструмент «Лассо» (в Illustrator).
  2. Перетащите по всему контуру.

    Если к контуру применена заливка, то для выделения всех опорных точек можно также щелкнуть инструментом «Частичное выделение» внутри контура.

Копирование контура

  1. Выделите контур или сегмент с помощью инструмента «Частичное выделение» и выполните одно из следующих действий:
    • Для копирования и вставки контуров в пределах одного приложения или между приложениями используются стандартные функции меню.

    • Нажмите и удерживайте клавишу Alt (Windows) или Option (Mac OS), перетащите контур в нужное положение, затем отпустите кнопку мыши и клавишу Alt или Option.

Корректировка сегментов контура

Отредактировать сегмент контура можно в любой момент, но редактирование существующих сегментов несколько отличается от их создания. При редактировании сегментов следует помнить приведенные ниже советы.

  • Если опорная точка соединяет два сегмента, то при ее перемещении изменяются оба эти сегмента.

  • При рисовании с помощью инструмента «Перо» можно временно активировать инструмент «Частичное выделение» (InDesign) или «Стрелка» (Photoshop) для корректировки уже нарисованных сегментов. Для этого при рисовании нажмите клавишу Ctrl (Windows) или Command (Mac OS). В Illustrator при нажатии клавиши Ctrl или Command во время рисования активируется инструмент выделения, который использовался до этого.

  • При создании гладкой точки с помощью инструмента «Перо» перетаскивание управляющей точки изменяет длину управляющей линии по обе стороны точки. Однако при редактировании существующей гладкой точки с помощью инструмента «Частичное выделение»/«Стрелка» длина управляющей линии изменяется только с той стороны, в которую направлено перетаскивание.

Перемещение прямых сегментов

  1. С помощью инструмента «Стрелка»  выберите сегмент, который необходимо скорректировать.
  2. Перетащите сегмент в новое место.

Корректировка длины и угла сегментов прямой

  1. С помощью инструмента «Стрелка»  выберите опорную точку сегмента для изменения.
  2. Перетащите опорную точку в нужное место. Удерживайте клавишу Shift, чтобы ограничить корректировку углом, кратным 45°.

    Примечание.

    Если в Illustrator или InDesign нужно сделать прямоугольник просто шире или уже, то легче выбрать инструмент «Выделение» и изменить размер объекта с помощью одного из манипуляторов по краям ограничительной рамки.

Корректировка положения и формы сегментов кривой

  1. С помощью инструмента «Частичное выделение» выберите сегмент кривой или опорную точку на любом конце сегмента. Отобразятся управляющие линии, если они есть (в некоторых сегментах кривой всего одна управляющая линия).
  2. Выполните одно из следующих действий:
    • Чтобы скорректировать положение сегмента, перетащите сегмент. Удерживайте клавишу Shift, чтобы ограничить корректировку углом, кратным 45°.

    Скорректируйте положение сегмента
    Щелкните сегмент кривой, чтобы выбрать его. Перетащите инструмент для корректировки

    • Для того чтобы скорректировать форму сегмента с любой стороны от выделенной опорной точки, перетащите опорную точку или управляющую точку. Удерживайте клавишу Shift, чтобы ограничить движение углом, кратным 45°.

    Скорректируйте форму сегмента
    Перетащите опорную точку или управляющую точку

    Примечание.

    Кроме того, к сегменту или опорной точке можно применить трансформирование, например, масштабирование или поворот.

Удаление сегмента

  1. Выберите инструмент «Стрелка» , затем выберите сегмент, который требуется удалить.
  2. Нажмите клавишу Backspace (Windows) или Delete (Mac OS), чтобы удалить выделенный сегмент. При повторном нажатии клавиши Backspace или Delete будет удалена остальная часть контура.

Удаление маркера опорной точки

  • При использовании инструмента «Преобразовать опорную точку» (Illustrator) или «Угол» (InDesign) щелкните опорную точку маркера.
  • Перетащите управляющую точку на опорную точку.

Расширение открытого контура

  1. Выберите инструмент «Перо» и наведите указатель на конечную точку открытого контура, который нужно расширить. Когда указатель окажется точно над конечной точкой, его значок изменится.

  2. Щелкните конечную точку.

  3. Выполните одно из следующих действий:

    • Для того чтобы создать угловую точку, поместите инструмент «Перо» в то место, где должен заканчиваться новый сегмент, затем щелкните мышью. Если расширяется контур, который заканчивается гладкой точкой, то новый сегмент будет изогнут существующей управляющей линией

    Примечание.

    В Illustrator при растягивании контура, который заканчивается гладкой точкой, новый сегмент будет прямым отрезком.

  4. Для того чтобы создать гладкую точку, поместите инструмент «Перо» в то место, где должен заканчиваться новый сегмент, затем перетащите инструмент.

Соединение двух открытых контуров

  1. Выберите инструмент «Перо» и поместите указатель на конечную точку открытого контура, который нужно соединить с другим контуром. Когда указатель окажется точно над конечной точкой, его значок изменится.
  2. Щелкните конечную точку.
  3. Выполните одно из следующих действий:
    • Для того чтобы соединить один открытый контур с другим, щелкните конечную точку второго контура. Когда инструмент «Перо» будет наведен точно на конечную точку другого контура, рядом с указателем появится значок объединения .

    • Для соединения нового контура с существующим нарисуйте новый контур рядом с существующим, затем переместите инструмент «Перо» к невыбранной конечной точке существующего контура. Щелкните конечную точку, когда рядом с указателем появится значок объединения.

Примечание.

В приложении InDesign для соединения контуров можно также использовать палитру «Обработка контуров». Чтобы замкнуть открытый контур, выберите контур при помощи инструмента «Выделение» и нажмите «Закрыть контур» в палитре «Обработка контуров». Чтобы замкнуть конечные точки между двумя контурами, выберите контуры и нажмите «Объединить контур». Нажав «Объединить контур» еще раз, можно присоединить вторую конечную точку.

Перемещение или пошаговое смещение опорных точек или сегментов с помощью клавиатуры

  1. Выберите опорную точку или сегмент контура.

    Примечание.

    В Photoshop таким способом можно перемещать только опорные точки.

  2. Щелкните или удерживайте любую из клавиш со стрелками для перемещения на 1 пиксел за один раз в направлении нажатой стрелки.

Удерживайте клавишу Shift в дополнение к клавише со стрелкой для перемещения на 10 пикселов за один раз.

Примечание.

В Illustrator и InDesign расстояние пошагового сдвига можно изменять с помощью параметра «Клавиатурная настройка». После изменения значения по умолчанию при нажатии клавиши Shift пошаговый сдвиг будет выполняться на указанное расстояние, умноженное на 10.

Добавление и удаление опорных точек

Добавление опорных точек позволяет более эффективно управлять контуром, а также расширять открытый контур. Однако не следует добавлять больше точек, чем требуется. Контур с меньшим числом точек легче редактировать, он быстрее отображается и выводится на печать. Можно уменьшить сложность контура путем удаления ненужных точек.

На панели «Инструменты» содержится три инструмента для добавления и удаления точек: инструмент «Перо» , инструмент «Добавить узловую точку»  и инструмент «Удалить узловую точку» .

По умолчанию инструмент «Перо» заменяется на инструмент «Добавить опорную точку», когда указатель наведен на выделенный контур, и на инструмент «Удалить опорную точку», когда указатель наведен на опорную точку (в приложении Photoshop для того чтобы инструмент «Перо» автоматически заменялся на инструмент «Добавить опорную точку» или «Удалить опорную точку», на панели параметров должен быть выбран параметр «Оптимизация».

В Photoshop и InDesign можно выбирать и редактировать несколько контуров одновременно, однако в Illustrator можно добавлять или удалять точки одновременно только в одном контуре. В Photoshop и InDesign можно перерисовать контур при добавлении опорных точек щелчком и перетаскиванием по мере добавления.

Примечание.

Не удаляйте опорные точки клавишами Delete, Backspace и Clear или с помощью команд меню «Редактирование» > «Вырезать» или «Редактирование» > «Очистить», так как при использовании этих клавиш и команд удаляются точки и отрезки линий, связанные с этими точками.

Добавление и удаление опорных точек

  1. Выделите контур, который необходимо изменить.
  2. Выберите инструмент «Перо», инструмент «Добавить опорную точку» или инструмент «Удалить опорную точку».
  3. Чтобы добавить опорную точку, наведите указатель на сегмент контура и щелкните левой кнопкой мыши. Чтобы удалить опорную точку, наведите указатель на опорную точку и щелкните левой кнопкой мыши.

Примечание.

Для добавления опорных точек в контур в приложении Illustrator можно выделить объект, затем выбрать команду «Объект» > «Контур» > «Добавить опорные точки».

Отключение или временное изменение автоматического переключения инструмента «Перо»

Автоматическое переключение инструмента «Перо» на инструмент «Добавить опорную точку» или «Удалить опорную точку» можно изменить. Это может понадобиться, если нужно нарисовать новый контур поверх существующего.

  • В Photoshop снимите флажок с параметра «Автоматическое добавление/удаление» на панели параметров.
  • В Illustrator удерживайте клавишу Shift, наводя инструмент «Перо» на выделенный контур или опорную точку. (для того чтобы клавиша Shift не ограничивала инструмент «Перо», отпускайте ее до того, как отпускаете кнопку мыши).
  • В Illustrator выберите «Редактирование» > «Установки» > «Основные» (Windows) или «Illustrator» > «Установки» > «Основные» (Mac OS), затем выберите «Отключить автоматическое добавление/удаление».
  • В приложении InDesign, удерживая любую горячую клавишу, внесите правки и отпустите кнопку мыши. К примеру, выбрав инструмент «Перо», можно нажать клавишу «A» для отображения инструмента «Частичное выделение», отредактировать точки, а затем отпустить клавишу «A» — будет снова выбран инструмент «Перо».

Преобразование между гладкими и угловыми точками

Контуры могут содержать опорные точки двух типов — угловые и гладкие. В угловой точке контур резко меняет направление. В гладкой точке сегменты контура соединены в виде непрерывной кривой. Инструмент «Угол» (Преобразовать точку привязки) . позволяет преобразовывать гладкие опорные точки в угловые и наоборот.

  1. С помощью инструмента «Частичное выделение»  выделите контур, который необходимо изменить.
  2. Переключитесь на инструмент «Угол» (Преобразовать точку привязки) . (при необходимости поместите курсор над инструментом «Перо» и перетащите его, чтобы выбрать инструмент «Угол» (Преобразовать точку привязки)).

    Примечание.

    Чтобы временно переключиться с инструмента «Угол» (Преобразовать точку привязки) на инструмент «Частичное выделение», нажмите клавишу «Ctrl» (Windows) или «Command» (Mac OS)».

  3. Поместите инструмент «Угол» (Преобразовать точку привязки) над нужной опорной точкой и выполните одно из следующих действий:

    Чтобы преобразовать угловую точку в гладкую, перетащите управляющие линии из угловой точки.

    Преобразование угловой точки в гладкую точку
    Перетаскивание управляющих линий из угловой точки для создания гладкой точки

    Чтобы преобразовать гладкую точку в угловую без использования управляющих линий, щелкните гладкую точку.

    Преобразование гладкой точки в угловую точку
    Создание угловой точки из гладкой точки с помощью щелчка

    • Чтобы преобразовать угловую точку без управляющих линий в угловую точку с независимыми управляющими линиями, сначала перетащите управляющие линии из угловой точки (преобразовав ее в гладкую точку). Отпустите кнопку мыши, а затем перетащите любую управляющую линию.

    • Чтобы преобразовать точку, откройте палитру «Обработка контуров» (выберите «Окно» > «Объекты и макет» > «Обработка контуров»), затем нажмите кнопку «Простая», «Угловая», «Гладкая» или «Симметричная» в разделе «Преобразовать точку».

    • Чтобы преобразовать гладкую точку в угловую точку с независимыми управляющими линиями, перетащите любую управляющую линию.

    Преобразование гладкой точки в угловую точку
    Преобразование гладкой точки в угловую точку

Примечание.

Чтобы преобразовать точку, выделите ее инструментом «Частичное выделение» и выберите команду меню «Объект» > «Преобразовать точку». Например, можно выделить гладкую точку в нижней части U-образного контура и выбрать «Объект» > «Преобразовать точку» > «Простая». При этом управляющие линии исчезнут, а контур будет преобразован в V-образный. Выберите «Угловая» для создания точки с управляющими линиями, которые могут перемещаться независимо друг от друга. Выберите «Гладкая» для создания точки с управляющими линиями, которые могут иметь одинаковую длину. Выберите «Симметричная» для создания точки с управляющими линиями одинаковой длины.

Разделение контура

Контур, графический фрейм или пустой текстовый фрейм можно разделить в любой опорной точке или по любому сегменту. При разделении контура необходимо помнить следующее.

  • Чтобы разделить замкнутый контур на два открытых, необходимо разрезать контур в двух местах. Если разрезать замкнутый контур только в одном месте, получится один незамкнутый контур.

  • Любые контуры, полученные путем разделения, наследуют параметры исходного контура (толщину обводки, цвет заливки и т. д.). Возможно, придется отменить выравнивание обводки от внутренней части к внешней.

Разбивка контура с помощью инструмента «Ножницы»

  1. (Необязательно) Выделите контур, чтобы увидеть его текущие опорные точки.
  2. Выберите инструмент «Ножницы» и щелкните контур в том месте, где его нужно разделить. Если контур разделить в середине сегмента, появятся две новые конечные точки (одна над другой), и одна из них будет выделена.
  3. С помощью инструмента «Частичное выделение» скорректируйте новую опорную точку или сегмент контура.

Открытие контура при помощи палитры «Обработка контуров»

  1. Выделите закрытый контур.
  2. Чтобы открыть палитру «Обработка контуров», выберите «Окно» > «Объекты и макет» > «Обработка контуров».
  3. Нажмите «Открыть контур» на палитре «Обработка контуров».

Сглаживание контуров

С помощью инструмента «Сглаживание» из существующего контура или его части удаляются лишние углы. Инструмент «Сглаживание» сохраняет первоначальную форму контура, насколько это возможно. В сглаженных контурах обычно меньше точек, что упрощает их редактирование, отображение и печать.

Сглаживание контуров
Контур до и после использования инструмента «Сглаживание»

  1. Выберите контур.
  2. Выберите инструмент «Сглаживание».

    Примечание.

    Если выбран инструмент «Карандаш», удерживайте клавишу «Alt» (Windows) или «Option» (Mac OS) для того, чтобы временно заменить «Карандаш» на «Сглаживание».

  3. Перетащите инструмент вдоль сегмента контура, который нужно сгладить.
  4. Выполняйте сглаживание до тех пор, пока обводка или контур не примут нужную форму.
  5. Чтобы изменить степень сглаживания, дважды щелкните инструмент «Сглаживание» и задайте следующие параметры:

    Точность

    Указывает значение отклонения кривых, при наличии которого необходимо изменять контур. Чем меньше значения точности, тем больше кривых будет примерно совпадать с движением указателя, — в результате узлы будут более острыми. Чем больше значения точности, тем меньше мелких движений указателя будет обрабатываться, что даст более гладкие кривые. Диапазон значений в пикселах — от 0,5 до 20.

    Сглаживание

    Управляет степенью сглаживания, применяемой при использовании инструмента. Плавность можно задавать в пределах от 0 до 100%. Чем больше значение, тем сильнее сглаживается контур.

    Сохранять выделение

    Определяет, сохраняется ли выделение после сглаживания контура.

Изменение формы замкнутых контуров или объектов

  1. С помощью инструмента «Частичное выделение»  выполните одно из следующих действий:
    • Перетащите курсор вокруг опорных точек, которые необходимо выделить.

    • При нажатой клавише «Shift» щелкните по очереди все опорные точки, которые необходимо выделить.

  2. Поместите курсор над опорной точкой или сегментом контура, который хотите использовать в качестве точки фокуса (то есть точки, позволяющей вытянуть выделенные сегменты контура), а затем щелкните опорную точку или сегмент контура.
  3. Перетащите подсвеченные опорные точки, чтобы скорректировать контур. Величина перемещения каждого из сегментов контура зависит от того, насколько далеко сегмент находится от точки, выделенной подсветкой.
    • Выделенные точки, служащие точкой фокуса, перемещаются вместе с инструментом «Выделение».

    • Остальные выделенные точки перемещаются вместе с перетаскиваемой точкой фокуса.

    • В процессе преобразования формы опорные точки, которые не выделены, остаются на месте.

Сведения об инструменте «Позиционирование»

Инструмент «Позиционирование»  недоступен в InDesign CS5. Вместо него можно использовать инструмент «Выделение» для выделения и управления фреймами или содержимым фрейма. См. раздел Выделение объектов.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет