Чтобы создать слайд-шоу для воспроизведения в Flash Player, экспортируйте файл в формат SWF или FLA. Основное отличие файлов SWF от FLA заключается в том, что файлы SWF готовы к просмотру и не могут быть изменены, а файлы FLA следует подготовить в Adobe Flash Professional, прежде чем просматривать в Adobe Flash Player.

SWF

Экспортированный файл SWF готов к просмотру в Adobe Flash Player и может содержать такие интерактивные элементы, как переходы страниц, гиперссылки, видеоролики, аудиоклипы, анимацию и навигационные кнопки.

FLA

Экспортированный файл FLA содержит лишь некоторые интерактивные элементы. Файл FLA можно открыть в Flash Pro и добавить дополнительные эффекты перед экспортом в SWF.

Экспорт в Flash
Экспорт в Flash

A. Экспорт непосредственно в SWF B. Экспорт в FLA для редактирования во Flash Professional 

Создание интерактивных файлов SWF (Flash) для Интернета

При экспорте в SWF создается интерактивный файл, готовый к просмотру в Adobe Flash Player или веб-браузере. Файл SWF может содержать кнопки, переходы страниц, видеоролики, аудиоклипы, анимацию и гиперссылки, добавленные в InDesign. Экспорт в SWF представляет собой удобный способ создания интерактивных слайд-шоу или книжек с переворачивающимися страницами на основе документа InDesign.

При необходимости редактирования документа в Flash Pro перед созданием файла SWF следует сначала экспортировать документ в формат FLA. См. Создание интерактивных файлов FLA для Интернета.

Экспорт в SWF
Экспорт в SWF

A. Документ в InDesign перед экспортом в SWF B. Интерактивный SWF-файл в веб-браузере 
  1. Создайте или измените документ InDesign для подготовки его к экспорту в Flash. Более подробные сведения о подготовке документа к экспорту см. в разделе Проблемы экспорта в Flash.

    • Создайте навигационные кнопки, которые позволят пользователям перемещаться со страницы на страницу в экспортированном файле SWF. Кнопки могут быть созданы посредством перетаскивания объекта и преобразования его в кнопку с использованием палитры «Кнопки» (выберите «Окно» > «Интерактивные элементы» > «Кнопки»). Можно также воспользоваться палитрой «Образцы кнопок» для перетаскивания предварительно созданных кнопок в документ. См. раздел Создание кнопок.

    • Используйте палитру «Переходы страниц» (выберите «Окно» > «Интерактивные элементы» > «Переходы страницы»), чтобы добавить такие переходы страниц, как «стирание» и «растворение». При экспорте в SWF можно также установить параметр «Включить интерактивное переворачивание страниц», позволяющий пользователю перетаскивать уголок страницы, чтобы ее перевернуть.

    • Воспользуйтесь палитрой «Анимация» («Окно» > «Интерактивные элементы» > «Анимация») для добавления стилей движения. См. раздел Анимация.

  2. Для экспорта документа в формат SWF выберите Файл > Экспорт

  3. Выберите Использовать имя документа InDesign в качестве имени файла вывода, если хотите, чтобы имя экспортированного файла PDF совпадало с именем следующего экспортированного документа.

  4. Выберите Flash Player (SWF) в меню Тип файла (Windows) или Формат (Mac OS) и нажмите Сохранить.

  5. В диалоговом окне «Экспорт SWF» укажите необходимые параметры и нажмите «OK». См. раздел Параметры экспорта SWF.

При экспорте SWF-файла, разделите созданные файлы HTML и SWF. Если файл SWF включает в себя фильм или звуковой клип, создается также папка «Ресурсы». Перед передачей или загрузкой файлов в Интернет убедитесь, что вы отправляете все ресурсы.

Параметры экспорта SWF

На вкладках «Основные» и «Дополнительные» диалогового окна «Экспорт SWF» имеются следующие параметры.

Экспорт

Укажите, следует ли экспортировать текущее выделение, все страницы в документе или определенный диапазон страниц. Выбор параметра «Выделение» особенно полезен, если требуется сохранить экспортированный файл SWF для использования в экспортированном файле PDF. При выборе параметра «Диапазон» укажите диапазон страниц, например 1-7, 9, чтобы напечатать страницы с 1 по 7 и 9. См. раздел Указание страниц для печати.

Генерировать файл HTML

Выберите этот параметр, чтобы создать HTML-страницу для воспроизведения файла SWF. Этот параметр удобен для быстрого просмотра файла SWF в веб-браузере.

Просмотр SWF после экспорта

Выберите этот параметр, чтобы воспроизвести файл SWF в веб-браузере по умолчанию. Этот параметр доступен только в случае создания HTML-файла.

Размер (пикс.)

Укажите процентное изменение масштаба файла SWF, подгонку под указанный размер экрана, либо задайте ширину и высоту вручную.

Фон

Укажите, будет ли фон документа SWF прозрачным или должен использоваться текущий цвет бумаги из палитры «Образцы». При выборе параметра «Прозрачный» отключаются параметры «Переходы страниц» и «Включить интерактивное переворачивание страниц».

Интерактивность и мультимедиа

Выберите «Включить все», чтобы включить интерактивность видеороликов, звуков, кнопок и анимированных объектов в экспортированном файле SWF. Выберите параметр «Только оформление», чтобы включить обычное состояние кнопок и видеоафиши в качестве статичных элементов. Если выбран параметр «Только оформление», анимации экспортируются в том виде, в котором они существуют в макете на момент экспорта. Параметр «Только оформление» выбран, если на панели «Дополнительные» выбран параметр «Свести прозрачность».

Переходы страниц

Выберите один переход страницы, который будет применен ко всем страницам в процессе экспорта. Если для указания переходов используется палитра «Переходы страниц», выберите параметр «Из документа», чтобы использовать эти настройки.

Включить интерактивное переворачивание страниц

Если выбран этот параметр, пользователи, воспроизводящие SWF-файл, смогут перелистывать страницу, перетягивая ее угол, как настоящую книжную страницу.

Частота кадров

При более высокой частоте кадров создаются более плавные анимации, однако размер файла может увеличиться. При изменении частоты кадров длительность воспроизведения не изменяется.

Текст

Укажите способ вывода текста InDesign. Выберите параметр «Классический текст Flash», чтобы выводить текст, доступный для поиска, что позволяет получить файл минимального размера. Выберите параметр «Преобразовать в кривые», чтобы выводить текст как ряд сглаженных прямых линий. Выберите параметр «Преобразовать в пикселях», чтобы выводить текст в растровое изображение. Текст, преобразованный в пиксели, может отображаться с зубчатыми краями при увеличении масштаба.

Растрировать страницы

Если выбран этот параметр, все элементы страницы InDesign будут преобразованы в растровые объекты. Выбор этого параметра приводит к увеличению размера SWF-файла, а элементы страницы могут отображаться с зубчатыми краями при увеличении масштаба.

Свести прозрачность

Этот параметр удаляет «живые» эффекты прозрачности из SWF и сохраняет оформление прозрачности. Если выбран этот параметр, из экспортированного файла SWF удаляются все интерактивные элементы.

Сжатие

Выберите параметр «Автоматически», чтобы программа InDesign автоматически выбирала наилучшее качество цветных изображений и изображений в градациях серого. Для большинства файлов этот параметр дает удовлетворительные результаты. JPEG (с потерей качества) подходит для цветных изображений или изображений в градациях серого. Сжатие JPEG выполняется с потерей данных, что предполагает удаление данных изображения, при этом возможно ухудшение качества изображения, однако уменьшение размера файла выполняется с минимально возможными потерями данных. Поскольку при сжатии JPEG данные частично удаляются, размер файлов становится намного меньше. PNG (без потери качества) позволяет экспортировать файл без сжатия, приводящего к потере данных.

Примечание.

Если при экспорте в SWF наблюдается потеря качества в прозрачных изображениях, выберите PNG (без потери качества), чтобы улучшить качество.

Качество JPEG

Задает степень детализации экспортируемого изображения. Чем выше качество, тем больше размер файла. Этот параметр недоступен, если для сжатия изображения был выбран параметр PNG (без потери качества).

Разрешение

Укажите разрешение растровых изображений в экспортированном SWF. Выбор высокого разрешения особенно важен для обеспечения возможности увеличения пиксельного изображения в экспортированном файле SWF. При высоком разрешении может значительно увеличиться размер файла.

Создание интерактивных файлов FLA для Интернета

Документ InDesign, экспортированный в формат FLA-файла, можно открыть в проигрывателе Adobe Flash® CS5 Professional для редактирования содержимого. Экспорт в формат FLA в InDesign CS5 заменяет экспорт в формат XFL в InDesign CS4. Используйте среду разработки авторских приложений Flash, чтобы добавить или изменить видео, аудио, анимацию и сложные интерактивные элементы.

При необходимости экспорта документа InDesign непосредственно в формат, который может быть открыт в веб-браузере, используйте SWF, а не FLA. См. Создание интерактивных файлов SWF (Flash) для Интернета.

Экспорт в FLA
Экспорт в FLA

A. Документ в InDesign перед экспортом в FLA B. FLA-файл, открытый в программе Flash Pro 
  1. Создайте или измените документ InDesign для подготовки его к экспорту в Flash. Более подробные сведения о подготовке документа к экспорту см. в разделе Проблемы экспорта в Flash.

  2. Для экспорта документа в формат FLA выберите «Файл» > «Экспорт». Выберите Flash CS5 Professional (FLA) в поле «Тип файла» (Windows) или «Формат» (Mac OS) диалогового окна «Сохранить как» и нажмите «Сохранить».

  3. В диалоговом окне «Экспорт Flash CS5 Professional (FLA)» укажите нужные параметры и нажмите «OK». Сведения о параметрах экспорта, см. в Параметры экспорта FLA.

  4. Откройте экспортированный в формат FLA файл в программе Flash Professional.

Параметры экспорта FLA

В диалоговом окне «Экспорт Flash CS5 Professional (FLA)» имеются следующие параметры.

Экспорт

Укажите, следует ли экспортировать текущее выделение, все страницы в документе или определенный диапазон страниц. При выборе параметра «Диапазон» укажите диапазон страниц, например 1-7, 9, чтобы напечатать страницы с 1 по 7 и 9. См. раздел Указание страниц для печати.

Растрировать страницы

Если выбран этот параметр, все элементы страницы InDesign будут преобразованы в растровые объекты. Выбор этого параметра приводит к увеличению размера FLA-файла, а элементы страницы могут отображаться с зубчатыми краями при увеличении масштаба.

Свести прозрачность

Выбор этого параметра позволяет свести прозрачность для всех объектов. Сведенные объекты плохо поддаются анимации в Adobe Flash Pro.

Размер (пикс.)

Укажите процентное изменение масштаба файла FLA, подгонку под указанный размер экрана, либо задайте ширину и высоту вручную.

Интерактивность и мультимедиа

Выберите «Включить все», чтобы включить интерактивность видеороликов, звуков, кнопок и анимированных объектов в экспортированном файле FLA. Если документ содержит объект с несколькими состояниями, он конвертируется в символ видеоклипа, в котором каждое состояние появляется в собственном кадре на шкале воспроизведения.

Выберите параметр «Только оформление», чтобы включить обычное состояние кнопок и видеоафиши в качестве статичных элементов. Если выбран параметр «Только оформление», анимации экспортируются в том виде, в котором они существуют в макете на момент экспорта. Параметр «Только оформление» выбран, если выбран параметр «Свести прозрачность».

Текст

Укажите способ вывода текста InDesign. Выберите параметр «Текст Flash TLF», чтобы воспользоваться богатым набором атрибутов текста в Flash Professional. Если выбран этот параметр, выберите «Вставлять переносы из словаря», чтобы разрешить расстановку переносов. Выберите параметр «Классический текст Flash», чтобы выводить текст, доступный для поиска, что позволяет получить файл минимального размера. Выберите параметр «Преобразовать в кривые», чтобы выводить текст как ряд сглаженных прямых линий. Выберите параметр «Преобразовать в пикселях», чтобы выводить текст в растровое изображение. Текст, преобразованный в пиксели, может отображаться с зубчатыми краями при увеличении масштаба.

Сжатие

Выберите параметр «Автоматически», чтобы программа InDesign автоматически выбирала наилучшее качество цветных изображений и изображений в градациях серого. Для большинства файлов этот параметр дает удовлетворительные результаты. JPEG (с потерей качества) подходит для цветных изображений или изображений в градациях серого. Сжатие JPEG выполняется с потерей данных, что предполагает удаление данных изображения, при этом возможно ухудшение качества изображения, однако уменьшение размера файла выполняется с минимально возможными потерями данных. Поскольку при сжатии JPEG данные частично удаляются, размер файлов становится намного меньше. PNG (без потери качества) позволяет экспортировать файл без сжатия, приводящего к потере данных.

Качество JPEG

Задает степень детализации экспортируемого изображения. Чем выше качество, тем больше размер файла. Этот параметр недоступен, если для сжатия изображения был выбран параметр PNG (без потери качества).

Разрешение

Укажите разрешение растровых изображений в экспортированном файле FLA. Выбор высокого разрешения особенно важен для обеспечения возможности увеличения пиксельного изображения. При высоком разрешении может значительно увеличиться размер файла.

Проблемы при экспорте в программу Flash

При подготовке документов InDesign к выводу в форматах SWF и FLA учитывайте следующие факторы.

Проблемы, связанные с параметрами документа

Преобразование страниц InDesign

При экспорте в формат SWF или FLA развороты InDesign преобразуются в отдельные клипы на временной шкале, как слайды в слайд-шоу. Каждому развороту соответствует отдельный ключевой кадр. В проигрывателе Flash Player переход от одного разворота экспортированного документа к другому выполняется нажатием клавиш со стрелками или щелчками на интерактивных кнопках.

Примечание.

При создании документа, предназначенного для Интернета, выбирайте «Браузер» в меню «Метод» диалогового окна «Новый документ».

Формат страницы

При создании документа можно выбрать определенное разрешение, например, 800 x 600, в меню «Формат страницы» диалогового окна «Новый документ». Во время экспорта можно также отрегулировать масштаб и разрешение экспортируемых файлов SWF и FLA.

Интерактивные возможности

В экспортируемые файлы SWF и FLA можно включать кнопки, переходы страниц, гиперссылки анимацию и файлы мультимедиа.

Кнопки

Кнопкам экспортируемого файла SWF или FLA можно назначить действия «Следующая страница» и «Предыдущая страница», часто используемые при воспроизведении в проигрывателе Flash Player. Тем не менее, некоторые действия, применяемые в интерактивных PDF-файлах, не поддерживаются в проигрывателе Flash Player. При выборе действия на палитре «Кнопки» не выбирайте параметры в разделе «Только PDF».

Примечание.

Можно добавить навигационные кнопки, для которых предопределены действия «Перейти на следующую страницу», «Перейти на предыдущую страницу». Выберите «Образцы кнопок» в меню палитры «Кнопки». См. раздел Добавление кнопки из палитры «Образцы кнопок».

Переходы страниц

Все переходы страниц поддерживаются в проигрывателе Flash Player. Кроме переходов страниц, отображающихся при переворачивании выбранной страницы, можно во время экспорта добавить интерактивное переворачивание страниц, позволяющее перелистывать страницы за их уголки.

Гиперссылки

Имеется возможность создания ссылок на веб-сайты или другие страницы документа. Гиперссылки в FLA-файлах нарушаются.

Аудио и видео

Фильмы и аудиоклипы включаются в экспортированный файл SWF, если поддерживается их формат, например SWF, FLV, F4V и MP4 для видео, MP3 для аудиоклипов.

При экспорте в FLA в файл включается только афиша. Поддерживаемые файлы мультимедиа появляются в папке с ресурсами, которая сохраняется в том же месте, что и экспортированный файл FLA.

Проблемы с конвертированием

Цвета

Файлы SWF и FLA используют цвета RGB. При экспорте документа в формат SWF или FLA программа InDesign конвертирует все цветовые пространства (например, CMYK или LAB) в sRGB. InDesign преобразует плашечные цвета в эквивалентные триадные цвета RGB.

Во избежание нежелательных изменений цвета в графическом объекте, содержащем текст с прозрачностью, выберите пункты меню «Редактирование» > «Пространство при обработке прозрачности» > «RGB документа». Во избежание нежелательных изменений цвета в изображениях с прозрачностью следует избегать сжатия с потерей качества при экспорте.

Текст

При экспорте в формат SWF или FLA можно задать вывод текста в виде флэш-текста, векторных контуров или растрового текста. Текст, экспортированный как «Классический текст Flash», остается полностью доступным для редактирования при открытии XFL-файла в среде Adobe Flash CS5 Professional и для поиска в веб-браузерах при сохранении в виде SWF-файлов.

Изображения

При экспорте изображений в формат SWF или FLA можно изменить параметры сжатия изображения, качество JPEG и настройки разрешения.

При экспорте в формат FLA изображения, несколько раз помещенного в документ InDesign, оно сохраняется как единый графический ресурс в папке с общим доступом. Следует помнить, что большое число векторных изображений в документе InDesign может снизить эффективность использования экспортируемого файла.

Для уменьшения размера файла помещайте повторяющиеся изображения на страницах-шаблонах, избегая копирования и вставки изображений. Если одно и то же изображение помещается в документ многократно без преобразования или обрезки, то в FLA-файл будет экспортирована только одна копия файла изображения. Изображения, добавляемые с использованием операций копирования и вставки, обрабатываются как отдельные объекты.

По умолчанию, помещенный файл Illustrator обрабатывается как единичное изображение в FLA-файле, в то время как при копировании и вставке файла Illustrator создается большое число отдельных объектов. Для получения наилучших результатов поместите изображение Illustrator как файл PDF вместо копирования и вставки из программы Illustrator. В результате копирования и вставки создается множество редактируемых контуров.

Примечание.

Можно изменить параметры установки таким образом, чтобы вставка объектов Illustrator выполнялась в виде одного объекта, а не набора небольших векторов. В разделе установок «Обработка файлов и буфер обмена» программы Illustrator установите флажок в поле «PDF» и снимите флажок в поле «AICB» (без поддержки прозрачности). В разделе установок «Обработка буфера» программы InDesign установите флажки в полях «Вставлять в формате PDF» и «Копировать в формате PDF».

Прозрачность

Перед началом экспорта в SWF убедитесь, чтобы прозрачные объекты не перекрывали интерактивные элементы, такие как кнопка или гиперссылка. Если объект с прозрачными областями перекрывает интерактивный элемент, его интерактивность не будет сохраняться во время экспорта. Перед экспортом в формат FLA, возможно, потребуется сведение прозрачности.

В отдельных случаях, при выборе сжатия с потерей качества, качество изображений с прозрачностью снижается. Для улучшения качества при экспорте следует выбирать параметр PNG (без потерь качества).

3D-атрибуты

3D-атрибуты не поддерживаются в экспортируемых файлах SWF и FLA.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет