Ratkaisuja sivustossa olevien PDF-tiedostojen katseluun liittyviin yleisiin ongelmiin.

Oireet 

Yleisiä oireita, kun PDF-tiedoston näyttäminen verkossa ei onnistu:

  • Tyhjä sivu verkkoselaimessa
  • Punainen X-kuvake
  • Toimimattoman linkin ilmaisin, kuten punainen neliö, sininen kolmio tai sininen ympyrä
  • Virhe: ”Käynnissä olevaa Adobe Acrobatia/Readeria ei voida käyttää PDF-tiedostojen katseluun Internet-selaimessa. Adobe Acrobatin/Readerin versiota 8 tai 9 vaaditaan. Poistu ja yritä uudelleen.”

Voit ratkaista yleisimmät PDF-tiedostojen näyttämiseen liittyvät ongelmat noudattamalla alla olevia ohjeita seuraavassa järjestyksessä: päivitä Reader- tai Acrobat-ohjelma, korjaa PDF-tiedostoon liittyvät ongelmat, tarkista selaimen asetukset, asenna Reader tai Acrobat tai asenna se uudelleen.

Reader- tai Acrobat-ohjelman päivittäminen

Adobe julkaisee ilmaisia tietoturvapäivityksiä neljännesvuosittain. Päivitä Reader tai Acrobat uusimpaan versioon. Päivitykset sisältävät usein korjauksia yleisiin ongelmiin. Lataa uusin ilmainen päivitys.

  1. Avaa Reader tai Acrobat.

  2. Valitse Ohje > Tarkista päivitykset. 

    Acrobat 9 ja sitä aikaisemmat versiot: Jos uusi päivitys on saatavilla, se asennetaan automaattisesti.

    Acrobat X ja XI: Valitse Päivitä ja sitten Asenna.

    Acrobat DC: Jatka seuraavaan vaiheeseen.

    Tarkista päivitykset
  3. Kun päivitysohjelman valintaikkuna tulee näyttöön, valitse Lataa.

    Päivitä Acrobat
  4. Kun lataus on päättynyt, napsauta Acrobatin asennuskuvaketta. Valitse Acrobatin päivitysohjelman ikkunasta Asenna.

    Päivitys on valmiina
  5. Kun asennus on suoritettu, käynnistä tietokone uudelleen ja tarkista, pystytkö näyttämään PDF-tiedoston.

PDF-tiedostoihin liittyvät ratkaisut

Päivitä sivu tai lataa se uudelleen

PDF-tiedosto latautuu usein kokonaan, kun päivität selaimen sivun.

  • Pidä Vaihto-näppäintä painettuna ja paina selaimen  Päivitä- tai  Lataa uudelleen -painiketta.

Yritä näyttää toinen PDF-tiedosto

Yritä näyttää toinen PDF-tiedosto. Tarkista esimerkiksi, näkyykö tämä mallilomake selaimessasi. Jos Acrobat tai Reader pystyy avaamaan mallilomakkeen, toinen PDF-tiedosto voi olla vioittunut tai verkkopalvelimella voi olla ongelmia. Ota mahdollisuuksien mukaan yhteyttä verkkosivuston ylläpidosta vastaavaan henkilöön tai yritykseen.

Yritä näyttää kiintolevyllä oleva PDF-tiedosto

Määritä, voiko Internet-selain avata PDF-tiedoston paikalliselta kiintolevyltä verkon sijaan. Tarvitset tätä kokeilua varten tietokoneelle tallennetun PDF-tiedoston.

  1. Toimi verkkoselaimessa seuraavasti:

    • Mac OS: Valitse Tiedosto > Avaa (tai Avaa tiedosto).
    • Windows: Paina Control + O.
  2. Valitse Selaa.

  3. (Vain Windows) Valitse Tiedostoja, joiden tyyppi on -valikosta Kaikki tiedostot.

    Valitse kaikki tiedostot
  4. Etsi tietokoneelta PDF-tiedosto, valitse se ja napsauta Avaa-painiketta.

    Jos PDF-tiedosto avautuu, ongelma voi olla katsomassasi sivustossa. Ota yhteyttä verkkosivuston ylläpidosta vastaavaan henkilöön tai yritykseen.

Selaimeen ja selaimen asetuksiin liittyvät ratkaisut

Eri verkkoselaimen käyttäminen

Tietyt tietokoneeseen liittyvät tekijät, kuten tietoturva-asetukset tai selaimen evästeet, voivat estää PDF-tiedoston näyttämisen. Usein nopein ratkaisu on yrittää avata sivu toisella selaimella. Kokeile jotakin seuraavista selaimista, jota et vielä ole yrittänyt käyttää:

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

Readerin ja Acrobatin kanssa yhteensopivien selainten luettelo on artikkelissa Yhteensopivat verkkoselaimet.

Siirry yhteensopivuusnäkymään (Internet Explorer)

Jotkin sivustot näkyvät paremmin Internet Explorerin yhteensopivuusnäkymässä. Yhteensopivuusnäkymässä sivu näytetään aivan kuin selaimen aikaisemmassa versiossa.

Ohjeet tähän näkymään siirtymiseksi on esitetty artikkelissaSivuston näyttöongelmien korjaaminen Yhteensopivuusnäkymässä.

Käynnistä tietokone uudelleen ja yritä sitten avata PDF-tiedosto

Käynnistä tietokone uudelleen ja avaa sitten verkkosivu uudelleen. Tietokoneen muisti ja välimuisti tyhjennetään uudelleenkäynnistyksen yhteydessä. Tietokoneen uudelleenkäynnistäminen ratkaisee usein näyttöongelmat.

Poista väliaikaiset Internet-tiedostot (Internet Explorer, Firefox ja Chrome)

Tyhjennä selaimen välimuisti (jota kutsutaan joskus nimellä väliaikaiset Internet-tiedostot), jotta katsot varmasti sivun uutta versiota. 

Ole huolellinen, kun valitset asetuksia. Tyhjennä vain selaimen välimuisti. Jos poistat kaikki väliaikaiset Internet-tiedostot, voit poistaa kirjautumistiedot ja määritykset sisältävät evästeet. Useimmat selaimet antavat sinun valita poistettavien sisältöjen tyypin.

Poista historia
Firefoxin Poista historiatietoja -valintaikkunassa voit tyhjentää vain selaimen välimuistin.

Ohjeita selaimen välimuistin tyhjentämiseen on seuraavissa artikkeleissa:

Firefox: Poista selaus-, haku- ja lataushistoria

Chrome: Poista välimuisti-, historia- ja muut selaustiedot

Internet Explorer 8–11: Selaushistorian tarkasteleminen ja poistaminen

Internet Explorer 7Verkkosivuhistorian poistaminen

Palauta Näytä PDF-tiedosto selaimessa -asetuksen valinta (Acrobat / Reader X tai sitä aikaisempi versio)

Yritä ratkaista näyttöongelma palauttamalla selaimen näyttöasetukset.

  1. Napsauta Readerissa tai Acrobatissa asiakirjaikkunaa hiiren kakkospainikkeella ja valitse Sivun näyttö -asetukset.

    Sivun näyttö -asetukset
  2. Valitse vasemmalla olevasta luettelosta Internet.

    Valitse Internet-asetukset.
  3. Poista Näytä PDF selaimessa -asetuksen valinta ja napsauta sitten OK.

    Poista Näytä PDF selaimessa -asetuksen valinta
  4. Yritä ladata PDF-tiedosto uudelleen verkkosivustosta.

Näytä PDF-tiedosto Internet Explorerin tai Safarin 32-bittisellä versiolla (vain Windows Vista)

Tämä menetelmä koskee vain Internet Explorer 9:ää tai sitä aikaisempia versioita käyttäviä Windows Vistan käyttäjiä.

Acrobat ja Reader ovat Windowsissa 32-bittisiä sovelluksia. Jos yrität avata PDF-tiedostoa Internet Explorerin 64-bittisessä versiossa, PDF avautuu erillisessä Acrobat- tai Reader-ikkunassa Internet Explorerin sijaan.

Huomautus:

Vain Reader 10.1 tai Acrobat 10.1 ja niitä uudemmat versiot tukevat Internet Explorer 9:ää.

Voit tarkistaa, että käytössä on 32-bittinen Internet Explorer -versio, noudattamalla seuraavia ohjeita:

  1. Valitse Internet Explorerista Ohje > Tietoja Internet Explorerista. (Joissakin Internet Explorerin versioissa on valittava oikean yläkulman kysymysmerkki, jotta Tietoja Internet Explorerista voidaan valita.)

    Tietoja Internet Explorer 9:stä

    Jos näet version vieressä maininnan ”64-bit Edition”, siirry vaiheeseen 2.

    64-bittinen Internet Explorer
  2. Jos haluat siirtyä Internet Explorerin 32-bittiseen versioon, sulje ensin Internet Explorerin 64-bittinen versio. Kaksoisnapsauta sitten 32-bittisen version ohjelmakuvaketta:

    C:\Program Files (x86)\Internet Explorer\iexplore.exe

    32-bittinen Internet Explorer

Readerin ja Acrobatin ratkaisut

Korjaa Reader tai Acrobat

Reader tai Acrobat voivat olla vioittuneita. Asennuksen korjaaminen on nopea tapa korjata virhe.

Korjaa Readerista tai Acrobatista

Valitse Ohje > Korjaa asennus.

Ohje, Korjaa asennus

Korjaa Ohjauspaneelista (Windows)

Voit korjata Acrobatin tai Readerin asennuksen myös Windowsin Ohjauspaneelista.

  1. Sulje Reader tai Acrobat.

  2. Valitse Käynnistä > Ohjauspaneeli.

    Käynnistä Ohjauspaneeli
  3. Tee jokin seuraavista toimista Ohjauspaneelissa käytössä olevan Windows-version mukaan:

    • (Windows 8/7/Vista) Valitse Ohjelmat ja sen jälkeen Ohjelmat ja toiminnot.
    • (Windows XP) Kaksoisnapsauta Lisää tai poista sovellus.
  4. Valitse ohjelmaluettelosta Adobe Reader tai Adobe Acrobat.

  5. Valitse Muuta ja noudata ohjeita ohjelman korjaamiseksi.

    Korjaa valitsemalla Muuta
  6. Kun prosessi on valmis, napsauta Valmis.

Edistykselliset ratkaisut

Jos mikään edellä olevien osien ratkaisuista korjannut PDF-tiedostojen näyttämiseen liittyvää ongelmaa, voit kokeilla seuraavia edistyksellisiä ohjeita.

Ota Adoben PDF-tiedostojen selainlisäosa käyttöön (Internet Explorer 8 ja sitä uudemmat versiot)

Varmista, että Adoben PDF-tiedostojen selaimen lisäosa on käytössä.

  1. Avaa Internet Explorer ja valitse Työkalut > Lisäosien hallinta.

  2. Valitse Lisäosatyypit-kohdasta Työkalurivit ja laajennukset.

  3. Valitse Näytä-valikosta Kaikki lisäosat.

    Kaikki lisäosat
  4. Valitse lisäosaluettelosta Adobe PDF Reader.

    Huomautus:

    Jos Adobe PDF Reader -lisäosaa ei näy, kokeile valikon muita vaihtoehtoja. Joissakin järjestelmissä saat lisäosan näkyviin esimerkiksi valitsemalla Suorita ilman käyttöoikeutta.

  5. Napsauta Ota käyttöön -painiketta.

    Huomautus:

    Jos painikkeessa lukee Poista käytöstä, lisäosa on jo käytössä. Tällä painikkeella voi vaihtaa Ota käyttöön- ja Poista käytöstä -tilojen välillä valitun lisäosan tilan mukaan.

    Jos valitset Ota käyttöön, Adobe PDF Reader -lisäosa määritetään avaamaan PDF-tiedostot selaimessa.

    Jos valitset Poista käytöstä, lisäosa poistetaan käytöstä eikä se avaa PDF-tiedostoja selaimessa.

    Ota Acrobat Reader käyttöön

Ota Adoben PDF-tiedostojen selaimen lisäosa käyttöön (Firefox)

Varmista, että Adoben PDF-tiedostojen selaimen lisäosa (nppdf32.dll) on käytössä.

  1. Kirjoita Firefoxin osoiteriville about:plugins

  2. Vieritä alas osioon nimeltä Adobe Acrobat.

    Käytössä Firefoxissa
  3. Varmista, että tiedostossa lukee ”nppdf32.dll” ja ”Adobe Acrobat Plug-In for Netscape”.
    Jos tämä valinta ei ole käytettävissä, asenna Readerin tai Acrobatin uusin versio.

Acrobatin tai Readerin suorittaminen kirjautuneena uuteen paikalliseen järjestelmänvalvojan tiliin

Luo käyttäjätili, jolla on samat käyttöoikeudet kuin tilillä, jota käytät silloin, kun ongelma ilmenee. Voit myös luoda paikallisen pääkäyttäjätilin. Jos ongelma ei toistu, kun olet kirjautunut uuteen tiliin, alkuperäinen käyttäjätili saattaa olla vioittunut.

Tietoja käyttäjätilin luonnista saat seuraavista resursseista tai ottamalla yhteyttä verkonvalvojaan:

Windows XP: Uuden käyttäjän lisääminen tietokoneelle

Windows Vista/7/8: Luo käyttäjätili

Mac OS X: Käyttäjien luominen Macilla

Optimoi laajoja PDF-tiedostoja

Jos PDF-tiedosto on 4 Mt tai suurempi, pyydä tarjoajaa optimoimaan PDF-tiedosto. Lisätietoja PDF-tiedostojen optimoinnista on ohjeaiheessa PDF-tiedostojen optimointi.

Tarkista Acrobatin tai Readerin rekisteripolku (Windows)

Vastuuvapauslauseke: Rekisteri sisältää järjestelmään liittyviä tietoja, jotka ovat kriittisiä tietokoneen ja sovellusten kannalta. Muista ottaa varmuuskopio rekisteristä ennen sen muokkaamista. Adobe ei tarjoa tukea ongelmiin, jotka saattavat aiheutua siitä, että rekisteriä muokataan virheellisesti. Adobe suosittelee vahvasti, että rekisteriä muokkaavalla henkilöllä on kokemusta järjestelmätiedostojen muokkaamisesta. Lisätietoja rekisteristä saat Windowsin dokumentaatiosta tai ottamalla yhteyttä Microsoftiin.

  1. Siirry kohtaan Käynnistä > Suorita.

  2. Kirjoita regedit ja valitse OK.

  3. Selaa avaimeen HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. Varmista, että Acrobatin tai Readerin poluksi on määritetty oletusarvo.

    • Readerin oletuspolku on C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe.
    • Acrobatin oletuspolku on C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe.

    Huomautus:

    Jos Acrobat tai Reader on asennettu muuhun kuin oletussijaintiin, varmista, että avaimen oletusarvo osoittaa ohjelmiston nykyiseen sijaintiin.

Katso ohjeiden videoesittely Oikean rekisteripolun tarkistaminen.

Jos yllä mainittua rekisterikohdetta ei löydy järjestelmästä, toimi seuraavasti:

  1. Siirry kohtaan Käynnistä > Suorita.

  2. Kirjoita regedit ja valitse OK.

  3. Varmuuskopioi nykyinen rekisteritiedosto:

    • Valitse rekisterieditorin valintaruudussa Tiedosto > Vie.
    • Kirjoita tiedostolle nimi ja valitse paikka.
    • Valitse vientialueeksi Kaikki.
    • Valitse Tallenna.
  4. Siirry kohtaan Muokkaa > Uusi > Avain ja luo sitten puuttuva HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  5. Siirry kohtaan Muokkaa > Uusi > Merkkijonoarvo ja anna sen nimeksi (oletus).

  6. Valitse (oletus) ja valitse sitten Muokkaa > Muokkaa. Kirjoita tuotteen oletuspolku (katso yllä) Arvon data -kenttään.

  7. Käynnistä tietokone uudelleen.

Korjaa rekisteriavain HKCR\AcroExch.Document (Windows)

On mahdollista, että avain on vaurioitunut, viittaa Acrobatin tai Readerin vanhaan versioon tai viittaa kolmannen osapuolen PDF-katseluohjelmaan.

Vastuuvapauslauseke: Rekisteri sisältää järjestelmään liittyviä tietoja, jotka ovat kriittisiä tietokoneen ja sovellusten kannalta. Muista ottaa varmuuskopio rekisteristä ennen sen muokkaamista. Adobe ei tarjoa tukea ongelmiin, jotka saattavat aiheutua siitä, että rekisteriä muokataan virheellisesti. Adobe suosittelee vahvasti, että rekisteriä muokkaavalla henkilöllä on kokemusta järjestelmätiedostojen muokkaamisesta. Lisätietoja rekisteristä saat Windowsin dokumentaatiosta tai ottamalla yhteyttä Microsoftiin.

  1. Valitse Käynnistä > Suorita, Kirjoita regedit Suorita-valintaruudun avoimeen tekstikenttään ja napsauta sitten OK.

  2. Varmuuskopioi nykyinen rekisteritiedosto:

    • Valitse rekisterieditorin valintaruudussa Tiedosto > Vie.
    • Kirjoita tiedostolle nimi ja valitse paikka.
    • Valitse vientialueeksi Kaikki.
    • Valitse Tallenna.
  3. Siirry kohtaan HKEY_CLASSES_ROOT\AcroExch.Document.

  4. Napsauta hiiren kakkospainikkeella AcroExch.Document ja valitse Poista; varmista, että sinulla on oikea avain ja napsauta kaikissa kehotteissa Kyllä.

  5. Napsauta hiiren kakkospainikkeella AcroExch.Document.7 ja valitse Poista; varmista, että sinulla on oikea avain ja napsauta kaikissa kehotteissa Kyllä.

  6. Seuraavassa videossa esitellään yllä kuvatut vaiheet.

     

Vaihda verkkopalvelimen sisältötyypin otsikko (verkonvalvojat)

Jos olet sivustovastaava tai sinulla on hallintaoikeudet sivustoon, määritä verkkopalvelin lähettämään sisältötyyppiset ’application/pdf’-otsikot PDF-tiedostoille. Ohjeita on verkkopalvelimen mukana toimitetussa dokumentaatiossa tai tässä Microsoftin tukiartikkelissa.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö