Ongelma

PDFMaker-kuvake (Muunna Adobe PDF:ksi) ja Acrobat-valikko puuttuvat Microsoft Office 2003-, Office XP- tai Office 2000 -sovelluksesta (esimerkiksi Access, Excel tai Word).

Ratkaisu

Ohjeet:

Ratkaisu 1: Poista Adobe PDF käytöstä poistettujen kohteiden luettelosta Microsoft Office -sovelluksessa.

  1. Avaa Microsoft Office -ohjelma (Word, Excel, Publisher tai Excel).
  2. Valitse Ohje > Tietoja [ohjelman nimi].
  3. Napsauta Käytöstä poistetut kohteet.
  4. Valitse Adobe PDF luettelosta ja napsauta Ota käyttöön.
  5. Lopeta Microsoft Office -ohjelma ja käynnistä se uudelleen.

Huomautus: Microsoft Office -ohjelmat poistavat varokeinona apuohjelmat käytöstä, jos ohjelma sulkeutuu ennenaikaisesti (jos esimerkiksi järjestelmää ei suljettu kunnolla tai jos sovellus kaatui).

Ratkaisu 2: Varmista, että PDFMaker-komponentit on asennettu.

  1. Valitse Käynnistä > Suorita, kirjoita avoimeen tekstiruutuun appwiz.cpl ja avaa sitten Lisää tai poista sovellus -valintaikkuna napsauttamalla OK.
  2. Etsi ja valitse Adobe Acrobat 7 tai Adobe Acrobat 8 ja napsauta Muuta tai poista.
  3. Kun ohjattu toiminto tulee näyttöön, napsauta Seuraava.
  4. Valitse Muokkaa ja napsauta uudelleen Seuraava.
  5. Laajenna Luo Adobe PDF -puunäkymä ja napsauta sitten nuolta alaspäin Acrobat PDFMaker -objektissa.
  6. Valitse Ominaisuus asennetaan paikalliselle kiintolevylle, napsauta sitten Seuraava ja sitten Päivitä.

Ratkaisu 3: Ota COM-apuohjelmatiedosto käyttöön Office-sovelluksessa.

  1. Käynnistä Office-sovellus.
  2. Valitse Ohje > Tietoja [sovellus].
  3. Napsauta Käytöstä poistetut kohteet.
  4. Etsi luettelosta PDFMakerOfficeAddin-kohdetta:
    • Jos se on luettelossa, valitse se ja napsauta Ota käyttöön. Sulje kaikki valintaikkunat ja käynnistä Office-sovellus uudelleen.
    • Jos sitä ei ole luettelossa, varmista, että PDFMOfficeAddin.dll-tiedosto on Acrobat 7.0/PDFMaker/Office (Acrobat 7, Acrobat 3D) tai Acrobat 8.0/PDFMaker/Office (Acrobat 8) -kansiossa. Jos tiedosto puuttuu, asenna Acrobat uudelleen.

Ratkaisu 4: Nimeä Normal.dot -tiedosto uudelleen.

Nimeämällä yleinen malli (Normal.dot) uudelleen voidaan estää yleiseen malliin (Normal.dot) tallennettujen muotoilujen, automaattisen tekstin ja makrojen vaikuttaminen Wordiin ja muihin ohjelmiin. Näin voidaan nopeasti määrittää, aiheuttaako yleinen malli ongelman.

Tärkeää: Kun Normal.dot-malli nimetään uudelleen, monet asetukset palautetaan oletusarvoonsa, mukaan lukien mukautetut tyylit, mukautetut työkalurivit, makrot ja automaattiset tekstit. Tämän vuoksi Microsoft suosittelee, että Normal.dot-tiedostoa ei poisteta.

Joissakin tilanteissa Normal.dot-tiedostoja voidaan luoda useampia. Tämä ongelma voi ilmetä esimerkiksi silloin, kun tietokoneessa käytetään useampia Word-versioita tai jos samassa tietokoneessa on useita työasemien asennuksia.

Normal.dot-tiedoston nimeäminen uudelleen:

Huomautus: Seuraavat vaiheet koskevat Microsoft Wordia, mutta niitä voidaan käyttää pienin muutoksin myös muiden Microsoft Office -sovellusten kanssa. Älä käytä /a-valitsinta Wordin tai muun sovelluksen uudelleenkäynnistämiseen sen jälkeen, kun olet suorittanut nämä vaiheet.

Windows 2000:

  1. Lopeta kaikki Wordin esiintymät, mukaan lukien Outlook, jos Wordia käytetään sähköpostieditorina.
  2. Valitse Käynnistä > Etsi > Tiedostoja tai kansioita.
  3. Kirjoita Etsi tiedostoja tai kansioita -ruutuun Normal.dot.
  4. Valitse Kohde-luettelosta paikallinen kiintolevy.
  5. Hae tiedostoa napsauttamalla Etsi nyt.
  6. Toimi seuraavasti jokaisen Normal.dot-tiedoston osalta, joka näkyy Hakutulokset-valintaikkunassa.
    • Napsauta tiedostoa hiiren kakkospainikkeella ja valitse Nimeä uudelleen.
    • Anna tiedostolle uusi nimi (esimerkiksi VanhaNormal.dot tai Normal-1.dot) ja paina sitten Enter-näppäintä.
  7. Sulje haku napsauttamalla Tiedosto-valikossa Sulje ja käynnistä Word uudelleen.

Windows XP:

  1. Lopeta kaikki Wordin esiintymät, mukaan lukien Outlook, jos Wordia käytetään sähköpostieditorina.
  2. Valitse Käynnistä > Etsi.
  3. Valitse Valitse etsittävä kohde -ruudusta Kaikki tiedostot ja kansiot.
  4. Kirjoita Tiedostonimi tai nimen osa -ruutuun Normal.dot.
  5. Valitse Kohde-luettelosta paikallinen kiintolevy (tai jokin muu käyttäjän mallin sijainti, jos Word on käynnistetty verkkopalvelimelta).
  6. Napsauta Etsi.
  7. Toimi seuraavasti jokaisen Normal.dot-tiedoston osalta, joka näkyy Hakutulokset-valintaikkunassa.
    • Napsauta tiedostoa hiiren kakkospainikkeella ja valitse Nimeä uudelleen.
    • Anna tiedostolle uusi nimi (esimerkiksi VanhaNormal.dot tai Normal-1.dot) ja paina sitten Enter-näppäintä.
  8. Valitse Tiedosto-valikosta Sulje ja käynnistä Word uudelleen.

Jos ongelma ratkeaa, kun yleinen malli on nimetty uudelleen, ongelman aiheutti vaurioitunut Normal.dot-malli.

Ratkaisu 5: Muuta Office-sovelluksen makrojen suojaustasoa.

Jotta COM-apuohjelmatiedosto voidaan ladata Windowsiin, varmista, että Adobe Inc. on listattu Luotetut julkaisijat -välilehdellä. Jos näin ei ole, muuta suojausasetuksia.

Office 2000-, Office XP- ja Office 2003 -sovellukset:

  1. Valitse Työkalut-valikosta Makro > Suojaus.
  2. Valitse Luotetut julkaisijat -välilehti.
    1. Jos Adobe Inc. on luettelossa, muutoksia ei vaadita.

    2. Jos Adobe Inc. ei ole luettelossa, jatka vaiheeseen 3.

  3. Valitse jokin seuraavista asetuksista:
    • Valitse Suojaus-välilehdellä suojaustasoksi Erittäin suuri. Valitse Luotetut julkaisijat -välilehdellä Luota kaikkiin asennettuihin apuohjelmiin ja malleihin.
    • Valitse Suojaus-välilehdellä suojaustasoksi Suuri. Poista Luotetut julkaisijat -välilehdellä valinta kohdasta Luota kaikkiin asennettuihin apuohjelmiin ja malleihin.
  4. Sulje kaikki valintaikkunat ja käynnistä sovellus uudelleen.

Ratkaisu 6: Lisää COM-apuohjelmatiedosto Windows-rekisteriin.

  1. Etsi COM-apuohjelmatiedosto (PDFMOfficeAddin.dll) Windowsin resurssienhallinnassa ja merkitse tarkka polku muistiin. Polku voi sisältää myös välilyöntejä.
  2. Valitse Käynnistä > Suorita.
  3. Kirjoita regsvr32 ja välilyönti. Kirjoita sitten lainausmerkeissä polku, jonka kirjoitit ylös vaiheessa 1. Esimerkiksi:

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. Napsauta OK ja käynnistä sitten Office-sovellus.

Ratkaisu 7: Suorita Havaitse- ja korjaa -toiminto, kun muita sovelluksia ei ole käynnissä taustalla.

  1. Lopeta kaikki sovellukset ja käynnistä Windows uudelleen.
  2. Käynnistä Acrobat.
  3. Valitse Ohje > Havaitse ja korjaa, ja noudata näyttöön tulevia ohjeita.
  4. Kun korjaus on valmis, käynnistä tietokone uudelleen.

Ratkaisu 8: Poista Acrobat ja asenna se uudelleen yksinkertaistetussa tilassa.

Laiteohjaimet ja ohjelmistot, jotka käynnistetään automaattisesti Windowsin kanssa (esimerkiksi näytönsäästäjät ja virustorjuntaohjelmat), voivat aiheuttaa ristiriitoja ja ongelmia Acrobatin asennusohjelman kanssa. Asenna Acrobat ongelmien välttämiseksi uudelleen Windowsin yksinkertaistetussa tilassa. Yksinkertaistetussa tilassa ei-vakiomuotoiset laiteohjaimet ja käynnistysohjelmistot ovat poissa käytöstä.

Acrobatin poistaminen:

  1. Poista kaikki omat tiedostot Acrobatin sovelluskansiosta ja sen alikansioista.
  2. Valitse Käynnistä > Asetukset > Ohjauspaneeli ja kaksoisnapsauta Lisää tai poista sovellus -vaihtoehtoa.
  3. Valitse Adobe [Acrobat-tuote] ja napsauta Poista. Noudata näyttöön tulevia ohjeita ja poista sovellus.
  4. Käynnistä tietokone uudelleen.

Acrobatin asentaminen uudelleen yksinkertaistetussa tilassa:

  1. Sulje avoimet sovellukset.
  2. Siirrä Windowsin resurssienhallinnan avulla kaikki kuvakkeet ja pikakuvakkeet seuraavista kansioista muualle:
    • Documents and Settings/All Users/Start Menu/Programs/Startup
    • Documents and Settings/[user profile]/Start Menu/Programs/Startup
  3. Käynnistä Windows uudelleen.
  4. Napsauta hiiren kakkospainikkeella tehtäväpalkkia ja valitse Tehtävienhallinta.
  5. Valitse Sovellukset-välilehti.
  6. Valitse kaikki käynnissä olevat sovellukset ja napsauta Lopeta tehtävä.
  7. Kaksoisnapsauta asennusvälineellä olevaa Setup.exe-tiedostoa ja suorita asennus loppuun näyttöön tulevien ohjeiden mukaisesti.
  8. Kun asennus on suoritettu, palauta käynnistyskohteet käyttöön siirtämällä vaiheessa 2 siirretyt kuvakkeet ja pikakuvakkeet takaisin omiin kansioihinsa.

Ratkaisu 9: Poista makrot Wordista.

  1. Valitse Työkalut > Mallit ja apuohjelmat.
  2. Valitse jokainen kohde ja valitse Poista.
  3. Lopeta Word ja käynnistä se uudelleen.



    Huomautus:
    Jos Muunna PDF:ksi -kuvake edelleen puuttuu, valitse Työkalut > Mallit ja apuohjelmat, ja varmista, että poistetut kohteet eivät ole näkyvissä. Jos poistetut kohteet tulevat näkyviin, poista makro Wordista tai poista sovellus, joka asensi makron Wordiin.

Ratkaisu 10: Poista muut COM-apuohjelmatiedostot Wordista.

  1. Käynnistä Word.
  2. Valitse Työkalut > Mukauta.
  3. Napsauta Komennot-välilehteä ja valitse Työkalut Luokat-luettelossa.
  4. Valitse COM-apuohjelmat ja vedä se Wordin työkaluriville.
  5. Napsauta COM-apuohjelmat-valikkoa Wordin työkalurivillä.
  6. Valitse ja poista kaikki apuohjelmat lukuun ottamatta verkkosivuston ohjattua toimintoa ja Microsoft Wordin fonttityökalua.
  7. Lopeta Word ja käynnistä se uudelleen.

Ratkaisu 11: Korjaa Access (vain Access)

Jos Access 2000 on asennettu Office XP:n tai Office 2003:n asentamisen jälkeen, korjaa Office, jotta PDFMaker-valikko tulee näkyviin.

  1. Valitse Käynnistä > Ohjauspaneeli > Lisää tai poista sovellus (Windows 2000) tai Käynnistä > Ohjauspaneeli > Lisää tai poista sovellus (Windows XP).
  2. Valitse Microsoft Office ja valitse Muuta.
  3. Valitse Asetukset-valintaikkunassa Asenna uudelleen (Office 2003) tai Korjaa (Ofiice XP) ja napsauta sitten Seuraava.
  4. Valitse Etsi ja korjaa tuotteen Office asennuksesta löytyvät virheet ja napsauta sitten Asenna.

Ratkaisu 12: Mukauta työkalurivin asetukset (vain Access)

  1. Valitse Näytä > Työkalurivit > Mukauta.
  2. Valitse Työkalurivit-välilehdeltä Apuohjelma 1 ja Valikkorivin asetukset.
  3. Valitse Ominaisuudet.
  4. Valitse Salli näyttäminen ja piilottaminen.

Ratkaisu 13: Poista aiemmat PDFMaker-tiedostot järjestelmästä.

  1. Valitse Käynnistä > Etsi.
  2. Valitse Kaikki tiedostot ja kansiot.
  3. Kirjoita Tiedostonimi tai nimen osa -ruutuun PDFMaker.* .
  4. Valitse Haku.

    Huomautus: Haku voi kestää useita minuutteja riippuen järjestelmän suorituskyvystä.
  5. Poista kaikki tulokset, jotka ovat järjestelmätiedostoja (esimerkiksi PDFMaker.DOT tai PDFMaker.XLA). PDFMaker-nimellä (esimerkiksi PDFMaker.doc tai PDFMaker.pdf) luotujen asiakirjojen poistaminen ei ole tarpeen.

Ratkaisu 14: Poista Microsoft Works.

Adobe on vahvistanut, että Microsoft Works aiheuttaa ristiriidan Microsoft Wordin kanssa ja estää Muunna Adobe PDF:ksi -valikkoa näkymästä Wordissa. Microsoft Works on esiasennettuna useisiin tietokoneisiin.

Microsoft Worksin poistaminen:

  1. Valitse Käynnistä > Suorita, kirjoita avoimeen tekstiruutuun appwiz.cpl ja avaa sitten Lisää tai poista sovellus -valintaikkuna napsauttamalla OK.
  2. Esti ja valitse Microsoft Works ja napsauta Muuta tai poista.
  3. Kun ohjattu toiminto tulee näyttöön, napsauta Seuraava.
  4. Valitse Poista, napsauta Seuraava ja toimi näyttöön tulevien kehotteiden mukaisesti.

Lisätietoja

Acrobat 7.0-8.0 asentaa COM-apuohjelmatiedoston Acrobat 7.0/PDFMaker/Office - tai Acrobat 8.0/PDFMaker/Office -kansioon. Tämä tiedosto tuottaa Wordin, Excelin, PowerPointin, Accessin, Publisherin ja Projectin PDFMaker-kuvakkeet ja -valikkokomennot. COM-apuohjelman täytyy olla merkitty Windows-rekisteriin ennen kuin se näkyy sovelluksissa.

PDFMaker-kuvakkeet eivät näy työkalurivillä, jos Office-sovellus kaatuu ja poistaa käytöstä COM-apuohjelmatiedoston.

Muut COM-apuohjelmatiedostot ja makrot voivat aiheuttaa ristiriitoja PDFMakerin COM-apuohjelmatiedoston kanssa ja estää Muunna PDF:ksi -kuvakkeita näkymästä työkalurivillä.

Jos Apuohjelma1-työkalurivi ei ole käytössä Access-sovelluksessa, PDFMaker-kuvakkeet eivät näy.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö