About FXG

When creating structured graphics in Illustrator for use in Adobe Flex®, you can save in the FXG format. FXG is a graphics file format based on a subset of MXML, the XML-based programming language used by the Flex framework. You can use FXG files in applications such as Adobe Flash Builder/Adobe Flash Catalyst to develop rich Internet applications and experiences. When saving as FXG, images must be under 16,777,216 total pixels and less than 8192 pixels in width or height.

For more information on using these formats, see the Adobe Flex website at www.adobe.com/products/flex.

You can directly import both Illustrator(.ai) and FXG (.fxg) documents in Flash Catalyst. To import specific Flash Catalyst content in Illustrator, use the Edit in Illustrator option available in Flash Catalyst. However, some of the objects or attributes are treated differently in Illustrator and Flash Catalyst. Using the FXG options, you can control the conversion of these objects and attributes. In addition to this option, you can also paste Illustrator content directly into Flash Catalyst.

When saving content in FXG format in Illustrator, any object or attribute that is not compatible with the FXG specifications is expanded, rasterized, outlined, or dropped based on the complexity of the content and the FXG mapping. For example, to preserve the artwork with 3D effect, which is not supported in FXG, the content is rasterized to save in FXG format.

For a list of object and attribute mapping between Illustrator and FXG, see FXG mapping of Illustrator objects and attributes.

Best practices for using FXG

Use the following guidelines while saving Illustrator files in FXG format and editing them in Flash Catalyst:

  • Use Flash Catalyst or Basic RGB profile for creating content for FXG.

  • Avoid using brushes as it may cause performance issues due to expanded paths.

  • FXG provides mapping only for Drop Shadow, Inner/Outer Glow, and Blur, so prefer these effects over others.

  • Avoid horizontal or vertical scaling of text to avoid outlining when saving to FXG.

  • FXG does not support blends on filters. If you need to save FXG with filters editable or auto-save option, ensure that you set blend to Normal while applying filters (Drop Shadow, inner/outer glow) on any object for accurate appearance.

  • In most cases, items created in Illustrator are rendered as pixel-snapped in Flash Catalyst to make horizontal or vertical stroke edges look sharp. To avoid content from shifting between Illustrator and Flash Catalyst, select the Align to Pixel Grid option while working in Illustrator. For more information about aligning objects to the pixel grid, see Drawing pixel-aligned paths for web workflows.

  • Objects with a blend mode other than normal that are blended against the default document background may display differently in Flash Catalyst. Objects with non-normal blend modes should always have another object behind them.

  • Skewed items are not supported, and may be positioned differently when imported to Flash Catalyst.

  • 9-slice scaling grids are not supported in Flash Catalyst.

  • Reflected bitmaps and symbols are not supported in Flash Catalyst.

  • Spot and process colors are not supported in Flash Catalyst.

  • Vertical text is not supported in Flash Catalyst.

  • Warning messages are displayed to guide you about specific data modifications to the selected object or attributes. However, in some cases, the warning message may not be relevant to you. For example, a warning message such as "Some open type properties are dropped' when you deliberately set the language to a value other than USA. These warning messages about content editability are displayed only if the Save Illustrator Private Data option is selected.

Save an Illustrator file in FXG format

To map Illustrator content in FXG while preserving maximum appearance and editability, you can save a document in FXG format. This document can then be opened in either Illustrator or Flash Catalyst.

  1. Click either File > Save As or click File > Save A Copy.

  2. Type a filename, and choose a location for the file.

  3. Select Adobe FXG (*.FXG) as the file format, and click Save. The FXG Options dialog box is displayed.

    FXG Options Dialog Box
    FXG Options Dialog Box

  4. In the FXG Options dialog box, set the required options. The options available in this dialog box are:

    Save Illustrator Private Data

    This option is selected by default. It enables better re-editability, when you import FXG files in Illustrator:

    It allows maximum editability of FXG files, if you import these files in Illustrator.

    note: This option does not guarantee that all the content would be supported in the native Illustrator format. For example, brush strokes are not preserved because there is no support for retention of Illustrator private data for brush strokes. However, effects are preserved live on FXG import through Illustrator private data.

    Include Unused Symbols

    Use this option to keep or discard unused symbols in the FXG file. Saving unused symbols in FXG may increase the file size.

    Downsample Linked Images (72 ppi)

    Use this option for downsampling linked image files at 72 ppi, which is the standard web requirement.

    Filters

    Drop Shadow, Inner Glow, Outer Glow, and Gaussian Blur are supported as filters in FXG. Illustrator provides a trade-off between appearance and editability for these filters, when exported. If you want to preserve editability of these filters with some loss of appearance, select Maintain Editability (Convert to FXG). If you prefer appearance over editability, select the other options: Preserve Appearance (Expand), Preserve Appearance (Rasterize).

    Text

    To retain the appearance and maintain the editing capability, select the Automatic Conversion option. If editability cannot be maintained for the selected artwork, it is either expanded or rasterized to preserve appearance. To preserve visual appearance of text, select the Preserve Appearance (Rasterize) option or Preserve Appearance (Create Outline) to convert to Vector Outline for smaller file size. For maximum editability of text, select Maintain Editability (Convert to FXG). However, this option may result in loss of appearance.

    Gradients

    Gradients are not fully compatible with FXG when the gradient has more than 16 stops. Gradient mid points that are not equal to 50% are also mapped directly into FXG. Illustrator first tries to extrapolate those midpoints to actual stops and if they cannot be extrapolated, gradients are rasterized.

    Illustrator has the capability to determine the priority when exporting gradients in FXG. If content editability is high priority, then select Maintain Editability (Convert to FXG). Select the Automatic Conversion option to preserve visual appearance and maintain the editing capability. Automatic conversion analyses and determines if content can be kept editable and still match the appearance. If keeping the content editable does not match the appearance then the art is rasterized.

    Blend

    You can rasterize to preserve the appearance, by selecting Preserve Appearance (Rasterize) or select Automatic Conversion to allow Illustrator to automatically expand or rasterize the blending options based on the complexity of the blend.

    Show Code

    Click this button to view the FXG code before generating the FXG file.

    FXG is always saved with the Use Artboards option enabled. Artboards are imported as states in Flash Catalyst.

    Merk:

    The artboard range specified while saving FXG content decides the creation of pages or states for Flash Catalyst. If you save a document with multiple artboards in FXG format, any content that lies completely outside the artboard is not saved.

    For overlapping artboards, any content that is shared across artboards is saved on each page, when saving in FXG format. Therefore, multiple pages with the same content are saved.

  5. Click OK. If Illustrator makes any changes to save the content in FXG, the content changes are displayed in the FXG Save Warning dialog box.

    FXG Warning Dialog Box
    FXG Warning Dialog Box

Illustrator and Flash Catalyst workflow

To import or open an FXG file in Illustrator, click File > Open and select the .fxg file.

You can also open an FXG file in Illustrator by selecting the Edit in Illustrator option in Flash Catalyst. For more information, see Round-trip editing of artwork in Adobe Flash Catalyst documentation.

Merk:

You cannot link FXG content in Illustrator, you can only embed it.

Add or edit Flash Catalyst objects in Illustrator

To edit objects and attributes of an FXG file in Flash Catalyst, use the Edit in Illustrator option in Flash Catalyst. The selected objects are opened in Illustrator. After you finish editing in Illustrator, the object is reconverted to the FXG format, and passed back to Flash Catalyst.

You can edit an FXG file object in Illustrator, while working on the file in Flash Catalyst. To edit an object in Illustrator:

  1. In Flash Catalyst, select the object that you want to edit in Illustrator

  2. Do one of the following:

    • Right-click on the object, and then select the Edit in Adobe Illustrator CS5 option.

    • Choose Modify > Edit in Adobe Illustrator CS5.

    Illustrator CS5 opens and the corresponding FXG file is automatically opened for editing. At the upper-left corner of the Illustrator window, the Done and Cancel options are available.

    Done and cancel options for FXG file opened in Illustrator
    Done and cancel options for FXG file opened in Illustrator

    Merk:

    In Illustrator, only the selected objects are available for editing. All other objects are visible, but cannot be edited.

  3. Change the selected object or create new objects.

  4. Exit this mode by clicking the Done button at the upper-right corner in Illustrator.

    When you click Done, the edited object and any new objects are reconverted into FXG format and passed back to Flash Catalyst.

    If you click cancel, a dialog box is displayed to confirm that you do not want to save the changes made to the file.

    Dialog box to confirm cancellation of edit in Illustrator
    Dialog box to confirm cancellation of edit in Illustrator

  5. In Flash Catalyst, set the required options in the FXG Options dialog box, and then click OK.

Import Illustrator content in Flash Catalyst

Flash Catalyst uses the FXG (.fxg) format files to create rich Internet applications and experiences. You can use content between Illustrator and Flash Catalyst in three ways:

  • Import a .ai file directly in Flash Catalyst.

  • Import a .fxg file in Flash Catalyst, which was saved as .fxg in Illustrator.

  • Copy any object from Illustrator and paste it into a Flash Catalyst document.

For more information, see Round-trip editing of artwork in Adobe Flash Catalyst documentation.

When you copy and paste content into Flash Catalyst, certain objects and their attributes may not be compatible with the FXG specification. You can specify settings to manually control and preserve visual appearance, editability, or both.

To paste an Illustrator object in Flash Catalyst:

  1. Select and copy the object from an open Adobe Illustrator CS5 file.

  2. Paste the object in an open Flash Catalyst file.

  3. In the Illustrator Import Options dialog box, specify the correct options as stated in step 4 of Save an Illustrator file in FXG format.

FXG mapping of Illustrator objects and attributes

Following is the list of objects and attributes that are directly mapped into FXG:

Illustrator object/attribute

Object/attribute sub-area

FXG tag

Export to FXG

Import FXG

Illustrator Private Data support

Behavior

Paths/Open

Move Segment

<Path>

Mapping Live

Mapping Live

No

Line Segment

<Path>

Mapping Live

Mapping Live

No

Cubic Bezier Segment

<Path>

Mapping Live

Mapping Live

No

Line

<Line>

Mapping Live

Mapping Live

No

Compound Paths

<Path>

Mapping Live

Mapping Live

No

Shapes/Closed Paths

Ellipse

<Ellipse>

Mapping Live

Mapping Live

No

Rectangle/Rounded Rectangle

<Rect>

Mapping Live

Mapping Live

No

Star/Polygon

<Path>

Mapping Live

Mapping Live

No

Flare

<Path>

Expansion

Expansion

No

Compound Shape

<Group><Path>

Expansion

Expansion

Yes

Fill

Solid Fill

<Fill><Solid Colors>

Mapping Live

Mapping Live

No

Colors are not preserved for Swatch libraries.

Process/Spot Color/Registration/Global Process

<Fill><Solid Colors>

Convert to Solid

Convert to Solid

No

Colors are not preserved for Swatch libraries.

Linear Gradient Fill

<Fill><LinearGradient>

Mapping Live

Mapping Live

Yes

You have the option to choose Gradient export in FXG by using the FXG save options.

Radial Gradient Fill

<Fill><RadialGradient>

Mapping Live

Mapping Live

Yes

You have the option to choose Gradient export in FXG by using the FXG save options.

Pattern Fill

Rasterized

Rasterized

No

Multiple Fills (Appearance panel)

Expansion

Expansion

Yes

Stroke

Multiple Stroke (Appearance panel)

Expansion

Expansion

Yes

Pattern Stroke

Rasterization

Rasterization

No

Solid Color Stroke

<Stroke><SolidColorStroke>

Mapping Live

Mapping Live

No

Colors are not preserved for Swatch libraries.

Stroke Depth

Mapping Live

Mapping Live

No

Line Joins/Line Caps

<Stroke>

<joints=””>

<caps=””>

Mapping Live

Mapping Live

No

Dashed Line/Dotted Line/Stroke Align

Expansion

Expansion

No

Transparency

Opacity on Objects/Layer/Groups/Fills/Strokes

<alpha>

Mapping Live

Mapping Live

No

Transparency panel Options

Transparency

Knockout

Rasterization

Rasterization

Yes

Isolate Blending

Rasterization

Rasterization

Yes

Attribute panel Options

Attribute Panel

Overprint Fill/Overprint/Stroke/Image Maps/URL

Dropped

Dropped

No

Layers and sublayers

<Group>

Mapping Live

Mapping Live

No

Hidden/Lock layers

Mapping Live

Mapping Live

No

Group

<Group>

Mapping Live

Mapping Live

No

Blend Group

Expansion

Expansion

No

Blend is handled with FXG Save Options:

Auto: automatically detects the complexity of blend based on steps, shapes, and rasterizes it if output is too complex otherwise expand.

Rasterize: always rasterizes the blend output.

Live Paint Group

Expansion

Expansion

No

Symbols

<Graphic/Movie>

<Library><Definitions>

Mapping Live

Mapping Live

No

Placed Images (Embedded/Linked)

Linked/Embedded Images

Rasterization

Rasterization

Yes

Private data is written just to retain embedded art in Illustrator on round trip.

Raster Art

Rasterization

Rasterization

No

Opacity Mask

<maskType=luminosity>

Mapping Live

Mapping Live

Yes

Effects

3D

Extrude & Bevel

Rasterization

Rasterization

Yes

Thumb rule for vector effect mapping in FXG is to expand the object with effect. However, 3D effect is rasterized because expanding objects with 3D effects generates numerous paths and causes performance issues in Flash Catalyst.

Revolve

Rasterization

Rasterization

Rasterization

Thumb rule for vector effect mapping in FXG is to expand the object with effect. However, 3D effect is rasterized because expanding objects with 3D effects generates numerous paths and causes performance issues in Flash Catalyst.

Rotate

Rasterization

Rasterization

Yes

Thumb rule for vector effect mapping in FXG is to expand the object with effect. However, 3D effect is rasterized because expanding objects with 3D effects generates numerous paths and causes performance issues in Flash Catalyst.

Effects Converts to shape

Rectangle/Rounded Rectangle/Ellipse

Expansion

Expansion

Yes

Distort and Transform

Free Distort/ Pucker and Bloat/ Transform/ Twist/ Zigzag

Expansion

Expansion

Yes

Roughen/Tweak

Expansion

Expansion

No

Path

Offset Path/ Outline Object/ Outline Stroke

Expansion

Expansion

Yes

Pathfinder

Add/ Intersect/ Exclude/ Subtract/ Minus Back/ Divide/ trim/ Merge/ Crop/ Outline/ Hard Mix/ Soft Mix/ Trap

Expansion

Expansion

Yes

Rasterize

Rasterize

Rasterize

Yes

Stylize

Add Arrowheads/Round Corners/Scribble

Expansion

Expansion

Yes

Drop Shadow

<filters>

<DropShadowfilter>

Mapping Live

Mapping Live

Yes

When you save content as FXG, the "Mode" is always set to "Multiple" and "Darkness" is replaced by last used color in the Drop Shadow effect.

Inner Glow

<filters>

<GlowFilter inner=”true”

Mapping Live

Mapping Live

Yes

When you save content as FXG, the "Mode" is always set to "Normal" and "Center" is converted to Edge.

Outer Glow

<filters><GlowFilter> or

<filters><GlowFilter inner="false">

Mapping Live

Mapping Live

Yes

When you save as FXG, “Mode” is set to “Normal”.

Warp

Arc/ Arc Lower/ Arc Upper/ Arch/ Bulge/ Shell Lower/ Shell Upper/ Flag/ Wave/ Fisheye/ Rise/ Fish/ Inflate/ Squeeze/ Twist

Expansion

Expansion

Yes

Blur

Gaussian Blur

<filters><BlurFilter>

Mapping Live

Mapping Live

Yes

Smart/Radial Blur

Rasterization

Rasterization

Yes

Graphs

Column/ Stacked Column/ Bar/ Stacked/ Line/ Area/ Scatter/ Pie/ Radar Graph

Rasterization

Rasterization

No

Graphic Style

Expansion

Expansion

No

Tracing Objects

Expansion

Expansion

No

Image Maps

Dropped

Dropped

No

Envelope Distort

Expansion

Expansion

No

Foreign Art

Rasterization

Rasterization

No

Mesh Art

Rasterization

Rasterization

No

Pattern

Rasterization

Rasterization

No

Clipping Path and Clip Group

<Mask maskType="clip">

Mapping Live

Mapping Live

No

Masked objects with filled clipping path are rasterized on FXG save.

Gradient

Linear/Radial Gradient/Gradient Stops/Location/Angle

Mapping Live

Mapping Live

Yes

Gradient are handled with FXG Save Options:

Auto: automatically detects whether gradient is mappable in FXG. If gradient is mappable, then gradient mapping is saved in FXG content otherwise the gradient object is rasterized.

Maintain Editability [Convert To FXG]: This option preserves the editability of gradient in FXG preferred over appearance, regardless of the mapping being available.

Transformations on Image/Symbols/Gradients

Move/Scale

Mapping Live

Mapping Live

No

<Through Transform Effect>

Rotate/Reflect/Scale

Expansion

Expansion

Yes

Variables

Dropped

Dropped

Flash Text

Dropped

Dropped

SVG Interactivity

Dropped

Dropped

Plug-in Art Adobe

Expansion

Expansion

No

Plug-in Art Third Party

Expansion

Expansion

No

Blend Mode

Darken/ Multiply/ Color Burn/ Lighten/ Screen/ Color Dodge/ Overlay/ Soft Light/ Hard Light/ Difference/ Exclusion/ Hue/ Saturation/ Color/ Luminosity

Mapping Live

Mapping Live

No

Brushes

Calligraphic/ Scatter/ Art/ Pattern/ Bristle

Expansion

Expansion

No

Units

Points/Picas/Inches/Millimeters/Centimeters

Convert to Pixels

Convert to Illustrator Units as per Preferences

No

Pixels

Mapping Live

Convert to Illustrator units as per Preferences

No

Document Profiles

Convert to RGB profile

Convert to RGB profile

No

Document Orientation

Portrait (Vertical) / Landscape (Horizontal)

Dropped

Dropped

Yes

Perspective Grid

Dropped

Dropped

No

Embed Color Profile

Dropped

Dropped

No

Photoshop Effects

Artistic

Color Pencil/ Cutout/ Dry Brush/ Film Grain/ Fresco/ Neon Glow/ Paint Daubs/ Panel Knife/ Plastic Wrap/ Poster Edges/ Rough Pastels/ Smudge Stick/ Sponge/ Underpainting/ Watercolor

Rasterization

Rasterization

Yes

Blur

Gaussian Blur

Mapping Live

Mapping Live

Yes

Radial/Smart Blur

Rasterization

Rasterization

Yes

Brush Strokes

Accented Edges/ Angled Strokes/ Crosshatch/ Dark Strokes/ Ink Outlines/ Spatter/ Sprayed Strokes/ Sumi-e

Rasterization

Rasterization

Yes

Distort

Diffuse Glow/ Glass/ Ocean Ripple

Rasterization

Rasterization

Yes

Pixelate

Color Halftone/ Crystallize/ Mezzotint/ Pointillize

Rasterization

Rasterization

Yes

Sharpen

Unsharp Mask

Rasterization

Rasterization

Yes

Sketch

Bas Relief/ Chalk & Charcoal/ Charcoal/ Chrome/ Content Crayon/ Graphic Pen/ Halftone Pattern/ Note Paper/ Photocopy/ Plaster/ Reticulation/ Stamp/ Torn Edges/ Water Paper

Rasterization

Rasterization

Yes

Stylize

Glowing Edges

Rasterization

Rasterization

Yes

Texture

Craquelure/ grain/ Mosaic Tiles/ Patchwork/ Stained Glass/ Texturizer

Rasterization

Rasterization

Yes

Video

De-Interlace / NTSC Colors

Rasterization

Rasterization

Yes

Slices

Dropped

Dropped

No

Guides

Dropped

Dropped

No

Symbol Set

<Group><Symbol>

Expansion

Expansion

No

XMP

Dropped

Dropped

No

Multiple Artboards

Single Artboard

<d:layerType=Page>

Mapping Live

Mapping Live

No

Objects outside artboards are always discarded.

  • Size of the Main Graphic is:

    • Width: Artboard with maximum width

    • Height: Artboard with maximum height

  • Use Artboards options for FXG, generates a single FXG file with only pages corresponding to respective artboards:

    • Illustrator does not generate an FXG file for each artboard.

    • If you select all artboards then a single FXG file having all the artboards is generated.

    • If you select a range such as 1, 3, 5, then only a single FXG file containing page corresponding to artboard 1, 3 and 5 are generated.

Following text attributes are compatible with FXG:

Attribute Type

Illustrator Attribute

FXG Tag

Map/Outline/Drop/Conversion/Partial

Character Attributes

font Name

fontFamily

Preserved

font Size

fontSize

Preserved

leading

lineHeight

Preserved

underline

textDecoration

Preserved

strikethrough

lineThrough

Preserved

tracking

trackingRight

Preserved

fill color

color

Preserved

transparency

textAlpha

Preserved

kerning

Dropped

baseline shift

baselineShift

Preserved

Japanese properties (Aki, Tsume, Warichu, Tate-Chu -Yoko)

Text is outlined for CJK languages (for non-default values) and is dropped for others.

Paragraph Properties

Alignment

textAlign

Preserved

Justify with last line aligned (left, center, right, or all)

textAlignLast

Preserved

First line left indent

textIndent

Preserved

Left Indent

paragraphstartindent

Preserved

Right Indent

paragraphendindent

Preserved

spaceBefore

paragraphspacebefore

Preserve

spaceAfter

paragraphspaceafter

Preserve

Horizontal/Vertical text frame

blockProgression

Preserved

Rich Text Attributes

width

width

height

height

x

x

y

y

Indent Spacing

paddingLeft

Indent Spacing

paddingRight

Indent Spacing

paddingTop

Indent Spacing

paddingBottom

Legacy Text

Expanded

Text on Path

Expanded

Text objects with unsupported Area type options

Unsupported Area type options are dropped

Text objects with wraps

Expanded in Auto mode

Text objects with non-rectangular shape

Other features

Character attributes other than the ones mentioned in the table previously

Dropped

Paragraph Attributes other than the ones mentioned previously

Dropped

Character styles

Dropped (Appearance will be preserved)

Paragraph styles

Dropped (Appearance will be preserved)

Tab settings

tabStops

Preserved

Open Type features

Preserved (partially)

Composite fonts

Replaced by the default font of the script.

Text Frame Fill

The object is expanded

Following is a list of attributes that are not supported by Illustrator but are supported by FXG:

Attribute Name

FXG tag

Illustrator Import: level of support

Behavior

LinearGradientstroke

<Stroke><LinearGradientstroke>

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

RadialGradientstroke

<Stroke><RadialGradientstroke>

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

ColorTransform

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

Blend Modes:

Add/ alpha/ erase/ invert/ subtract

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

9 Slicing Attributes on Groups

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

Effects:

GradientBevel / Bevel/ GradientGlow/

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

ColorMatrix/ Displacement Map/ Convolution/ AdjustColor Filters

Preserved till not tampered

Illustrator preserves FXG data for this attribute until tampered. If any editing in Illustrator affects this attribute directly, then Illustrator overwrites the data causing drop of this attribute.

Dette produktet er lisensiert i henhold til Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Innlegg på Twitter™ og Facebook dekkes ikke av Creative Commons-vilkår.

Juridiske merknader   |   Regler for personvern på nettet