從圖層產生影像資產

上次更新時間 2026年10月29日

使用產生器,透過在圖層名稱後面加上 .png 或 .jpg 等格式副檔名,自動建立檔案。

在圖層名稱後面加上副檔名,會觸發 Photoshop 的產生器,讓您每次儲存時自動建立影像檔案。這樣可以省去網頁、應用程式及需要多種格式或尺寸的多裝置專案中重複的匯出步驟。

當您需要以多種格式或解析度進行一致且可重複的匯出時,此工作流程最為實用,例如為回應式設計產生 @1x、@2x 和 @3x 版本。如需單次匯出或需要特定格式控制,請改用「檔案」>「匯出」>「匯出為」。

產生器會為您的資產建立專用資料夾,並在您操作時自動更新檔案。您可以從單一圖層產生多種格式、指定品質設定、將資產縮放為不同尺寸,並將輸出整理到子資料夾中,這些全都可以透過圖層命名慣例完成。

  • 具有已命名圖層或圖層群組的 Photoshop 文件
  • 已將文件儲存到已知位置 (否則資產會顯示在桌面上)
  • 瞭解專案所需的輸出格式

啟用影像資產產生功能

選取「檔案」>「自動化」>「產生器外掛程式」>「影像資產」。

在「圖層」面板中,找到您要匯出的圖層或群組。

在圖層名稱後面加上副檔名來重新命名圖層:.jpg、.png、.gif 或 .svg。例如,將「logo」重新命名為「logo.png」。

按 Ctrl + S (Windows) 或 Command + S (macOS) 儲存文件。

Photoshop 會在已儲存文件旁的子資料夾中建立影像檔案。如果您的文件尚未儲存,資產會顯示在桌面上的新資料夾中。產生器會保持運作中,對已啟用產生器的圖層所做的任何變更,都會觸發對應資產的自動更新。

備註

圖層名稱不能包含 : (冒號) 或 * (星號),因為這些字元會阻止資產產生。

從一個圖層產生多種格式

單一圖層可以同時產生不同格式、尺寸和品質等級的資產。在圖層名稱中,使用逗號或加號分隔每個資產規格。

在「圖層」面板中選取圖層。

使用逗號分隔的格式重新命名圖層,例如:button.png, button.jpg90, 200% button@2x.png。

儲存文件。

Photoshop 會從相同的圖層內容產生三個不同的檔案,無需以不同格式手動匯出相同的圖形。

控制不同螢幕的資產品質與縮放比例

在「圖層」面板中選取圖層。

在檔案名稱中加入品質或大小參數。例如:「button.jpg90」會將 JPEG 品質設為 90%,或「200% logo@2x.png」會將資產大小加倍。

若需要多種解析度,請使用逗號分隔每個規格:「icon.png, 200% icon@2x.png, 300% icon@3x.png」。

儲存文件以產生所有變化版本。

品質後置詞可控制 JPG 檔案的壓縮比 (1 至 100),以及 PNG 檔案的位元深度 (8、24 或 32)。大小前置詞可接受百分比進行相對縮放,或接受絕對像素尺寸。您可以混合使用單位,例如「10in x 5cm banner.jpg」,並省略其中一個尺寸以按比例縮放:「1080 x icon.png」會將寬度設為 1080 像素,同時維持外觀比例。

秘訣

使用 @2x 和 @3x 命名慣例,可自動產生適用於回應式網頁專案和行動應用程式的 Retina 與高 DPI 版本。

相對縮放範例:

200% logo.png 會將資產大小加倍

50% thumbnail.jpg 會將資產縮小為一半

絕對尺寸範例:

300 x 200 hero.png 會建立 300×200 像素的影像

10in x 5cm banner.jpg 混合使用單位 (寬 10 英吋,高 5 公分)

1080 x icon.png 會將寬度設為 1080 像素,高度則按比例縮放

秘訣

指定像素尺寸時,請直接輸入數字,不需加上單位標示。請使用「300 x 200」,而非「300px x 200px」。

將資產整理至子資料夾

預設情況下,所有產生的資產都會儲存在 PSD 檔案旁的單一檔案夾中。在檔案名稱前加入子檔案夾名稱,可指示產生器自動建立並使用該子檔案夾。這樣可讓相關資產保持整理狀態,而不需要手動管理檔案夾。

使用正斜線在圖層名稱中加入子檔案夾路徑:subfolder/filename.png 或 icons/logo.svg。您可以巢狀多個層級:assets/icons/logo.png。

將資產匯出至特定資料夾

使用檔案名稱中的子檔案夾路徑來重新命名圖層。例如:mobile/button.png, desktop/button.png。

儲存文件。

Photoshop 會自動建立檔案夾結構,並將每個資產放置在指定的位置。將子檔案夾與大小前置詞和品質設定結合使用,可完全控制資產組織:mobile/200% button@2x.png, desktop/button.jpg90。

設定文件層級的預設值

建立特殊圖層,以設定套用至所有生成資產的基準線設定。這樣可避免在個體圖層名稱中重複指定參數。

建立一個空圖層,並以「default」開頭命名,後面接上您偏好的設定。常見的設定包括「default 200%」可將所有資產縮放為 200%、「default assets/」可將所有內容儲存到 assets 子檔案夾,或「default @2x」可在所有檔案名稱加上 @2x 後置詞。

您可以合併多個預設值:「default 200% retina/ @2x」會將所有資產縮放為 200%、儲存到 retina 子檔案夾,並在檔案名稱加上 @2x 後置詞。個體圖層設定會覆蓋文件預設值,如果您的預設值指定「default 200%」,但圖層名稱包含「50% thumbnail.png」,則該圖層會以 50% 生成。

使用雲端文件

雲端文件會將生成的資產儲存在本機,而非直接與 PSD 檔案放在一起。Photoshop 會維持此分隔,以區分本機內容和雲端同步內容。

雲端文件的資產會顯示在以下位置:

  • Windows:C:\Usersusername>\Documents\Adobe\Photoshop Cloud Associates
  • macOS:/Users//Documents/Adobe/Photoshop Cloud Associates

每個雲端文件都會在此目錄中建立自己的子資料夾。系統會在您工作時自動生成資產,但這些資產會保留在您的本機電腦上,直到您在 Creative Cloud 中明確共用或同步它們為止。

停用資產產生

影像資產生成功能一旦啟用,便會針對該文件保持運作,並在各工作階段中持續有效。此功能會在您每次儲存時自動重新生成資產,對於複雜的文件,可能會降低效能。

若要關閉目前文件的生成功能,請取消選取 檔案 > 自動 > 產生器外掛程式 > 影像資產。這樣會停止自動建立資產,但會保留任何現有的資產和圖層命名。

若要在所有文件中全域關閉產生器,請選取 編輯 > 偏好設定 > 外掛程式,取消選取 啟用產生器,然後選取 確定。這樣會完全關閉產生器功能,直到您在偏好設定中重新啟用為止。