修正啟動 Adobe Photoshop 時發生的產生器錯誤

上次更新時間 2026年10月29日

了解如何透過檢查安全性設定、移除衝突的外掛程式,並查看記錄,修正 Adobe Photoshop 中的產生器錯誤。

產生器是一款 Node.js 應用程式,負責處理 Photoshop 與產生器外掛程式之間的通訊。它提供「匯出為」和「影像資產」的資產建立邏輯。

當您啟動 Photoshop 或選取「檔案」 > 「匯出」 > 「匯出為」時,會出現一個對話框,顯示:「產生器發生問題。請結束 Photoshop 並再試一次。 如果問題仍然存在,請移除任何第三方外掛程式,或嘗試重新安裝 Photoshop。」

請依序嘗試下列解決方法。

安全性軟體封鎖產生器

安全性或防毒軟體可能會封鎖產生器透過連接埠 8010 進行的通訊,或阻止 node 處理程序執行。

開啟您的安全性或防毒設定。

將 Photoshop 新增至允許的應用程式清單中。

確保連接埠 8010 已針對產生器開啟。

在 Windows 上,將 node.exe 新增至 C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe 的允許應用程式清單中。

在 macOS 上,允許位於/Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node 的 node 處理程序。

在 Windows 上,允許 Photoshop 存取受控資料夾。

重新啟動 Photoshop,然後選擇「檔案」 > 「匯出」 > 「匯出為」以測試產生器。

第三方外掛程式與產生器發生衝突

Photoshop 產生器資料夾中的第三方外掛程式可能與您目前的版本不相容,或與預設的「影像資產」外掛程式發生衝突。

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

在您的桌面上建立一個名為Disabled Generator Plug-ins 的暫存資料夾。

將第三方外掛程式資料夾移至暫存資料夾。將預設的「影像資產」外掛程式留在「產生器」資料夾中。

啟動 Photoshop,然後選擇「檔案」 > 「匯出」 > 「匯出為」。

如果錯誤已消失,請一次新增一個外掛程式,並在每次新增後重新啟動 Photoshop,直到錯誤再次出現。

將預設的 Image Assets 外掛程式保留在 Generator 資料夾中。只移動您另外安裝的外掛程式。

generator 無法啟動,而且您不需要使用它

如果您不使用 Export As 或 Image Assets,可先關閉 Generator 作為因應方式。

啟動 Photoshop。

在 Windows 上,選取 Edit > Preferences > Plug-ins。在 macOS 上,選取「Photoshop」>「設定」>「Plug-ins」。

取消選取「啟動產生器」。

選取「OK」,然後重新啟動 Photoshop。

選取「File」>「Export」>「Export As」會再次開啟 Generator。如果您需要使用 Export As,請改為解決 Generator 錯誤,不要讓 Generator 持續關閉。

Generator 記錄顯示啟動錯誤

Generator 記錄可能包含無法載入的外掛程式資訊,或導致 Generator 無法啟動的系統問題。

在 Windows 上,前往 C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator。

在 macOS 上,前往 /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator。

開啟最新的 Generator 記錄,並查看錯誤訊息。

如果 Generator 資料夾不存在,請確認您對上層資料夾具有寫入權限。

如果您需要更多協助,請使用 Adobe Log Collector Tool 收集診斷記錄。

Windows 的 AppData 和 macOS 的 Library 資料夾預設為隱藏。在 Windows 中顯示隱藏檔案與資料夾的說明可協助您找到 Windows 記錄。

Generator 錯誤發生在 Apple Silicon 上

如果 Generator 在搭載 Apple silicon 的 Mac 上持續無法運作,以 Rosetta 執行 Photoshop 有助於判斷問題是否由原生模式相容性所造成。

結束 Photoshop。

在 Finder 中,開啟「應用程式」並找到 Adobe Photoshop。

按住 Control 並點按 Adobe Photoshop,然後選取「取得資訊」。

選取 「使用 Rosetta 開啟」,然後啟動 Photoshop 並測試產生器。

如果錯誤仍然存在,聯絡 Adobe 支援時請提供 Generator 記錄以取得協助。如需處理與 Generator 無關的 Export As 問題,請參閱 匯出和儲存操作的疑難排解指南。