複製並貼上圖層

上次更新時間 2026年10月29日

使用「複製」、「貼上」和「就地貼上」來複製圖層,並保留其效果和遮色片。

複製與貼上圖層會在文件之間轉移完整的圖層資料,包括點陣圖和向量遮色片、圖層效果,以及智慧型物件參照。此方法可在目的地文件中建立獨立的複本,同時保留所有圖層屬性。

使用複製與貼上,在文件之間轉移圖層,同時保留所有圖層屬性。若要在同一份文件中複製圖層,請使用 圖層 > 複製圖層。若要在不建立複本的情況下重新放置現有內容,請使用 移動 工具在文件視窗之間拖曳圖層。

複製並貼上圖層

在圖層 面板中,選取您要複製的圖層。

選取 編輯 > 複製,或按 Ctrl + C (Windows) 或 Command + C (macOS)。

切換到目的地文件,或建立新文件。

選取 編輯 > 貼上,或按 Ctrl + V (Windows) 或 Command + V (macOS)。

貼上的圖層會出現在目的地文件畫布的中央。貼上的圖層至少會有部分顯示在畫布上。

在原始位置貼上圖層

在 圖層 面板中,選取您要複製的圖層。

選取 編輯 > 複製,或按 Ctrl + C (Windows) 或 Command + C (macOS)。

切換到目的地文件。

選取 編輯 > 特殊貼上 > 就地貼上,或按 Ctrl + Shift + V (Windows) 或 Command + Shift + V (macOS)。

就地貼上 可讓複製的內容相對於畫布邊緣保持在相同位置。

建立符合複製圖層尺寸的文件

選取並複製一個或多個圖層。

選取「檔案 > 新增」。

在 新增文件 對話框中,從預設選項中選取 剪貼簿。

選取 建立 以產生符合複製圖層尺寸的新文件。

選取 編輯 > 貼上,或按 Ctrl + V (Windows) 或 Command + V (macOS)。

剪貼簿預設集會建立一個文件,其尺寸符合所有已複製圖層的邊界方框。

管理色彩和解析度。

在文件之間貼上時,如果來源文件和目的地文件使用不同的色彩描述檔,Photoshop 可能會顯示色彩描述檔不符對話框。您可以轉換色彩以符合目的地文件,或保留原始色彩。編輯 > 色彩設定中的色彩管理設定會決定這些提示出現的時機。

如果您在解析度不同的文件之間貼上圖層,貼上的內容會保留其像素尺寸。這可能會使貼上的元素在目的地文件中顯示得比實際更大或更小。為維持視覺一致性,請在複製和貼上之前使用 影像 > 影像大小 來符合解析度,或使用 編輯 > 任意變形 來調整貼上內容的大小。

了解智慧型物件的複製貼上行為

警告

編輯複製貼上的智慧型物件圖層不會更新原始智慧型物件圖層,反之亦然。複製貼上的智慧型物件會建立獨立的內嵌執行個體。

若要維持跨文件智慧型物件執行個體之間的連結,請使用連結的智慧型物件。連結的智慧型物件會參照外部來源檔案,確保您編輯來源時,所有實例都會更新。

複製合併內容

合併複製 指令會在選取範圍內建立所有可見圖層的平面化複本。

使用任何選取工具進行選取,或不選取任何內容以複製所有可見內容。

選擇 編輯 > 合併複製,或按 Ctrl + Shift + C (Windows) 或 Command + Shift + C (macOS)。

將合併的內容貼到任何文件中。合併的內容會顯示在單一圖層上。

合併複製 會遵循圖層可見度,只有可見圖層才會計入合併結果。即使隱藏圖層已被選取,也會被排除。

使用路徑專屬行為

複製含有向量路徑的圖層 (包括形狀圖層和向量圖遮色片) 時,複製貼上行為會取決於版面上是否已選取路徑。

複製形狀圖層和向量圖遮色片

當版面上未選取任何路徑時:

  • 複製形狀圖層或含有向量圖遮色片的圖層時,會將整個圖層複製到剪貼簿
  • 貼上時會建立重複的圖層,並完整保留所有遮色片、效果和路徑資料

在畫布上選取路徑時:

  • 複製含有選取路徑的形狀圖層時,只會將路徑資料複製到剪貼簿
  • 貼上路徑資料的行為取決於目的圖層類型 (請參閱下文)

貼上路徑資料

路徑資料的貼上行為會因選取的圖層類型而有所不同:

  • 貼到點陣圖圖層 (無路徑):會從貼上的路徑資料建立新的向量圖遮色片
  • 貼到未選取路徑的形狀圖層:會用貼上的路徑取代現有形狀
  • 貼到已選取路徑的形狀圖層:會將貼上的路徑與形狀圖層中現有的路徑結合
  • 貼到含有向量圖遮色片的圖層 (未選取遮色片):會用貼上的資料取代向量圖遮色片路徑
  • 貼到含有向量圖遮色片的圖層 (已選取遮色片):會將貼上的路徑與現有的向量圖遮色片路徑結合
備註

當選取圖層時,無法使用 剪下 指令 (編輯 > 剪下)。如要在複製圖層的同時將其移除,請使用 複製,然後在 圖層 面板中刪除原始圖層。