瞭解如何在 Adobe Photoshop 中使用「還原/重做」指令和「步驟記錄」面板控制影像狀態。

使用「還原/重做」指令和「步驟記錄」面板,便可輕鬆控制影像狀態。

使用還原或重做指令

Photoshop CC 20.0 版的更新功能 (2018 年 10 月版)

自 Photoshop CC 2018 年 10 月 (20.0) 版起,您可以使用 Control + Z (Win)/Command + Z (Mac),在 Photoshop 文件中還原多個步驟。全新多步驟還原模式預設為啟用。

若要執行還原或重做作業,請執行下列動作:

  • 還原: 移至上一個步驟。選擇「編輯 > 還原」,或使用鍵盤快速鍵 Control + Z (Win)/Command +Z (Mac)。
  • 重做: 移至下一個步驟。選擇「編輯 > 重做」,或使用鍵盤快速鍵 Shift + Control + Z (Win)/Shift + Command + Z (Mac)。

「編輯」選單也會在「還原」和「重做」指令旁,顯示所還原的步驟名稱。例如,「編輯 > 重做編輯文字」。

(Photoshop)

若要切換回 Photoshop 舊版還原模式,請執行下列動作:

  1. 在選單列,選擇「編輯 > 鍵盤快速鍵」
  2. 「鍵盤快速鍵和選單」對話框,選取「使用舊版還原快速鍵」,然後按一下「確認」
  3. 重新啟動 Photoshop。

(Adobe Camera Raw)

若要在 Adobe Camera Raw 中切換回舊版的還原模式,請依照以下步驟操作:

  1. 在 Photoshop 的選單列中,依序選擇「編輯 > 偏好設定 > 檔案處理」
  2. 按一下「檔案相容性」區段的「Camera Raw 偏好設定」
  3. 「Camera Raw 偏好設定」對話框中,選取「使用舊版還原快速鍵」,然後按一下「確認」
  4. 重新啟動 Photoshop。

回復至前次儲存的版本

  1. 選擇「檔案 > 回復」。

    註解:

    「回復」會加入「步驟記錄」面板中作為一種記錄狀態,而且可以復原。

將部分影像復原成先前儲存的版本

  1. 執行下列任一項作業:
    • 使用「步驟記錄筆刷」工具 ,以「步驟記錄」面板中選取的狀態或快照進行繪圖。

    • 使用「橡皮擦」工具 ,並選取「自步驟記錄中擦除」選項。

    • 選取想要復原的區域,然後選擇「編輯 > 填滿」。在「使用」中選擇「步驟記錄」,然後按一下「確定」。

    註解:

    從「面板」選單中選擇「步驟記錄選項」,並確定選取了「自動建立首次快照」選項,就可以用文件初始狀態的快照來復原影像。

取消操作

  1. 按住 Esc 鍵,直到進行中的操作停止。在 Mac OS 中,可以按 Command + 句號鍵。

在操作完成時收到通知

進度列代表操作正在執行。您可以打斷這個操作,或讓程式在操作完成時通知您。

  1. 執行下列其中一項動作: 選擇「編輯 > 偏好設定 > 一般」(Windows) 或「Photoshop > 偏好設定 > 一般」(Mac OS)。

  2. 選取「完成時發出嗶聲」。
  3. 按一下「確定」。

使用操作記錄面板

您可以使用「步驟記錄」面板,將影像回復到目前工作階段中所建立影像的任何最近狀態。每次在影像上套用更改時,影像的新狀態就會新增到面板中。

例如,如果選取、繪畫並旋轉部分影像,這些狀態都會個別列在面板中。當您選取其中一種狀態時,影像便會回復至第一次套用變更時的外觀,您就可以從這個狀態繼續工作。

您也可以使用「步驟記錄」面板刪除影像狀態,以及在 Photoshop 中從狀態或快照中建立文件。

若要顯示「步驟記錄」面板,請選擇「視窗 > 步驟記錄」,或按一下「步驟記錄」面板索引標籤。

Photoshop 步驟記錄面板
Photoshop 步驟記錄面板

A. 設定步驟記錄筆刷的來源 B. 快照的縮圖 C. 步驟記錄狀態 D. 步驟記錄狀態滑桿 

使用「步驟記錄」面板時,請牢記下列原則:

  • 「步驟記錄」面板中不會反映整個程式的變更 (例如,面板、色彩設定、動作和偏好設定的變更),因為這些變更並非針對特定影像的變更。

  • 依預設,「步驟記錄」面板會列出之前的 20 個狀態。您可以在「偏好設定 > 效能」下設定偏好設定,來變更記錄的狀態數目。為了釋放出更多記憶體供 Photoshop 使用,系統會自動刪除較早的狀態。若要保留整個工作階段的特定狀態,請製作該狀態的快照 (請參閱建立影像的快照)。

  • 文件一旦關閉又重新開啟後,上次工作階段的所有狀態和快照就會從面板中清除。

  • 依預設值,文件初始狀態的快照會顯示在面板的頂端。

  • 狀態會加入清單的底部。也就是說,最舊的狀態會顯示在清單的頂端,最近的狀態顯示在底端。

  • 每個狀態都會一併列出用來更改影像的工具名稱或指令。

  • 依預設,當您選取狀態時,該狀態下面的所有狀態都會變成灰色,無法使用。這樣您就能清楚地看到,如果從選取的狀態繼續工作,有哪些更改會被放棄。

  • 依預設,選取狀態後如果變更影像,會將這個狀態之後的所有狀態消除掉。

  • 當您選了某個狀態,之後又更改影像,因而消除掉後面所有的狀態,這時可以使用「還原」指令還原前次更改,並復原消除掉的狀態。

  • 依預設,刪除狀態會刪除該狀態和該狀態之後的所有狀態。如果您選擇了「允許非線性步驟記錄」選項,這時刪除一個狀態就只會刪除該狀態。

回復至先前的影像狀態

  1. 執行下列任一項作業:
    • 按一下狀態的名稱。

    • 從「步驟記錄」面板選單或「編輯」選單中選擇「向前」或「退後」,移至下一個或前一個狀態。

刪除一或多個影像狀態

  1. 執行下列任一項作業:
    • 按一下狀態的名稱,然後從「步驟記錄」面板選單中選擇「刪除」,將這一個和後面所有更改的狀態刪除。

    • 將狀態拖移到「刪除」圖示 ,將該變更和之後所有的變更都刪除。

    • 從面板選單中選擇「清除步驟記錄」,從「步驟記錄」面板中刪除狀態清單,但不會更改影像。這個選項不會減少 Photoshop 所使用的記憶體量。

    • 按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac S),並從面板選單中選擇「清除步驟記錄」,在不更改影像的情況下清除狀態清單。如果出現訊息指出 Photoshop 的可用記憶體太少,此時清除狀態會很有用,因為這個指令會刪除「還原」緩衝區中的狀態,並釋放記憶體。但是這個指令是無法還原的。

    • 選擇「編輯 > 清除記憶 > 步驟記錄」,清除所有開啟文件的狀態清單。這個動作是無法還原的。

以影像狀態建立或取代文件

  1. 執行下列任一項作業:
    • 將狀態或快照拖移到「步驟記錄」面板中的「從目前狀態中建立新增文件」按鈕 。新建立文件的步驟記錄清單只會包含「複製狀態」項目。

    • 選取狀態或快照,然後按一下「從目前狀態中建立新增文件」按鈕 。新建立文件的步驟記錄清單只會包含「複製狀態」項目。

    • 選取狀態或快照,並從「步驟記錄」面板選單中選擇「新增文件」。新建立文件的步驟記錄清單只會包含「複製狀態」項目。

    • 將狀態拖曳到現有的文件上。

    註解:

    若要儲存一個或數個快照或影像狀態,以便在日後的編輯工作階段中使用,請為每個儲存的狀態建立一個新檔案,並將每個狀態儲存在個別的檔案中。當您重新開啟原始檔案時,請同時準備開啟其他儲存的檔案。您可以將每個檔案的初始快照拖移到原始影像中,再次從原始影像的「步驟記錄」面板中存取快照。

設定歷史選項

您可以指定「步驟記錄」面板中最多可容納多少項目數量,並設定其他選項,以自訂面板。

  1. 從「步驟記錄」面板選單中選擇「步驟記錄選項」。
  2. 選取選項:

    自動建立首次快照

    在開啟文件時自動建立影像初始狀態的快照。

    儲存時自動建立新增快照

    在每次儲存時產生快照。

    允許非線性步驟記錄

    對選取的狀態進行變更,但不刪除後面的狀態。通常當您選取狀態並更改影像時,在選取狀態後的所有狀態都會被刪除,透過這種方式,「步驟記錄」面板可以按照執行的先後順序,顯示編輯步驟清單。透過非線性的方式記錄狀態,您便可以選取狀態、對影像進行更改,並且只刪除該狀態,而這項變更則會加入清單的最後面。

    依預設顯示新增快照對話框

    強制 Photoshop 提示您輸入快照名稱,就算使用面板上的按鈕也是如此。

    使圖層可見度的變更可以還原

    此選項預設為選取。開啟或關閉圖層可見度,會計入步驟記錄的步驟。取消選取這個選項,即可將圖層可見度的變更排除於步驟記錄的步驟之外。

設定編輯步驟記錄選項

為了您個人的記錄、用戶端的記錄或是法律目的,您可能必須仔細追蹤在 Photoshop 中對檔案所做的變更。「編輯步驟記錄」可以幫助您保存對影像所做變更的文字步驟記錄。您可以使用 Adobe Bridge 或「檔案資訊」對話框,檢視「編輯步驟記錄」的中繼資料

您可以選擇將文字轉存成外部日誌檔案,或者將資訊儲存在編輯過檔案的中繼資料裡。將許多編輯操作儲存為檔案中繼資料會增加檔案大小;這種檔案開啟及儲存所需的時間可能比較長。

註解:

如果您需要證明記錄檔並未遭人擅自竄改,請將編輯記錄保存在檔案的中繼資料內,再使用 Adobe Acrobat 為記錄檔加上數位簽章。

根據預設,關於每個工作階段的步驟記錄資料都會儲存成中繼資料,並嵌入影像檔案中。您可以指定步驟記錄資料的儲存位置,以及步驟記錄包含資料的詳細程度。

  1. 選擇「編輯 > 偏好設定 > 一般」(Windows) 或「Photoshop > 偏好設定 > 一般」(Mac OS)。
  2. 按一下「步驟記錄」偏好設定,切換開啟或關閉的設定。
  3. 在「將記錄項目儲存到」選項中,選擇下列其中一個項目:

    中繼資料

    將步驟記錄儲存成嵌入每個檔案的中繼資料。

    文字檔案

    將步驟記錄轉存成文字檔。您會收到為文字檔案命名及選擇儲存位置的提示。

    兩者

    將中繼資料儲存於檔案中,並建立文字檔。

    註解:

    如果您想將文字檔儲存在不同的位置或是想儲存另一個文字檔,請按一下「選擇」按鈕,接著指定儲存文字檔的位置,並於必要時命名檔案,然後按一下「儲存」。

  4. 在「編輯記錄項目」選單中,選取下列任一項選項:

    僅限工作階段

    保存每次啟動或結束 Photoshop,以及每次開啟與關閉檔案的記錄 (包括每個影像的檔案名稱)。不包含編輯檔案的任何資訊。

    簡要

    除了「工作階段」的資訊外,也包含「步驟記錄」面板中出現的文字。

    詳細

    除了「簡要」的資訊外,也包含「動作」面板中出現的文字。如果您需要檔案所有變更的完整步驟記錄,請選擇「詳細」。

建立影像的快照

「快照」指令可以讓您為影像的任何狀態建立暫時的拷貝 (或快照)。新的快照會新增到「步驟記錄」面板頂端的快照清單中。選取快照可以讓您從該版本的影像開始工作。

快照類似於列在「步驟記錄」面板中的狀態,但是它們還提供了其他優點:

  • 您可以為快照命名,以方便辨識。

  • 您可以儲存整個工作階段的快照。

  • 您可以輕鬆地比較各種效果。例如,您可以在套用濾鏡的前後建立快照,然後選取第一個快照,並且用不同的設定使用相同的濾鏡。然後切換不同的快照,找出您最喜歡的設定。

  • 使用快照可以輕鬆復原您的工作。當您實驗複雜的技巧或套用動作時,請先建立快照。如果對結果不滿意,您可以選取快照以還原所有的步驟。

註解:

快照不會與影像儲存在一起,關閉影像就會將快照刪除。此外,除非選取了「允許非線性步驟記錄」選項,否則選取快照和變更影像,都會刪除「步驟記錄」面板目前列出的所有狀態。

建立快照

  1. 選取狀態,然後執行下列任一項作業:
    • 若要自動建立快照,請按一下「步驟記錄」面板上的「建立新增快照」按鈕 ,或從「步驟記錄」面板選單中選擇「新增快照」(若已選取步驟記錄選項中的「儲存時自動建立新增快照」)。

    • 若要在建立快照時設定選項,請從「步驟記錄」面板選單中選擇「新增快照」,或按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),再按一下「建立新增快照」按鈕。

  2. 在「名稱」文字方塊中輸入快照的名稱。

  3. 從「來源」選單中選擇快照內容:

    全文件

    建立在影像中該狀態所有圖層的快照

    合併圖層

    建立快照,以合併影像中該狀態的所有圖層

    目前圖層

    只建立該狀態目前所選取的圖層快照

使用快照

  1. 執行下列任一項作業:
    • 若要選取快照,請按一下快照的名稱,或是將快照左邊的滑桿向上或向下拖移到不同的快照上。

    • 若要重新命名快照,請按兩下快照並輸入名稱。

    • 若要刪除快照,請選取快照並從面板選單中選擇「刪除」、按一下「刪除」圖示 ,或將快照拖移到「刪除」圖示。

以影像的狀態或快照繪圖

「步驟記錄筆刷」工具  可以讓您將影像狀態或快照的拷貝,繪製到目前的影像視窗中。這個工具會建立影像的拷貝或樣本,並用它們繪畫。

例如,您可以為您用繪畫工具或濾鏡所做的更改建立快照 (當您建立快照時,「全文件」選項是被選取的)。在還原對影像的更改後,您可以使用「步驟記錄筆刷」工具,選擇性地將更改套用到影像的區域上。除非您所選取的是合併的快照,否則「步驟記錄筆刷」工具以從選取狀態的某一圖層到另一狀態的相同圖層的方式繪畫。

「步驟記錄筆刷」工具會將一個狀態或快照拷貝至另一個狀態或快照,但僅限於在相同的位置。在 Photoshop 中,您也可以使用「藝術步驟記錄筆刷」工具繪畫,建立特殊效果。

  1. 選取「步驟記錄筆刷」工具 
  2. 在選項列中執行下列任一項作業:
    • 指定不透明度和混合模式。

    • 選擇筆刷,並設定筆刷選項。

  3. 在「步驟記錄」面板中,按一下狀態或快照左方的欄位,用該狀態或快照當做「步驟記錄筆刷」工具的來源。
  4. 拖移「步驟記錄筆刷」工具來繪畫。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策