Scoprite come rendere Illustrator più veloce ed efficiente in Windows.

Diversi fattori influenzano la velocità e l'efficienza con cui viene eseguito Adobe Illustrator; ad esempio, il sistema operativo e la configurazione dell'hardware, il flusso di lavoro o le opzioni selezionate. Se notate che Illustrator viene eseguito più lentamente del solito, provate le tecniche riportate di seguito per ottimizzare non solo le prestazioni di Illustrator, ma anche quelle delle altre applicazioni.(I miglioramenti delle prestazioni sono evidenti soprattutto quando lavorate con file di grandi dimensioni).

Prima di iniziare

Prima di eseguire le operazioni descritte di seguito, accertati di installare la versione più recente di Illustrator o eventuali aggiornamenti°disponibili per la versione di Illustrator utilizzata. Gli aggiornamenti del software includono spesso correzioni o miglioramenti correlati alle prestazioni. 

Se utilizzate Illustrator CC, potete aggiornare Illustrator tramite l'applicazione Creative Cloud per desktop.

Nota:

Le procedure riportate nel presente documento sono basate sull’interfaccia predefinita. Se l'interfaccia è stata personalizzata, alcune procedure sono differenti. Ad esempio, il percorso per accedere al Pannello di controllo può variare. Scegliete Start > Impostazioni > Pannello di controllo o Start > Pannello di controllo, a seconda della vostra versione di Windows.Per suggerimenti per la risoluzione dei problemi e informazioni generali su Windows, contattate l'assistenza di Adobee l'assistenza di Microsoft.

Ottimizzare Windows

Configurando il vostro sistema in modo efficiente aumentate la memoria disponibile per le applicazioni e ne assicurate un funzionamento ottimale. Di seguito trovate diverse tecniche per ottimizzare Windows e migliorare le prestazioni di Illustrator.

Aumentare la memoria disponibile

La memoria virtuale vi consente di utilizzare lo spazio su disco rigido per memorizzare informazioni normalmente archiviate nella RAM. Tuttavia, l'accesso alle informazioni su disco rigido richiede più tempo rispetto all'accesso alle informazioni in memoria. Pertanto, è possibile che si verifichi un calo delle prestazioni se il sistema deve basarsi troppo sulla memoria virtuale.

Per migliorare le prestazioni, scegliete le dimensioni corrette per il vostro file di paging (l'area del disco rigido che contiene la memoria virtuale). Per modificare le dimensioni del file di paging sono richiesti privilegi di amministratore. Illustrator offre le prestazioni migliori quando le dimensioni massime del file di paging sono all'incirca tre volte superiori alla quantità di RAM installata.

  1. Chiudi tutte le applicazioni.

  2. Scegli Start > Pannello di controllo > Sistema > Impostazioni di sistema avanzate.

  3. Nella finestra di dialogo Proprietà del sistema, scegli la scheda Avanzate.

  4. Fai clic su°Impostazioni°nella sezione Prestazioni, quindi scegli la scheda Avanzate.

  5. Nella sezione Memoria virtuale, fai clic su Cambia.

  6. Deseleziona la casella di controllo°Gestisci automaticamente dimensioni file di paging per tutte le unità.

  7. Dall'elenco delle unità, selezionate un disco rigido con una quantità di spazio libero disponibile pari ad almeno tre volte quella della RAM installata nel computer. Ad esempio, se il computer dispone di 64 MB di RAM, selezionate un disco rigido con almeno 192 MB di spazio libero. Per migliorare ulteriormente le prestazioni, selezionate un disco rigido non utilizzato per il disco di memoria virtuale di Illustrator.

Disattivare le funzionalità dei driver

Alcuni driver della scheda video offrono impostazioni avanzate per l'accelerazione o la modifica della visualizzazione degli elementi grafici. Talvolta queste impostazioni possono rallentare l'aggiornamento della schermata in Illustrator. Per determinare le impostazioni migliori per Illustrator, provate a disattivare le funzionalità specifiche dei driver. Per ulteriori informazioni, fate riferimento alla documentazione fornita con la scheda video.

Gestione dei font

Ogni font installato aumenta la quantità di RAM utilizzata da Windows. Per migliorare le prestazioni del sistema e delle applicazioni che accedono ai font, installate solo i font di cui avete bisogno. Per gestire numerosi font, utilizzate un'utilità dedicata.

Limitare le applicazioni di avvio

Le applicazioni eseguite automaticamente all'avvio di Windows riducono la quantità di RAM disponibile per Illustrator. Per evitare che le applicazioni vengano avviate automaticamente, effettuate le seguenti operazioni:

  1. Chiudete tutte le applicazioni.

  2. Avviate Esplora risorse.
  3. Disattiva tutte le applicazioni di avvio spostando in un’altra cartella tutte le icone e i collegamenti presenti nella cartella di avvio (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp).

  4. Riavviate Windows.

Per chiudere le applicazioni per le quali è previsto l'avvio automatico nel Registro, effettuate le seguenti operazioni:

  1. Riavviate Windows.
  2. Premete Ctrl+Maiusc+Esc.

  3. Scegli la scheda Processi.

  4. Selezionate un'applicazione, quindi fate clic su Termina operazione.

  5. Riavviate Illustrator. Se riscontrate un miglioramento nelle prestazioni di Illustrator, contattate il produttore dell'applicazione per ottenere assistenza al fine di disattivare permanentemente l'avvio automatico. Ripetete le operazioni da 2 a 5 per tutte le altre applicazioni di avvio.

Riattivare le icone e i collegamenti

Se non notate alcun miglioramento delle prestazioni di Illustrator dopo il riavvio, riattivate le icone e i collegamenti in Esplora risorse, reinserendole nella cartella di avvio.

Se invece le prestazioni di Illustrator risultano migliorate, individuate i programmi che sono all'origine dei problemi prestazionali e riattivate le loro icone e collegamenti, inserendoli nella cartella di avvio con Esplora risorse.

Riavviate il computer dopo aver riabilitato ciascun insieme di icone e collegamenti, poi testate le prestazioni di Illustrator.

Ripetete questa procedura fino alla comparsa dei problemi relativi alle prestazioni di Illustrator. Una volta individuata l'icona o il collegamento all'origine del problema di prestazioni, eliminate tale elemento e contattate il produttore del programma per eventuali aggiornamenti.

Ottimizzare l'hardware

L'hardware che utilizzate influisce sulle prestazioni di Illustrator: maggiore è la velocità del processore o del disco rigido, maggiore sarà la velocità di elaborazione delle informazioni da parte di Illustrator. Potete migliorare le prestazioni apportando anche altre modifiche all'hardware, ad esempio installando RAM ulteriore, utilizzando un sistema a più processori oppure eseguendo l'ottimizzazione e la deframmentazione delle unità. Provate le seguenti tecniche per ottimizzare l'hardware.

Usare un processore più veloce

La velocità di Illustrator dipende dalla velocità della CPU (Central Processing Unit, unità centrale di elaborazione) del computer utilizzato. Poiché Illustrator gestisce grandi quantità di dati ed esegue numerosi calcoli, la velocità dipende dalla potenza del processore. Valutate la possibilità di utilizzare un computer con un processore più potente.

Installazione di RAM aggiuntiva

Se Illustrator non dispone di una quantità sufficiente di RAM, utilizzerà lo spazio su disco rigido (memoria virtuale, disco di memoria virtuale o entrambi) per elaborare le informazioni. Illustrator assicura prestazioni più rapide quando è in grado di elaborare le informazioni tramite la memoria, senza utilizzare il disco rigido.

Ottimizzazione dello spazio su disco

Di seguito sono riportati alcuni modi per ottimizzare lo spazio su disco:

  • Controllate il disco rigido per verificare la presenza di errori, deframmentare i file e fare un uso più efficiente dello spazio disponibile sul disco rigido mediante i programmi CHKDSK.exe e l'Utilità di deframmentazione dischi. Per ulteriori informazioni, consultate la documentazione di Windows o Ottimizzare Windows per migliori prestazioni.
  • Salvate i file su unità con maggiore velocità di accesso. Ad esempio, potete usare un disco interno anziché un server di rete (unità di rete) o il dispositivo esterno.
  • Per salvare un file in una rete o su un'unità esterna, dovete prima salvare il file su un disco rigido. Quindi chiudi il file e utilizza Esplora risorse per copiarlo sull’unità esterna o di rete.

Usare una stampante PostScript

Per ottenere i migliori risultati quando si stampa da Illustrator, utilizzate una stampante PostScript. La maggior parte delle stampanti non PostScript utilizzano informazioni di visualizzazione, risorse di computer host e driver di stampanti proprietari per trasmettere informazioni di stampa alla stampante. Di conseguenza, stampano molto più lentamente rispetto alle stampanti PostScript.

Utilizzo efficace delle funzionalità di Illustrator

Il modo in cui si lavora con Illustrator e in particolar modo come viene visualizzata la grafica, può incidere sulle prestazioni di Illustrator. Di seguito sono riportati alcuni modi per utilizzare le funzioni di Illustrator in maniera efficiente.

Lavorare in vista Contorno

La vista Contorno nasconde gli attributi di colore e visualizza i disegni come tracciati privi di riempimento. L'utilizzo della vista Contorno accelera la visualizzazione di disegni complessi, ad esempio di quelli contenenti sfumature o motivi. Inoltre, la vista Contorno semplifica la modifica degli oggetti nascosti dietro altri oggetti con riempimento.

Per visualizzare un documento Illustrator in vista Contorno, scegliete Visualizza > Contorno.

Creare viste personalizzate

Potete creare viste personalizzate di un documento. Le viste personalizzate vi consentono di cambiare rapidamente la modalità di visualizzazione, l'ingrandimento, la posizione di scorrimento e le opzioni di livello.

Per creare una vista personalizzata di un documento di Illustrator, impostate gli attributi che desiderate salvare. Quindi selezionate Visualizza > Nuova vista e digitate un nome nella finestra di dialogo visualizzata. La vista personalizzata viene inclusa nel menu Visualizza.

Cambiare le impostazioni degli effetti raster

Potete modificare la risoluzione degli effetti raster per ottimizzare le prestazioni di Illustrator.

Per modificare la risoluzione degli effetti raster, scegliete Effetto > Impostazioni effetti raster del documento. Nel menu a comparsa Risoluzione, effettua una delle seguenti operazioni:

  • Se state modificando i file, scegliete Schermo. Illustrator adotta una risoluzione di 72 ppi per gli effetti raster, che aumenta la velocità di visualizzazione.
  • Se state stampando i file, scegliete Alta. Illustrator adotta una risoluzione di 300 ppi per gli effetti raster, che riduce la velocità di stampa ma ne aumenta la qualità.

Poi, fate clic su OK.

Nascondere livelli e rimuovere le miniature

Usare il pannello Livelli per organizzare e modificare i disegni. Quando vengono nascosti i livelli che contengono disegni complessi o immagini bitmap ad alta risoluzione, Illustrator aggiorna la schermata più rapidamente.

Per nascondere un livello, fate clic sull'icona dell'occhio a sinistra del nome del livello. Per nascondere tutti i livelli tranne quello selezionato, tenete premuto il pulsante Alt (il pulsante Opzione in Mac) e fate clic sull'icona a forma di occhio.

Nel pannello Livelli possono essere visualizzate miniature per livelli superiori, livelli nidificati, gruppi e oggetti. Per ridurre il numero di miniature e consentire a Illustrator di aggiornare lo schermo più velocemente, scegliete Opzioni pannello dal menu del pannello Livelli, poi riducete il numero di miniature.

Pannello Opzioni

Disattivare l'anteprima sovrastampa

Anteprima sovrastampa offre una "anteprima a inchiostri" che simula il risultato di fusioni, trasparenze e sovrastampa nella stampa in selezione colori. Per migliorare le prestazioni, evitate di utilizzare Anteprima sovrastampa.

Per attivare e disattivare Anteprima sovrastampa, selezionate Visualizza > Anteprima sovrastampa.

Eliminare tavole da disegno inutilizzate

Le tavole da disegno sono le aree che possono contenere grafica stampabile. Per ottimizzare le prestazioni, si consiglia di eliminare le tavole da disegno non utilizzate o non necessarie.

Per gestire le tavole da disegno, scegliete Finestra > Tavole da disegno. Selezionate una Tavola da disegno da rimuovere e fate clic su Elimina.

Modificare la selezione del disco di memoria virtuale

Se si lavora con un'immagine bitmap incorporata e il sistema non dispone di RAM sufficiente, Illustrator utilizza lo spazio su disco rigido come un disco di memoria virtuale. L'accesso alle informazioni su disco rigido richiede più tempo rispetto all'accesso alle informazioni in memoria. Di conseguenza, l'utilizzo di una porzione del disco rigido come memoria virtuale può diminuire le prestazioni. Se l'utilizzo di Illustrator richiede più memoria, Adobe consiglia di espandere la RAM.

Per impostazione predefinita, Illustrator utilizza l'unità di sistema come disco di memoria virtuale principale. Impostate il disco rigido più veloce come disco di memoria virtuale principale di Illustrator.

Per modificare la preferenza relativa al disco di memoria virtuale, effettuate le seguenti operazioni:

  1. Scegli Modifica > Preferenze > Plug-in e disco di memoria virtuale.

  2. Scegli un disco rigido dal menu a comparsa degli elementi principali. Se lavori con immagini di grandi dimensioni e disponi di più di un disco rigido, scegli un altro disco dal menu a comparsa degli elementi secondari.

  3. Fate clic su OK e riavviate Illustrator.

Rimuovere elementi non usati dai profili dei documenti

I profili per documenti di Illustrator contengono motivi, sfumature, ideogrammi, colori, librerie di colori e pennelli predefiniti che vengono visualizzati nei nuovi documenti di Illustrator. Questi file determinano inoltre il livello di zoom, la dimensione delle finestre, le preferenze di visualizzazione e la posizione di scorrimento per i nuovi documenti. Minimizzate le dimensioni del file dei nuovi documenti rimuovendo campioni e pennelli non necessari dai profili per nuovi documenti Illustrator.

Per ulteriori istruzioni su come creare profili documento personalizzati in Illustrator, consulta Startup Profiles: A great tool to customize your new documents.

Rimozione di elementi non usati dai modelli

I modelli consentono di creare documenti che condividono impostazioni ed elementi grafici comuni. Puoi ridurre le dimensioni dei nuovi documenti rimuovendo campioni, simboli, stili grafici e pennelli non necessari dai modelli.

Per istruzioni su come creare i file dei modelli, consultate File e modelli.

Abilitare i collegamenti alle immagini

Le immagini bitmap incorporate (ad esempio TIFF, BMP e Photoshop EPS) aumentano notevolmente le dimensioni dei documenti di Illustrator e rallentano le prestazioni del programma. Per migliorare le prestazioni, attivate l'opzione Collega al momento dell'inserimento di un'immagine bitmap. L'opzione Collega crea un riferimento nel disco rigido all'immagine inserita.

  • Seleziona File > Inserisci. Nella finestra di dialogo Inserisci, scegliete Collega.

Se un service di stampa richiede immagini integrate, salvate una copia dei file. Seleziona Includi file collegati nella finestra di dialogo delle Opzioni del formato nativo di Illustrator o in quella delle Opzioni del formato EPS .

Usare le anteprime EPS a bassa risoluzione

Se un documento contiene immagini EPS collegate e dotate di anteprime ad alta risoluzione, Illustrator aggiornare più lentamente lo schermo quando si modifica la grafica. Per consentire a Illustrator di aggiornare lo schermo più rapidamente, utilizzate anteprime EPS a bassa risoluzione. Seguite la procedura descritta di seguito.

  1. Scegli Modifica > Preferenze > Gestione file e Appunti.

  2. Selezionate Per EPS collegati usa proxy a bassa risoluzione e fate clic su OK.

Disabilitare Mostra interazioni trasparenza DCS

La finestra di dialogo dello opzioni del pannello Collegamenti include l'opzione Mostra interazioni trasparenza DCS. Se selezionate questa opzione, nel pannello Collegamenti viene visualizzata un'icona gialla che consente di identificare gli elementi grafici EPS DCS che sono trasparenti o si sovrappongono a oggetti trasparenti. Poiché questa opzione obbliga Illustrator a stabilire di frequente se i file EPS collegati interagiscono con la trasparenza, le prestazioni potrebbero risultare rallentate.

Per disattivare l'opzione Mostra interazioni trasparenza DCS, seguite la procedura descritta in seguito.

  1. Seleziona Windows > Collegamenti. Scegliete Opzioni pannello dal menu del pannello Collegamenti.

  2. Deselezionate Mostra interazioni trasparenza DCS e fate clic su OK.

Nascondere il pannello Navigatore

Il pannello Navigatore visualizza una miniatura del disegno corrente per facilitare la navigazione. I tempi di elaborazione relativi all'aggiornamento della miniatura ogni volta che si modifica il documento dipendono dalla complessità del disegno. Per velocizzare l'aggiornamento della schermata con un documento complesso, nascondete il pannello Navigatore. Nel menu Finestra, deselezionate Navigatore.

È possibile impostare visualizzazioni personalizzate°per ottenere uno zoom maggiore per particolari aree del documento.

Disabilitare grafica anti-alias

L'opzione Grafica anti-alias migliora testo e grafica mediante la fusione del colore dei pixel del bordo di un oggetto con il colore dei pixel vicini. Tuttavia, questo processo può rallentare l'aggiornamento della schermata. Per disattivare questa opzione, seguite la procedura descritta di seguito.

  1. Scegli Modifica > Preferenze > Generale.

  2. Disattiva Grafica anti-alias e fai clic su OK.

Applicare il comando Semplifica

Il comando Semplifica riduce il numero di punti di ancoraggio in tracciati e forme dei tracciati, riducendo le dimensioni del file e migliorando le prestazioni. Per applicare il comando Semplifica, seleziona il tracciato o l'oggetto desiderato, quindi scegli Oggetto > Tracciato > Semplifica.

Per ulteriori informazioni sul comando Semplifica, consultate l'Aiuto di Illustrator.

Disattivare le Guide sensibili

Le guide sensibili consentono di creare, allineare, modificare e trasformare oggetti di Illustrator in relazione ad altri oggetti. Se nel disegno sono presenti molti oggetti, la visualizzazione delle guide sensibili richiede più tempo. Per disattivare le guide sensibili, deselezionate Guide sensibili del menu Visualizza.

Per ulteriori informazioni sulle guide sensibili, consultate Righelli, griglie, guide e indicatori di ritaglio.

Rasterizzare i tracciati del Pennello setole e disattivare le funzionalità PDF

I tratti dei pennelli setole sono composti da diversi tracciati con riempimenti trasparenti e sovrapposti. Tali tracciati, come qualsiasi altro tracciato con riempimento in Illustrator, interagiscono con la pittura di altri oggetti, inclusi altri tracciati realizzati con il pennello setole.

Effettuate delle prove e sperimentate con i pennelli setole e le opzioni di colore prima di realizzare grafiche su larga scala. La modifica degli attributi dei pennelli e la riapplicazione degli stessi renderizza nuovamente tutti i pennelli utilizzati.

Quando utilizzi i pennelli setole, puoi ridurre la complessità e le dimensioni del file del documento effettuando le seguenti operazioni:

  • Rasterizzare alcuni tracciati pannello setole. Accertatevi di salvare una copia della grafica originale prima di eseguire la rasterizzazione del contenuto.

Se la grafica contiene un numero considerevole di pennelli setole (più di 30), riducete la complessità e il numero dei tracciati pennello setole. Seleziona i tracciati dei pennelli setole e scegli Oggetto > Rasterizza.

  • Disattivare le funzionalità PDF.

Per impostazione predefinita Illustrator salva dati PDF che consentono ai file di Illustrator (*ai) di essere compatibili con le altre applicazioni Adobe. Scegli File Salva File > Salva con nome e fai clic su Salva.  Deseleziona Crea file PDF compatibile nella finestra di dialogo Opzioni Illustrator.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online