Sdílení obsahu

Zásuvné moduly Adobe InCopy LiveEdit Workflow umožňují autorům a redaktorům vytvářet podklady v InCopy ve stejné době, kdy návrháři připravují rozvržení v aplikaci Adobe InDesign. Tento pracovní postup zahrnuje kontejnerové soubory označované jako úlohy pro seskupení souvisejících částí obsahu a dále nástroje pro zamykání souborů a posílání zpráv pro sdílení a aktualizaci souborů v aplikacích InCopy nebo InDesign přes sdílenou síť nebo v komprimovaných balíčcích, které lze distribuovat e-mailem.

V pracovním postupu na sdílené síti exportují uživatelé aplikace InDesign text a grafiky do sdíleného umístění v souborovém systému, kde k těmto souborům mají přístup uživatelé InCopy, kteří mohou zapisovat a upravovat jejich obsah. Vybrané textové a grafické rámečky se exportují buď do úlohy nebo jako samostatné soubory InCopy, kde se stanou součástí spravovaného procesu a jsou propojeny s dokumentem aplikace InDesign. Tyto sdílené soubory se označují jako spravované soubory. Při práci v souboru úlohy nebo v souboru aplikace InDesign na lokálním serveru se změny příslušného rozvržení nebo obsahu předávají všem uživatelům, kteří se účastní pracovního postupu pro tento dokument.

Stejný soubor obsahu může otevřít zároveň více uživatelů aplikací InCopy nebo InDesign a stejný soubor úlohy může otevřít zároveň více uživatelů InCopy. Ale pouze jeden uživatel si může v daný okamžik vyhradit soubor InCopy pro úpravy. Ostatní mohou tento soubor pouze prohlížet v režimu pouze ke čtení. Uživatel, který si vyhradí soubor spravovaný v InCopy, může sdílet svou práci s ostatními uživateli uložením souboru na sdílený server nebo vrácením souboru uživateli aplikace InDesign; ostatní uživatelé ale nemohou v tomto souboru provádět změny, dokud není znovu zpřístupněn. Tento systém umožňuje více uživatelům získávat přístup ke stejnému souboru, ale zabraňuje uživatelům vzájemně si přepisovat svou práci.

Další informace najdete v příručce InCopy LiveEdit Workflow (ve formátu PDF), která je dostupná na www.adobe.com/go/learn_liveedit_cz.

Způsoby práce s obsahem v InCopy

Obsah je buď text, který prochází jedním nebo více rámečky, nebo importovaná grafika. Existuje pět základních způsobů práce s obsahem v InCopy: otevřít soubor úlohy, otevřít balíček úlohy, otevřít připojený soubor InCopy, otevřít soubor aplikace InDesign, ke kterému jsou připojené soubory InCopy nebo sestavit celý obsah zcela v InCopy.

Otevření souborů úloh vytvořených v aplikaci InDesign

Uživatelé aplikace InDesign mohou vytvořit soubor úlohy a určit obsah, který se bude sdílet. Tato metoda umožňuje uživateli aplikace InDesign spojit související komponenty (nadpis, základní text, grafiky, popisky a podobně) a pak je přidělit různým uživatelům InCopy pro zápis a úpravy. Uživatelé InCopy otevřou soubor úlohy a pracují pouze na komponentách, které jsou jim přiřazené. Zobrazení živého rozvržení ukazuje, jak souvisí jejich upravovaná kopie s rozvržením aplikace InDesign, aniž by bylo potřeba otevřít celý dokument aplikace InDesign. Pokud se ale rozvržení změní, musí uživatel aplikace InDesign aktualizovat úlohy a tím informovat uživatele InCopy o těchto změnách. Soubory úloh je možné sdílet na serveru nebo pomocí balíčků úloh.

Panel Úlohy
Dokument aplikace InDesign (.indd) se souborem úlohy (.icml) složený ze tří připojených souborů s obsahem (.incx). Úloha a její komponenty se zobrazují v panelu Úlohy a otevírají se v InCopy.

Otevření balíčků úloh

Pracovní postup s balíčky úloh je užitečný hlavně v případě, kdy návrháři a autoři pracují na stejném projektu, ale nemají přístup na stejný lokální server. V takových případech může uživatel aplikace InDesign vytvořit jeden nebo více balíčků a e-mailem poslat komprimované soubory přiřazeným uživatelům InCopy. Uživatelé InCopy mohou otevřít balíčky úloh, upravit jejich obsah a vrátit tyto balíčky uživateli aplikace InDesign, který pak může aktualizovat příslušný dokument.

Otevření připojených souborů InCopy exportovaných z aplikace InDesign

V určitých pracovních postupech mohou uživatelé aplikace InDesign exportovat text a grafiky jako samostatné soubory, místo jejich zabalení do souboru úlohy. Export samostatných souborů je užitečný, pokud pracujete na navzájem nesouvisejících grafikách nebo částech textu. Uživatelé InCopy ale nemohou vidět, jak se obsah vejde do rozvržení aplikace InDesign.

Otevření připojených souborů InCopy exportovaných z aplikace InDesign
Dokument aplikace InDesign (.indd) se třemi připojenými, ale nepřiřazenými soubory obsahu (.icml) otevřenými v InCopy

Otevření dokumentů aplikace InDesign, ke kterým jsou připojené soubory InCopy

Pokud chtějí uživatelé InCopy vidět všechny položky stránky v kontextu celého rozvržení, mohou otevřít a upravovat dokument aplikace InDesign v InCopy. Tento přístup může být užitečný pro úpravy a přizpůsobení rozsahu, pokud je důležité vidět celkové rozvržení, případně když se v dokumentu neupravují pouze některé z článků, ale spíše většina z nich. Poté, co uživatel InCopy upraví články, může uživatel aplikace InDesign aktualizovat vazby na změněné soubory. Pokud uživatel aplikace InDesign změní rozvržení, uživateli InCopy se pošle upozornění při uložení dokumentu aplikace InDesign.

Sestavení celého obsahu v InCopy

V InCopy lze vytvořit obsah, který není spojený se souborem aplikace InDesign. V těchto samostatných dokumentech je možné zapisovat text a pak tento text vylepšit přiřazením písem a stylů a importováním grafik z jiných aplikací (např. Illustratora Photoshop). Můžete také přiřadit tagy pro budoucí použití v XML. Tento přístup je dobrou volbou v redakčních pracovních postupech, kde obsah předchází návrh. Pro samostatné dokumenty InCopy můžete také nastavit a upravit textovou oblast, velikost a orientaci stránky. Pokud se ale článek později připojí k dokumentu aplikace InDesign, nastavení aplikace InDesign nahradí nastavení používaná v InCopy.

Spravované soubory

Chcete-li spravovat soubor, musíte ho přidat do souboru úlohy, exportovat z aplikace InDesign jako obsah InCopy nebo umístit jako obsah InCopy do aplikace InDesign. Spravované soubory obsahují informace o stavu obsahu a o jeho vlastnictví. Se spravovanými soubory můžete:

  • Zamykat a odemykat články, abyste zachovali neporušenost a celistvost souboru.

  • Informovat uživatele InCopy, když se související rozvržení aplikace InDesign změní a není již aktuální.

  • Rozpoznat uživatele, který se souborem pracuje.

  • Informovat uživatele, když již soubor obsahu InCopy není aktuální, když ho někdo používá, nebo když je dostupný pro úpravy. Metody upozornění zahrnují zprávy s upozorněním, ikony rámečků, stavové ikony v panelu Vazby a stavové ikony v panelu Úlohy.

Soubory pouze ke čtení

Když se soubor obsahu změní na spravovaný, je vždy pouze ke čtení pro všechny uživatele v pracovním postupu, s výjimkou osoby, která si ho vyhradila. Když si uživatel vyhradí určitý soubor, software vytvoří soubor zámku (*.idlk) a poskytne tak uživateli výluční právo pro jeho úpravy. Soubory pouze ke čtení mají následující charakteristiky:

  • Uživatel InCopy nemůže ručně formátovat obsažený text. Pokud ale má text přiřazené znakové a odstavcové styly, uživatel aplikace InDesign může změnit definice těchto stylů a tím změnit formátování textu i tehdy, když je soubor vyhrazený pro někoho jiného. Tyto změny definice stylu se projeví v textu, jakmile uživatel aplikace InDesign soubor zaktualizuje.

  • Obecně platí, že uživatel InCopy ani uživatel aplikace InDesign nemůže v zamknutém obsahu InCopy změnit objekty, jako je text a aplikované styly. Některé objekty, například znakové a odstavcové styly, obsah pouze používá. Nemůžete například změnit, jak se znakový styl aplikuje na objekty v zamknutém obsahu, ale můžete změnit samotný znakový styl a tím změnit vzhled textu.

  • Uživatel aplikace InDesign může změnit okraje a sloupce textového obsahu, stejně jako tvar, polohu a počet textových rámečků vyplněných článkem.

  • Uživatel aplikace InDesign může změnit geometrii a formátování grafického rámečku, aniž by si musel grafiku vyhradit. Uživatel InCopy nemůže změnit grafický rámeček ani jakékoli formátování rámečku. Ale uživatelé aplikací InDesign i InCopy si musejí grafický rámeček vyhradit, aby mohli upravit samotnou grafiku (například ji otočit nebo změnit její velikost).

Osvědčené postupy pro práci se spravovanými soubory

Pomocí následujících postupů můžete zajistit, že budete vždy pracovat s nejaktuálnějším obsahem a nebudete přepisovat práci někoho jiného:

  • Soubory úloh ukládejte na serveru, na který mají přístup všichni členové týmu. Pokud někteří členové týmu nemají přístup na příslušný server, můžete vytvořit a distribuovat balíčky úloh.

  • Při vytvoření úlohy se vytvoří speciální složka, která obsahuje soubor úlohy a příslušný obsah. Tyto složky úloh se používají k uchovávání souborů úloh a obsahu. Tyto složky zjednodušují správu sdílených souborů v pracovní skupině a zajišťují, že uživatelé otevírají správné soubory.

  • V InCopy otevírejte raději soubor úlohy místo jednotlivého článku InCopy. Tak můžete vidět informace o délce článku a jeho rozvržení v zobrazení sloupců a rozvržení. Pokud exportujete obsah bez použití souborů úloh, můžete zobrazit informace o přizpůsobení délky textu a rozvržení pouze pomocí otevření souboru aplikace InDesign.

  • Jakmile otevřete soubor úlohy, otevřete dokument aplikace InDesign nebo si vyhradíte obsah v aplikaci InDesign nebo InCopy, zkontrolujte, že se zobrazují okraje rámečků (Zobrazení > Zobrazovat netištěné > Zobrazovat okraje rámečku), abyste mohli vidět ikony rámečku, když se objeví.

  • Pokud musíte v aplikaci InDesign odstranit soubory z pracovního postupu (například kvůli termínu výroby), můžete je odpojit nebo zrušit balíček úlohy.

Příklady pracovních postupů se spravovanými soubory

Po spuštění správy pracovního postupu mezi aplikacemi InCopy a InDesign mohou autoři a redaktoři vytvářet, přepisovat, rozšiřovat a upravovat dokumenty ve stejném okamžiku, kdy návrháři připravují rozvržení. Běžné pracovní postupy zahrnují správu souborů na lokálním serveru, sdílení souborů přes e-mailové balíčky nebo použití kombinace těchto dvou metod.

V těchto pracovních postupech se předpokládá, že máte základní předlohu aplikace InDesign s geometrií rozvržení, styly a vyhrazenými místy pro text. Geometrie rozvržení zahrnují rozměry stránky a také textové a grafické rámečky. InCopy používá tyto položky při zobrazování informací, zda se text vejde do vyhrazených textových rámečků.

Pracovní postup pro lokální server

1. V aplikaci InDesign vytvořte úlohy a přidejte do nich obsah.

Tento krok začlení exportovaný text a grafiky do spravovaného procesu, kde budou dostupné uživatelům InCopy pro zápis a úpravy.

2. Zpřístupněte soubory úloh pro uživatele InCopy.

Uložte soubory na server, na který mají přístup všichni uživatelé z pracovního postupu.

3. V InCopy otevřete soubor úlohy a vyhraďte si a upravte článek nebo grafiku.

V InCopy se v panelu Úlohy zobrazí soubory s obsahem, který je vám přiřazený. Kdykoli soubor uložíte na lokální server, změny se uloží do souborového systému a všichni, kdo pracují na tomto dokumentu (v rozvržení aplikace InDesign nebo v jiném spravovaném souboru obsahu z dokumentu) dostanou upozornění o změnách. Tito uživatelé si pak mohou obsah aktualizovat, aby viděli poslední změny. Obsah zůstává vyhrazený pro vás, dokud ho nezpřístupníte.

4. V aplikaci InDesign pracujte na rozvržení.

Bez ohledu na to, zda se soubory obsahu upravují v InCopy, mohou uživatelé aplikace InDesign pracovat na rozvržení dokumentu; nemusí si dokument vyhradit. Kdykoliv uživatel InCopy uloží vyhrazený obsah, může si uživatel aplikace InDesign aktualizovat tento obsahu v rozvržení, aby viděl nejnovější verzi.

5. V InCopy pokračujte v práci.

Když úpravy dokončíte, obsah zpřístupněte. Ostatní uživatelé si pak budou moci tento obsah vyhradit a pracovat na něm. Pokud uživatel aplikace InDesign souběžně upravuje rozvržení, můžete si při práci aktualizovat a zobrazit geometrii rozvržení.

6. V aplikaci InDesign zkontrolujte, že je zpřístupněný veškerý obsah.

Spravovaný pracovní postup umožňuje zjistit, kdo si soubory vyhradil. Po zpřístupnění souborů obsahu si uživatelé aplikace InDesign mohou tyto soubory vyhradit a dokončit rozvržení podle potřeby.

Pracovní postup s e-mailovými balíčky

1. V aplikaci InDesign vytvořte a odešlete balíčky úloh.

Vytvořte balíčky úloh, přiřaďte obsah příslušným uživatelům InCopy a pak odešlete tyto balíčky uživatelům InCopy. Soubory v balíčku se automaticky vyhradí, aby se předešlo konfliktům při úpravách.

2. V aplikaci InCopy otevřete balíček úlohy a vyhraďte si a upravte článek nebo grafiku.

Pokud dostanete balíček úlohy v e-mailu, dvojitě klikněte na něj, aby se otevřel v InCopy. Změny provedené v souboru se uloží pouze místně. Pokud provedete změny, ostatní uživatelé nebudou upozorněni.

3. V aplikaci InDesign pracujte na rozvržení.

Bez ohledu na to, zda jsou soubory obsahu zabalené, mohou uživatelé aplikace InDesign pracovat na rozvržení dokumentu; nemusí si dokument vyhradit. Pokud potřebujete aktualizovat rozvržení nebo úlohy, můžete aktualizovaný balíček odeslat uživatelům InCopy.

4. V InCopy vraťte upravený balíček.

Když úpravy dokončíte, zpřístupněte obsah a vraťte upravený balíček. Další uživatelé pak mohou kontrolovat obsah, zobrazit poslední revize a pracovat na souboru.

5. V aplikaci InDesign zkontrolujte, že je zpřístupněný veškerý obsah.

Spravovaný pracovní postup umožňuje zjistit, kdo si soubory vyhradil. Poté, co se balíčky úloh vrátí, články v balíčcích úloh se zpřístupní. uživatelé aplikace InDesign si mohou vyhradit soubory a dokončit rozvržení podle potřeby.

Zadání identifikace uživatele

Všichni uživatelé v pracovním postupu musí mít jméno uživatele. Tato identifikace ukáže, kdo si vyhradil určitý soubor, a poskytne tyto informace ostatním uživatelům. Vyžaduje se také pro vyhrazení souboru pro úpravy.

Pokud jste již určili jméno uživatele a chcete ho změnit, musíte zpřístupnit všechen obsah, který jste si vyhradili. V opačném případě byste při změně identifikace uživatele během úprav mohli přijít o možnost upravovat obsah, který jste si vyhradili; tento obsah byste měli vyhrazený pod jiným jménem.

Identifikace uživatele je specifická pro aplikaci; žádný uživatel nemůže mít více identifikací uživatele v jedné aplikaci.

Poznámka:

Funkce pro poznámky a sledování změn v InCopy také používají zadané jméno pro identifikaci autora poznámky nebo sledované změny.

  1. Proveďte jeden z následujících úkonů:
    • Zvolte Soubor > Uživatel.

    • Z nabídky panelu Úlohy zvolte Uživatel.

  2. Zadejte jednoznačné jméno a klikněte na OK.

Pokud zapomenete při použití této metody zadat uživatelské jméno, objeví se dotaz na jeho zadání, když se pokusíte poprvé použít funkci pracovního postupu.

Poznámka:

Rozbalovací nabídka Barva v tomto dialogovém okně slouží pro identifikaci redakčních poznámek a sledovaných změn. Pokud chcete, můžete nyní vybrat barvu, neovlivní to ale nic, co děláte v řízeném pracovním postupu.

Ikony pracovního postupu

Ikony se mohou objevit na textových a grafických rámečcích, panelu Úlohy a v pruhu článků (pouze v InCopy). Ikony stavu úprav se zobrazují vedle spravovaného souboru v panelech Vazby a Úlohy a informují o stavu obsahu. Na rámečcích obsahujících propojený článek InCopy se zobrazují ikony (v zobrazení Rozvržení v programech InDesign i InCopy). Tyto ikony také informují o stavu obsahu a můžete je použít pro rozlišení spravovaného a nespravovaného obsahu. Příslušný tip nástroje ukazuje stav úprav a jejich vlastníka. Chcete-li zobrazovat ikony rámečků, zkontrolujte, zda jsou v aplikacích InDesign i InCopy viditelné okraje rámečků (Zobrazení > Zobrazovat netištěné > Zobrazovat okraje rámečku).

Poznámka:

(InDesign) Aby se zobrazovaly okraje rámečků, musí být okno dokumentu aplikace InDesign v normálním režimu. (klikněte na tlačítko Normální režim vlevo dole v panelu nástrojů.)

Ikona

Název

Umístění

Dostupný

Panel Úlohy (InDesign a InCopy), textové a grafické rámečky

Používá [jméno]

Panel Úlohy, textové a grafické rámečky

Upravovaný

Panel Úlohy, textové a grafické rámečky

Dostupný a neaktuální

Textové a grafické rámečky

Používán uživatelem [jméno] a neaktuální

Textové a grafické rámečky

Upravovaný a neaktuální

Textové a grafické rámečky

Neaktuální

Panel Úlohy

Neaktuální textový obsah

Panel Úlohy a textové rámečky

Aktuální textový obsah

Panel Úlohy a textové rámečky

Neaktuální grafický obsah

Panel Úlohy a grafické rámečky

Aktuální grafický obsah

Panel Úlohy a grafické rámečky

Obsah sbalený do balíčku

Panel Úlohy

Poznámka:

Ikona Neaktuální u ikon Dostupný, Používaný, Upravovaný, Textový obsah a Grafický obsah označuje, že obsah není aktuální; to znamená, že verze v souborovém systému je novější než verze zobrazená na vašem počítači.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online