Guida utente Annulla

Creazione di estensioni HTML

  1. Guida utente di Adobe Animate
  2. Introduzione ad Animate
    1. Novità di Animate
    2. Glossario visivo
    3. Requisiti di sistema per Animate
    4. Scelte rapide da tastiera di Animate
    5. Utilizzare diversi tipi di file in Animate
  3. Animazione
    1. Concetti di base sulle animazioni in Animate
    2. Come utilizzare i fotogrammi e i fotogrammi chiave in Animate
    3. Animazione fotogramma per fotogramma in Animate
    4. Come utilizzare le animazioni con interpolazione classica in Animate
    5. Strumento Pennello
    6. Guida di movimento
    7. Interpolazione di movimento e ActionScript 3.0
    8. L’animazione con interpolazione di movimento
    9. Animazioni con interpolazione di movimento
    10. Creazione di un’animazione con interpolazione di movimento
    11. Utilizzo dei fotogrammi chiave di proprietà
    12. Animare la posizione con un'interpolazione
    13. Come modificare le interpolazioni di movimento con l'Editor movimento
    14. Modifica del tracciato di movimento di un’animazione con interpolazione
    15. Manipolazione delle interpolazioni di movimento
    16. Aggiunta di andamenti personalizzati
    17. Creazione e applicazione di preimpostazioni di movimento
    18. Impostazione delle estensioni di interpolazione per l’animazione
    19. Operazioni con le interpolazioni di movimento salvate come file XML
    20. Interpolazioni di movimento e classiche a confronto
    21. Interpolazione di forme
    22. Utilizzare lo strumento di animazione Osso in Animate
    23. Utilizzare il rigging dei personaggi in Animate
    24. Come utilizzare i livelli maschera in Adobe Animate
    25. Come utilizzare le scene in Animate
  4. Interattività
    1. Come creare pulsanti con Animate
    2. Convertire progetti Animate in altri formati di tipi di documenti
    3. Creare e pubblicare documenti HTML5 Canvas in Animate
    4. Aggiungere interattività con gli snippet di codice in Animate
    5. Creazione di componenti HTML5 personalizzati
    6. Utilizzo dei componenti in HTML5 Canvas
    7. Creazione di componenti personalizzati: esempi
    8. Snippet di codice per componenti personalizzati
    9. Best practice - Pubblicità con Animate
    10. Creazione e pubblicazione di contenuti in realtà virtuale
  5. Area di lavoro e flusso di lavoro
    1. Creazione e gestione dei pennelli artistici
    2. Utilizzo di Google Fonts nei documenti HTML5 Canvas
    3. Utilizzo di Creative Cloud Libraries con Adobe Animate
    4. Utilizzare il pannello Strumenti e Stage per Animate
    5. Flusso di lavoro e area di lavoro di Animate
    6. Utilizzo di font Web nei documenti HTML5 Canvas
    7. Linee temporali e ActionScript
    8. Operazioni con più linee temporali
    9. Impostare le preferenze
    10. Uso dei pannelli di creazione di Animate
    11. Creare livelli della linea temporale con Animate
    12. Esportare animazioni per dispositivi mobili e motori grafici
    13. Spostamento e copia degli oggetti
    14. Modelli
    15. Trova e sostituisci in Animate
    16. Annulla, Ripeti e il pannello Cronologia
    17. Scelte rapide da tastiera
    18. Come utilizzare la linea temporale in Animate
    19. Creazione di estensioni HTML
    20. Opzioni di ottimizzazione per immagini e GIF animati
    21. Impostazioni per l’esportazione di immagini e file GIF
    22. Pannello Risorse in Animate
  6. File multimediali e video
    1. Trasformazione e combinazione di oggetti grafici in Animate
    2. Creazione e utilizzo di istanze di simboli in Animate
    3. Ricalco immagine
    4. Come utilizzare l’audio in Adobe Animate
    5. Esportazione di file SVG
    6. Creare file video da utilizzare in Animate
    7. Come aggiungere un video in Animate
    8. Operazioni con i cue point video
    9. Disegnare e creare oggetti con Animate
    10. Rimodellare linee e forme
    11. Tratti, riempimenti e gradienti con Animate CC
    12. Utilizzo di Adobe Premiere Pro e After Effects
    13. Pannelli per il colore in Animate CC
    14. Apertura di file Flash CS6 con Animate
    15. Utilizzare il testo classico in Animate
    16. Inserimento di grafica in Animate
    17. Bitmap importate in Animate
    18. Grafica 3D
    19. Utilizzo dei simboli in Animate
    20. Disegnare linee e forme con Adobe Animate
    21. Utilizzare le librerie in Animate
    22. Esportazione di suoni
    23. Selezione degli oggetti in Animate CC
    24. Utilizzare i file AI di Illustrator in Animate
    25. Applicare pattern con lo strumento Pennello spray
    26. Applicazione di metodi di fusione
    27. Disposizione degli oggetti
    28. Automazione delle operazioni con il menu Comandi
    29. Testo in più lingue
    30. Utilizzo della funzione Videocamera di Animate
    31. Utilizzo di Animate con Adobe Scout
    32. Operazioni con file di Fireworks
    33. Filtri grafici
    34. Suono e ActionScript
    35. Preferenze di disegno
    36. Disegno con lo strumento Penna
  7. Piattaforme
    1. Convertire progetti Animate in altri formati di tipi di documenti
    2. Supporto piattaforme personalizzate
    3. Creare e pubblicare documenti HTML5 Canvas in Animate
    4. Creazione e pubblicazione di un documento WebGL
    5. Come creare pacchetti di applicazioni per AIR per iOS
    6. Pubblicazione di applicazioni AIR for Android
    7. Pubblicazione per Adobe AIR per desktop
    8. Impostazioni di pubblicazione ActionScript
    9. Procedure ottimali - Organizzazione del codice ActionScript in un’applicazione
    10. Come utilizzare ActionScript con Animate
    11. Best practice - Linee guida per l’accessibilità
    12. Accessibilità dell’area di lavoro di Animate
    13. Creazione e gestione di script
    14. Abilitazione del supporto per piattaforme personalizzate
    15. Panoramica di Supporto piattaforme personalizzate
    16. Creazione di contenuto accessibile
    17. Operazioni con i plug-in di Supporto piattaforme personalizzate
    18. Debug di ActionScript 3.0
    19. Abilitazione del supporto per piattaforme personalizzate
  8. Esportazione e pubblicazione
    1. Come esportare i file da Animate CC
    2. Pubblicazione OAM
    3. Esportazione di file SVG
    4. Esportazione di elementi grafici e video con Animate
    5. Pubblicazione di documenti AS3
    6. Esportare animazioni per dispositivi mobili e motori grafici
    7. Esportazione di suoni
    8. Esportare i file video QuickTime
    9. Controllo della riproduzione dei video esterni mediante ActionScript
    10. Best practice - Suggerimenti per la creazione di contenuti per dispositivi mobili
    11. Best practice - Convenzioni per i contenuti video
    12. Best practice - Linee guida per la creazione di applicazioni SWF
    13. Best practice - Strutturazione dei file FLA
    14. Best practice per ottimizzare i file FLA per Animate
    15. Impostazioni di pubblicazione ActionScript
    16. Specificare le impostazioni di pubblicazione per Animate
    17. Esportazione di file proiettore
    18. Esportare immagini e GIF animati
    19. Modelli di pubblicazione HTML
    20. Utilizzo di Adobe Premiere Pro e After Effects
    21. Condividere e pubblicare rapidamente le animazioni

Animate può essere esteso mediante estensioni HTML. Adobe Extension Builder 3 consente di creare estensioni HTML per Animate. In precedenza, era possibile estendere Animate solo con estensioni SWF. Tuttavia, Adobe Extension Builder 3 consente di creare estensioni HTML per le applicazioni Creative Cloud. Per iniziare, scaricate e installate Eclipse ed Extension Builder 3.0.

Creazione di un’estensione HTML

Per creare un’estensione HTML, effettuate le seguenti operazioni.

  1. Avviate Eclipse. 
  2. Nella procedura guidata New Project (Nuovo progetto), create un nuovo progetto Application Extension (Estensione applicazione). Immettete un nome per il progetto e fate clic su Next (Avanti).
  3. Nel pannello New Adobe Application Extension Project (Nuovo progetto estensione applicazione Adobe), scegliete Adobe Animate. Fate clic su Avanti.
  4. Configurate l’estensione mediante le opzioni disponibili:
    1. Bundle ID (ID bundle) identifica in modo univoco l’estensione.
    2. Menu name (Nome menu) è il nome che verrà visualizzato per l’estensione. Questo nome verrà usato nel menu Finestra > Estensioni di Animate.
    3. Window Details (Dettagli finestra): usate queste opzioni per personalizzare il tipo e le dimensioni della finestra dell’estensione.

      Fate clic su Next (Avanti).
  5. Potete personalizzare ulteriormente le librerie di riferimento dell’estensione nelle schermate che seguono:
    1. CEP Interface Library (Libreria di interfaccia CEP): questa libreria fornisce funzioni per l’interazione con l’applicazione host. Questa opzione è selezionata per impostazione predefinita.
    2. Frameworks (Framework): i framework vengono usati per librerie JavaScript condivise, come jQuery.
    3. Services (Servizi): i servizi includono Adobe IPC Communication Toolkit, che abilita la comunicazione tra le applicazioni Adobe, le estensioni e le applicazioni esterne. Fornisce un protocollo per la gestione dei messaggi tramite CEP Service Manager, che funge da centralina per le comunicazioni Creative Cloud.

      Fate clic su Finish (Fine) per creare un nuovo progetto Eclipse.

Debug dell’estensione in Animate

Potete eseguire l’estensione direttamente da Eclipse:

  1. Fate clic con il pulsante destro del mouse sul progetto e selezionate Esegui come > Estensione Adobe Flash. Viene avviato Animate.
  2. In Animate selezionate la voce di menu Finestra > Estensioni . Viene aperto il pannello delle estensioni.

Esportazione dell’estensione

Per distribuire l’estensione, è necessario esportarla come pacchetto ZXP. Il pacchetto ZXP viene quindi scaricato ed eseguito da Adobe Extension Manager nelle applicazioni Creative Cloud:

  1. In Eclipse, passate alla vista Script Explorer. Fate clic con il pulsante destro del mouse sul progetto e selezionate Export > Adobe Extension Builder 3 > Application Extension (Esporta > Adobe Extension Builder 3 > Estensione applicazione). Viene visualizzata la procedura di esportazione guidata.
  2. È necessario disporre di un certificato per firmare il pacchetto dell’estensione. Individuate un certificato oppure fate clic su Create (Crea) per crearne uno nuovo.
  3. Fate clic su Finish (Fine).
  4. Al termine dell’esportazione, il pacchetto ZXP dell’estensione si trova nella cartella del progetto ed è pronto per la distribuzione.

Nota: per l’installazione è necessario accedere al file <extension>\.staged-extension\CSXS\manifest.xml e aggiornare il tag host impostando la versione minima di Animate su 13.0.

Installazione dell’estensione in Animate

Potete installare le estensioni HTML in Animate mediante Adobe Extension Manager. Con le estensioni HTML è possibile estendere le funzionalità di Animate.

Aggiunta di interattività alle estensioni HTML

È possibile creare un’estensione HTML che interagisca con Animate aggiungendo dei controlli e definendone il comportamento e ottenere informazioni sull’ambiente host (inclusi Animate e il sistema operativo). Questo può essere effettuato in due modi:

  1. Utilizzando la libreria di interfaccia CEP: la libreria di interfaccia CEP fornisce le API necessarie per ottenere informazioni sull’ambiente host e uno script eval che consente di eseguire gli script JSFL. Per ulteriori informazioni sulla libreria di interfaccia CEP, aprite Help > Help Contents > Adobe Extension Builder > References (Aiuto > Contenuti Aiuto > Adobe Extension Builder > riferimenti) in Eclipse.
  2. Utilizzando script JSFL: gli script JSFL possono essere eseguiti mediante lo script eval API della libreria di interfaccia CEP.

    Oltre agli script JSFL, l’infrastruttura CEP in Animate espone i seguenti eventi che possono essere utilizzati solo nei pannelli HTML.
    • com.adobe.events.flash.documentChanged viene attivato in seguito a una modifica nel documento attivo corrente.
    • com.adobe.events.flash.timelineChanged viene attivato in seguito a una modifica nella linea temporale del documento attivo corrente.
    • com.adobe.events.flash.documentSaved viene attivato quando si salva il documento corrente.
    • com.adobe.events.flash.documentOpened viene attivato quando si apre un nuovo documento.
    • com.adobe.events.flash.documentClosed viene attivato quando si chiude il documento attivo corrente.
    • com.adobe.events.flash.documentNew viene attivato quando si crea un nuovo documento.
    • com.adobe.events.flash.layerChanged viene attivato quando si seleziona un altro livello.
    • com.adobe.events.flash.frameChanged viene attivato quando si seleziona un altro fotogramma.
    • com.adobe.events.flash.selectionChanged viene attivato quando si seleziona un altro oggetto sullo stage.
    • com.adobe.events.flash.mouseMove viene attivato quando si sposta il mouse sullo stage.

Esempio

csinterface.addEventListener(&quot;com.adobe.events.flash.selectionChanged&quot;, CallbackFunction)

Nello snippet di codice precedente:

  • csinterface: oggetto della libreria di interfaccia CEP.
  • com.adobe.events.flash.selectionChanged: evento che attiva una modifica nella selezione di un oggetto. È possibile utilizzare anche uno qualsiasi degli eventi precedentemente descritti.
  • CallbackFunction: metodo in ascolto dell’evento attivato.
Logo Adobe

Accedi al tuo account