Creare istanze

Dopo aver creato un simbolo, potete creare istanze del simbolo in qualsiasi punto del documento, anche all'interno di altri simboli. Quando si modifica il simbolo, Animate CC (già Flash Professional CC) aggiorna tutte le istanze di tale simbolo.

Potete assegnare un nome alle istanze nella finestra di ispezione Proprietà. Utilizzate il nome per fare riferimento all'istanza in ActionScript. Per controllare le istanze in ActionScript®, assegnate un nome univoco a ciascuna istanza di una linea temporale. 

Per specificare gli effetti di colore, assegnare azioni, impostare la modalità di visualizzazione grafica o modificare il comportamento delle nuove istanze, utilizzate la finestra di ispezione Proprietà. Il comportamento dell'istanza equivale al comportamento del simbolo a meno che non si specifichi diversamente. Le eventuali modifiche apportate sono relative soltanto all'istanza e non al simbolo.

Creare un'istanza di simbolo

  1. Selezionate un livello nella linea temporale. Animate può posizionare le istanze solo in fotogrammi chiave, sempre sul livello corrente. Se non si seleziona un fotogramma chiave, Animate aggiunge l'istanza al primo fotogramma chiave a sinistra del fotogramma corrente.

    Nota:

    un fotogramma chiave è un fotogramma nel quale è possibile apportare una modifica all'animazione. Per maggiori informazioni, vedete Inserire fotogrammi nella linea temporale.

  2. Selezionate Finestra > Libreria.

  3. Trascinate l'elemento dalla libreria sullo stage.

  4. Se avete creato un'istanza di un simbolo grafico, selezionate Inserisci > Linea temporale > Fotogramma per aggiungere il numero di fotogrammi che conterranno il simbolo grafico.

Assegnare un nome personalizzato a un'istanza

  1. Selezionate l'istanza sullo stage.

  2. Selezionate Finestra > Proprietà e immettete un nome di istanza nella casella Nome istanza.

Modifica delle proprietà delle istanze

Ogni istanza presenta delle proprietà specifiche distinte dal simbolo. Potete cambiare la tinta, la trasparenza e la luminosità di un'istanza, ridefinitene il comportamento (ad esempio, trasformate un'immagine in un clip filmato) e specificate la modalità di riproduzione dell'animazione all'interno dell'istanza di un'immagine. Potete inoltre inclinare, ruotare o modificare in scala un'istanza senza modificare il simbolo.

Inoltre, potete assegnare un clip filmato o unistanza di pulsante, in modo da poter utilizzare il linguaggio ActionScript per modificarne le proprietà. Per ulteriori informazioni, consultate Objects and classes (Oggetti e classi) nella guida all’apprendimento di ActionScript 3.0. Per modificare le proprietà di un'istanza, utilizzate la finestra di ispezione Proprietà (Finestra > Proprietà).

Le proprietà di un'istanza vengono salvate insieme a essa. Se modificate un simbolo o ricollegate un'istanza a un simbolo diverso, le proprietà dell'istanza modificate rimangono valide per l'istanza.

Impostare la visibilità di un’istanza

Potete rendere invisibile un'istanza di simbolo sullo stage disattivando la proprietà Visible. L'utilizzo della proprietà Visible consente di ottenere prestazioni di rendering migliori rispetto all'impostazione della proprietà Alpha del simbolo su 0.

La proprietà Visible richiede l'impostazione del lettore su Flash Player 10.2 o versione successiva ed è compatibile solo con istanze di clip filmato, pulsanti e componenti.

  1. Selezionate l'istanza sullo stage.

  2. Nella sezione Visualizza del pannello Proprietà deselezionate la proprietà Visible.

Modificare il colore e la trasparenza di un'istanza

Ogni istanza di un simbolo può avere il suo effetto colore. Per impostare le opzioni relative al colore e alla trasparenza delle istanze, utilizzate la finestra di ispezione Proprietà. Le impostazioni contenute in tale finestra di dialogo hanno effetto anche sulle bitmap contenute nei simboli.

Quando si modificano il colore e la trasparenza per un'istanza in un fotogramma specifico, Animate applica le modifiche non appena visualizza il fotogramma. Per apportare modifiche graduali al colore, applicate un'interpolazione di movimento. Quando effettuate un'interpolazione del colore, dovete immettere diverse impostazioni di effetti nei fotogrammi chiave iniziale e finale di un'istanza, quindi interpolare le impostazioni per cambiare gradualmente i colori dell'istanza.

sy_tint_tween
sy_alpha_tween
L'interpolazione cambia gradualmente il colore o la trasparenza di un'istanza.

Nota:

Se si applica un effetto colore al simbolo di un clip filmato con più fotogrammi, tale effetto viene applicato a ogni fotogramma contenuto nel simbolo del clip filmato.

  1. Selezionate l'istanza sullo stage, quindi selezionate Finestra > Proprietà.
  2. Nella finestra di ispezione Proprietà, selezionate una delle opzioni seguenti dal menu Stile nella sezione Effetto colore:

    Luminosità

    Regola la luminosità dell'immagine, misurata su una scala da nero (-100%) a bianco (100%). Per regolare la luminosità, fate clic sul triangolo e trascinate il cursore oppure immettete un valore nella casella.

    Tinta

    Colora l'istanza con la stessa tonalità. Utilizzate il cursore Tinta nella finestra di ispezione Proprietà per impostare la percentuale della tinta su un valore compreso tra 0% (trasparente) e 100% (completamente satura). Per regolare la tinta, fate clic sul triangolo e trascinate il cursore oppure immettete un valore nella casella. Per selezionare un colore, immettete i valori RGB (rosso, verde, blu) nelle rispettive caselle oppure fate clic sul controllo dei colori e selezionate un colore dal selettore Colore.

    Alfa

    Regola la trasparenza dell'istanza, da trasparente (0%) a completamente satura (100%). Fate clic sul triangolo e trascinate il cursore oppure immettete un valore nella casella per regolare il valore dell'effetto Alfa.

    Avanzate

    Regola separatamente i valori RGB (rosso, verde, blu) e la trasparenza di un'istanza. Questa opzione è molto utile per creare e animare lievi effetti di colore su oggetti come le bitmap. I comandi a sinistra consentono di ridurre i valori di colore o trasparenza di una determinata percentuale. I comandi a destra consentono di ridurre o aumentare i valori di colore o trasparenza di un valore costante.

    I valori RGB correnti (rosso, verde, blu) e alfa vengono moltiplicati per i valori percentuali, quindi aggiunti ai valori costanti nella colonna destra, producendo i valori dei nuovi colori. Ad esempio, se il valore corrente del rosso è 100, impostando il cursore sinistro su 50% e il cursore destro su 100% si produce un nuovo valore di rosso pari a 150 ([100 x 0,5] + 100 = 150). 

    Nota: le impostazioni Avanzate del pannello Effetto consentono di implementare la funzione (a * y+ b)= x in cui a indica la percentuale specificata nel gruppo di caselle di testo a sinistra, y il colore della bitmap originale, b il valore specificato nel gruppo di caselle a destra e x l'effetto finale (tra 0 e 255 per RGB e 0 e 100 per la trasparenza alfa).

    Potete anche modificare il colore di un'istanza utilizzando l'oggetto ColorTransform di ActionScript. Per informazioni dettagliate sull'oggetto Color, vedete ColorTransform nella Guida di riferimento di ActionScript 2.0 o nella Guida di riferimento dei componenti ActionScript 3.0.

Scambiare istanze

Per visualizzare un’istanza diversa sullo stage e mantenere tutte le proprietà di quella originale, come effetti di colore e azioni dei pulsanti, assegnate allistanza un simbolo diverso.

Supponiamo ad esempio che volete creare un cartone utilizzando per un personaggio il simbolo di un topo. Successivamente, però, decidete di cambiare questo personaggio in un gatto. Potete sostituire il simbolo del topo con il simbolo del gatto, e quest’ultimo viene visualizzato in tutti i fotogrammi più o meno nella stessa posizione del personaggio precedente.

Assegnare un simbolo diverso a un'istanza

  1. Selezionate l'istanza sullo stage, quindi selezionate Finestra > Proprietà.

  2. Nella finestra di ispezione Proprietà, fate clic sul pulsante Scambia.

  3. Selezionate un simbolo da sostituire a quello attualmente assegnato all'istanza. Per duplicare un simbolo selezionato, fate clic su Duplica simbolo e fate clic su OK.

    La duplicazione consente di basare un nuovo simbolo su un simbolo esistente nella libreria e di semplificare l'operazione di copia se create numerosi simboli che differiscono leggermente.

Sostituire tutte le istanze di un simbolo

  1. Trascinate un simbolo con lo stesso nome di quello che state sostituendo da un pannello Libreria al pannello Libreria del file FLA che state modificando, quindi fate clic su Sostituisci. Se la libreria contiene della cartelle, il nuovo simbolo deve essere trascinato nella stessa cartella del simbolo da sostituire.

Modificare il tipo di un'istanza

Per ridefinire il comportamento di un'istanza in un'applicazione Animate, cambiatene il tipo. Ad esempio, se l'istanza di un'immagine contiene un'animazione che desiderate riprodurre indipendentemente dalla linea temporale principale, ridefinitela come istanza di clip filmato.

  1. Selezionate l'istanza sullo stage, quindi selezionate Finestra > Proprietà.
  2. Selezionate Grafico, Pulsante o Clip filmato dal menu della finestra di ispezione Proprietà.

Impostare la ripetizione ciclica per un'istanza di immagine

Per determinare come vengono riprodotte le sequenze di un'animazione nell'istanza di un'immagine nell'applicazione Animate, impostate le opzioni appropriate nella finestra di ispezione Proprietà.

Il simbolo grafico animato è collegato alla linea temporale del documento in cui è posizionato il simbolo. Il simbolo di un clip filmato invece è dotato di una propria linea temporale indipendente. Poiché i simboli grafici animati utilizzano la stessa linea temporale del documento principale, essi visualizzano la propria animazione in modalità di modifica del documento. I simboli di clip filmato invece vengono visualizzati come oggetti statici sullo stage e non come animazioni nell'ambiente di editing di Animate.

  1. Selezionate un'istanza di immagine sullo stage, quindi selezionate Finestra > Proprietà.
  2. Selezionate un'opzione di animazione dal menu Opzioni nella sezione Ripetizione ciclica della finestra di ispezione Proprietà:

    Ciclo

    Ripete ciclicamente la sequenza di animazione contenuta nell'istanza corrente per tutti i fotogrammi occupati dall'istanza.

    Riproduci una volta

    Riproduce la sequenza di animazione a partire dal fotogramma specificato fino alla fine dell'animazione, quindi interrompe la riproduzione.

    Fotogramma singolo

    Visualizza un fotogramma della sequenza di animazione. Specificate quale fotogramma visualizzare.

  3. Per specificare il primo fotogramma del simbolo grafico da visualizzare quando applicate la ripetizione ciclica, immettete un numero di fotogramma nella casella di testo Primo. Anche l'opzione Fotogramma singolo utilizza il numero di fotogramma specificato in questa casella.

Selettore fotogramma

Il selettore Fotogrammi offre un'anteprima visiva e permette di scegliere il primo fotogramma per un simbolo grafico. Nelle versioni precedenti, non era possibile visualizzare in anteprima i fotogrammi senza entrare all’interno del simbolo in modalità Modifica. Questa funzione migliora l’esperienza dell'utente per i flussi di lavoro di animazione, come ad esempio la sincronizzazione labiale.

Nota:

il pannello Selettore fotogramma funziona solo con i simboli grafici ed è disattivato per simboli di tipo pulsante o clip filmato. Prima di usare questa funzione, accertatevi di aver convertito le risorse in simboli.

  1. Selezionate un simbolo grafico; nel Pannello Proprietà, nella sezione Ripetizione continua, selezionate il pulsante Usa selettore fotogramma per visualizzare il pannello Selettore fotogramma oppure selezionate Finestra > Selettore fotogramma

    Frame Picker_ PI
    Selettore fotogramma

  2. Nel pannello Selettore fotogramma, selezionate la vista Elenco o Miniature per visualizzare tutte le anteprime del fotogramma del simbolo selezionato. È inoltre possibile visualizzare i numeri di fotogramma e le relative etichette. 

    Elenco presenta i fotogrammi sotto forma di elenco verticale. 

    Miniature presenta i fotogrammi in una vista griglia che si adatta se si ridimensiona il pannello. 

    Crea fotogramma chiave consente di creare automaticamente un fotogramma chiave quando si seleziona una posizione dal pannello Selettore fotogramma. 

    Ripetizione ciclica visualizza le opzioni di ciclo continuo per la grafica, come Ripetizione ciclica, Riproduzione singola e Fotogramma singolo. 

    La freccia del cursore consente di regolare la dimensione dell’anteprima.

    Il pulsante a sinistra del cursore consente di far rientrare più fotogrammi nella vista.

    Il pulsante a destra del cursore riduce il numero di fotogrammi nella vista.

    Il menu a discesa delle opzioni per filtrare i fotogrammi presenta varie opzioni con cui filtrare i fotogrammi.

    list
    Vista elenco

    thumnail
    Vista miniature


  3. Usate il cursore o i pulsanti di zoom per regolare le dimensioni dell’anteprima o delle miniature. Regolate il cursore spostandolo verso sinistra nel pannello per visualizzare più fotogrammi. Se spostate il cursore verso destra, le anteprime diventano più grandi.

  4. Fate clic su un qualsiasi fotogramma per impostarlo come primo fotogramma del simbolo selezionato.

Crea fotogramma chiave

Nel pannello Selettore fotogramma, la casella di controllo Crea fotogramma chiave consente di creare automaticamente dei fotogrammi chiave quando si seleziona un fotogramma nello stesso pannello. Inoltre, è possibile impostare l’opzione di ripetizione ciclica dei simboli grafici direttamente nel pannello Selettore fotogramma.

Per accedere al pannello Selettore fotogramma, selezionate un simbolo grafico e nel pannello Proprietà, nella sezione Ripetizione ciclica, selezionate il pulsante Usa selettore fotogramma per visualizzare il Selettore fotogramma oppure selezionate Finestra > Selettore fotogramma.

CreateKeyframe

Opzioni per filtrare i fotogrammi

Animate offre alcune opzioni con cui è possibile filtrare i fotogrammi elencati nel pannello. Potete scegliere di filtrare in base a: 

  • Tutti i fotogrammi: vengono visualizzati tutti i fotogrammi.
  • Fotogrammi chiave: vengono visualizzati solo i fotogrammi chiave che avete selezionato.
  • Etichette: vengono visualizzati solo i fotogrammi a cui sono state assegnate delle etichette.
filterOptions

Sincronizzazione labiale automatica

La sincronizzazione labiale automatica offre il metodo più semplice e rapido per posizionare le forme della bocca appropriate sulla linea temporale, in base al livello audio selezionato. Potete ottenere questo effetto con l'elenco esistente delle posizioni labiali, disegnate all'interno di un simbolo grafico. Applicando la sincronizzazione labiale automatica a un simbolo grafico, dopo l'analisi del livello audio specificato si creano automaticamente dei fotogrammi chiave corrispondenti ai visemi audio in diverse posizioni. Una volta completata l'operazione, potete apportare ulteriori modifiche secondo necessità con i normali flussi di lavoro e il Selettore fotogramma.

Un visema è un'immagine generica del volto che può essere utilizzata per indicare un suono. 

Creazione della sincronizzazione labiale

Per iniziare a creare una sincronizzazione labiale, seguite i passaggi riportati di seguito:

  1. Create un simbolo grafico (espressione bocca).

    All'interno del simbolo grafico potete tracciare qualsiasi posizione labiale o visema.

  2. Nella linea temporale principale, importate un file audio nel nuovo livello.

    Nota:

    La sincronizzazione labiale automatica funziona meglio se l’impostazione di sincronizzazione audio è impostata su Flusso.

    Simbolo di esempio con il livello audio
    Simbolo di esempio con il livello audio
  3. Selezionate il simbolo grafico per la bocca. Nella finestra di ispezione delle proprietà, fate clic su Sincronizzazione labiale.

    Sincronizzazione labiale nella finestra di ispezione Proprietà
    Sincronizzazione labiale nella finestra di ispezione Proprietà

    Viene visualizzata la finestra di dialogo Crea sincronizzazione labiale. Per impostazione predefinita, vengono visualizzati i 12 visemi base come mostrato nella schermata di seguito:

    Crea sincronizzazione labiale
    Crea sincronizzazione labiale
  4. Per modificare la posizione della bocca, fate clic su un visema qualsiasi. Viene visualizzata una finestra a comparsa con tutte le posizioni presenti all'interno del simbolo grafico. Selezionate il fotogramma appropriato dalla finestra a comparsa per impostarla per visema corrente.

    Modifica della posizione labiale per ciascun visema
    Modifica della posizione labiale per ciascun visema
  5. Selezionate il livello audio con cui sincronizzare il labiale. Fate clic sul pulsante Sincronizza.

    Schermata della linea temporale in seguito all'applicazione della sincronizzazione labiale
    Schermata della linea temporale in seguito all'applicazione della sincronizzazione labiale

    Nota:

    La sincronizzazione labiale automatica viene applicato ai fotogrammi in cui è presente il simbolo grafico selezionato. Potete anche selezionare prima più fotogrammi chiave per applicare la sincronizzazione labiale nell’intervallo di fotogrammi selezionato.

  6. Per eseguire il file e visualizzare l'output in anteprima, premete Ctrl + Invio.

    Potete visualizzare il file animato con i movimenti labiali generati automaticamente e in sincronia con il file audio.

Dividere un'istanza di simbolo

Per spezzare il collegamento tra un’istanza e un simbolo e trasformare l’istanza in una raccolta di forme e linee non raggruppate, dovete dividere l’istanza. Questa funzione è utile per cambiare in modo sostanziale l’istanza senza conseguenze per le altre istanze. 

Le modifiche apportate al simbolo di origine di un'istanza non influiscono sull'istanza dopo che è stata divisa.

  1. Selezionate l'istanza sullo stage.
  2. Selezionate Elabora > Dividi. In questo modo l'istanza viene suddivisa nei suoi elementi grafici costitutivi.
  3. Per modificare questi elementi, utilizzate gli strumenti di colorazione e disegno.

Ottenere informazioni sulle istanze nello stage

La finestra di ispezione Proprietà e il pannello Informazioni visualizzano le seguenti informazioni sulle istanze selezionate sullo stage:

  • Nella finestra di ispezione Proprietà potete visualizzare il comportamento e le impostazioni di un'istanza. Per tutti i tipi di istanza sono visualizzate le impostazioni degli effetti di colore, la posizione e le dimensioni; per la grafica, la finestra visualizza la modalità di ripetizione ciclica e il primo fotogramma che contiene la grafica; per i pulsanti, potete visualizzare il nome di istanza (se assegnato) e l'opzione di tracciamento; per i clip filmato, infine, viene visualizzato il nome di istanza (se assegnato). Per la posizione, la finestra di ispezione Proprietà mostra le coordinate x e y del punto di registrazione del simbolo.

  • Il pannello Informazioni visualizza le dimensioni e la posizione dell’istanza, la posizione del relativo punto di registrazione, i valori RGB (rosso, verde e blu) e Alfa (se l’istanza ha un riempimento di colore uniforme), nonché la posizione del puntatore. La sezione Posizione e dimensioni della finestra di ispezione Proprietà visualizza le coordinate x e y del punto di registrazione del simbolo oppure del punto di trasformazione. Potete alternare tra i due tipi di coordinate.

  • In Esplora filmato, visualizzate il contenuto del documento corrente, compresi i simboli e le istanze.

    Visualizzate le eventuali azioni assegnate a un pulsante o a un filmato nel pannello Azioni.

Visualizzare informazioni su un'istanza

  1. Selezionate l'istanza sullo stage.

  2. Visualizzate la finestra di ispezione Proprietà (Finestra > Proprietà) o il pannello da utilizzare.

    • Per visualizzare il pannello Informazioni, selezionate Finestra > Informazioni.

    • Per visualizzare Esplora filmato, selezionate Finestra > Esplora filmato.

    • Per visualizzare il pannello Azioni, selezionate Finestra > Azioni.

Visualizzare la definizione del simbolo selezionato in Esplora filmato

  1. Fate clic sul pulsante Mostra i pulsanti, i clip filmato e i grafici nella parte superiore di Esplora filmato.

  2. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto Ctrl (Macintosh) e selezionate Mostra definizioni simboli e Vai alla definizione del simbolo; in alternativa, selezionate queste opzioni dal menu nell'angolo superiore destro della finestra Esplora filmato.

Passare alla scena che contiene le istanze di un simbolo selezionato

  1. Visualizzate le definizioni del simbolo.

  2. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto Ctrl (Macintosh) e selezionate Mostra elementi filmato e Vai alla definizione del simbolo; in alternativa, selezionate queste opzioni dal menu nell'angolo superiore destro della finestra Esplora filmato.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online