File Animate

In Animate potete utilizzare numerosi tipi di file diversi, ciascuno dei quali ha uno scopo specifico:

  • I file FLA sono i file principali che vengono elaborati in Animate e includono i contenuti multimediali di base, la linea temporale e gli script di un documento Animate. Gli oggetti multimediali sono gli oggetti grafici, di testo, audio e video che costituiscono il contenuto del documento Animate. La linea temporale è l'area di Animate che consente di specificare quando i singoli oggetti multimediali devono essere visualizzati sullo stage. Potete aggiungere codice ActionScript® ai documenti Animate per controllarne con maggiore precisione il comportamento e consentire l'interazione con gli utenti.

  • I file XFL non compressi sono simili ai file FLA. Un file XFL e gli altri file associati all'interno della stessa cartella, sono semplicemente l'equivalente non compresso di un file FLA. Questo formato consente a gruppi di utenti di lavorare contemporaneamente su diversi elementi di un progetto Animate. Per ulteriori informazioni, vedete Operazioni con i file XFL non compressi.

  • I file SWF sono file FLA in versione compilata e vengono visualizzati in una pagina Web. Quando si pubblica un file FLA, Animate lo trasforma in un file SWF.

    Il formato SWF di Animate è uno standard aperto supportato da altre applicazioni. Per ulteriori informazioni sui formati dei file Animate, consultate www.adobe.com/go/flashplayer_it.

  • I file AS sono file ActionScript che potete utilizzare per tenere una parte o tutto il codice ActionScript al di fuori dei file FLA. Sono utili per organizzare il codice e per i progetti in cui più persone lavorano a parti diverse del contenuto Animate.

  • I file SWC contengono i componenti Animate riutilizzabili. Ogni file SWC contiene un clip filmato compilato, il codice ActionScript e tutte le altre risorse richieste dal componente. Nota: non è possibile importare file SWC in Animate.
  • I file ASC sono usati per archiviare il codice ActionScript che verrà eseguito su un computer nel quale è in esecuzione Adobe Media Server; questi file offrono la possibilità di implementare la logica server-side che funziona assieme ad ActionScript nei file SWF. Nota: i file ASC non sono supportati in Animate.
  • I file JSFL sono file JavaScript che consentono di aggiungere nuove funzionalità allo strumento di creazione Animate.
  • I file APR consentono di integrare il modello di pubblicazione Canvas con le rispettive impostazioni dei profili di pubblicazione. In futuro, ogni nuova risorsa collegata a un profilo di pubblicazione sarà anch’essa raggruppata e condivisa. Per ulteriori informazioni, vedete Impostazioni di pubblicazione.

 

Cos’è Animate?

Cos’è Animate?
Adobe

Questa esercitazione spiega lavorare con Animate/Flash Pro.

Operazioni con altre applicazioni Adobe

Animate è stato progettato per funzionare in combinazione con altre applicazioni Adobe®, in modo da consentire una vasta gamma di flussi di lavoro. Potete importare file di Illustrator® e Photoshop® direttamente in Animate. Potete anche creare un video in Animate e modificarlo in Adobe® Premiere® Pro o After Effects® oppure importare video da una di queste applicazioni in Animate. Quando pubblicate i file SWF, potete utilizzare Dreamweaver® per incorporare il contento in pagine Web e lanciare Animate direttamente da Dreamweaver per modificare il contenuto.

Apertura di file XFL

A partire da Animate, XFL è il formato interno dei file FLA che create. Quando salvate un file in Animate, il formato predefinito è FLA, ma internamente all'applicazione il formato del file è XFL.

Altre applicazioni Adobe®, ad esempio After Effects®, possono esportare i file in formato XFL. Questi file hanno l'estensione XFL anziché FLA. InDesign® consente di esportare direttamente nel formato FLA, che internamente è XFL. In questo modo potete iniziare a lavorare a un progetto in After Effects o InDesign e quindi proseguire in Animate.

Potete aprire e utilizzare i file XFL in Animate come i file FLA. Quando aprite un file XFL in Animate, potete salvarlo come file FLA oppure come file XFL non compresso.

Per aprire un file XFL in Animate:

  1. In un'applicazione Adobe® diversa, ad esempio InDesign o After Effects, esportate il lavoro come file XFL.

    Tutti i livelli e gli oggetti del file originale vengono mantenuti nel file XFL.

  2. In Animate scegliete File > Apri e passate al file XFL. Fate clic su Apri.

    Il file XFL si apre in Animate come un file FLA. Tutti i livelli del file originale sono visualizzati nella linea temporale, mentre gli oggetti originali sono visualizzati nel pannello Libreria.

    Potete ora lavorare normalmente sul file.

  3. Per salvare il file, scegliete File > Salva.

    Animate richiede di assegnare un nome al nuovo file FLA nella finestra di dialogo Salva con nome.

  4. Digitate un nome e salvate il file FLA.

Operazioni con i file XFL non compressi

A partire da Animate, potete scegliere di lavorare con i file Animate nel formato XFL non compresso. Questo formato consente di vedere tutte le parti distinte (sotto-file) che compongono il file Animate. Le parti sono:

  • Un file XML che descrive il file Animate a livello generale.

  • FIle XML separati che descrivono ciascuno un simbolo della libreria.

  • Altri file XML contenenti impostazioni di pubblicazione, impostazioni per dispositivi mobili e di altro tipo.

  • Cartelle contenenti risorse esterne, ad esempio file bitmap, utilizzate dal file Animate.

Utilizzando il formato XFL non compresso, potete fare in modo che persone diverse lavorino separatamente sulle varie parti del file Animate. Inoltre potete utilizzare un sistema di controllo delle versioni per gestire le modifiche apportate a ogni sotto-file del file XFL non compresso. Queste possibilità permettono una migliore e più semplice collaborazione nell'ambito dei progetti di grandi dimensioni che prevedono l'intervento di più designer e sviluppatori.

Uso dell'aggiornamento in tempo reale con i file XFL

Utilizzando l'aggiornamento in tempo reale delle risorse modificabili per i documenti XFL non compressi, potete modificare qualunque risorsa della libreria da un documento XFL non compresso mentre il documento è aperto in Animate. Le modifiche che apportate alla risorsa vengono riportate in Animate quando finite di modificare la risorsa in un'altra applicazione.

Per modificare una risorsa da un documento XFL non compresso in un'altra applicazione:

  1. Salvate un documento Animate nel formato XFL non compresso.

  2. In un editor appropriato, ad esempio Photoshop, aprite la risorsa che volete modificare dalla cartella LIBRARY del documento XFL non compresso.

  3. Modificate la risorsa e salvate le modifiche.

  4. Tornate a Animate.

    La risorsa viene aggiornata immediatamente in Animate.

Modifica di un file SWF con Animate in Dreamweaver 

Se avete installato sia Animate che Dreamweaver, potete selezionare un file SWF in un documento Dreamweaver e utilizzare Animate per modificarlo. In Animate non viene modificato direttamente il file SWF, bensì il documento di origine (file FLA), quindi il file SWF viene esportato nuovamente.

  1. In Dreamweaver, aprite la finestra di ispezione Proprietà (Finestra > Proprietà).
  2. Nel documento di Dreamweaver, effettuate una delle seguenti operazioni:
    • Selezionate il file SWF facendo clic sul suo segnaposto, quindi fate clic su Modifica nella finestra di ispezione Proprietà.

    • Fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Ctrl (Mac OS) sul file SWF e, dal menu di scelta rapida, selezionate Modifica con Animate.

      Dreamweaver attiva Animate, che prova a individuare il file di authoring di Flash (FLA) relativo al file SWF selezionato. Se Animate non è in grado di trovare il file di authoring di Flash, viene richiesto di specificarne il percorso.

      Nota: se il file FLA o SWF è bloccato, controllate il file in Dreamweaver.

  3. In Animate, modificate il file FLA. Nella finestra Documento di Animate viene indicato che state modificando il file dall’interno di Dreamweaver.

  4. Al termine delle modifiche, fate clic su Fine.

    Il file FLA viene aggiornato e riesportato come file SWF; Animate si chiude e viene visualizzato nuovamente il documento Dreamweaver.

    Nota:

    per aggiornare il file SWF e tenere Animate aperto, in Animate selezionate File > Aggiorna per Dreamweaver.

  5. Per visualizzare il file aggiornato nel documento, fate clic su Riproduci nella finestra di ispezione Proprietà di Dreamweaver oppure premete F12 per visualizzare la pagina in anteprima in un browser.

Creare un nuovo documento

Mentre si lavora in Animate, è possibile creare un nuovo documento o aprire un documento salvato in precedenza. È anche possibile aprire una nuova finestra mentre si lavora. Le proprietà possono essere impostate per i documenti nuovi o per quelli esistenti.

Potete scegliere la destinazione dell’animazione usando uno dei vari intenti disponibili, Animate fornisce relativi i formati predefiniti. Scegliete un intento tra le schede nella parte superiore della schermata, ad esempio Animazione carattere, Social, Giochi, Istruzione, Pubblicità, Web e Avanzate.

Selezionate le impostazioni predefinite appropriate per ciascuno degli intenti e fate clic su Crea per iniziare a creare le animazioni. Potete visualizzare le risorse utilizzate di recente nel riquadro a sinistra. Le risorse campione sono fornite nella parte inferiore della schermata di avvio.

Launch-screen

Creazione di un nuovo documento

  1. Selezionate File > Nuovo.

    Nuovo documento
    Nuovo documento
  2. Scegliete un intento tra le schede nella parte superiore della schermata, ad esempio Animazione carattere, Social, Giochi, Istruzione, Pubblicità, Web e Avanzate.

  3. Selezionate le impostazioni predefinite appropriate per ciascuno degli intenti e fate clic su Crea.

    Potete anche scegliere le impostazioni per il documento. Vedete Impostare le proprietà per un documento nuovo o esistente.

Utilizzo dei diversi tipi di documento in Animate

In Animate, per convertire i documenti in diversi tipi (HTML5, WebGL, GLTF, 360 gradi, panoramica e così via) bastano un paio di clic. Per convertire i video da visualizzare su piattaforme diverse con diverse opzioni, seguite l’esercitazione riportata alla fine di questo esempio ed effettuate le seguenti operazioni.

  1. Nella pagina Home, fate clic sulla scheda Avanzate.

  2. Visualizzate le opzioni per utilizzare il documento su piattaforme diverse.

  3. Fate clic su File > Converti in e selezionate l’opzione desiderata.

Come utilizzare i diversi tipi di documento in Animate

Come utilizzare i diversi tipi di documento in Animate
Guardate questo video sulle caratteristiche di ciascuna funzionalità.

Creare un nuovo documento da un modello

  1. Scegliete File > Nuovo da modello.

    Finestra Nuovo da modello
    Finestra Nuovo da modello
  2. Selezionate una categoria nell'elenco Categoria e un documento nell'elenco Elementi della categoria, quindi fate clic su OK. Potete scegliere tra i modelli standard forniti con Animate o selezionare un modello che è stato precedentemente salvato.

Aprire un documento esistente

  1. Selezionate File > Apri.

  2. Nella finestra di dialogo Apri, individuate il file oppure immettete il percorso del file nella casella Vai a.
  3. Fate clic su Apri.

Visualizzare un documento quando sono aperti più documenti

Quando aprite più documenti, le schede nella parte superiore della finestra del documento identificano i documenti aperti e vi permettono di spostarvi con facilità da uno all'altro. Le schede sono visualizzate solo quando i documenti sono ingranditi al massimo nella finestra del documento.

  1. Fate clic sulla scheda del documento che desiderate visualizzare.

    Per impostazione predefinita, le schede sono visualizzate nell'ordine di creazione dei documenti. Non è possibile trascinare le schede del documento per modificarne l'ordine.

Aprire una nuova finestra per il documento corrente

  1. Selezionate Finestra > Duplica finestra.

Impostare le proprietà per un documento nuovo o esistente

  1. Con il documento aperto, selezionate Elabora > Documento.

    Viene visualizzata la finestra di dialogo Impostazioni documento.

  2. Per impostare e dimensioni dello stage, effettuate una delle seguenti operazioni:
    • Per specificare le dimensioni dello stage in pixel, immettete i valori nelle caselle Larghezza e Altezza. Le dimensioni minime sono 1 pixel x 1 pixel, quelle massime 2880 pixel x 2880 pixel.

    • Per fare in modo che le dimensioni dello stage corrispondano esattamente alla quantità di spazio utilizzata dal contenuto sullo stage, selezionate l'opzione Corrispondenza/Contenuto.

    • Per impostare le dimensioni dello stage sull'area di stampa massima disponibile, selezionate Corrispondenza/Stampante. Questa area è determinata dal formato carta da cui deve essere sottratto il valore del margine corrente impostato nell'area Margini della finestra di dialogo Impostazione pagina (Windows) o Margini di stampa (Macintosh).

    • Per impostare le dimensioni dello stage sul valore predefinito, 550x400 pixel, selezionate l’opzione per le impostazioni predefinite.

  3. Per specificare la frequenza fotogrammi, utilizzate l’opzione Frequenza fotogrammi.

    frame_rate
    Frequenza fotogrammi
  4. Per regolare la posizione e l'orientamento degli oggetti 3D sullo stage per mantenerne l'aspetto relativamente ai bordi dello stage, selezionate Correggi angolo prospettiva 3D per mantenere la proiezione corrente dello stage.

    Questa opzione è disponibile solo se modificate le dimensioni dello stage.

  5. (Solo CS5.5) Per ridimensionare automaticamente il contenuto dello stage relativamente alla modifica delle dimensioni dello stage, selezionate Ridimensiona contenuto con lo stage.

    Questa opzione è disponibile solo se modificate le dimensioni dello stage. Potete scegliere se ridimensionare il contenuto nei livelli bloccati e nascosti in Preferenze. Per ulteriori informazioni, vedete Impostare le preferenze generali.

  6. Per specificare l'unità di misura dei righelli visualizzati nell'area di lavoro, selezionate un'opzione dal menu Unità di misura righello. Questa impostazione definisce anche le unità usate nel pannello Informazioni.
  7. Per impostare il colore di sfondo del documento, fate clic sulla casella Colore sfondo e selezionate un colore dalla tavolozza.
  8. In Frequenza fotogrammi, immettete il numero di fotogrammi dell'animazione da visualizzare al secondo.

    Per la maggior parte delle animazioni visualizzate su computer, in particolare per quelle riprodotte da siti Web, sono sufficienti da 8 fotogrammi al secondo (fps) a 15 fps. Quando modificate la frequenza dei fotogrammi, la nuova frequenza diventa quella predefinita per i nuovi documenti.

  9. (Solo in CS5.5) Per salvare automaticamente il documento a intervalli di tempo prestabiliti, selezionate l'opzione Salvataggio automatico e specificate il numero di minuti tra un salvataggio e l'altro.
  10. Effettuate una delle seguenti operazioni:
    • Per applicare le nuove impostazioni solo al documento corrente, fate clic su OK.

    • Per utilizzare le nuove impostazioni come proprietà predefinite per tutti i nuovi documenti, fate clic su Impostazione predefinita.

Modificare le proprietà del documento mediante la finestra di ispezione Proprietà

  1. Fate clic nell'area di lavoro al di fuori dello stage per deselezionare tutti gli oggetti sullo stage. Le proprietà del documento vengono visualizzate nella finestra di ispezione Proprietà. Per aprire la finestra di ispezione Proprietà, scegliete (Finestra > Proprietà).
  2. (Solo CS5.5) Nella sezione Pubblica, scegliete una versione di Flash Player e di ActionScript per il documento. Per accedere a ulteriori impostazioni di pubblicazione, fate clic sul pulsante Impostazioni pubblicazione. Per ulteriori informazioni, vedete Impostazioni di pubblicazione.

  3. Nella sezione Proprietà, alla voce FPS (fotogrammi al secondo), immettete il numero di fotogrammi di animazione da riprodurre al secondo.
  4. Per cambiare le dimensioni dello stage, immettete i valori desiderati nelle caselle Larghezza e Altezza.
  5. Per impostare un colore di sfondo per lo stage, fate clic sulla casella del colore accanto alla proprietà Stage e selezionate un colore dalla tavolozza.
  6. Per modificare ulteriori proprietà del documento, fate clic sul pulsante Modifica accanto alle proprietà Dimensione. Per ulteriori informazioni su tutte le proprietà del documento, vedete Impostare le proprietà per un documento nuovo o esistente.

Animate CC è un’applicazione intuitiva che offre diversi componenti. Per capire come usare l’interfaccia e gli strumenti di base di Animate, seguite l’esercitazione riportata alla fine di questo esempio ed effettuate le seguenti operazioni.

Aggiungere metadati XMP a un documento

Nei file FLA potete includere dati Extensible Metadata Platform (XMP) quali titolo, autore, descrizione, copyright e altro ancora. XMP è un formato di metadati supportato da alcune altre applicazioni Adobe®. I metadati sono visualizzabili in Animate e in Adobe® Bridge. Per ulteriori informazioni sui metadati XMP, vedete Metadata and Keywords (Metadati e parole chiave) nella Guida di Bridge.

Nota: Bridge a 32 bit non è supportato in Adobe Animate.

L'incorporamento dei metadati consente di incrementare la possibilità da parte dei motori di ricerca basati su Web di restituire risultati significativi relativamente al contenuto Animate. I metadati di ricerca si basano sulle specifiche XMP (Extensible Metadata Platform) e sono archiviati nel file FLA in formato compatibile con W3C.

Nei metadati di un file sono contenute informazioni relative a contento stato del copyright, origine cronologia del file. Nella finestra di dialogo Info sul file potete visualizzare e modificare i metadati per il file corrente.

A seconda del file selezionato, possono essere visualizzati i seguenti tipi di metadati:

Descrizione

Contiene autore, titolo, copyright e altre informazioni.

IPTC

Visualizza i metadati modificabili. Potete aggiungere didascalie ai file, oltre a informazioni sul copyright. IPTC Core è una specifica approvata da IPTC (International Press Telecommunications Council) nell'ottobre 2004. Differisce dalla precedente specifica IPTC (in precedenza IIM) per il fatto che sono state aggiunte nuove proprietà, è stato modificato il nome di alcune proprietà e sono state eliminate alcune proprietà.

Dati fotocamera (Exif)

Visualizza le informazioni assegnate dalle fotocamere digitali, incluse le impostazioni usate dalla fotocamera al momento dell'acquisizione dell'immagine.

Dati video

Visualizza i metadati per i file video, inclusi rapporto proporzionale dei pixel, scena e scatto.

Dati audio

Visualizza i metadati per i file audio, inclusi artista, album, numero del brano e genere.

SWF mobile

Elenca le informazioni sui file SWF, inclusi titolo, autore, descrizione e copyright.

Cronologia

Mantiene un registro delle modifiche apportate alle immagini con Photoshop.

Nota: per consentire il salvataggio del registro con i metadati del file, le preferenze del registro cronologia devono essere attivate in Photoshop.

Version Cue

Elenca le eventuali informazioni sulla versione del file di Version Cue.

DICOM

Visualizza le informazioni sulle immagini salvate nel formato DICOM (Digital Imaging and Communications in Medicine).

Per aggiungere i metadati:

  1. Scegliete File > Info file.
  2. Nella finestra di dialogo Informazioni file visualizzata, immettete i metadati che desiderate includere. Potete aggiungere o rimuovere i metadati nel file FLA in qualsiasi momento.

Salvataggio di documenti Animate

Un documento Animate di tipo FLA può essere salvato utilizzando il nome e il percorso correnti oppure specificando un nome o un percorso diversi.

Se un documento contiene modifiche che non sono state salvate, un asterisco (*) viene visualizzato dopo il nome del documento nella barra del titolo del documento, nella barra del titolo dell'applicazione e nella scheda del documento. Una volta che il documento è stato salvato, l'asterisco viene rimosso.

Salvataggio di un documento Animate nel formato FLA predefinito

  1. Effettuate una delle seguenti operazioni:
    • Per sovrascrivere la versione corrente sul disco, selezionate File > Salva.

    • Per salvare il documento in una nuova posizione e/o con un nuovo nome, oppure per comprimere il documento, selezionate File > Salva con nome.

  2. Se avete selezionato Salva con nome o se il documento non è mai stato salvato prima, immettete il nome e il percorso del file.
  3. Fate clic su Salva.

Salvare un documento nel formato XFL non compresso

  1. Scegliete File > Salva con nome.
  2. Dal menu Tipo file, scegliete Documento Animate non compresso (*xfl).

  3. Specificate un nome e una posizione per il file e fate clic su Salva.

Ripristinare l'ultima versione salvata di un documento

  1. Selezionate File > Ripristina.

Salvare un documento come modello

  1. Selezionate File > Salva come modello.
  2. Nella finestra di dialogo Salva come modello, immettete un nome per il modello nella casella Nome.
  3. Selezionate una categoria dal menu a comparsa Categoria o immettete un nome per creare una nuova categoria.
  4. Immettete una descrizione del modello nella casella Descrizione (fino a 255 caratteri), quindi fate clic su Salva.

    La descrizione viene visualizzata quando il modello viene selezionato nella finestra di dialogo Nuovo documento.

    Per eliminare un modello salvato, accedete a una delle cartelle seguenti ed eliminate il file FLA del modello dalla cartella di categoria in cui è contenuto.

    • Windows 10 - C:\Utenti\<nomeutente>\AppData\Local\Adobe\<versione>\<lingua_app>\Configuration\Templates\
    • Mac OS - <DiscoRigido>/Utenti/<nomeUtente>/Library/Supporto applicazioni/Adobe/Flash CS5/<lingua>/Configuration/Templates/

Salvare documenti al momento della chiusura di Animate

  1. Selezionate File > Esci (Windows) oppure Animate > Esci da Animate (Macintosh).

  2. Se vi sono documenti aperti contenenti modifiche che non sono state salvate, Animate chiede se si desidera salvare le modifiche o scartarle.

    • Fate clic su Sì per salvare le modifiche e chiudere il documento.

    • Fate clic su No per chiudere il documento senza salvare le modifiche.

Stampa di documenti Animate (obsoleto a partire da Flash Professional

Per visualizzare in anteprima i documenti e modificarli, potete stampare i fotogrammi dai documenti Adobe Animate, oppure specificare i fotogrammi stampabili da Flash Player mediante un visualizzatore.

Quando stampate fotogrammi da un documento Animate, utilizzate la finestra di dialogo Stampa per specificare l'intervallo di scene o di fotogrammi da stampare e il numero di copie. In Windows, nella finestra di dialogo Impostazione pagina potete specificare il formato carta, l'orientamento e le diverse opzioni di stampa, incluse le impostazioni dei margini, e se stampare tutti i fotogrammi di ogni pagina. In Macintosh, queste opzioni sono divise fra le finestre di dialogo Impostazione pagina e Margini di stampa.

Le finestre di dialogo Stampa e Impostazione pagina sono standard in entrambi i sistemi operativi e il loro aspetto dipende dal driver di stampa selezionato.

  1. Selezionate File > Impostazione pagina (Windows) o File > Margini di stampa (Macintosh).
  2. Impostate i margini della pagina. Selezionate entrambe le opzioni Centra per stampare il fotogramma al centro della pagina.
  3. Nel menu Fotogrammi, selezionate se stampare tutti i fotogrammi del documento o solo il primo fotogramma di ogni scena.
  4. Nel menu Layout, selezionate una delle seguenti opzioni:

    Dimensioni effettive

    Stampa il fotogramma nelle dimensioni reali. Immettete un valore nel campo Scala per ridurre o ingrandire il fotogramma stampato.

    Adatta alla pagina

    Riduce o ingrandisce ogni fotogramma in modo da riempire l'area di stampa della pagina.

    Storyboard

    Consente di stampare diverse miniature su una pagina. Selezionate Riquadri, Griglia oppure Vuoto. Nella casella Fotogrammi per riga, immettete il numero di miniature da stampare per ciascuna pagina. Impostate lo spazio tra le miniature nella casella Margine fotogrammi e selezionate Etichetta fotogrammi per stampare l'etichetta del fotogramma come miniatura.

  5. Per stampare i fotogrammi, selezionate File > Stampa.

Usare le etichette dei fotogrammi per disattivare la stampa

Se non desiderate stampare alcun fotogramma della linea temporale principale, assegnate a un fotogramma l'etichetta !#p per definire l'intero file SWF come non stampabile. L'assegnazione dell'etichetta !#p a un fotogramma disattiva il comando Stampa nel menu di scelta rapida di Flash Player. Potete anche rimuovere il menu di scelta rapida di Flash Player.

Se disabilitate la stampa da Flash Player, l'utente può comunque stampare i fotogrammi usando il comando Stampa del browser. Poiché questo comando è una funzione del browser, non è possibile controllarlo o disabilitarlo da Animate.

Disabilitare la stampa nel menu di scelta rapida di Flash Player

  1. Aprite o attivate il documento Animate (file FLA) da pubblicare.

  2. Selezionate il primo fotogramma chiave nella linea temporale principale.
  3. Selezionate Finestra > Proprietà per visualizzare la finestra di ispezione Proprietà.
  4. Nella finestra di ispezione Proprietà, nella casella Etichetta fotogramma immettete !#p per specificare il fotogramma come non stampabile.

    Specificate una sola etichetta !#p per disabilitare il comando Stampa nel menu di scelta rapida.

    Nota:

    in alternativa, potete selezionare un fotogramma vuoto, anziché un fotogramma chiave, ed etichettarlo con #p.

Disabilitare la stampa mediante la rimozione del menu di scelta rapida di Flash Player

  1. Aprite o attivate il documento Animate (file FLA) da pubblicare.

  2. Selezionate File > Impostazioni pubblicazione.
  3. Selezionate la scheda HTML e deselezionate Visualizza menu, quindi fate clic su OK.

Definire un'area di stampa per i fotogrammi

  1. Aprite il documento Animate (file FLA) in cui si trovano i fotogrammi da stampare.

  2. Selezionate un fotogramma che non è stato designato per la stampa con l'etichetta #p e che si trova sullo stesso livello di un fotogramma con un'etichetta #p.

    Per organizzare il lavoro, selezionate il fotogramma successivo dopo un fotogramma con etichetta #p.

  3. Create sullo stage una forma che abbia le stesse dimensioni dell'area di stampa desiderata. Per utilizzare il riquadro di delimitazione di un fotogramma, selezionate un fotogramma contenente un oggetto con le dimensioni dell'area di stampa desiderate.
  4. Selezionate nella linea temporale il fotogramma che contiene la forma da usare per definire il riquadro di delimitazione.
  5. Nella finestra di ispezione Proprietà (Finestra > Proprietà), immettete #b in Etichetta fotogramma per indicare la forma selezionata come riquadro di delimitazione dell'area di stampa.

    È ammessa un'unica etichetta di fotogramma #b per linea temporale. Questa opzione corrisponde alla selezione di Filmato in Riquadro di delimitazione per l'azione Print.

Modificare il colore di sfondo stampato

Potete stampare il colore di sfondo impostato nella finestra di dialogo Proprietà documento. Cambiare il colore di sfondo solo per i fotogrammi che verranno stampati inserendo un oggetto colorato nel livello più basso della linea temporale da stampare.

  1. Posizionate una forma piena che copra lo stage sul livello più basso della linea temporale da stampare.
  2. Selezionate la forma, quindi selezionate Elabora > Documento. Selezionate un colore per lo sfondo della stampa.

    Questa azione modifica il colore di sfondo di tutto il documento, compreso quello dei clip filmato e dei file SWF caricati.

  3. Effettuate una delle seguenti operazioni:
    • Per stampare il colore come sfondo del documento, specificate per la stampa il fotogramma in cui è stata inserita la forma.

    • Per mantenere un colore di sfondo diverso per i fotogrammi che non verranno stampati, ripetete i punti 2 e 3, quindi inserite la forma nel livello più basso della linea temporale, in tutti i fotogrammi non stampabili.

Utilizzate il comando Stampa del menu di scelta rapida di Flash Player per stampare i fotogrammi di qualsiasi file SWF di Animate.

Questo comando non può stampare effetti di colore o trasparenza e non può stampare i fotogrammi di altri clip filmato. Per funzioni di stampa più avanzate, usate l'oggetto PrintJob o la funzione print().

  1. Aprite il documento.

    Il comando stampa i fotogrammi etichettati con #p, utilizzando come area di stampa lo stage o il riquadro di delimitazione specificato.

    Se non sono stati indicati fotogrammi specifici da stampare, vengono stampati tutti i fotogrammi della linea temporale principale del documento.

  2. Selezionate File > Anteprima pubblicazione > Predefinito o premete F12 per visualizzare il contenuto Animate in un browser.

  3. Fate clic con il pulsante destro del mouse (Windows) o premete Ctrl e fate clic (Macintosh) sul contenuto Animate nella finestra del browser per visualizzare il menu di scelta rapida di Flash Player.

  4. Selezionate Stampa dal menu di scelta rapida di Flash Player per visualizzare la finestra di dialogo Stampa.
  5. In Windows, selezionate l'intervallo di fotogrammi da stampare.
  6. In Macintosh, nella finestra di dialogo Stampa, selezionate le pagine da stampare.
  7. Selezionate altre opzioni di stampa, in base alle proprietà della stampante in uso.
  8. Fate clic su OK (Windows) o Stampa (Macintosh).

Nota:

la stampa dal menu di scelta rapida non interagisce con le chiamate all'oggetto PrintJob.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online